Ciao a tutti,
stasera ho aperto il browser Firefox e andando su un sito che utilizza java mi ha chiesto di aggiornare tale versione perché vecchia.
Ero alla versione 7 di java e l'ho aggiornato alla 8.
Riavviando il browser mi lancia il seguente messaggio di errore:

startup error: java.lang.no class Defound error: could not initialize class sun.awt.x11.xpopup menu peer.

Non ci ho capito una mazza! Qualcuno mi può cortesemente aiutare? Adesso non visualizzo più le pagine java.

Grazie.

chiesto 15 Ott '13, 22:27

pitstop's gravatar image

pitstop
204244350

modificato 15 Ott '13, 22:44

enzotib's gravatar image

enzotib ♦♦
14.0k112186

1

Non mi risulta che nei repository ufficiali della versione attuale di Ubuntu (mi riferisco alla 13.04) sia disponibile java 8, quindi sarebbe il caso di spiegare come lo hai installato.
Potrebbe essere che l'installazione in qualche modo non ha comunicato al browser la disponibilità del nuovo plugin, può succedere quando si usa software non testato ufficialmente per il sistema operativo che si usa.

(16 Ott '13, 15:14) enzotib ♦♦ enzotib's gravatar image

Probabilmente devi reinstallare anche Firefox aggiornato all' ultima versione (gli hai cambiato il Java senza dirgli nulla).

coll. permanente

ha risposto 16 Ott '13, 09:23

agric's gravatar image

agric
1.5k111529

ma il firefox che ho installato adesso e' il 24.0 non e' gia' l'ultima versione? scusa ma non ho molta competenza, eventualmente per reinstallare firefox quale e' la procedura? Credevo che si aggiornasse saltuariamente attraverso gli aggiornamenti automatici di sistema..

(16 Ott '13, 13:02) pitstop pitstop's gravatar image
1

Come spiegava @enzotib se installi nuove versioni puo accadere che queste non aggiornino i programmi collegati (nel tuo caso firefox), comunque java 8 per ubuntu è ancora in fase di sviluppo e potrebbe creare problemi, comunque per reinstallare firefox in modo semplice e pratico vai nel Ubuntu sofware center cerchi Firefox selezioni rimuovi, poi una volta terminato scegli installa,cioò serve a Firefox per vedere che cè un nuovo plugin, se anche così non funziona, significa che java 8 non è compatible e devi tornare alla versione precedete di java reinstallando il 7.

(16 Ott '13, 19:23) agric agric's gravatar image

sono passato alla versione 8 seguendo una semlice guida da terminale che ho trovato su internet...la stessa procedura che avevo utilizzato per quando ero passato alla versione 7, ho solo modificato il 7 in 8... la mia versione di ubuntu e' la 12.04 e tornerei alla versione precedente di java ma sono stato obbligato ad aggiornare perche' mi diceva che avevo una versione vecchia e da li' non c'e' piu' stato verso di schiodarmi..ho dovuto aggiornare per forza.. ma se disinstallo firefox, perdo tutti i dati?

(16 Ott '13, 20:28) pitstop pitstop's gravatar image

Mah direi che gli aggiornamenti nessuno ci obbliga a farli per forza , la cosa sa di bruciato,avrei spento il pc anche forzatamente.Per Firefox si qualcosa perdi tipo la cronologia, ma se le pagine le Hai salvate a parte esempio nella cartella documenti o dowload, questi rimangono.

(16 Ott '13, 20:34) agric agric's gravatar image

ho visto sul sito di java che c'e' la versione 7 update 45, magari bastava fare quell'aggiornamento...il problema e' che non ho competenza con la shell e non so come fare praticamente l'avanzamento...

(16 Ott '13, 20:38) pitstop pitstop's gravatar image

ti giuro che non mi lasciava propio piu' fare nulla, mi reindirizzava sempre al sito di java per fare l'update ma come detto prima la procedura per me che non ho competenza da terminale era complessa.. comunque questo e' il link di quella semplice guida che ho seguito per fare l'aggiornamento.. http://www.chimerarevo.com/linux/java-7-update-7-rilasciato-installiamolo-su-ubuntu/

(16 Ott '13, 20:48) pitstop pitstop's gravatar image

Allora vai sul sito Java, clicca download gratuito java, scarichi la versione 32o 64 a seconda di come è il tuo sistema operativo,non scaricare le versioni rpm che sono per fedora, poi a fianco ci sono le istruzioni,non le ho lette, ma ti dico in linea di massima una volta scaricato, vai nella cartella download( di solito finiscono li i file) se è un file .deb lo clicchi ti si aprirà automaticamente Ubuntu software center, e clicchi installa, se ti dice software non fidato procedi comunque,non hai altra scelta.

(16 Ott '13, 20:49) agric agric's gravatar image

l'ho scaricato..e' un tar.gz non e' un.deb

(16 Ott '13, 20:55) pitstop pitstop's gravatar image

ho risolto! ho seguito dinuovo quella guida che ho linkato sopra per tornare alla versione 7, evidentemente lui mi ha scaricato l'ultima versione, la 7.45 e adesso mi funziona...forse reinstallando la 7 sopra la 7, lui automaticamente mi mette la versione piu' recente?

(16 Ott '13, 21:21) pitstop pitstop's gravatar image

Bene , sicuramente se è uguale a quella del sito java è la pù recente, il bello di Ubuntu è che ti puoi sbizzarrire a fare di tutto, scarica ,sbaglia, aggiusta, aggiorna ,rifai,ecc....tanto nella peggiore delle ipotesi,in 20 minuti o meno reinstalli da capo, senza preoccuparti di licenze, viva l' open source.

(16 Ott '13, 21:31) agric agric's gravatar image

comunque grazie e mille! siete stati gentilissimi... come devo fare per chiudere il post e darti il voto?

(16 Ott '13, 21:32) pitstop pitstop's gravatar image

Se ritieni che ti abbia aiutato in maniera soddisfacente basta cliccare pollice su, dove cè mia risposta, e se pensi che sia stata risolutiva devi accettare la risposta nel cerchiolino con la spunta sotto i pollici, decidi tu.

(16 Ott '13, 21:37) agric agric's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×93
×7

domanda posta: 15 Ott '13, 22:27

domanda visualizzata: 2,096 volte

ultimo aggiornamento: 16 Ott '13, 21:37

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.