E' da due mesi che cerco di far andare questa wifi, quello che nei vecchi notebook si chiamava wlan0 Ho provato diversi SO quali Mate, Parrot, Kali, Kubuntu, e Ubuntu di quest'anno. Non c'era neppure il simbolo del wifi nella maggioranza, e ora ho installato Ubunto del 2016 perché vidi che almeno il simbolo del wifi c'è...ma ecco alcune risposte:

~$ iwconfig lo no wireless extensions. enx020953523261 no wireless extensions.

~$ lspci -knn | grep Net -A3 02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:d723] Subsystem: Hewlett-Packard Company Device [103c:8319] 05:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265] [1002:6900] (rev ff) Kernel driver in use: amdgpu

~$ lspci 00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1576 00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo (rev c8) 00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio 00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157b 00:02.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 157c 00:02.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 157c 00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157b 00:03.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 157c 00:08.0 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 1578 00:09.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157d 00:09.2 Audio device: Advanced Micro Devices, Inc. [AMD] Device 157a 00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 20) 00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 49) 00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 49) 00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 4a) 00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11) 00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1570 00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1571 00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1572 00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1573 00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1574 00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1575 01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15) 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723 05:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265] (rev ff)

Aiuto vi prego

chiesto 31 Ott, 00:21

VladAkai's gravatar image

VladAkai
20124

Ciao sacarde, grazie dell'intervento. Ecco cos'ho dunque fatto

Ho iniziato col seguire i primi 4 comandi come leggevo su quel sito:

1) Install git and dkms if they're not installed by running sudo apt install git dkms

2) Clone the repository git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git

3) Run the following commands to install sudo dkms add rtlwifi_new sudo dkms install rtlwifi-new/0.6

4) Reboot.

If you get very weak signal try changing your antenna selection sudo tee /etc/modprobe.d/rtl8723de.conf <<< "options rtl8723de ant_sel=2"

(01 Nov, 22:21) VladAkai VladAkai's gravatar image

Ho fatto anche questo anche se sapevo non sarebbe servito, visto che iwconfig mi dava sempre il solito output (come nella domanda)

Non avendo funzionato (iwconfig solito output), ho eseguito questi altri comandi, pur non sapendo cosa volessero dire:

sudo apt update sudo apt install build-essential dkms git git clone https://github.com/jeremyb31/rtl8723de.git sudo dkms add ./rtl8723de sudo dkms build rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414 sudo dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414

Riavvio e solito output senza wifi

(01 Nov, 22:22) VladAkai VladAkai's gravatar image

Visto che leggevo che occorreva anche avere un firmware aggiornato, ho eseguito:

sudo apt-add-repository -y ppa:teejee2008/ppa sudo apt-get update sudo apt-get install ukuu

E per aggiornare questo strumento (ukuu) all'ultima versione, ho certato digitando:

sudo ukuu --list

Visto che nell'elenco l'ultima versione era la v4.19 ho digitato:

sudo ukuu --install v4.19

Quindi riavvio e tadaaa, non mi riavvia. Si blocca. Riprovo e niente, con la versione 4.19 non parte. Era rimasta l'opzione 4.4 (in verità c'erano 3 versioni della 4.19 e una decina di 4.4 e una di queste è partita)

(01 Nov, 22:24) VladAkai VladAkai's gravatar image

Ma, ho pensato, tanto valeva passare al SO Ubuntu 18 e così ho fatto (dove sono ora)

Riprovo con: ~$ sudo apt install git dkms Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto Il pacchetto git non ha versioni disponibili, ma è nominato da un altro pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto oppure è disponibile solo all'interno di un'altra sorgente

E: Il pacchetto "git" non ha candidati da installare E: Impossibile trovare il pacchetto dkms

(01 Nov, 22:26) VladAkai VladAkai's gravatar image

Tento con:

~$ git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git Comando «git» non trovato, ma può essere installato con: sudo apt install git

~$ sudo apt install git Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto Il pacchetto git non ha versioni disponibili, ma è nominato da un altro pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto oppure è disponibile solo all'interno di un'altra sorgente

E: Il pacchetto "git" non ha candidati da installare

Altre idee?

(01 Nov, 22:27) VladAkai VladAkai's gravatar image

Ecco la risposta col Ubuntu 18 a

~$ iwconfig

enp0s16u3 no wireless extensions.

enp1s0 no wireless extensions.

lo no wireless extensions.

(01 Nov, 22:31) VladAkai VladAkai's gravatar image
  • in genere le modifiche ai moduli valgono per il kernel che stai usando

  • adesso quale versione di ubuntu e quale kernel stai usando?

(02 Nov, 09:39) sacarde sacarde's gravatar image

Ho Ubuntu 18.10 da 64bit col kernel

~$ uname -r

4.18.0-10-generic

Nessun problema a riprendere la versione di Ubuntu di 2 anni fa...o qualsiasi versione, perdio, basta che funzioni il wifi!

(02 Nov, 20:52) VladAkai VladAkai's gravatar image

ok

qui forse e' un po piu' chiaro

https://subinsb.com/install-realtek-d723-wifi-driver-linux/

p.s. mi mostri cosa vedi da: inxi -n

(02 Nov, 21:05) sacarde sacarde's gravatar image

~$ inxi -n Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 IF: enp1s0 state: down mac: 10:e7:c6:a7:5a:b2 Device-2: Realtek driver: N/A Device-3: Samsung GT-I9500 [Galaxy S4] / GT-I9250 [Galaxy Nexus] (network tethering) type: USB driver: rndis_host IF: enp0s16u3 state: unknown speed: N/A duplex: N/A mac: d6:1b:00:ad:52:97

Ps: sto eseguendo la procedura del Method 1

(02 Nov, 21:14) VladAkai VladAkai's gravatar image

Ok, diciamo che progressi ci sono stati: Ho seguito il metodo 1 e dopo il riavvio c'era qualcosa di strano tra i simboli in alto a destra. Il wifi c'era, ma non connetteva (non faceva mettere la password al router del telefono). Poi appena connesso col tethering è comparso il simbolo del cavo x internet.

Inoltre il wifi rileva solo una rete, sulle 8-10 che rilevo normalmente con altri dispositivi.

Guarda un po' che non capisco perché al posto dell'amato mio wlan0 c'è quest'altro

(02 Nov, 21:33) VladAkai VladAkai's gravatar image

~$ iwconfig wlp2s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off Power Management:off

enp0s16u3 no wireless extensions.

lo no wireless extensions.

enp1s0 no wireless extensions.

Morale: wifi debole e non collega neppure il cellulare

(02 Nov, 21:34) VladAkai VladAkai's gravatar image
  • wlan0 viene rinominata, lo vedi da: dmesg | grep wl

  • che vedi da: inxi -n

(02 Nov, 21:45) sacarde sacarde's gravatar image

~$ inxi -n

Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 IF: enp1s0 state: down mac: 10:e7:c6:a7:5a:b2 Device-2: Realtek driver: rtl8723de IF: wlp2s0 state: down mac: 80:c5:f2:38:3b:2d Device-3: Samsung GT-I9500 [Galaxy S4] / GT-I9250 [Galaxy Nexus] (network tethering) type: USB driver: rndis_host IF: enp0s16u3 state: unknown speed: N/A duplex: N/A mac: d6:1b:00:ad:52:97

Praticamente di nuovo è comparso il driver: rtl8723de IF: wlp2s0 state: down col proprio mac

Quindi che si fa per potenziare il segnale, o l'antenna?

(03 Nov, 12:52) VladAkai VladAkai's gravatar image

Sempre che sia quello il problema, la potenza dell'antenna, o la completa compatibilità del driver che la fa funzionare...non è che hai anche dei siti da cui hai imparato queste cose? Non ci capisco praticamente nulla ahimé. Non è che la comunità Ubuntu, o quella Linux, abbia creato dei corsi?

(03 Nov, 13:21) VladAkai VladAkai's gravatar image

per gestire le reti usi networkmanager, no?

riesci a gestire le 2 reti:

l'ethernet: enp1s0

e

la wireless: wlp2s0

?

p.s. cosa vedi dal comando: modinfo rtl8723de

(03 Nov, 13:51) sacarde sacarde's gravatar image

Purtroppo, caro sacarde, continuo a non capirci praticamente nulla. Non ce l'ho installato networkmanager e mi hai fatto venire il dubbio se devo installarlo. Non so neppure gestire le reti

Eccoti la risposta:

~$ modinfo rtl8723de filename: /lib/modules/4.18.0-10-generic/updates/dkms/rtl8723de.ko firmware: rtlwifi/rtl8723defw.bin description: Realtek 8723DE 802.11n PCI wireless license: GPL author: Realtek WlanFAE wlanfae@realtek.com author: PageHe page_he@realsil.com.cn srcversion: D0106708CBAFF38BF5A32A2

(03 Nov, 14:07) VladAkai VladAkai's gravatar image

alias: pci:v000010ECd0000D723svsdbcsci* depends: rtlwifi,rtl_pci,btcoexist,rtl8723-common,phydm_mod retpoline: Y name: rtl8723de vermagic: 4.18.0-10-generic SMP mod_unload sig_id: PKCS#7 signer:
sig_key:
sig_hashalgo: md4 signature: 30:82:01:BC:06 ecc per 23 righi parm: dma64:bool parm: swenc:Set to 1 for software crypto (default 0) (bool) parm: ips:Set to 0 to not use link power save (default 1) (bool) parm: swlps:Set to 1 to use SW control power save (default 0) (bool)

(03 Nov, 14:09) VladAkai VladAkai's gravatar image

parm: fwlps:Set to 1 to use FW control power save (default 1) (bool) parm: msi:Set to 1 to use MSI interrupts mode (default 1) (bool) parm: aspm:Set to 1 to enable ASPM (default 0) (int) parm: debug_level:Set debug level (0-5) (default 0) (int) parm: debug_mask:Set debug mask (default 0) (ullong) parm: disable_watchdog:Set to 1 to disable the watchdog (default 0) (bool) parm: ant_sel:Set to 1 or 2 to force antenna number (default 0) (int)

Se vuoi puoi anche spiegarmi altro, nel mentre mi stai aiutando

(03 Nov, 14:11) VladAkai VladAkai's gravatar image
  • ubuntu ha networkmanager gia' installato , e puoi configurare le reti dall'applet in alto a destra (dovrebbe trovarti le 2 schede di rete)

  • devi impostare le reti in dhcp, cosi' possono prendere l'IP dal router (il quale ha configurato il dhcp)

https://wiki.ubuntu-it.org/InternetRete/ConfigurazioneRete/NetworkManager

(03 Nov, 14:20) sacarde sacarde's gravatar image

Guarda è da quando hai scritto che sto cercando di capire ma non esce nulla

In alto a destra ho, a partire da destra, la freccina in giù, la batteria, volume e il simbolino rella rete ethernet (non wifi)

Quando schiaccio tutto ciò, escono, in ordine dall'alto in basso: due barre di volume e luminosità, poi c'è: 1. ethernet collegato > 2. wi-fi non collegato > 3. [simbolo Bluetooth] collegato > 4. [simbolo batteria] carica > 5. [omino] mio nome > E sotto i 3 simbolini, da sx a dx di: impostazioni, lucchetto, spegni

Nelle impostazioni, dopo quel Method1, ho la voce wifi sopra Bluetooth

(03 Nov, 15:25) VladAkai VladAkai's gravatar image

Nella voce WI-FI (che intanto è acceso), quindi, ho:

Modalità aereo (in grassetto) (e sotto:) Disabilita Wi-Fi, Bluetooth, e la connessione a banda larga mobile (disabilitato)

Reti visibili (in grassetto) (e sotto:) 2 reti che rilevo col wi-fi. Con altri dispositivi se ne vedono una decina

Insomma, non so come si fa a cambiare la rete e se serve:

~$ iwconfig wlp2s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off Power Management:off E 3 reti sena estensione

(03 Nov, 15:31) VladAkai VladAkai's gravatar image

bisognerebbe entrare in configurazione del wireless wlp2s0

inserendo ESSID e eventuale chiave

e abilitarla/attivarla

(03 Nov, 16:59) sacarde sacarde's gravatar image

Ti ringrazio tanto per il tuo aiuto, ma sono arrivato a leggere e rileggere le stesse cose, è da 2 mesi che lo faccio, e sono stufo. Ho passato giorni di seguito di cupa tristezza, depresso, perché una cosa che mi sembra tanto semplice non vada sul mio Realteck

Non riesco a configurare, non so come si fa, e butterò questi 2 mesi al vento. Torno al tanto odiato (da me) windows, non ho altra scelta. Pare che l'hardware sia più adatto per quello che per i Linux

Per adesso sono stanco di essere triste e depresso, e devo andare avanti nella vita che ho messo da parte per tutto questo tempo

(05 Nov, 14:06) VladAkai VladAkai's gravatar image
  • ti capisco e hai ragione

  • qui trovi dei negozi che installano linux

http://www.linuxsi.com/

(05 Nov, 14:15) sacarde sacarde's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×255
×129
×11
×7

domanda posta: 31 Ott, 00:21

domanda visualizzata: 69 volte

ultimo aggiornamento: 05 Nov, 14:15

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.