Salve a tutti.

Ieri pomeriggio il sistema mi ha segnalato la possibilità di aggiornare Ubuntu dalla versione 13.04 alla versione 13.10. Premesso che da quando ho Ubuntu questa è la prima volta che faccio un upgrade in corsa, senza fare un'installazione da CD.
Dopo aver lanciato l'avanzamento, l'installazione ha richiesto la conferma per sovrascrivere o modificare alcuni file di configurazione che, guardando il dettaglio, mi sono sembrati di minore importanza, per cui ho deciso di sovrascriverli.

Al termine dell'upgrade, il sistema si è riavviato, ma all'avvio ho ottenuto uno schermo nero e non avevo nemmeno possibilità di accedere al terminale con Ctrl+Alt+Fn. Non essendo la prima volta che mi succedeva una cosa simile, ho imputato il problema ai driver ATI della mia scheda video; dunque ho disinstallato fglrx e correlati e ho anche rimosso lo xorg-server, che ho poi ripristinato re-installandolo da zero.
Fatto ciò, ho notato un piccolo miglioramento: la schermata di login è riapparsa con il mio sfondo, ma superata questa il desktop mi si presenta tutto nero con il solo cursore visibile e una finestrella di errore col seguente messaggio:

System program problem detected

Da lì in poi, non sono più riuscito a resuscitare il mio desktop: ho provato a reinstallare ubuntu-desktop e unity, ma niente, stessa schermata nera con il cursore.

Qualcuno saprebbe darmi una mano al riguardo?

Vi ringrazio in anticipo.

chiesto 18 Ott '13, 08:56

AlexKibo88's gravatar image

AlexKibo88
20125

modificato 18 Ott '13, 19:49

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Prova a partire con kernel precedenti per vedere se quantomeno non si "freeza" e poi se puoi usare la combinazione ctrl+alt+f1 per operare...

Prova ad inserire fra i parametri del kernel il parametro nomodeset

(18 Ott '13, 13:55) marcobra marcobra's gravatar image

Grazie della risposta. In realtà non si "freeza" come dici: riesco ad accedere al desktop facendo login, ma non vedo le icone e Unity. Vedo uno schermo nero e quel messaggio d'errore. Riesco già ad entrare in Ctrl+Alt+F1.

(18 Ott '13, 13:59) AlexKibo88 AlexKibo88's gravatar image

Prova, se riesci ad aprire un terminale con ctrl+alt+t o prova a fare il login con ctrl+alt+f1 a fare così:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install dconf-editor
dconf reset -f /org/compiz/
unity --reset-icons & disown

Ma poi riavvia

sudo reboot
(18 Ott '13, 18:05) marcobra marcobra's gravatar image

Ciao. Non funziona: sia dconf reset che unity --reset mi dicono che c'è un errore spawn sul bus e che la procedura è uscita con codice errore 1.

(18 Ott '13, 20:42) AlexKibo88 AlexKibo88's gravatar image

scusate sono un neofita per Ubuntu e mi trovo nella situazione tipo quell descritta sopra, ovvero ieri ho installato Ubuntu come unico SO e tutto abbastanza bene, poi ho aggiornato il driver della mia scheda Ati, ho riavviato e adesso ho solo uno schermo nero. cosa devo fare, re istallare tutto da capo o riesco a uscirne in maniera diversa? grazie

(20 Mar '14, 10:10) mirko22676 mirko22676's gravatar image

Avanzare di versione non è mai troppo salutare , cambia sistemista

(20 Mar '14, 11:27) Paolo- Paolo-'s gravatar image

@mirko22676 ti consiglio di seguire una delle procedure presenti a questo link:

http://forum.ubuntu-it.org/viewtopic.php?t=296090

Mi hanno salvato la vita più di una volta. ;-)

(20 Mar '14, 11:31) AlexKibo88 AlexKibo88's gravatar image

@mirko22676 le risposte servono per proporre soluzioni alla domanda, non per porre un'altra domanda.

Per chiedere aiuto devi porre una nuova domanda (tasto "Chiedi" sulla barra arancione in alto).

(20 Mar '14, 14:45) alevipri alevipri's gravatar image

@AlexKibo88 accetta la tua risposta, può servire anche ad altri utenti (simbolo "V" accanto alla risposta).

(21 Mar '14, 09:47) alevipri alevipri's gravatar image

Alla fine ho re-installato Ubuntu dal live CD e tutto è andato per il meglio. Il problema sembrava essere dovuto ai driver ATI Catalyst installati sul mio 13.04, che pare non siano compatibili con la versione 13.10 di Ubuntu. Credevo che il sistema li rimuovesse o che perlomeno ci passasse sopra, invece sono andati in conflitto e hanno generato il problema.

Se a qualcuno può aiutare, dunque, assicuratevi di rimuovere i vostri driver grafici prima di aggiornare Ubuntu.

coll. permanente

ha risposto 19 Ott '13, 11:42

AlexKibo88's gravatar image

AlexKibo88
20125

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×229
×61
×48

domanda posta: 18 Ott '13, 08:56

domanda visualizzata: 7,090 volte

ultimo aggiornamento: 21 Mar '14, 09:47

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.