Ciao a tutti, da quando ho installato Bionic mi capita esattamente questa cosa:

https://askubuntu.com/questions/964646/strange-appearance-of-text-background-in-gedit

Ho tentato le soluzioni proposte ma la cosa non cambia. Qualcuno ha idea di cosa possa causare questo strano comportamento? Dopotutto la medesima installazione su un altro PC non ha dato alcun problema. Grazie in anticipo a tutti!

chiesto 25 Nov, 13:20

attux's gravatar image

attux
203

modificato 4 ore fa

  • lo fa sempre? soltanto con gedit?

  • usi xorg o wayland?

  • che driver video usi?

(27 Nov, 10:00) sacarde sacarde's gravatar image

Ciao, perdona le tempistiche ma in questo periodo purtroppo va così. Rimuovere "run_im xim" da ~/.xinputrc era stato il mio primissimo tentativo, proprio come suggerito nel link con cui ho aperto questa richiesta. Non avevo però ottenuto esito positivo. Adesso, sulla tua imbeccata, ci ho riprovato e Gedit finalmente funziona bene sia da user che da root. L'unica differenza di configurazione rispetto al tentativo iniziale risiede nei driver proprietari Nvidia 340.107 che adesso sto adoperando al posto di Nouveau. Tra i vari test ho anche provato ad aprire una consolle non grafica e lanciare Gedit da la. La sorpresa è che adesso la combinazione di tasti Ctrl Alt F1...F6 non viene percepita per niente per cui l'unica consolle attualmente attiva è reperibile da Ctrl Alt T. Non so se questi fenomeni siano correlati ma proverò anche a indagare questa poco piacevole sorpresa.

Comunque grazie di tutto.

coll. permanente

ha risposto 09 Dic, 15:35

attux's gravatar image

attux
203

  • non ho capito come fai a lanciare un editor grafico su una consolle testuale

  • f1-..-f6 dovrebbero aprirsi in framebuffer, quindi attivando o meno il parametro "nomodeset" al kernel

(09 Dic, 17:03) sacarde sacarde's gravatar image

Avevo il dubbio che lanciare un editor grafico da una consolle solo testuale fosse inverosimile; il tentativo difatti era dovuto al test che avevi proposto: avevo svolto tutti i tentativi precedenti tramite il terminale di Gnome (Ctrl Alt T). Le consolle di solo testo mi suonavano strane ma, non considerandomi un genio, ho voluto fare anche quel tentativo. Detto questo, la mia ignoranza mi fa chiedere come mai la combinazione Ctrl Alt F1 (che da Edgy ha sempre funzionato) con Bionic non va. I parametri del kernel per me sono arabo per cui, prima di rischiare danni, mi potresti dare due dritte?

(11 Dic, 23:15) attux attux's gravatar image
  • una volta nel sistema vedi servizi in errore? con:

sudo systemctl --failed

  • provato a aggiungere o togliere il parametro "nomodeset" al kernel?
(12 Dic, 08:41) sacarde sacarde's gravatar image

Ciao, il comando sudo systemctl --failed restituisce "0 loaded units listed". Circa l'altro tentativo, come scritto in precedenza, non ho mai avuto esperienza con i magheggi sul kernel. Ho seguito questa pagina https://ubuntuforums.org/showthread.php?t=1901194 (spero di avere azzeccato) ma Ctrl Alt F1...F6 ancora non va.

(10 ore fa) attux attux's gravatar image
  • dal comando: systemctl list-unit-files

vedi il servizio: getty@.service o simile e' "enabled" ?

  • si si la pagina va bene, puoi metterlo nella stessda riga:

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

e toglierei: quiet splash

(9 ore fa) sacarde sacarde's gravatar image

Ciao, perdona la non tempestività ma sono stato fuori casa per lavoro,senza accesso al PC (fisso). Il problema avviene solo con gedit v. 3.28.1 Ho installato Bionic "liscio" per cui adopero Xorg, attualmente v. 1.19.6 La scheda video è una Nvidia Quadro 295 NVS con i driver Nouveau v. 1.0.15-2

coll. permanente

ha risposto 29 Nov, 19:54

attux's gravatar image

attux
203

Dimenticavo: lo fa sempre

coll. permanente

ha risposto 29 Nov, 19:56

attux's gravatar image

attux
203

mah...

potresti provare un avvio passando al kernel "xforcevesa" per vedere se lo fa con i driver video generici vesa

oppure dalla live sempre aggiungendo il parametro "xforcevesa"

(29 Nov, 20:33) sacarde sacarde's gravatar image

Ho fatto delle prove ulteriori:

  • xforcevesa non apporta alcun miglioramento;
  • i driver proprietari Nvidia 340.107 migliorano leggermente le prestazioni globali ma non risolvono il problema.

Ho tuttavia notato che sudo gedit funziona bene, gedit senza sudo invece continua a manifestare il solito inghippo. Sembra pertanto che gedit necessiti di alcuni privilegi di root. Forse ciò è dovuto al fatto che ho installato Bionic al posto di Xenial + xfce per cui nella Home permane qualche file di configurazione non consono al nuovo ambiente. Detto questo, come mi consigliate di procedere?

coll. permanente

ha risposto 02 Dic, 12:05

attux's gravatar image

attux
203

  • cioe' sei sulla partizione (dedicata) dati-utente che avevi col vecchio sistema 16.04 ?

  • hai un'altro utente o puoi crearne uno per fare la verifica?

  • il problema si presenta sia con file nuovi che in modifica?

(02 Dic, 13:46) sacarde sacarde's gravatar image

Ho formattato e sovrascritto la partizione root di Xenial con la root di Bionic, la home è rimasta la stessa per cui ho il dubbio che ci sia qualche .file o .cartella da cancellare. Il problema si manifesta sia con nuovi che con vecchi file, sia via shell che via terminale. Mi spiego meglio: gedit -> inutilizzabile; sudo gedit -> OK. Ciò a prescindere che dopo gedit sia indicato un "nomefile".

coll. permanente

ha risposto 03 Dic, 08:37

attux's gravatar image

attux
203

dal tuo link si vede che si cancella la configurazione di gedit ma quando si e' root (primo carattere "#")

provato la stessa cosa quando sei utente normale? (primo carattere "$" ?)

(03 Dic, 08:55) sacarde sacarde's gravatar image

Penso che sia il contrario. Ti riporto il test che eseguo tramite terminale:

1) da utente digito "gedit" (primo carattere $) -> errore

2) sudo su + password per diventare root

3) digito "gedit" (primo carattere #) -> tutto ok

Mi sembra pertanto che l'inghippo esista solo da user. Mi viene quindi da pensare che possano esistere dei file di configurazione di gedit da copiare da /qualcosa a /home, a cui poi adattare gli opportuni permessi. Purtroppo non riesco nemmeno a individuare dove Bionic conservi questi file, altrimenti come prima cosa li cancellerei.

coll. permanente

ha risposto 03 Dic, 19:38

attux's gravatar image

attux
203

prova a rinominare (da utente normale):

mv ~/.config/gedit ~/.config/gedit-old

(03 Dic, 20:23) sacarde sacarde's gravatar image

Grazie a te ho appena scoperto dove Bionic archivia i file di configurazione di Gedit. Nonostante questo però il problema rimane anche dopo la loro cancellazione. Mi fa strano di non trovare online altre domande simile a questa: non pensavo di trovarmi in una condizione tanto unica.

(04 Dic, 19:23) attux attux's gravatar image
  • hai rimosso anche la riga: "run_im xim" da ~/.xinputrc

  • provi a tenere aperto solo una consolle, e a eseguire da li' "gedit" per vedere se da qualche messaggio di errore

(04 Dic, 20:37) sacarde sacarde's gravatar image

Evvai, funziona!!! Ho impostato GRUB_ CMDLINE_ LINUX_DEFAULT="nomodeset" togliendo quit splash in Grub e riavviato. Adesso va. Ho notato tuttavia che le console di testo adesso vanno da Ctrl Alt F2 in poi, mentre la GUI è in F1. Giusto per completezza: systemctl list-unit-files | grep getty restituisce

console-getty.service disabled
container-getty@.service static
getty-static.service static
getty@.service enabled
serial-getty@.service disabled
getty-pre.target static
getty.target static

Davvero grazie mille !!!

coll. permanente

ha risposto 4 ore fa

attux's gravatar image

attux
203

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×7

domanda posta: 25 Nov, 13:20

domanda visualizzata: 95 volte

ultimo aggiornamento: 4 ore fa

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.