salve

ho aggiornato da due giorni ubuntu (da 16.04 a 18.04) e mi sono trovato in un problema importate prima non presente: non riesco a switchare dalla scheda video Nvidia ad Intel (crasha).

Il mio computer è un Notebook zenbook UX32VD dotato di due schede video 1- Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) 2- Geforce GT 620 M (installati e funzionanti i driver proprietari 340.107)

Nela versione precedente di Ubuntu, girava predefinita l'Intel e poi, quando avevo bisogno, facevo partire la seconda scheda con il comando "optirun <applicazione>" senza problemi. Bumblebee installato e funzionante.

Dopo l'upgrade a 18.04. la scheda predefinita è l'NVIDIA con evidenti consumi energetici.

Segnalo che erano già, e lo sono ancora, installati:

xserver-xorg-video-intel driver proprietari NVIDIA 340.107

Ecco quello che ho fatto (dopo ore spese a leggere guide) - Ho (re)installato prime-select, bbswitch-dpkms, bswitch - Ho quindi installato in /etc/modules: bbswitch-dpkms bswitch

Ecco cosa vede il sistema secondo i comandi illustrati:

sudo ubuntu-drivers devices

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 == modalias : pci:v000010DEd00001140sv00001043sd00001507bc03sc02i00 vendor : NVIDIA Corporation model : GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (GeForce GT 620M) driver : nvidia-340 - distro non-free recommended driver : xserver-xorg-video-nouveau - distro free builtin

lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

xorg.conf (vi segnalo che è sempre rimasto lo stesso rispetto al 16.04):

Section "ServerLayout" Identifier "layout" Screen 0 "nvidia" Inactive "intel" EndSection

Section "Device" Identifier "intel" Driver "modesetting" BusID "PCI:0@0:2:0" Option "AccelMethod" "None" EndSection

Section "Screen" Identifier "intel" Device "intel" EndSection

Section "Device" Identifier "nvidia" Driver "nvidia" BusID "PCI:1@0:0:0" Option "ConstrainCursor" "off" EndSection

Section "Screen" Identifier "nvidia" Device "nvidia" Option "AllowEmptyInitialConfiguration" "on" Option "IgnoreDisplayDevices" "CRT" EndSection

Infine vi segnalo blacklist: non c'è traccia di intel (ma penso che non ci debba essere dato che il driver è intergato nel kernel)

Quando scelgo di switchare sulla scheda video INTEL (tramite prime-select intel), alla disconnessione o al riavvio la schermata risulta nera o, se riavviato, si ferma alla visualizzazione log del kernel.

Tenete presente che utilizzo Ubuntu dal 8.04 (forse prima), ma è la prima volta che non riesco a risolvere il problema ! Vi prego di aiutarmi !!

grazie!

chiesto 26 Nov, 18:01

gabriele-ciuti's gravatar image

gabriele-ciuti
2012

Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×115
×34

domanda posta: 26 Nov, 18:01

domanda visualizzata: 21 volte

ultimo aggiornamento: 26 Nov, 18:01

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.