Buongiorno a tutti!

Il mio Ubuntu 12.04 non fa più gli aggiornamenti da un pezzo! Non posso neanche installare né rimuovere programmi e tanto meno eseguire gli aggiornamenti, e la frase che mi compare è sempre questa:

ci sono dei pacchetti danneggiati

in più ho un segnale di divieto fisso in alto a destra. Ogni tanto mi appare la schermata chiedendomi se voglio ripararlo, io premo ripara e poi quasi alla fine riesce sempre fuori "alcuni pacchetti sono danneggiati"!

Qualcuno che mi può aiutare per favore? :-) In più non facendo gli aggiornamenti da un pezzo il PC va lentissimo.

Edit

Ciao, prima di tutto grazie per la tua risposta! :-)
Ho fatto nel terminale tutto quello che mi hai detto per ordini e ti copio sotto quello che ne è uscito:

$ sudo apt-get update
[sudo] password for carla: 
Trovato http://extras.ubuntu.com precise Release.gpg
Trovato http://archive.canonical.com precise Release.gpg       
Trovato http://extras.ubuntu.com precise Release               
Trovato http://archive.canonical.com precise Release                           
Trovato http://extras.ubuntu.com precise/main Sources                          
Trovato http://archive.canonical.com precise/partner i386 Packages
Trovato http://extras.ubuntu.com precise/main i386 Packages    
Ign http://extras.ubuntu.com precise/main TranslationIndex                     
Ign http://archive.canonical.com precise/partner TranslationIndex              
Ign http://extras.ubuntu.com precise/main Translation-it_IT                    
Ign http://archive.canonical.com precise/partner Translation-it_IT             
Ign http://extras.ubuntu.com precise/main Translation-it                       
Ign http://archive.canonical.com precise/partner Translation-it                
Ign http://extras.ubuntu.com precise/main Translation-en                       
Ign http://archive.canonical.com precise/partner Translation-en                
Trovato http://archive.ubuntu.com precise Release.gpg          
Scaricamento di:1 http://archive.ubuntu.com precise-updates Release.gpg [198 B]
Scaricamento di:2 http://archive.ubuntu.com precise-backports Release.gpg [198 B]
Scaricamento di:3 http://archive.ubuntu.com precise-security Release.gpg [198 B]
Trovato http://archive.ubuntu.com precise Release
Scaricamento di:4 http://archive.ubuntu.com precise-updates Release [49,6 kB]
Scaricamento di:5 http://archive.ubuntu.com precise-backports Release [49,6 kB]
Scaricamento di:6 http://archive.ubuntu.com precise-security Release [49,6 kB]
Trovato http://archive.ubuntu.com precise/main Sources 
Trovato http://archive.ubuntu.com precise/restricted Sources
Trovato http://archive.ubuntu.com precise/universe Sources
Trovato http://archive.ubuntu.com precise/multiverse Sources
Trovato http://archive.ubuntu.com precise/main i386 Packages
Trovato http://archive.ubuntu.com precise/restricted i386 Packages
Trovato http://archive.ubuntu.com precise/universe i386 Packages
Trovato http://archive.ubuntu.com precise/multiverse i386 Packages
Trovato http://archive.ubuntu.com precise/main TranslationIndex
Trovato http://archive.ubuntu.com precise/multiverse TranslationIndex
Trovato http://archive.ubuntu.com precise/restricted TranslationIndex
Trovato http://archive.ubuntu.com precise/universe TranslationIndex            
Scaricamento di:7 http://archive.ubuntu.com precise-updates/main Sources [422 kB]
Scaricamento di:8 http://archive.ubuntu.com precise-updates/restricted Sources [7006 B]
Scaricamento di:9 http://archive.ubuntu.com precise-updates/universe Sources [98,0 kB]
Scaricamento di:10 http://archive.ubuntu.com precise-updates/multiverse Sources [8343 B]
Scaricamento di:11 http://archive.ubuntu.com precise-updates/main i386 Packages [716 kB]
Scaricamento di:12 http://archive.ubuntu.com precise-updates/restricted i386 Packages [11,4 kB]
Scaricamento di:13 http://archive.ubuntu.com precise-updates/universe i386 Packages [224 kB]
Scaricamento di:14 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [14,0 kB]
Trovato http://archive.ubuntu.com precise-updates/main TranslationIndex        
Trovato http://archive.ubuntu.com precise-updates/multiverse TranslationIndex  
Trovato http://archive.ubuntu.com precise-updates/restricted TranslationIndex  
Trovato http://archive.ubuntu.com precise-updates/universe TranslationIndex    
Scaricamento di:15 http://archive.ubuntu.com precise-backports/main Sources [4615 B]
Scaricamento di:16 http://archive.ubuntu.com precise-backports/restricted Sources [14 B]
Scaricamento di:17 http://archive.ubuntu.com precise-backports/universe Sources [35,5 kB]
Scaricamento di:18 http://archive.ubuntu.com precise-backports/multiverse Sources [5311 B]
Scaricamento di:19 http://archive.ubuntu.com precise-backports/main i386 Packages [3044 B]
Scaricamento di:20 http://archive.ubuntu.com precise-backports/restricted i386 Packages [14 B]
Scaricamento di:21 http://archive.ubuntu.com precise-backports/universe i386 Packages [36,3 kB]
Scaricamento di:22 http://archive.ubuntu.com precise-backports/multiverse i386 Packages [5178 B]
Trovato http://archive.ubuntu.com precise-backports/main TranslationIndex      
Trovato http://archive.ubuntu.com precise-backports/multiverse TranslationIndex
Trovato http://archive.ubuntu.com precise-backports/restricted TranslationIndex
Trovato http://archive.ubuntu.com precise-backports/universe TranslationIndex  
Scaricamento di:23 http://archive.ubuntu.com precise-security/main Sources [91,8 kB]
Scaricamento di:24 http://archive.ubuntu.com precise-security/restricted Sources [2494 B]
Scaricamento di:25 http://archive.ubuntu.com precise-security/universe Sources [28,4 kB]
Scaricamento di:26 http://archive.ubuntu.com precise-security/multiverse Sources [1804 B]
Scaricamento di:27 http://archive.ubuntu.com precise-security/main i386 Packages [348 kB]
Scaricamento di:28 http://archive.ubuntu.com precise-security/restricted i386 Packages [4620 B]
Scaricamento di:29 http://archive.ubuntu.com precise-security/universe i386 Packages [86,7 kB]
Scaricamento di:30 http://archive.ubuntu.com precise-security/multiverse i386 Packages [2640 B]
Trovato http://archive.ubuntu.com precise-security/main TranslationIndex       
Trovato http://archive.ubuntu.com precise-security/multiverse TranslationIndex 
Trovato http://archive.ubuntu.com precise-security/restricted TranslationIndex 
Trovato http://archive.ubuntu.com precise-security/universe TranslationIndex   
Trovato http://archive.ubuntu.com precise/main Translation-it                  
Trovato http://archive.ubuntu.com precise/main Translation-en                  
Trovato http://archive.ubuntu.com precise/multiverse Translation-it            
Trovato http://archive.ubuntu.com precise/multiverse Translation-en            
Trovato http://archive.ubuntu.com precise/restricted Translation-it            
Trovato http://archive.ubuntu.com precise/restricted Translation-en            
Trovato http://archive.ubuntu.com precise/universe Translation-it              
Trovato http://archive.ubuntu.com precise/universe Translation-en              
Trovato http://archive.ubuntu.com precise-updates/main Translation-it          
Trovato http://archive.ubuntu.com precise-updates/main Translation-en          
Trovato http://archive.ubuntu.com precise-updates/multiverse Translation-it    
Trovato http://archive.ubuntu.com precise-updates/multiverse Translation-en    
Trovato http://archive.ubuntu.com precise-updates/restricted Translation-it    
Trovato http://archive.ubuntu.com precise-updates/restricted Translation-en    
Trovato http://archive.ubuntu.com precise-updates/universe Translation-it      
Trovato http://archive.ubuntu.com precise-updates/universe Translation-en      
Trovato http://archive.ubuntu.com precise-backports/main Translation-en        
Trovato http://archive.ubuntu.com precise-backports/multiverse Translation-en  
Trovato http://archive.ubuntu.com precise-backports/restricted Translation-en  
Trovato http://archive.ubuntu.com precise-backports/universe Translation-en    
Trovato http://archive.ubuntu.com precise-security/main Translation-en         
Trovato http://archive.ubuntu.com precise-security/multiverse Translation-en   
Trovato http://archive.ubuntu.com precise-security/restricted Translation-en   
Trovato http://archive.ubuntu.com precise-security/universe Translation-en     
Recuperati 2307 kB in 11s (207 kB/s)                                           
Lettura elenco dei pacchetti... Fatto

$ sudo apt-get autoclean
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto

$ sudo apt-get clean

$ sudo apt-get autoremove
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 linux-generic-pae : Dipende: linux-headers-generic-pae (= 3.2.0.39.47) ma la versione 3.2.0.54.64 è installata
E: Dipendenze non trovate. Riprovare usando -f.

Edit2

ecco l'output che mi hai chiesto :-)

$ sudo apt-get -f install 
[sudo] password for carla: 
Lettura elenco dei pacchetti... Fatto 
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto 
Correzione delle dipendenze... Fatto 
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti: 
    linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic-pae 
Usare "apt-get autoremove" per rimuoverli. 
I seguenti pacchetti saranno inoltre installati: 
    linux-generic-pae linux-image-generic-pae 
I seguenti pacchetti saranno aggiornati: 
    linux-generic-pae linux-image-generic-pae 
2 aggiornati, 0 installati, 0 da rimuovere e 327 non aggiornati. 
4 non completamente installati o rimossi. 
È necessario scaricare 0 B/4002 B di archivi. 
Dopo quest'operazione, verranno occupati 2048 B di spazio su disco. 
Continuare [S/n]? S 
Configurazione di linux-image-3.2.0-39-generic-pae (3.2.0-39.62)... 
Running depmod. 
Failed to run depmod dpkg: errore nell'elaborare linux-image-3.2.0-39-generic-pae (--configure): il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1 
Configurazione di linux-image-3.2.0-54-generic-pae (3.2.0-54.82)... 
Running depmod. 
Failed to run depmod dpkg: errore nell'elaborare linux-image-3.2.0-54-generic-pae (--configure): il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1 
E: Sub-process /usr/bin/dpkg returned an error code (1)

Edit3

Ciao, ho fatto come mi hai detto e ancora nulla. Ti mando l'esito:

$ sudo rm /var/lib/dpkg/info/linux-image-3.2.0-39-generic-pae.posting
rm: impossibile rimuovere "/var/lib/dpkg/info/linux-image-3.2.0-39-generic-pae.postinst": File o directory non esistente

$ sudo rm /var/lib/dpkg/info/linux-image-3.2.0-54-generic-pae.postinst 
rm: impossibile rimuovere "/var/lib/dpkg/info/linux-image-3.2.0-54-generic-pae.postinst": File o directory non esistente

$ sudo apt-get -f install 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic-pae
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
  linux-generic-pae
I seguenti pacchetti saranno aggiornati:
  linux-generic-pae
1 aggiornati, 0 installati, 0 da rimuovere e 327 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/1730 B di archivi.
Dopo quest'operazione, verranno occupati 1024 B di spazio su disco.
Continuare [S/n]? S
dpkg: problemi con le dipendenze impediscono la configurazione di linux-generic-pae:
 linux-generic-pae dipende da linux-image-generic-pae (= 3.2.0.39.47), ma:
  La versione di linux-image-generic-pae nel sistema è 3.2.0.54.64.
 linux-generic-pae dipende da linux-headers-generic-pae (= 3.2.0.39.47), ma:
  La versione di linux-headers-generic-pae nel sistema è 3.2.0.54.64.
dpkg: errore nell'elaborare linux-generic-pae (--configure):
 problemi con le dipendenze - lasciato non configurato
Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
Si sono verificati degli errori nell'elaborazione:
 linux-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo apt-get --reinstall install linux-image-3.2.0-54-generic-pae
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
 linux-generic-pae : Dipende: linux-image-generic-pae (= 3.2.0.39.47) ma la versione 3.2.0.54.64 sta per essere installata
    Dipende: linux-headers-generic-pae (= 3.2.0.39.47) ma la versione 3.2.0.54.64 sta per essere installata
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).

chiesto 19 Ott '13, 10:15

carladasilva's gravatar image

carladasilva
10112

modificato 20 Ott '13, 20:34

enzotib's gravatar image

enzotib ♦♦
14.0k112186

@carladasilva: le rispose non vanno usate, come hai fatto tu, per aggiungere informazioni o rispondere alle risposte. Le risposte sono riservate a quelli che propongono soluzioni, per tutto il resto devi usare i commenti o modificare e integrare la domanda.

(19 Ott '13, 23:34) enzotib ♦♦ enzotib's gravatar image

ah ok! scusate non lo sapevo :-) ma comunque dopo aver fatto questo continua a dirmi la stessa cosa... in piu non ho synaptic.. lo cercato ovunque e lo trovato solo dove mi dice che se lo voglio lo devo scaricare...cosa che non posso fare perche mi dice sempre pachetti danneggiati!ti scrivo anche cosa riporta il segnale di divieto che mi appare sempre:"ERRORE BROKENCOUNT <0

(20 Ott '13, 10:03) carladasilva carladasilva's gravatar image

@carladasilva: segui l'ultima indicazione che ti dà, ed esegui:
sudo apt-get -f install

(20 Ott '13, 10:26) enzotib ♦♦ enzotib's gravatar image

ciao! allora fatto come mi hai detto e si apre una finestra che mi dice: SI È VERIFICATO UN PROBLEMA DI SISTEMA, le opzioni sono ANNULLA O SEGNALA PROBLEMA..invece dal terminale ti copio sotto cosa mi dice:
il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1 E: Sub-process /usr/bin/dpkg returned an error code (1)

(20 Ott '13, 14:17) carladasilva carladasilva's gravatar image

@carladasilva: bisognerebbe vedere l'output completo del comando: inseriscilo nella domanda

(20 Ott '13, 14:25) enzotib ♦♦ enzotib's gravatar image

fatto! non so se l'ho inserito nel posto giusto! ma era l'unico spazio che me lo faceva copiare tutto :-)

(20 Ott '13, 14:56) carladasilva carladasilva's gravatar image

@carladasilva, l'hai inserito nel posto giusto, ma formattato una schifezza, nemmeno gli "a capo" erano giusti. Ho dovuto lavorarci un po' per renderlo leggibile.
Vediamo se con queste istruzioni risolvi:
sudo rm /var/lib/dpkg/info/linux-image-3.2.0-39-generic-pae.postinst sudo rm /var/lib/dpkg/info/linux-image-3.2.0-54-generic-pae.postinst sudo apt-get -f install sudo apt-get --reinstall install linux-image-3.2.0-54-generic-pae

(20 Ott '13, 17:18) enzotib ♦♦ enzotib's gravatar image

scusami non sono bravissima a fare queste cose... :-) ora ci provo. grazie!!!

(20 Ott '13, 17:56) carladasilva carladasilva's gravatar image

ciao,scusami ti ho mandato l'esito ma non riesco a metterli bene dritti come fai tu :-( ci ho provato fino adesso ma non mi viene dritto perfetto come fai tu...perciò per non rischiare di modificare il risultato ho copiato un'altra volta e lo incollato senza toccarlo più.. ti ringrazio anche per la tua pazienza :-)

(20 Ott '13, 20:01) carladasilva carladasilva's gravatar image

Apri synaptic (Il gestore pacchetti di ubuntu )poi seleziona stato e controlla quanti sono i pacchetti dannegiati.A questo punto da click destro sul/sui pacchetti seleziona dal menu voce ripara.Se non si risolve,in gestore aggiornamenti apri impostazioni(voce in basso a sinistra) Software per ubuntu scegli di scaricare da Server principale.Chiudi apri terminale e dai in sequenza uno per volta i seguenti comandi.

sudo apt-get update

sudo apt-get autoclean

sudo apt-get clean

sudo apt-get autoremove
coll. permanente

ha risposto 19 Ott '13, 16:01

Webber's gravatar image

Webber
3.0k1535

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×253
×165
×110

domanda posta: 19 Ott '13, 10:15

domanda visualizzata: 8,040 volte

ultimo aggiornamento: 20 Ott '13, 20:34

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.