Ho da poco installato 18.04 (ubuntu server da mini.iso per i386 + install ubuntu-desktop da terminale, un metodo che consiglio).

Ho diversi problemini mai riscontrati da anni nelle precedenti distro ma quello che al momento non riesco a capire è perché la mia wifi venga immediatamente trovata (era stata già settata durante l'installazione) - quindi il mio dispositivo USB wireless funziona bene - MA nel desktop di gnome non ho l'applet funzionate.

In pratica se dal menù opzioni in alto a destra faccio scendere la tendina vedo le opzioni wireless, ma nulla è connesso e posso aprire anche la finestra "seleziona rete" che però rimane vuota e con il logo di sospensione. Di conseguenza non mi compare mai l'indicatore di wifi bianco vicino al tasto accensione, perché il desktop non sembra poter accedere al network manager. Molto strano.

Ho usato unity in precedenza quindi non sono pratico di questo nuovo desktop. Grazie per i consigli!

chiesto 08 Mar, 17:22

Tanaka's gravatar image

Tanaka
201

preciso, per chiarezza, che il mio dispositivo wifi funziona e si connette alla rete, è l'ambiente grafico che sembra non capirlo.

(08 Mar, 17:40) Tanaka Tanaka's gravatar image

vedi problemi al networkmanager? eseguendo:

systemctl --failed

journalctl -b -p err

p.s. che vedi da: systemctl status network-manager

(08 Mar, 20:37) sacarde sacarde's gravatar image

ciao, grazie per l'attenzione. per il primo comando, noto che systemd-networkd-wait-online.service sembra LOADED ma non a livello active (high level unit) e sub (low level). può darsi che questo spieghi perché la mia rete funzioni e il device wifi sia di fatto impegnato, anche se il manager non si carica del tutto.

il secondo comando rivela una sequenza ripetuta di errori, il più ricorrente dei quali è così descritto:

Failed to initialize control interface '/run/wpa_supplicant'. You may have another wpa_supplicant process already running or the fil left by an unclean termination of wpa_supplicant in which case you wil to manually remove this file before starting wpa_supplicant again.

lo status del network-manager rivela questa serie di errori:

NetworkManager[1067]: <warn> [1552139791.9781] device (wlxd85d4c8ca9ea): re-acquiring supplicant interface (#3). NetworkManager[1067]: <error> [1552139792.1039] sup-iface[0x12e1ed8,wlxd85d4c8ca9ea]: error adding interface: wpa_suppl NetworkManager[1067]: <info> [1552139792.1040] device (wlxd85d4c8ca9ea): supplicant interface state: starting -> down NetworkManager[1067]: <warn> [1552139801.9784] device (wlxd85d4c8ca9ea): re-acquiring supplicant interface (#4). NetworkManager[1067]: <error> [1552139802.0877] sup-iface[0x12e1f40,wlxd85d4c8ca9ea]: error adding interface: wpa_suppl NetworkManager[1067]: <info> [1552139802.0878] device (wlxd85d4c8ca9ea): supplicant interface state: starting -> down NetworkManager[1067]: <warn> [1552139811.9781] device (wlxd85d4c8ca9ea): re-acquiring supplicant interface (#5). NetworkManager[1067]: <error> [1552139812.1037] sup-iface[0x1313008,wlxd85d4c8ca9ea]: error adding interface: wpa_suppl NetworkManager[1067]: <info> [1552139812.1038] device (wlxd85d4c8ca9ea): supplicant interface state: starting -> down NetworkManager[1067]: <info> [1552139812.1039] device (wlxd85d4c8ca9ea): supplicant interface keeps failing, giving up

che cosa posso fare? grazie in anticipo.

coll. permanente

ha risposto 09 Mar, 20:53

Tanaka's gravatar image

Tanaka
201

non compare la mia risposta, vediamo se provo a commentare...

(09 Mar, 20:57) Tanaka Tanaka's gravatar image

con il comando systemctl list ottengo:

systemctl list-unit-files UNIT FILE STATE
proc-sys-fs-binfmt_misc.automount static
-.mount generated
dev-hugepages.mount static
dev-mqueue.mount static
home.mount generated
proc-sys-fs-binfmt_misc.mount static
sys-fs-fuse-connections.mount static
sys-kernel-config.mount static
sys-kernel-debug.mount static
acpid.path enabled
apport-autoreport.path enabled
cups.path enabled
systemd-ask-password-console.path static
systemd-ask-password-plymouth.path static
systemd-ask-password-wall.path static
session-3.scope transient
session-c1.scope transient
accounts-daemon.service enabled
acpid.service disabled
alsa-restore.service static
alsa-state.service static
alsa-utils.service masked

coll. permanente

ha risposto 09 Mar, 21:20

Tanaka's gravatar image

Tanaka
201

(09 Mar, 21:35) sacarde sacarde's gravatar image

si, ha sempre funzionato perfettamente, da anni. peraltro, avevo già testato 18.04 con un avanzamento, ma evidentemente in fresh install questa volta non ho conservato i vecchi servizi e temo che tutto dipenda dai nuovi kernel (ci sono anche altri problemi). quando ho fatto l'avanzamento, per esempio, mi aveva conservato unity e lightDM.

non so cosa guardare in particolare nella pagina che mi indichi, vorrei piuttosto capire come far funzionare via CLI o altro il network manager con gnome.

(09 Mar, 22:15) Tanaka Tanaka's gravatar image
(10 Mar, 09:09) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×436
×84
×20

domanda posta: 08 Mar, 17:22

domanda visualizzata: 176 volte

ultimo aggiornamento: 10 Mar, 09:09

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.