Salve,

avrei intenzione di aggiornare l'intera suite LibreOffice alla versione 4.1 visto che da repo ufficiali di Ubuntu è ferma alla versione 3.6 per Precise. Ho visto che il seguente ppa

http://ppa.launchpad.net/libreoffice/libreoffice-4-1/ubuntu

contiene i pacchetti per Precise, perciò non dovrebbero esserci problemi. Per iniziare, è corretto?

Successivamente vorrei chiedere lumi su una questione che non mi è chiara: su alcune guide reperibili su internet raccomandano fortemente di disinstallare completamente la versione 3.6 prima di procedere ad aggiungere il ppa ed installare LO 4.1 mentre altrettante altre sostengono che ciò non sia per nulla necessario. Quale delle due scuole di pensiero merita credito? Qualora servisse la disinstallazione totale, qual è il comando giusto da terminale per essere certi che non rimanga nulla?

Infine, per maggiore sicurezza, assumendo che si sia preventivamente proceduto alla disinstallazione completa della vecchia versione, i comandi da dare sarebbero

sudo add-apt-repository ppa:libreoffice/libreoffice-4-1
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libreoffice
sudo apt-get install libreoffice libreoffice-l10n-it libreoffice-help-it

Sono corretti?

Grazie per il vostro aiuto.

chiesto 20 Ott '13, 15:24

Jeerva's gravatar image

Jeerva
2056918

modificato 21 Ott '13, 13:54


Da terminale:

sudo apt-get remove --purge libreoffice*
sudo apt-get clean
sudo apt-get autoremove

Così hai terminato e puoi installare la nuova versione di LO. Se però volessi rimuovere qualsiasi voce dal sistema:

locate libreoffice | less

Il terminale ti restituirà una serie di percorsi verso piccoli files di LO, ininfluenti e trascurabili. Se li vuoi rimuovere, lo devi fare manualmente entrando nel file manager come root. Alla fine installi il nuovo LibreOffice.

coll. permanente

ha risposto 21 Ott '13, 08:48

Beppe's gravatar image

Beppe
68718

modificato 21 Ott '13, 08:58

enzotib's gravatar image

enzotib ♦♦
14.0k112186

@beppe grazie mille. Quindi è meglio prima disinstallare la versione precedente. Per quel che riguarda la successiva installazione, invece? Vanno bene i comandi che ho scritto nella domanda? Ed il ppa è quello giusto oppure è meglio quello che termina con "libreoffice" senza specificare "4-1"? Grazie ancora.

(21 Ott '13, 11:04) Jeerva Jeerva's gravatar image
1

sudo add-apt-repository ppa:libreoffice/ppa sudo apt-get update sudo apt-get install libreoffice e avrai LO 4.1

(21 Ott '13, 12:14) Beppe Beppe's gravatar image

@beppe perfetto. Grazie!

(21 Ott '13, 13:01) Jeerva Jeerva's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×263
×185
×42
×13

domanda posta: 20 Ott '13, 15:24

domanda visualizzata: 4,275 volte

ultimo aggiornamento: 21 Ott '13, 13:54

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.