ciao ragazzi ho appena installato xubuntu e non capisco perchè per avviarsi ci mette un eternità 4 o 5 minuti poi una volta avviato va alla grande.. anche per spegnersi ci mette un po.. preciso che il mio pc non è nuovissimo ma con windows in un minuto partiva.. P.S. non me ne intendo molto di pc quindi vi chiedo una mano grazie.

chiesto 09 Apr '19, 18:58

fra993's gravatar image

fra993
30223

modificato 14 Apr '19, 19:12

1

per analizzare il boot ci sono:

systemd-analyze critical-chain

systemd-analyze blame

(09 Apr '19, 20:59) sacarde sacarde's gravatar image

francesco@francesco-HP-Compaq-6720s:~$ systemd-analyze Startup finished in 35.800s (kernel) + 15min 55.011s (userspace) = 16min 30.812s graphical.target reached after 1min 28.007s in userspace

coll. permanente

ha risposto 10 Apr '19, 11:18

fra993's gravatar image

fra993
30223

1

in effetti....

ha qualcosa di particolare?

p.s.

systemd-analyze critical-chain

systemd-analyze blame

(10 Apr '19, 11:22) sacarde sacarde's gravatar image
francesco@francesco-HP-Compaq-6720s:~$ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @1min 28.007s
└─multi-user.target @1min 28.006s
  └─snapd.service @13min 12.010s +215ms
    └─snapd.socket @9min 11.195s +5ms
      └─sysinit.target @43.954s
        └─systemd-journald.service @14min 11.664s +114ms
          └─systemd-journald-dev-log.socket @2.993s
            └─system.slice @2.845s
              └─-.slice @2.839s
coll. permanente

ha risposto 10 Apr '19, 11:32

fra993's gravatar image

fra993
30223

francesco@francesco-HP-Compaq-6720s:~$ systemd-analyze blame
   13min 32.064s apt-daily-upgrade.service
    1min 20.089s apt-daily.service
         32.821s plymouth-quit-wait.service
         32.812s lightdm.service
         32.393s plymouth-start.service
         11.817s dev-sda1.device
          9.942s NetworkManager.service
          8.140s udisks2.service
          7.793s NetworkManager-wait-online.service
          7.562s systemd-sysctl.service
          6.308s networkd-dispatcher.service
          6.222s ModemManager.service
          6.203s accounts-daemon.service
          5.524s gpu-manager.service
          4.574s apparmor.service
          4.284s console-setup.service
          4.282s systemd-udevd.service
          4.281s plymouth-read-write.service
          4.214s systemd-tmpfiles-setup-dev.service
          3.707s thermald.service
          3.004s grub-common.service
          2.814s rtkit-daemon.service
          2.651s keyboard-setup.service
lines 1-23...skipping...
   13min 32.064s apt-daily-upgrade.service
    1min 20.089s apt-daily.service
         32.821s plymouth-quit-wait.service
         32.812s lightdm.service
         32.393s plymouth-start.service
         11.817s dev-sda1.device
          9.942s NetworkManager.service
          8.140s udisks2.service
          7.793s NetworkManager-wait-online.service
          7.562s systemd-sysctl.service
          6.308s networkd-dispatcher.service
          6.222s ModemManager.service
          6.203s accounts-daemon.service
          5.524s gpu-manager.service
          4.574s apparmor.service
          4.284s console-setup.service
          4.282s systemd-udevd.service
          4.281s plymouth-read-write.service
          4.214s systemd-tmpfiles-setup-dev.service
          3.707s thermald.service
          3.004s grub-common.service
          2.814s rtkit-daemon.service
          2.651s keyboard-setup.service
          2.559s systemd-tmpfiles-clean.service
          2.050s hddtemp.service
          1.990s fwupd.service
          1.658s swapfile.swap
          1.288s upower.service
          1.274s user@1000.service
          1.211s apport.service
          1.169s avahi-daemon.service
          1.129s systemd-remount-fs.service
          1.114s speech-dispatcher.service
          1.108s dev-mqueue.mount
          1.106s dev-hugepages.mount
          1.102s sys-kernel-debug.mount
          1.094s pppd-dns.service
          1.054s rsyslog.service
          1.002s systemd-logind.service
           993ms lm-sensors.service
           985ms systemd-modules-load.service
           812ms systemd-tmpfiles-setup.service
           698ms systemd-rfkill.service
           674ms wpa_supplicant.service
           342ms packagekit.service
           276ms systemd-random-seed.service
           271ms ufw.service
lines 1-47
coll. permanente

ha risposto 10 Apr '19, 11:33

fra993's gravatar image

fra993
30223

1

hai installato pacchetti con snap?

snap list

p.s. da: sudo software-properties-gtk

quando verifichi gli aggiornamenti? (aggiornamenti)

(10 Apr '19, 11:43) sacarde sacarde's gravatar image

No, non ho installato niente, ho solo installato il sistema operativo.

(10 Apr '19, 11:51) fra993 fra993's gravatar image
1
  • la rete e' tutto a posto?

  • prova mettere "verifica aggiornamenti automatico" mai

(10 Apr '19, 11:53) sacarde sacarde's gravatar image

Per quanto riguarda la rete non c'è nessun problema, ho disattivato gli aggiornamenti automatici ma non cambia niente, all'avvio il pc si blocca su una schermata nera per 4 5 minuti e poi parte

(10 Apr '19, 12:17) fra993 fra993's gravatar image
1
  • prova a togliere i parametri passati al kernel "quiet splash"

premi "e" sulla voce del menu di grub, poi sulla riga "linux ...." togli i parametri "quiet splash" in fondo e avvia : ctrl-x

per vedere dove si ferma il boot

(10 Apr '19, 13:18) sacarde sacarde's gravatar image

Ho fatto ciò che mi hai detto

(10 Apr '19, 19:51) fra993 fra993's gravatar image
1

-avviando senza quei 2 parametri dovresti vedere dei messaggi dei servizi avviati con un [OK] , confermi?

in quale punto rallenta?

(10 Apr '19, 20:22) sacarde sacarde's gravatar image
1
(10 Apr '19, 21:21) sacarde sacarde's gravatar image

ho seguito le indicazioni che danno in quel link ma niente.. cercando un po in rete altri con il pc simile al mio hanno lo stesso problema.. comunque la scheda video è: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller (rev 0c)

(11 Apr '19, 00:12) fra993 fra993's gravatar image
1
  • il parametro lo ha preso? che vedi da: cat /proc/cmdline

  • quali drive video usi? lo vedi da: inxi -G

  • una volta impostato "aggiornamento automatico mai" cosa vedi da: systemd-analyze blame

(11 Apr '19, 08:47) sacarde sacarde's gravatar image

FUNZIONA!!! Ho riprovato questa mattina ad aggiungere quel parametro e il pc si avvia subito.. Evidentemente ieri sera ho sbagliato qualcosa... Grazie mille per l'aiuto

(11 Apr '19, 10:34) fra993 fra993's gravatar image

quale parametro , anche io ho lo stesso problema come hai fatto?

(11 Apr '19, 14:17) Hacker18 Hacker18's gravatar image

copio e incollo da un altro forum: This is a bug. To avoid delay you can use workaround. From terminal run:

  1. sudo nano /etc/default/grub

Then add the kernel boot parameter: video=SVIDEO-1:d, so it will look like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

  1. sudo update-grub
  2. sudo reboot
(12 Apr '19, 13:34) fra993 fra993's gravatar image

funziona??

(12 Apr '19, 14:24) Hacker18 Hacker18's gravatar image

si a me ha funzionato

(12 Apr '19, 19:36) fra993 fra993's gravatar image

quanto tempo ci mette ad avviarsi?

(14 Apr '19, 14:21) Hacker18 Hacker18's gravatar image

poco meno di un minuto

(14 Apr '19, 19:09) fra993 fra993's gravatar image

io avrei qualche pacchetto come > flightgear che è snapd

guarda qui > https://pastebin.ubuntu.com/p/TdKHsg8TpV/

e ho notato che non riesco più a rimuoverlo tra l'altro

(09 May, 20:23) lorenzo-z lorenzo-z's gravatar image

in più i comandi come " sudo software-properties-gtk" e "ctrl-x" non me li prende il terminale

(09 May, 20:47) lorenzo-z lorenzo-z's gravatar image

che errore hai?

(09 May, 21:01) sacarde sacarde's gravatar image

a me il parametro in uscita lo da diverso da come doveva essere inserito per il grub

https://pastebin.ubuntu.com/p/cdxXHj37xP/

coll. permanente

ha risposto 09 May, 20:50

lorenzo-z's gravatar image

lorenzo-z
10135

nei parametri tipo:

quiet

splash

video=SVIDEO-1:d

vt.handoff=7

non ha importanza l'ordine di immissione

(09 May, 21:01) sacarde sacarde's gravatar image

okay, però ci sta mettendo sempre più di 3 minuti all'avvio

(09 May, 21:07) lorenzo-z lorenzo-z's gravatar image

https://pastebin.ubuntu.com/p/FyQNn9b6Wv/ magari tu vedi altro che non va

(09 May, 21:10) lorenzo-z lorenzo-z's gravatar image

https://pastebin.ubuntu.com/p/x4XmksPF9b/ poi sto vedendo qui > https://pastebin.ubuntu.com/p/KHFP2jhzQv/ se modifico qualcosa come riportato qui, quindi elimino e metto solamente

cat /etc/systemd/journald.conf ...

See journald.conf(5) for details.

[Journal]

Storage=auto

Storage=volatile

(10 May, 09:05) lorenzo-z lorenzo-z's gravatar image

che vedi da: xrandr

(10 May, 09:14) sacarde sacarde's gravatar image
(10 May, 09:59) lorenzo-z lorenzo-z's gravatar image

potresti provare a mettere come parametro:

video=LVDS-1:d

(10 May, 10:16) sacarde sacarde's gravatar image

perdona la domanda, ma dove lo inserisco ? qui > sudo nano /etc/default/grub

?

(10 May, 12:42) lorenzo-z lorenzo-z's gravatar image

okay, ho scelto la seconda strada permanente, ma non funziona

ecco > https://pastebin.ubuntu.com/p/z8cg2Byw4x/

(10 May, 14:43) lorenzo-z lorenzo-z's gravatar image

cioe... hai editato il file /etc/default/grub

e sostituito il parametro "video=SVIDEO-1:d" con "video=LVDS-1:d"

e poi: sudo update-grub

ti da errore questo comando?

(10 May, 15:07) sacarde sacarde's gravatar image

Ciao, ho fatto entrambe le prove, ammesso che le abbia fatte bene, ma mi ha dato diversi problemi all'avvio, tra cui non partiva più e avevo lo schermo nero. Ora è tornato attivo ma ha sempre con la lentezza di prima e anche nelle fasi iniziali sembra troppo appesantito Boh, non so che altri tentativi fare a questo punto

https://pastebin.ubuntu.com/p/rJSd3vCMKf/

(10 May, 23:25) lorenzo-z lorenzo-z's gravatar image

per vedere se hai messo i parametri giusti:

cat /proc/cmdline

(10 May, 23:30) sacarde sacarde's gravatar image

lorenzo@lorenzo-Satellite-A200:~$ cat /proc/cmdline BOOT_IMAGE=/boot/vmlinuz-5.8.0-50-generic root=UUID=772ba1dd-6533-43db-83f3-a7630a8a34f1 ro recovery nomodeset dis_ucode_ldr

(10 May, 23:48) lorenzo-z lorenzo-z's gravatar image

sono dovuto ricorrere al recovery mode dove mi ha impostato un generico

(10 May, 23:49) lorenzo-z lorenzo-z's gravatar image
  • quindi non hai provato col parametro: "video=LVDS-1:d" ?

  • col recovery come sono i tempi?

(11 May, 08:19) sacarde sacarde's gravatar image

nono ho provato, ma è prorpio quello che non mi fa più partire il pc col recovery poco meno lento

(11 May, 20:16) lorenzo-z lorenzo-z's gravatar image

prova a togliere del tutto il parametro "video=....." e a mettere "nomodeset"

(11 May, 20:56) sacarde sacarde's gravatar image

altro modo per guadagnare tempo e' posticipare il servizio:

apt-daily.service

come dicono qui (risposta 3) https://askubuntu.com/questions/800479/ubuntu-16-04-slow-boot-apt-daily-service

(11 May, 21:04) sacarde sacarde's gravatar image

va bene grazie, ora le ho appena provate entrambe ti posto il risultato di systemd analyze blame

https://pastebin.ubuntu.com/p/v8m5RPFttv/

(11 May, 22:37) lorenzo-z lorenzo-z's gravatar image

mmm non ho mica capito bene, questo soggetto non sa calcolare quanto tempo effettivo il suo pc impieghi a trovare la quadra dei boot, però non vedo molto cosa centri col mio...detto ciò ho rilanciato

systemd-analyze && systemd-analyze blame

e la situazione è la medesima

https://pastebin.ubuntu.com/p/dghkYTS8ny/

(12 May, 13:22) lorenzo-z lorenzo-z's gravatar image

okay, provato anche così ma questo il risultato > https://pastebin.ubuntu.com/p/YGZWhDRrn3/

(12 May, 17:15) lorenzo-z lorenzo-z's gravatar image

proviamo a aggiornare snapd:

sudo apt update && sudo apt install snapd

p.s. cosa c'e' in sda5?

(12 May, 17:43) sacarde sacarde's gravatar image

aggiornato ora, in dev-sda5.device bella domanda, come faccio a vederlo?

https://pastebin.ubuntu.com/p/bz8Zvkmnqf/

(12 May, 22:17) lorenzo-z lorenzo-z's gravatar image

da: df -HT

(12 May, 23:33) sacarde sacarde's gravatar image

sda5 e' tutto il sistema ...

quindi non ci sono stati benefici...

p.s.

che vedi da: journalctl -b --unit systemd-journald

(13 May, 08:22) sacarde sacarde's gravatar image
coll. permanente

ha risposto 13 May, 08:30

lorenzo-z's gravatar image

lorenzo-z
10135

si potrtebbe mettere nel file: /etc/systemd/journald.conf

valori tipo:

SystemMaxFileSize=50M

Storage=volatile

salvare e riavviare

(13 May, 08:46) sacarde sacarde's gravatar image

su Password: root@lorenzo-Satellite-A200:/home/lorenzo# /etc/systemd/journald.conf bash: /etc/systemd/journald.conf: Permesso negato root@lorenzo-Satellite-A200:/home/lorenzo# root@lorenzo-Satellite-A200:/home/lorenzo# exit exit lorenzo@lorenzo-Satellite-A200:~$ /etc/systemd/journald.conf bash: /etc/systemd/journald.conf: Permesso negato lorenzo@lorenzo-Satellite-A200:~$

(13 May, 09:04) lorenzo-z lorenzo-z's gravatar image

forse devo scrivere sudo nano ....

(13 May, 09:06) lorenzo-z lorenzo-z's gravatar image

ma dove li aggiungo, alla fine ? devo cancellare qualcosa ?

(13 May, 09:07) lorenzo-z lorenzo-z's gravatar image

li ho inseriti alla fine con sudo nano /etc... e adesso ti posto il risultato di sys analyze blame > https://pastebin.ubuntu.com/p/sWQGSBxfzx/

(13 May, 09:15) lorenzo-z lorenzo-z's gravatar image

si devi editare il file con: sudo nano ...ecc..

all'interno dovresti trovare gia' i parametri commentati, togli il # e metti il valore suddetto

(13 May, 09:19) sacarde sacarde's gravatar image

ho fatto così, ma sei sicuro che debbo togliere il cancelletto?

https://pastebin.ubuntu.com/p/CmfZbPrnMC/

(13 May, 09:55) lorenzo-z lorenzo-z's gravatar image

lasciando il cancelletto risulta un commento

ecco da dove ho preso https://askubuntu.com/questions/1094389/what-is-the-use-of-systemd-journal-flush-service

(13 May, 10:02) sacarde sacarde's gravatar image

non vedo cambiamenti però > https://pastebin.ubuntu.com/p/5QnZWtM5Wr/

(13 May, 10:39) lorenzo-z lorenzo-z's gravatar image

altre prove

https://itectec.com/ubuntu/ubuntu-extremely-slow-ubuntu-18-04-boot-time/

p.s. sinceramente non so cos'altro farti provare

p.s. potresti chiedere sul forum italiano o internazionale, c'e' un po' piu gente che legge

(13 May, 10:40) sacarde sacarde's gravatar image

okay, la terrò presente, ma aprendolo mi sono reso conto che è identico, e ho paura a disabilitare nm come dice all'ultimo punto 2) If you're not using your computer remotely by yourself or someone else you can disable the NetworkManager-wait-online.service which just make sure networking is online and available by running sudo systemctl disable NetworkManager-wait-online.service.

(13 May, 10:58) lorenzo-z lorenzo-z's gravatar image

quindi il collo di bottiglia adesso quale e'?

snapd.service

qui lo disabilitano.... mah https://serverfault.com/questions/1044689/how-do-i-stop-snaps-mounting-during-boot-on-ubuntu-18-04

ma nei nuovi sistemi la pacchettizzazione e' sempre piu utilizzata

p.s. il servizio NetworkManager-wait-online.service non e' NetworkManager.service

(13 May, 11:10) sacarde sacarde's gravatar image

ma l'ho disabilitato, anzi proprio rimosso, ma nulla è ancora presente anche se dice che sarebbe permanente

(13 May, 11:36) lorenzo-z lorenzo-z's gravatar image

non puoi rimuoverlo, e' richiesto dai pacchetti "snap"

credo ne hai molti: snap list

https://wiki.ubuntu-it.org/AmministrazioneSistema/InstallareProgrammi/PacchettiSnap

(13 May, 11:43) sacarde sacarde's gravatar image

ah, :/ allora mi sa che me la farò andare bene così a sto punto

(13 May, 11:54) lorenzo-z lorenzo-z's gravatar image

però scusa, come prima avevo usato il comando anche per snapd e adesso guarda mi dice così > ~$ sudo systemctl disable NetworkManager-wait-online.service [sudo] password di lorenzo: Removed /etc/systemd/system/network-online.target.wants/NetworkManager-wait-online.service.

(13 May, 11:57) lorenzo-z lorenzo-z's gravatar image
  • anche snapd diceva "Removed"?

  • li vedi dalla lista generale?

sudo systemctl list-unit-files

(13 May, 13:36) sacarde sacarde's gravatar image

anche su snapd diceva ( removed ) ecco > https://pastebin.ubuntu.com/p/kJ8QtDNSp6/

(13 May, 15:36) lorenzo-z lorenzo-z's gravatar image

non vengono cancellati ma possono essere richiamati da delle dipendenze

(13 May, 17:15) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×290
×209
×18
×5

domanda posta: 09 Apr '19, 18:58

domanda visualizzata: 2,222 volte

ultimo aggiornamento: 13 May, 17:15

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.