Improvvisamente nella schermata di un utente scompare l'icona audio in alto a destra (prima c'era e l'audio funzionava). Nelle impostazioni audio non figura nessuna scheda audio. Da terminale con cat /proc/asound/cards: 0 [PCH ]: HDA-Intel - HDA Intel PCH HDA Intel PCH at 0xdf140000 irq 124 1 [NVidia ]: HDA-Intel - HDA NVidia HDA NVidia at 0xdf080000 irq 17 Conseguenza di un aggiornamento? Soluzioni?

chiesto 13 Apr, 22:23

argonautilus174's gravatar image

argonautilus174
10

  • da alsamixer la vedi? con F6

  • da /var/log/apt/history.log vedi rimozioni di software?

  • hai aggiornato anche il kernel?

(14 Apr, 08:58) sacarde sacarde's gravatar image

Buongiorno Sacarde! Si, da alsamixer mi sembra elencata.0 hda intel pch / 1 hda nvidia.

L'history log contiene 192 righe nelle quali non so muovermi, suggerimenti?

Questo che segue potrebbe essere l'ultimo aggiornamento del kernel da dpkg? ...2019-04-11 13:47:28 status installed libunistring2:amd64 0.9.9-0ubuntu2 2019-04-11 13:47:28 startup archives unpack 2019-04-11 13:47:28 upgrade ufw:all 0.35-5 0.36-0ubuntu0.18.04.1 2019-04-11 13:47:28 status half-configured ufw:all 0.35-5 2019-04-11 13:47:28 status unpacked ufw:all 0.35-5 2019-04-11 13:47:28 status half-installed ufw:all 0.35-5 2019-04-11 13:47:28 status triggers-pending systemd:amd64 237-3ubuntu10.19...

coll. permanente

ha risposto 14 Apr, 09:57

argonautilus174's gravatar image

argonautilus174
10

se hai un kernel vecchio lo dovresti trovare nel menu avanzato di grub, proverei a avviare quello

(14 Apr, 10:15) sacarde sacarde's gravatar image

Questo potrebbe essere l'aggiornamento kernel nell'history.log? Start-Date: 2019-04-02 21:30:27 Commandline: aptdaemon role='role-commit-packages' sender=':1.73' Install: linux-modules-extra-4.18.0-17-generic:amd64 (4.18.0-17.18~18.04.1, automatic)

(14 Apr, 10:22) argonautilus174 argonautilus174's gravatar image

per vederlo dai pacchetti installati:

dpkg -l|grep linux

(14 Apr, 10:29) sacarde sacarde's gravatar image

Ho risposto troppo in fretta, sorry. Sto studiando l'history.log. Ci sono un paio di remove-packages: A -ubuntu-web-launchers:amd64; B -libconfig9:amd64 (1.5-0.4), python3-setproctitle:amd64 (1.1.10-1build2), python-mate-menu:amd64 (1.20.0-2), python2.7-minimal:amd64 (2.7.15~rc1-1ubuntu0.1), libmate-desktop-2-17:amd64 (1.20.1-2ubuntu1), mate-panel:amd64 (1.20.1-3ubuntu1), mate-desktop-common:amd64 (1.20.1-2ubuntu1), python2.7:amd64
Ma non riconosco nulla che ricordi Audio

(14 Apr, 10:52) argonautilus174 argonautilus174's gravatar image
  • ma hai anche l'ambiente "mate" ?

  • hai visto se hai piu' di un kernel?

(14 Apr, 11:09) sacarde sacarde's gravatar image

(0.1~beta2+20150922-1), mate-desktop:amd64 (1.20.1-2ubuntu1), libmate-menu2:amd64 (1.20.0-2), libmateweather-common:amd64 (1.20.0-1), libmateweather1:amd64 (1.20.0-1), mate-tweak:amd64 (18.04.16-1), menu:amd64 (2.1.47ubuntu2.1), mate-menus:amd64 (1.20.0-2), libmate-panel-applet-4-1:amd64 (1.20.1-3ubuntu1), mate-user-guide:amd64 (1.20.0-1), libido3-0.1-0:amd64 (13.10.0+17.04.20161028-0ubuntu1), mate-panel-common:amd64 (1.20.1-3ubuntu1), mate-indicator-applet:amd64 (1.20.0-1), python-minimal:amd64 (2.7.15~rc1-1), mate-indicator-applet-common:amd64 (1.20.0-1) End-Date: 2019-04-03 10:24:12

(14 Apr, 11:38) argonautilus174 argonautilus174's gravatar image
  • ma sei su ubuntu o ubuntu-mate?

  • che vedi: dpkg -l|grep linux

(14 Apr, 11:52) sacarde sacarde's gravatar image

Ma le rimozioni software e la versione kernel che mi hai chiesto ti suggeriscono qualcosa?

Non credo di avere vecchi kernel considerato che ho installato il 18.04 una settimana fa e ho fatto un solo aggiornamento software in questo periodo.

Mate non so cosa sia. Studierò. Ha a che fare con l'audio?

dpkg -l|grep linux è un comando da dare nel terminale?

coll. permanente

ha risposto 14 Apr, 13:07

argonautilus174's gravatar image

argonautilus174
10

  • mate e' un ambiente grafico come lo e' KDE, Gnome ecc..

  • " dpkg -l|grep linux " mostra i pacchetti del kernel

  • da alsamixer o pavucontrol i volumi sono alzati?

  • da "aplay /usr/share/sounds/alsa/*" senti qualcosa?

(14 Apr, 13:39) sacarde sacarde's gravatar image

Questi sono i risultati: ii linux-image-4.18.0-15-generic 4.18.0-15.16~18.04.1 amd64 Signed kernel image generic ii linux-image-4.18.0-17-generic 4.18.0-17.18~18.04.1 amd64 Signed kernel image generic ii linux-image-generic-hwe-18.04 4.18.0.17.67 amd64 Generic Linux kernel image

Alsamixer: ho controllato e alzato i volumi sull'utente "muto", nulla di fatto.

Aplay: SORPRESA!!! Sento i vari controlli centro, destro, sinistro ed altro

(15 Apr, 09:23) argonautilus174 argonautilus174's gravatar image

proverei da "pavucontrol" a gestire le entrate delle applicazioni

(15 Apr, 09:29) sacarde sacarde's gravatar image

Commenti sui kernel? Va bene. Non va bene. La "sorpresa" di apley? valutazioni? Il "proverei" mi lascia un po' spiazzato. Pavucontrol non è installato. Se lo installo ho qualche ragione di veder comparire l'icone dell'audio in alto a destra?

(15 Apr, 11:22) argonautilus174 argonautilus174's gravatar image
  • se aplay funziona, la scheda in se va bene... (quindi anche cambiando kernel)

  • pavucontrol non c'e' installato??

  • per l'icona credo ci sia un'applet apposita in gnome (mi informo)

(15 Apr, 11:46) sacarde sacarde's gravatar image

No, pavucontrol non è installato. Grazie del tempo che mi dedichi.

(15 Apr, 12:02) argonautilus174 argonautilus174's gravatar image
(15 Apr, 13:39) sacarde sacarde's gravatar image

E' proprio quello che manca nella barra in alto a destra. C'è il simbolo dell'ethernet, quello per lo spegnimento ma non c'è quello dell'altoparlante. La cosa strana è che sull'utente amministratore c'è e funziona tutto e sul secondo utente manca.

Provo ad installare pavucontrol. Grazie

(15 Apr, 21:49) argonautilus174 argonautilus174's gravatar image

Buon giorno! Chiedo scusa ma mi sono allontanato per un po'. Niente neanche con pavucontrol si è risolto qualcosa. Ho scopreto una particolarità: se clicco destro fra il simbolo ethernet e lo spegnimento si apre la tendina in cui compare, oltre al nome utente e l'etherrnet colegato, un cursore senza simbolo dell'altoparlante in posizione 0 (se provo ad alzare non ci sono effetti sull'audio) ed un cursore con il microfono (che però non ho collegato). Il mistero si infittisce! :-/

(17 Apr, 14:32) argonautilus174 argonautilus174's gravatar image

Ovviamente quanto sopra accade nella pagina del secondo utente mentre in quella dell'utente principale funziona tutto con l'audio.

(17 Apr, 14:34) argonautilus174 argonautilus174's gravatar image
  • l'utente principale intendi "root" ?

  • il comando "aplay ...." funziona su tutti e due gli utenti?

(17 Apr, 14:55) sacarde sacarde's gravatar image

Nella scheda utenti compaio due utenti. Dovrebbe comparire un terzo utente amministratore? Si. Aplay.... funziona anche sul primo utente.

(17 Apr, 17:07) argonautilus174 argonautilus174's gravatar image
  • dalla consolle per vedere quale utente sei: whoami

  • per vedere la lista di gruppi a cui l'utente appartiene: groups

eseguilo per i 2 utenti per vedere se appartengono agli stessi gruppi

(17 Apr, 17:27) sacarde sacarde's gravatar image

utente principale: whoami = nome; groups = nome adm cdrom sudo dip plagev lpadmin sambashare Secondo utente: whoami = nome; groups= nome

Ti dice qualcosa?

(17 Apr, 21:47) argonautilus174 argonautilus174's gravatar image

Fatta la prova. Riavviato e verificato le impostazioni del secondo utente: nessun cambiamento. Una nota singolare: in avvio utente lo spazio fra l'icona ethernet e l'icona di spegnimento risulta legermente aperto come se vi fosse qualcosa, dopo qualche secondo le icone si uniscono.

(17 Apr, 22:21) argonautilus174 argonautilus174's gravatar image

Dopo aver dato un'occhiata più ampia al guide.debianizzati mi sta balenando l'idea di cancellare il secondo utente, ovviamente dopo aver fatto il backup, e ricreare l'account. Suggerimenti?

(17 Apr, 22:37) argonautilus174 argonautilus174's gravatar image

si, e' una prova da fare, anche se non lo vuoi cancellare puoi fare un terzo utente

(18 Apr, 08:51) sacarde sacarde's gravatar image

Mah, sono perplesso. Ho eliminato l'utente "problematico" come indicato nella guide.debianizzati, ricreato, con lo stesso nome e psw sono entrato per ricaricare il back up ma l'ho ritrovato uguale uguale. Pensavo si cancellassero tutte le impostazioni restituendo un utente "vergine". C'è una qualche procedura da far seguire al deluser nel terminale per arrivare ad una cancellazione più profonda?

(18 Apr, 10:53) argonautilus174 argonautilus174's gravatar image

cancellando l'utente dal comando non viene cancellato la sua /home (devi farlo a mano)

quindi hai solo ricreato l'entrata nel file utenti e password

o usare l'interfaccia grafica "utenti e gruppi" users-admin

(18 Apr, 11:06) sacarde sacarde's gravatar image

Qundi posso andare sul disco e cancellare la cartella utente?

(18 Apr, 11:38) argonautilus174 argonautilus174's gravatar image

come credi (anche rinominarla se hai dati sopra)

(18 Apr, 11:41) sacarde sacarde's gravatar image

Eureka!! Preventivamente, cercando di capire la procedura di eliminazione dell'utente, sono entrato nella cartella home dell'utente ed ho notato una serie di lucchetti grigi sulle cartelle e su alcuni file. Ho cercato in rete ed ho capito come si tolgono modificando i permessi. Ho trovato la cartella principale dell'utente impostata su root. Modificati da terminale, in favore dell'utente i parametri su tutte le cartelle e i file con lucchetto, sono rientrato sulla pagina utente e si mostrava in bella vista l'icona dell'altoparlante con i controlli attivi.

(18 Apr, 12:14) argonautilus174 argonautilus174's gravatar image

Al momento non mi so dare una spiegazione ma spero che la cosa sia di un qualche aiuto per altri utenti. Ringrazio sarcade per il tempo che mi ha dedicato, cordialità, Alessio

(18 Apr, 12:16) argonautilus174 argonautilus174's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×42

domanda posta: 13 Apr, 22:23

domanda visualizzata: 172 volte

ultimo aggiornamento: 18 Apr, 12:16

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.