salve a tutti è il mio primo approccio a ubuntu,provavo a installarlo su un nuovo pc per vedere un pò come si presentava e come mi trovavo ma non riesco a installarlo...ho seguito tutte le procedure per creare una usb ma arrivato alla schermata di istallazione dove scegliere le varie opzioni non fa niente la pagina è quella gnu grub 2.02 quella dove si sceglie se usarlo senza installarlo,istallazione oem check disc ecc ecc, l'unica cosa che fa è darmi questo errore su check disc: error:file '/casper/vmlinuz' not found error: you need to load the kernel first.

vedo ora che è un problema comune dato in certi casi dall estensione del file (.efi)(ma non è il mio caso) e da un errore dello scaricamento della iso (probabilmente il mio caso visto che il file non c è nella cartella casper dove dovrebbe essere).proverò a rifarla anche se ho provato un sacco di volte con due pennette diverse e funzionanti e con varie distro ma per una cosa o per l'altra mai andate a buon fine.

grazie del consiglio,sapevo che potevo controllare se c'erano errori prima,ma non credevo di essere così sfortunato da beccarmi l'errore per almeno 10 volte con diverse distro e con diverse penne usb che funzionano penna usb ri-preparata,non mi dava l'errore faccio partire la prova senza istallazione su ssd...schermata violetta di ubuntu con relativa scritta e pallini di caricamento appena sotto che lampeggiano come se stesse caricando il sistema operativo...ma mi pare che si sia bloccato tutto anche se i pallini si "muovono" ancora,ormai saranno 15 minuti che ho quella schermata e non è partito.

chiesto 25 Apr, 12:14

ince's gravatar image

ince
204

modificato 25 Apr, 17:19

puoi controllare l'md5sum anche sul file iso scaricato

(prima di metterlo sul supporto)

(25 Apr, 14:47) sacarde sacarde's gravatar image

grazie mille,non pensavo di errere così sfortunato,ho rifatto le pennine almeno 10 volte con diverse distro e con diverse penne...ora a quanto pare mi sta dando un altro problema rimane con schermo viola di istallazione con pallini in caricamento perpetuo

(25 Apr, 17:21) ince ince's gravatar image

per vedere eventuali errori devi togliere i parametri al kernel "quiet splash" e aggiungere "nomodeset"

https://wiki.ubuntu-it.org/Installazione/ParametriAvvio

(25 Apr, 17:27) sacarde sacarde's gravatar image

mi dava un errore cliccando f11 se non ricordo male nella prima riga riguardava un bug nel bios,poi semmai ti allego la stringa e poi un qualcosa riguardante il kernel ma non so dirti di più non sono così pratico,dopo cerco di trascrivere le due stringhe,nel frattempo ho provato un clear cmos ora rimane con lo schermo nero e un cursore lampeggiante

(25 Apr, 18:00) ince ince's gravatar image

se premi F6 entri in edit sulla riga dei parametri al kernel?

(25 Apr, 18:11) sacarde sacarde's gravatar image

questa è la schermata : https://ibb.co/YPRXVxD

(25 Apr, 18:30) ince ince's gravatar image

se clicco f6 o qualsiasi altro tasto(f) mi da sempre quella schermata

(25 Apr, 19:12) ince ince's gravatar image

non tutte le distro hanno la versione live

prova una delle *ubuntu e al menu iniziale premi F6 come si vede qui

https://wiki.ubuntu-it.org/Installazione/ParametriAvvio

(25 Apr, 20:22) sacarde sacarde's gravatar image

le ho provate un pò tutte questa che provavo dovrebbe essere ubuntu 18.04.2

(26 Apr, 12:38) ince ince's gravatar image

eccoti le schermate,la prima come ti avevo già spiegato fa parte del bios;alla prima accensione se clicco f6 mi da il messaggio di istant flash(evidentemente la mia scheda madre è impostata così)(ecco l'immagine: https://ibb.co/TKyc473 )

(26 Apr, 12:39) ince ince's gravatar image

chiusa quella pagina mi manda sul menu di ubuntu che ti dicevo che è questo: https://ibb.co/YtRP0pB dove la riga che tu vedi bianca perchè selezionata dice try ubuntu without installing(nessuna delle opzioni funziona)alcune mi mettono la pagina di ubuntu violetta che carica all'infinito.

(26 Apr, 12:39) ince ince's gravatar image

(il check del disco mi da la schermata che avevo caricato questa: https://ibb.co/YPRXVxD );nella parte sotto come puoi vedere ho un opzione per andare sulla command line e la schermata risultante con i comandi messi in vista con tab è questa: https://ibb.co/YPRXVxD spero così si capisca meglio quello che intendo

(26 Apr, 12:39) ince ince's gravatar image

ti ringrazio ancora dell'aiuto sacarde,le opzioni me le ha date anche prima ma non mi fa fare niente, con f6 la mia scheda madre avvia l'istant flash (aggiornamento del bios da usb credo)e giustamente mi dice no image file detected. ho una z370 gaming k6 e gli ho già aggiornato il bios alla terzultima versione,non ho scelto le ultime due perchè sono ancora acerbe e stanno dando problemi a molte persone l'acpi comunque l'ho disabilitato da bios. forse ci sono arrivato a capire cosa intendevi ora sono nella pagina di comando grub> e se clicco tab ho una lista di comandi da usare...ora provo quello che mi hai suggerito prima

coll. permanente

ha risposto 25 Apr, 21:29

ince's gravatar image

ince
204

modificato 25 Apr, 21:37

il BIOS --> lancia l'usb --> lancia Grub ---> lancia il sistema con i parametri del kernel

(25 Apr, 21:45) sacarde sacarde's gravatar image

eh sacarde non sono così pratico sto andando per tentativi perchè non so di preciso quello che intendi...da grub ho(tramite tab)una lista di comandi e molti li ho pure provati;in quella lista ci trovo xnu_kernel e xnu_kernel64 ma se li inserisco come comando mi da error:filename expected. ti ringrazio per la pazienza

(25 Apr, 22:18) ince ince's gravatar image

arrivi alla seconda videata?

(25 Apr, 23:40) sacarde sacarde's gravatar image

no come ti ho detto la mia schermata mette alcune di quelle opzioni ma in piccolo in alto a sinistra(in inglese) e alcune cose non ci sono in uno e alcune mancano nell'altro(tipo l'istallazione oem per gli installatori di pc assemblati(che è presente nel mio menu)

(26 Apr, 11:11) ince ince's gravatar image

la prima schermata neanche la vedo

(26 Apr, 11:13) ince ince's gravatar image

ma stiamo parlando di ubuntu?

non stiamo parlando del bios/uefi, no?

(26 Apr, 11:22) sacarde sacarde's gravatar image

certo che è ubuntu alcune schermate le ho pure messe(anche se non quella in particolare,ho scritto anche le opzioni usa ubuntu senza insttallare ecc) il bios è tutt altra cosa non mi da quelle opzioni... quella che ho messo non so se è di ubuntu di schermata...vedo di farti le foto alle altre così le puoi vedere,ma sono di ubuntu te lo assicuro

(26 Apr, 11:45) ince ince's gravatar image

ora sto provando a fare una chiavetta con windows 10,appena finisce carico le foto

(26 Apr, 11:52) ince ince's gravatar image
  • la videata postata sopra sembra quella di archlinux

  • quale iso hai scaricato?

p.s. https://wiki.ubuntu-it.org/Installazione/InstallareUbuntu

(26 Apr, 11:55) sacarde sacarde's gravatar image

eccoti le schermate,la prima come ti avevo già spiegato fa parte del bios;alla prima accensione se clicco f6 mi da il messaggio di istant flash(evidentemente la mia scheda madre è impostata così)(ecco l'immagine: https://ibb.co/TKyc473 ) chiusa quella pagina mi manda sul menu di ubuntu che ti dicevo che è questo: https://ibb.co/YtRP0pB dove la riga che tu veci bianca perchè selezionata dice try ubuntu without installing.cliccandole vado su ubuntu che carica all'infinito. sulla command line la schermata risultante con i comandi messi in vista con tab è questa: https://ibb.co/YPRXVxD

(26 Apr, 12:53) ince ince's gravatar image

prova dalla videata con "prova ubuntu senza installare"

premi "e" sulla prima riga

vai sulla riga: "linux ................."

e in fondo togli: "quiet splash" e aggiungi "nomodeset"

premi ctrl-x per avviare

(26 Apr, 13:53) sacarde sacarde's gravatar image

mi fa piacere che stia provando ad aiutarmi,ma così non si va avanti ti sto riscrivendo le cose ogni volta...se avessi la possibilità di fare le cose che dici avrei risolto da tempo(scusa la polemica ma le cose delle guide e le varie opzioni le ho provate ma nessuna mi ha risolto il problema).come ti ho già detto sia nel messaggio sopra sia alcuni messaggi fa se clicco su prova ubuntu senza installare(ma anche su installa ubuntu)mi manda sulla pagina violetta di ubuntu con i pallini che caricano all'infinito...purtroppo non ho righe su cui scrivere

(26 Apr, 14:25) ince ince's gravatar image
  • mah , anche in basso si legge che per editare l'entrata premere "e"

  • nelle iso che conosco io, si aggiungono i parametri premendo F6

mah, in effetti non so come altro aiutarti

(26 Apr, 14:45) sacarde sacarde's gravatar image

ti chiedo scusa,la e io non l'avevo neanche notata,ora la provo. per quanto riguarda f6 lo fa solo appena lo accendoaltrimenti mi rimanda alla prima schermata che ho messo;ossia questa: https://ibb.co/YPRXVxD (in quel caso era archlinux)la versione che sto usando ora è ubuntu 18.04.2...vedo di verificare se cambia qualcosa cliccando sulla e...ti ringrazio grazie per la pazienza...ho trovato la riga linux che dicevi e modificato la parte finale con nomodeset,come risultato mi ha dato una miriade di righe e ogni tanto ne sta aggiungendo delle altre,poi ti aggiorno

(26 Apr, 15:22) ince ince's gravatar image

ti ho scritto ma il messaggio è sparito. ti chiedo scusa la lettera "e" non l'avevo notata. ho fatto la prova e cambiato la riga linux con nomodeset;avviato e come risultato ho una miriade di righe e il cursore lampeggiante a fondo pagina.ti ringrazio per la pazienza e ti chiedo nuovamente scusa,ora con questa schermata che devo fare?la lascio fare ancora?

questo è quello che vedo ora(una parte) https://ibb.co/LZV5W6g

(26 Apr, 15:49) ince ince's gravatar image

mah... non ci capisco un granche'

se premi la "e" sulla prima voce del menu dovresti poter modificare i parametri da passare al kernel: quiet splash o aggiungere: nomodeset

vedi simile a queste guide? https://wiki.ubuntu-it.org/Installazione/InstallareUbuntu o https://wiki.ubuntu-it.org/Installazione/AvvioSupportoDiInstallazione

(26 Apr, 16:33) sacarde sacarde's gravatar image

è quello che ho fatto sacarde ho sostituito quella voce sulla riga linux,quel risultato dovrebbe dire quali sono gli errori che ci sono...ma io sinceramente non so decifrarli

(26 Apr, 16:52) ince ince's gravatar image

ah, non avevo capito, hai tolto "quiet splash" e messo "nomodeset" ok

poi con ctrl-x hai avviato il sistema

il sistema dovrebbe presentarti la grafica (come si vede dalle guide che ho elencato) mi descrivi dove si ferma? puoi fare il login? puoi mettere comandi?

(26 Apr, 16:57) sacarde sacarde's gravatar image

ti ho messo la foto dopo cambiato quella riga ha scritto per un bel pò la prima parte purtroppo non ho fatto a tempo a fotografarla poi si è fermato con questa schermata che ti ho messo sopra: https://ibb.co/LZV5W6g dove potevo scrivere qualcosa

(26 Apr, 17:20) ince ince's gravatar image
  • da quella schermata non si vede nessun prompt dove dare comandi

  • hai provato altre distribuzioni "live" e in nessuna e' partita la grafica? ho capito bene?

(26 Apr, 17:41) sacarde sacarde's gravatar image

si le ho provate quasi tutte ma non riesco a farle andare

(26 Apr, 19:18) ince ince's gravatar image
  • avevi mai installato linux su quel computer?

  • puoi vedere se i cd/dvd/usb su altri computer funzionano?

(26 Apr, 20:44) sacarde sacarde's gravatar image

non ho lettore dwd in quel pc le usb funzionano tutte ho provato sia le frontali sia le posteriori e l'istallazione comincia sempre,dovrei provare la distro su questo pc ma non so se posso far partire questo pc da usb,poi domani provo ssd e hdd su questo pc così vedo se funzionano.il pc è nuovo non ha mai avuto installato nessun sistema operativo...provato la usb su questo pc ma nonostante mi faccia mettere la usb come prima opzione non la fa partire e cerca il sistema operativo,ma quello è normale mi sembrava di ricordare che non partiva da usb il mio vecchio pc

(26 Apr, 21:59) ince ince's gravatar image
  • i controlli sul md5sum delle iso li hai fatti? oppure far partire la voce: check disc for defect

  • il pc nuovo cosa e' ?

(27 Apr, 08:47) sacarde sacarde's gravatar image

ciao sacarde,ho controllato e letto qualcosa su md5sum ma non ho capito bene come fare per vedere se la iso è integra o no(la cosa strana è che siano due pennine corrotte o tutte le installazioni scaricate).il check disk l'ho fatto e mi dava come errore quello che vedi nel primo messaggio ossia questo:error:file '/casper/vmlinuz' not found error: you need to load the kernel first.

(27 Apr, 14:27) ince ince's gravatar image

il pc nuovo è composto così:mainboard z370 gaming k6 (a cui ho aggiornato il bios alla penultima versione dopo i problemi di installazione) processore intel i5 8600k alimentatore seasonic focus platinum 650w(con voltaggi perfetti visti su bios)ddr4 3200 mhz g skill (mi pare), scheda video rx 570 8 gb. in ogni caso...ho fatto qualche progresso ma sicuramente mi servirà anche un tuo aiuto.

(27 Apr, 14:28) ince ince's gravatar image

sono riuscito tramite rescatux a fare qualche controllo(sì hai capito bene rescatux è partito:-) )controllando gparted ho notato una partizione del precedente tentativo di istallazione con un punto esclamativo giallo e su file sistem(dove dovrebbe esserci il tipo di partizione se non ricordo male c è scritto unknown e la partizione è nera. ora mi studio un pò il programma rescatux e vedo di sistemare qualcosa,se tu hai delle dritte su qualche procedimento o sulle cose che potrebbero risolvere fammi sapere...ti ringrazio per l'aiuto

(27 Apr, 14:28) ince ince's gravatar image

da sistemi linux c'e' il comando: md5sum .....file.iso

devi controllare i valori dal sito dove scarichi (i rispettivi md5sum)

p.s. rescatux e' del 2017, no?

(27 Apr, 14:39) sacarde sacarde's gravatar image

no io ho trovato anche video del 2012 di rescatux. eh a poterli usare i comandi linux...non ne partiva nessuno ecco l'immagine che dicevo : https://ibb.co/NtP0BXH

pare le la partizione riservata di microsoft sia corrotta tu che dici dipende dalla iso scaricata? ho fatto la prova su hdd e il risultato era identico,quella partizione non la segna in che modo è stata formattata ne da altre indicazioni,

(27 Apr, 15:24) ince ince's gravatar image

e queste sono le informazioni che ottengo se clicco sul punto esclamativo : https://ibb.co/BG89s4R

wuesto è l'errore trovato su usb: https://ibb.co/f4fhLvb

(27 Apr, 15:43) ince ince's gravatar image
  • mah, non saprei, comunque sono piccolissime: sda3 16MB e sdg2 1MB

  • se parte rescatux puoi controllare l'md5sum da li', opppure anche da windows (penso ci sara' un modo per calcolarlo anche da li')

oppure provare la funzione "check-disc for difect" che appare dal menu di ubuntu

(27 Apr, 17:23) sacarde sacarde's gravatar image

come ti avevo scritto il check disk l'ho fatto e mi dava come errore quello che vedi nel primo messaggio ossia questo:error:file '/casper/vmlinuz' not found error: you need to load the kernel first.vediamo se riesco a fare qualche progresso

(27 Apr, 21:59) ince ince's gravatar image

su gparted facendo un controllo sui dischi ottengo questo messaggio: La tabella GPT di backup è corrotta, ma la primaria appare OK, quindi verrà utilizzata.

(27 Apr, 23:18) ince ince's gravatar image
  • proverei a calcolare md5sum o sha... sull'iso

https://wiki.ubuntu-it.org/Installazione/MD5Sum

  • oppure proverei a riscaricare l'iso (dimmi dove la scarichi)
(27 Apr, 23:35) sacarde sacarde's gravatar image

non saprei come verificare l'md5sum. per la iso quale intendi? una qualsiasi di linux(ubuntu,lubuntu ecc)?per ora non mi azzardo a scaricarla;sulla usb da 32 gb dopo formattata non mi fa mettere nulla,sto provando a vedere se riesco a sistemarla;(probabilmente era quella corrotta)e su quella da 4 gb dove ho rescatux(il mio spiraglio di salvezza ahahahah)non vorrei metterci altro e lunedì ne prendo un'altra

(28 Apr, 00:21) ince ince's gravatar image

ho trovato un problema simile e anche una soluzione(qui: https://ubuntuforums.org/showthread.php?t=2361339 ) ma ora mi serve una distro che parta e una usb funzionante per provare a risolvere poichè con rescatux non saprei se c è un modo di avere il terminale...secondo te è nato da un problema di iso corrotta o è più probabile che la usb abbia "contaminato" l'ssd e l'hdd...quello che non capisco è come rimane questo problema se io comunque formatto tutto,che ci sia una specie di partizione nascosta che continua a trascinare quell'errore???

(28 Apr, 00:27) ince ince's gravatar image
(28 Apr, 08:37) sacarde sacarde's gravatar image

non sto cercando di sitemare una iso corrotta...sto cercando di capire dove sia il problema e cosa lo ha generato dal momento che sia una penna usb ora mi da problemi sia l'ssd e sia l'hdd c è qualcosa che mi ha corrotto dati o qualcos'altro e devo capire cosa...non ha senso avere un altra penna usb... se rescatux su una usb parte ma comunque non viene installato su ssd ne su hdd c è qualcosa che lo impedisce e questo qualcosa è passato sulla usb più grande dal momento che le altre installazioni provate le avevo fatte da lì.

(28 Apr, 16:24) ince ince's gravatar image

per fare la chiavetta ho usato tutti i programmi che sono riuscito a far girare su vista;quello usato che ha fatto partire rescatux è iso2disc(usato anche nell'altra usb)

(28 Apr, 16:24) ince ince's gravatar image
  • ma l'installazione parte? come fai a dire che siano problemi di ssd o hdd?

  • primo passo e' scaricare l'iso e controllarla

  • secondo metterla su usb (da windows e qui non ti posso aiutare)
  • terzo far avviare la versione live
  • quarto eseguire l'installer e installarla su disco
(28 Apr, 17:15) sacarde sacarde's gravatar image

sacarde ok che non sono il più pratico di questo mondo,ma neanche uno sprovveduto,l'istallazione parte?se ti ho fatto gli screen dell'unica parte che riesco a vedere e se ti ho detto che neppure in live si avviano secondo te parte? non ho mai detto che siano problemi di ssd o di hdd ho detto semplicemente che con gparted(avviato da rescatux[L'UNICO CHE SI AVVIA IN LIVE])trovo degli errori nelle partizioni create,idem per la usb.

(28 Apr, 17:58) ince ince's gravatar image

in qualche screen ti ho anche fatto vedere che restituiva un messaggio di acpi bios(bug). ho messo le iso di ubuntu lubuntu arch e tante altre anche sulla pennina da 4 gb(quella che non da problemi con rescatux)creato i file iso su due pennine diverse per almeno 15/20 volte(anche togliendo rescatux e rimettendolo dopo che non andavano gli altri)non è possibile che su 15 volte 3/4 volte è andato a buon fine solo rescatux!

(28 Apr, 18:04) ince ince's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×811
×287

domanda posta: 25 Apr, 12:14

domanda visualizzata: 233 volte

ultimo aggiornamento: 28 Apr, 18:05

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.