Buonasera, come da titolo la porta usb 3.0 non funziona su ubuntu 18.10. Nota di errore: usb 5-1: device descriptor read/64, error -71

Grazie

chiesto 02 Mag, 01:43

juda70's gravatar image

juda70
203

come la stai testando? cosa inserisci?

che hai: lspci e lsusb

(02 Mag, 10:01) sacarde sacarde's gravatar image

ho inserito pen-drive, telefono e mouse la verifica l'ho fatta con vari comandi tra cui lsusb

(02 Mag, 18:39) juda70 juda70's gravatar image

ho provato in vari modi tra cui lsub

coll. permanente

ha risposto 02 Mag, 18:21

juda70's gravatar image

juda70
203

  • alcuni risolvono passando al modulo "usbcore" il parametro: use_both_schemes=y

quindi devi creare un file: /etc/modprobe.d/usbcore.conf

con dentro:

options usbcore use_both_schemes=y

p.s. https://urukrama.wordpress.com/2009/01/27/usb-drive-not-recognised-error-71/

(02 Mag, 20:28) sacarde sacarde's gravatar image

Grazie per l'indicazione. Sinceramente, data la mia incapacità, non so come procedere

(03 Mag, 16:50) juda70 juda70's gravatar image

sai usare un editor? tipo "nano"

da terminale esegui: sudo nano /etc/modprobe.d/usbcore.conf

all'interno inserisci la riga:

options usbcore use_both_schemes=y

esci e salva (ctrl-X e confermi)

(03 Mag, 17:02) sacarde sacarde's gravatar image

Ci ho provato, ma nulla

(03 Mag, 17:28) juda70 juda70's gravatar image

cioe'? l'hai fatto e non e' servito ? hai riavviato?

che vedi (dop il riavvio) col comando:

systool -vm usbcore|grep use

(03 Mag, 17:37) sacarde sacarde's gravatar image

Ciao Sacarde, ho fatto ciò mi hai indicato, ho riavviato e da terminale col comando
systool -vm usbcore|grep use vedo use_both_schemes = "Y"

(03 Mag, 18:04) juda70 juda70's gravatar image

inserisci chiavette usb o altri dispositivi, e hai lo stesso errore?

(03 Mag, 18:45) sacarde sacarde's gravatar image

ecco qualche riga dopo il comando dmesg | grep -i USB

38.773312] usb 4-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0 [ 113.012450] usb 5-1: new full-speed USB device number 6 using xhci_hcd [ 113.152395] usb 5-1: device descriptor read/64, error -71 [ 113.400389] usb 5-1: device descriptor read/64, error -71 [ 113.636156] usb 5-1: new full-speed USB device number 7 using xhci_hcd [ 113.772210] usb 5-1: device descriptor read/64, error -71 [ 114.016191] usb 5-1: device descriptor read/64, error -71 [ 114.124103] usb usb5-port1: attempt power cycle [ 114.779730] usb 5-1: new full-speed USB device number 8 using xhci_hcd [ 114.780083] usb 5-1: Device not responding to setup address. [ 114.988020] usb 5-1: Device not responding to setup address. [ 115.195574] usb 5-1: device not accepting address 8, error -71 [ 115.323550] usb 5-1: new full-speed USB device number 9 using xhci_hcd [ 115.323919] usb 5-1: Device not responding to setup address. [ 115.531812] usb 5-1: Device not responding to setup address. [ 115.739401] usb 5-1: device not accepting address 9, error -71

con mouse (a cui arriva corrente) al comando dmesg | less esce

363.532977] usb 5-1: new full-speed USB device number 10 using xhci_hcd [ 363.669037] usb 5-1: device descriptor read/64, error -71 [ 363.913185] usb 5-1: device descriptor read/64, error -71 [ 364.148970] usb 5-1: new full-speed USB device number 11 using xhci_hcd [ 364.284968] usb 5-1: device descriptor read/64, error -71 [ 364.529006] usb 5-1: device descriptor read/64, error -71 [ 364.637092] usb usb5-port1: attempt power cycle [ 365.292776] usb 5-1: new full-speed USB device number 12 using xhci_hcd [ 365.293119] usb 5-1: Device not responding to setup address. [ 365.501050] usb 5-1: Device not responding to setup address. [ 365.708690] usb 5-1: device not accepting address 12, error -71 [ 365.836724] usb 5-1: new full-speed USB device number 13 using xhci_hcd

coll. permanente

ha risposto 03 Mag, 19:14

juda70's gravatar image

juda70
203

  • con altri sistemi (o con la live) funzionavano?

  • le usb2.0 funzionano ?

(03 Mag, 20:40) sacarde sacarde's gravatar image

la porta usb 3.0 ha funzionato fino a qualche giorno fa. Le usb 2.0 funzionano. Ho provato ad immettere ubuntu live da usb, ma, una volta nel bios, non riesco a vedere la chiavetta per dare il boot (la chiavetta con live non la vedo neanche ).

Partito ubuntu live usb grazie a chiavetta inserita in altra porta, per verificare la funzionalità della porta ho dato i comandi dmesg | grep -i USB e dmesg | less ed ho ottenuto il solito risultato usb 5-1: device descriptor read/64, error -71

coll. permanente

ha risposto 03 Mag, 22:24

juda70's gravatar image

juda70
203

  • e' un pc "uefi" ? (o legacy)

  • il secureboot e' disabilitato?

  • nel bios, hai abilitato "usb legacy"?

  • hai fatto un aggiornamento ? del kernel?

(04 Mag, 08:46) sacarde sacarde's gravatar image

il pc ha è in boot mode legacy riguardo gli aggiornamenti credo di averne fatti (nell'ultima settimana, nel tentativo di risolvere, sono passato da 18.04 a 19.04)

coll. permanente

ha risposto 04 Mag, 10:11

juda70's gravatar image

juda70
203

  • quando funzionava quale kernel aveva? ti ricordi?

i log degli aggiornamenti sono in: /var/log/apt/archives

  • hai, da grub, la possibilita' di avviare kernel vecchi?
(04 Mag, 10:32) sacarde sacarde's gravatar image

purtroppo non ricordoquale kernel ci fosse Comunque ho provato nei giorni scorsi ad accedere con qualche kernel precedente ma non ho avuto buoni risultati

(04 Mag, 10:38) juda70 juda70's gravatar image
  • hai altri sistemi su quel pc? o provando da la live (18.04 o 19.04) ?

  • alcuni risolvono staccando il cavo di alimentazione per qualche minuto.. (mah)

  • il secureboot e' disabilitato?

(04 Mag, 11:12) sacarde sacarde's gravatar image

non riesco ad accedere ai vecchi kernel

(04 Mag, 11:12) juda70 juda70's gravatar image
  • dal menu di grub, ---> opzioni avanzate---> non hai varie voci?

  • dovresti vedere i kernel rimasti anche nella dir /boot

(04 Mag, 11:26) sacarde sacarde's gravatar image

ho provato ad accedere con kernel precedenti ma si blocca

(04 Mag, 11:31) juda70 juda70's gravatar image

-Ho provato con live 18.04 e anche da li ho ottenuto lo stesso errore - non ho altri SO - riguardo il secure boot provo a vedere, ma ho paura di far casino (quando anni fa installai ubuntu mi si impallò l'installazione e ricorsi ad un tecnico che ci mise un pò) -provo a staccare il cavo di alimentazione (boh!!)

(04 Mag, 11:41) juda70 juda70's gravatar image
  • si blocca? vedi errori dai messaggi ?

  • provato a avviare in recovery-mode ? (anche dalle voci dei vecchi kernel)

  • alcuni risolvono staccando il cavo di alimentazione per qualche minuto.. (mah)

  • il secureboot e' disabilitato?

(04 Mag, 11:42) sacarde sacarde's gravatar image

eppure se ha funzionato... ! ci deve essere il modo

se scopro altre soluzioni te lo dico

(04 Mag, 12:21) sacarde sacarde's gravatar image

Per le tue pazienza disponibità e competenza Grazie!!!!

Attendo qualche tua notizia

In ogni caso grazie istess

(04 Mag, 12:26) juda70 juda70's gravatar image

ho riprovato con i kernel precedenti anche con "l'opzione riparazione"

riguardo il sicure boot il pc non dovrebbe esser disabilitato visto che son
riuscito ad accedere con ubuntu 18.04 live? (in ogni caso il boot è impostato in boot legacy)

ho anche staccato l'alimentazione - ho spento - ho riacceso co alimentazione staccata (manca il wodooo)

coll. permanente

ha risposto 04 Mag, 12:15

juda70's gravatar image

juda70
203

se vuoi fare un'altro tentativo, passare al kernel: (lo puoi fare anche temporaneamente editando la voce di grub)

usbcore.autosuspend=-1 irqpoll

(04 Mag, 21:06) sacarde sacarde's gravatar image

ho digitato nel terminale il comando indicato nel link consigliato sudo echo Y > /sys/module/usbcore/parameters/old_scheme_first mi risponde accesso negato. Sbaglio nel dare il comando?

(04 Mag, 23:12) juda70 juda70's gravatar image

lo puoi dare anche temporaneamente al kernel da grub:

usbcore.old_scheme_first=Y

(05 Mag, 08:51) sacarde sacarde's gravatar image

Per andare su vecchio kernel, ho provato anche con usbcore.old_scheme_first=Y

e successivo

sudo update-grub

ma al riavvio con vecchio kernel in modalita recovery

il boot si blocca su riga che dice start up failed boot freezato.

Ho provato anche con live usb di Lubuntu 16.04 montata su usb.2.0: non si vede usb 3.0.

(05 Mag, 16:28) juda70 juda70's gravatar image
  • per fare prove e' piu' veloce (sopratutto se poi va male) farle temporaneamente, aggiungendo parametri sulla riga del grub di avvio

  • non ho capito se adesso hai dei problemi ad avviare il sistema!

  • non ho capito se hai provato: usbcore.autosuspend=-1 irqpoll

(05 Mag, 17:41) sacarde sacarde's gravatar image

Scusa, sono stato un po sintetico nel riportare ciò ho fatto.

Il sistema si avvia normalmente con l'ultimo kernel; mentre si blocca su quelli vecchi.

Ho provato con usbcore.autosuspend=-1 irqpoll, ma non ho avuto miglioramenti

Ora riprovo per verificare che tutto sia stato fatto a modo e sperem

(05 Mag, 18:11) juda70 juda70's gravatar image

ho rifatto e nulla di nuovo

(05 Mag, 18:41) juda70 juda70's gravatar image

lo sai come controllare i parametri:

systool -vm usbcore|grep autosuspend

systool -vm usbcore|grep scheme

(05 Mag, 21:00) sacarde sacarde's gravatar image

Sono abbastanza ignorante, ma se hai pazienza nell'indicare i passaggi potrei riuscire a eseguire.

questi sono le risposte giorgio@pcgio:~$ systool -vm usbcore|grep autosuspend

autosuspend         = "-1"

giorgio@pcgio:~$ systool -vm usbcore|grep scheme

old_scheme_first    = "N"

use_both_schemes    = "Y"
(05 Mag, 21:18) juda70 juda70's gravatar image

la prova era anche con: old_scheme_first = "Y"

ma il risultato non cambierebbe...

bisognerebbe che tu ricordassi con quale versione del kernel funzionava (anche perche' funzionava senza toccare alcun parametro)

(05 Mag, 21:47) sacarde sacarde's gravatar image

per risolvere negli ultimi giorni ho fatto due avanzamenti dal 18.04 al 19.04,direi il 3.19....., ma non so

linux: /boot/vmlinuz-5.0.0-13-generic initrd: /boot/initrd.img-5.0.0-13-generic linux: /boot/vmlinuz-4.18.0-18-generic initrd: /boot/initrd.img-4.18.0-18-generic linux: /boot/vmlinuz-3.19.0-43-generic initrd: /boot/initrd.img-3.19.0-43-generic linux: /boot/vmlinuz-3.13.0-66-generic initrd: /boot/initrd.img-3.13.0-66-generic linux: /boot/vmlinuz-3.11.0-20-generic initrd: /boot/initrd.img-3.11.0-20-generic linux: /boot/vmlinuz-3.5.0-44-generic initrd: /boot/initrd.img-3.5.0-44-generic

(05 Mag, 22:06) juda70 juda70's gravatar image

possibile che fosse un 4.0.... e che non l'abbia più in lista?

(05 Mag, 22:16) juda70 juda70's gravatar image

l'history degli aggiornamenti: /var/log/apt/history.log

/var/log/apt/term.log

la cache: /var/cache/apt/archives

(05 Mag, 23:38) sacarde sacarde's gravatar image

ciao sacarde ecco la mia ignoranza al 1° viene giorgio@pcgio:~$ /var/log/apt/history.log bash: /var/log/apt/history.log: Permesso negato giorgio@pcgio:~$ sudo /var/log/apt/history.log [sudo] password di giorgio: sudo: /var/log/apt/history.log: comando non trovato giorgio@pcgio:~$

(06 Mag, 20:18) juda70 juda70's gravatar image

stesse risposte col 2° e 3° comando

Sicuramente sbaglio qualcosa...cosa? abbi pazienza ... ci tento ma ho i miei limiti

(06 Mag, 20:23) juda70 juda70's gravatar image

ti ho indicato i file da guardare, non erano comandi...

nel senso che puoi visualizzarli con l'editor che vuoi, esempio:

less /var/log/apt/history.log

less /var/log/apt/term.log

sudo ls -l /var/cache/apt/archives

(06 Mag, 20:33) sacarde sacarde's gravatar image

vedo i file ma per me è arabo

(06 Mag, 21:32) juda70 juda70's gravatar image

devi vedere se trovi una versione del kernel (nel nome: ...generic...) che e' stata eliminata

(06 Mag, 21:41) sacarde sacarde's gravatar image

Rimozione di linux-image-4.15.0-47-generic (4.15.0-47.50). potrebbe essere?

(06 Mag, 22:05) juda70 juda70's gravatar image

si puo' tentare.. se non te lo trova lo puoi scaricare da qui:

http://security.ubuntu.com/ubuntu/pool/main/l/linux-signed/linux-image-4.15.0-47-generic_4.15.0-47.50_amd64.deb

e installarlo con: dpkg -i linux-image-4.15.0-47-generic_4.15.0-47.50_amd64.deb

(07 Mag, 08:45) sacarde sacarde's gravatar image

Ciao Sacarde, dopo qualche giorno di latitanza per impegni vari, sto tentando di nuovo di far funzionare l'usb, ma per mia grande ignoranza non riesco a installare il kernel.... ecco il risultato

(10 Mag, 22:43) juda70 juda70's gravatar image

giorgio@pcgio:~/Scrivania$ sudo dpkg -i linux-image-4.15.0-47-generic_4.15.0-47.50_amd64.deb [sudo] password di giorgio: Selezionato il pacchetto linux-image-4.15.0-47-generic non precedentemente selezionato. (Lettura del database... 340204 file e directory attualmente installati.)

(10 Mag, 22:44) juda70 juda70's gravatar image

Preparativi per estrarre linux-image-4.15.0-47-generic_4.15.0-47.50_amd64.deb... Estrazione di linux-image-4.15.0-47-generic (4.15.0-47.50)... dpkg: problemi con le dipendenze impediscono la configurazione di linux-image-4.15.0-47-generic: linux-image-4.15.0-47-generic dipende da linux-modules-4.15.0-47-generic; tuttavia: Il pacchetto linux-modules-4.15.0-47-generic non è installato.

(10 Mag, 22:44) juda70 juda70's gravatar image

dpkg: errore nell'elaborare il pacchetto linux-image-4.15.0-47-generic (--install): problemi con le dipendenze - lasciato non configurato Si sono verificati degli errori nell'elaborazione: linux-image-4.15.0-47-generic giorgio@pcgio:~/Scrivania$

(10 Mag, 22:44) juda70 juda70's gravatar image
  • lo vedi installato? dpkg -l|grep linux-image-4.15.0-47-generic

  • lo trovi con: sudo apt search linux-image-4.15.0-47-generic

(11 Mag, 08:43) sacarde sacarde's gravatar image

ciao sacarde ho avuto seri problemi e il pc è passato in 2° piano. il primo comando da:

dpkg -l|grep linux-image-4.15.0-47-generic

giorgio@pcgio:~$ dpkg -l|grep linux-image-4.15.0-47-generic rc linux-image-4.15.0-47-generic 4.15.0-47.50 amd64 Signed kernel image generic giorgio@pcgio:~$

(15 Mag, 23:32) juda70 juda70's gravatar image

il 2°:

giorgio@pcgio:~$ sudo apt search linux-image-4.15.0-47-generic [sudo] password di giorgio: Ordinamento... Fatto Ricerca sul testo... Fatto linux-image-4.15.0-47-generic/now 4.15.0-47.50 amd64 [configurazione residua] (none)

(15 Mag, 23:33) juda70 juda70's gravatar image

sembrerebbe installato...

hai eseguito: sudo update-grub

per aggiornare la lista dei kernel in grub

potresti provare a avviarlo, dal menu avanzato di grub dovrebbe esserti apparso anche quel kernel: ..4.15.0-47..

(16 Mag, 08:59) sacarde sacarde's gravatar image

Purtroppo non credo che sia installato

Il pacchetto linux-modules-4.15.0-47-generic non è installato.

dpkg: errore nell'elaborare il pacchetto linux-image-4.15.0-47-generic (--install): problemi con le dipendenze - lasciato non configurato Si sono verificati degli errori nell'elaborazione: linux-image-4.15.0-47-generic giorgio@pcgio:~/Scrivania$

(16 Mag, 16:43) juda70 juda70's gravatar image

vista la mia difficoltà nel trovare soluzioni, cosa ne dici se cambiassi SO? pensi che avrei ancora il problema? quale SO mi consigli? grazie

(16 Mag, 17:00) juda70 juda70's gravatar image

non avevo visto il modules

prova:

sudo apt install linux-modules-4.15.0-47-generic

(16 Mag, 17:17) sacarde sacarde's gravatar image

cambiare SO cosa intendi? un'altra distribuzione?

se e' un problema di kernel... a parita' di versione il kernel e' sempre lo stesso

se vuoi fare prove di altre "famiglie" ci sono molte live tipo:

debian, fedora, suse, MX ecc. trovi i dettagli su distrowatch.org

(16 Mag, 17:25) sacarde sacarde's gravatar image

pensavo ad uno dei seguenti: mint o lubuntu, kubuntu, xubuntu, ma se credi che con questi il problema rimanga, mi adatto ad altro

(16 Mag, 17:44) juda70 juda70's gravatar image
  • potrei risponderti se fosse chiaro a cosa sia dovuto il malfunzionamento dell'usb3.0

se per un certo periodo ha funzionato (anche con ubuntu)...

che dirti... prova qualche live

(16 Mag, 17:51) sacarde sacarde's gravatar image

Ciao Sacarde, Grazie per il supporto dato. Ho provato con il kernel 4.15, ma nulla di nuovo. Abbiamo provato varie vie e ora sto pensando di provare cambiando Sistema. quando mi decido.... grazie

(16 Mag, 19:21) juda70 juda70's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×218

domanda posta: 02 Mag, 01:43

domanda visualizzata: 133 volte

ultimo aggiornamento: 16 Mag, 19:21

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.