Ciao, ho un Asus collegato ad un TV Samsung via HDMI.

Per potere ascoltare l'audio dal browser devo aprire alsamixer e disabilitare/abilitare (tasto M) l'S/PDIF

Devo ripetere la stessa procedura ogni volta che apro il browser oppure interrompo la visione.

C'e un modo di abilitare permanentemente l'HDMI ?

chiesto 03 Mag, 22:03

cdandre's gravatar image

cdandre
201


E simile ma non sono riuscito a risolvere Cerco di essere piu preciso Ho una scheda HDA Intel HDMI e l'unica uscita audio che posso utilizzare è quella attraverso HDMI su ubuntu 19.04 (ma avevo lo stesso problema su 18.10) Qualunque sorgente audio non funziona fino a quando non apro alsamixer e flaggo/deflaggo S/PDIF (tasto M) Il sistema per qualche ragione se non sente un flusso audio non abilita l'HDMI che deve essere abilitata a caldo mentre il flusso audio è presente.

Vorrei inserire qualche script da qualche aparte affinche l'audio HDMI sia permanentemente abilitato

coll. permanente

ha risposto 08 Mag, 13:29

cdandre's gravatar image

cdandre
201

quindi i 2 comandi:

sudo alsactl store (per memorizzare lo stato)

e

sudo alsactl restore (per ricaricare)

non funzionano?

(08 Mag, 13:36) sacarde sacarde's gravatar image

confermo sudo alsactl store chiudo il browser altrimenti mi da errore sudo alsactl restore

quando riapro il browser devo ripassare da alsamixer per riavere l'audio

coll. permanente

ha risposto 08 Mag, 16:28

cdandre's gravatar image

cdandre
201

mmm

puoi controllare se il file: /var/lib/alsa/asound.state prima e dopo l'intervento su alsamixer, viene modificato?

(08 Mag, 16:54) sacarde sacarde's gravatar image

si, la data di ultima modifica risulta modificata

coll. permanente

ha risposto 08 Mag, 17:12

cdandre's gravatar image

cdandre
201

un tentativo... salviamo il file quando funziona: sudo cp /var/lib/alsa/asound.state /var/lib/alsa/asound.state.ok

e poi invece di modificare alsamixer provare a ricaricarlo:

sudo alsactl restore -f /var/lib/alsa/asound.state.ok

(08 Mag, 17:46) sacarde sacarde's gravatar image

ho salvato quando funziona con cp /var/lib/alsa/asound.state /var/lib/alsa/asound.state.ok

per poterlo ricaricare ho dovuto spegnere il browser altrimenti dava errore ma quando lo riaccendo e lancio il comando sudo alsactl restore -f /var/lib/alsa/asound.state.ok è di nuovo muto

coll. permanente

ha risposto 08 Mag, 18:01

cdandre's gravatar image

cdandre
201

invece di eseguire: sudo alsactl restore -f ......

prova a copiarlo direttamente:

sudo cp /var/lib/alsa/asound.state.ok /var/lib/alsa/asound.state

(08 Mag, 20:30) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×22

domanda posta: 03 Mag, 22:03

domanda visualizzata: 175 volte

ultimo aggiornamento: 08 Mag, 20:30

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.