Buongiorno, ci sono due kernel che non riesco a rimuovere e che non consentono di installare o aggiornare niente. Volevo installare chrome e questo è il risultato da terminale:

(Lettura del database... 368133 file e directory attualmente installati.) Rimozione di linux-image-4.18.0-16-generic (4.18.0-16.17)... /etc/kernel/postrm.d/initramfs-tools: update-initramfs: Deleting /boot/initrd.img-4.18.0-16-generic /etc/kernel/postrm.d/zz-update-grub: Letrura file "/etc/default/grub" Letrura file "/etc/default/grub.d/init-select.cfg" Generazione file di configurazione GRUB... Found background image: Foto.png Trovata immagine linux: /boot/vmlinuz-5.0.0-13-generic Trovata immagine initrd: /boot/initrd.img-5.0.0-13-generic /etc/grub.d/bin/grubcfg_proxy: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127 dpkg: errore nell'elaborare il pacchetto linux-image-4.18.0-16-generic (--remove): il sottoprocesso installato pacchetto linux-image-4.18.0-16-generic script post-removal ha restituito lo stato di errore 1 Rimozione di linux-image-4.18.0-17-generic (4.18.0-17.18)... /etc/kernel/postrm.d/initramfs-tools: update-initramfs: Deleting /boot/initrd.img-4.18.0-17-generic /etc/kernel/postrm.d/zz-update-grub: Letrura file "/etc/default/grub" Letrura file "/etc/default/grub.d/init-select.cfg" Generazione file di configurazione GRUB... Found background image: Foto.png Trovata immagine linux: /boot/vmlinuz-5.0.0-13-generic Trovata immagine initrd: /boot/initrd.img-5.0.0-13-generic /etc/grub.d/bin/grubcfg_proxy: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127 dpkg: errore nell'elaborare il pacchetto linux-image-4.18.0-17-generic (--remove): il sottoprocesso installato pacchetto linux-image-4.18.0-17-generic script post-removal ha restituito lo stato di errore 1 Si sono verificati degli errori nell'elaborazione: linux-image-4.18.0-16-generic linux-image-4.18.0-17-generic

Grazie per l'attenzione,

chiesto 05 Mag, 10:44

aanesti's gravatar image

aanesti
202

  • l'avanzamento si e' concluso?

  • il file libcrypto.so.1.0.0 si trova nelle precedenti la 19.04 nel pacchetto: libssl1.0.0

cel'hai?

dpkg -l|grep libssl

(05 Mag, 11:50) sacarde sacarde's gravatar image

« precedente123avanti »

Nessun esito ai due primi comandi; non c'è nsight-systems nsight-compute ne lib.... il grub era 5.1.0-1

coll. permanente

ha risposto 06 Mag, 22:00

aanesti's gravatar image

aanesti
202

Mi viene proposto un aggiornamento parziale.... lo faccio?

coll. permanente

ha risposto 06 Mag, 22:01

aanesti's gravatar image

aanesti
202

Aggiornamento sparito, ma ho fatto questo da terminale: user@user-Satellite-Pro-R50-B:~$ sudo update-grub [sudo] password di user: Letrura file "/etc/default/grub" Letrura file "/etc/default/grub.d/init-select.cfg" Generazione file di configurazione GRUB... Found background image: Foto.png Trovata immagine linux: /boot/vmlinuz-5.0.0-13-generic Trovata immagine initrd: /boot/initrd.img-5.0.0-13-generic /etc/grub.d/bin/grubcfg_proxy: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory user@user-Satellite-Pro-R50-B:~$

coll. permanente

ha risposto 06 Mag, 22:17

aanesti's gravatar image

aanesti
202

appare quella libreria?

dpkg -L libssl1.0.0:i386

p.s. da quale versione sei passato alla 19.04?

(07 Mag, 08:42) sacarde sacarde's gravatar image

Sono passato dalla 18.04. Ecco l'esito del comando:

user@user-Satellite-Pro-R50-B:~$ dpkg -L libssl1.0.0:i386 /. /usr /usr/lib /usr/lib/i386-linux-gnu /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0 /usr/lib/i386-linux-gnu/libssl.so.1.0.0 /usr/lib/i386-linux-gnu/openssl-1.0.0 /usr/lib/i386-linux-gnu/openssl-1.0.0/engines /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/lib4758cca.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libaep.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libatalla.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libcapi.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libchil.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libcswift.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libgmp.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libgost.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libnuron.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libpadlock.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libsureware.so /usr/lib/i386-linux-gnu/openssl-1.0.0/engines/libubsec.so /usr/share /usr/share/doc /usr/share/doc/libssl1.0.0 /usr/share/doc/libssl1.0.0/README.Debian /usr/share/doc/libssl1.0.0/changelog.Debian.gz /usr/share/doc/libssl1.0.0/copyright /usr/share/lintian /usr/share/lintian/overrides /usr/share/lintian/overrides/libssl1.0.0 user@user-Satellite-Pro-R50-B:~$

coll. permanente

ha risposto 07 Mag, 15:24

aanesti's gravatar image

aanesti
202

la libreria libcrypto.so.1.0.0 c'e' ma a 32bit (presumo che la cerchi a 64bit), tale libreria non c'e' nel 19.04

potresti provare a scaricare il pacchetto che la contiene 18.04 da qui: http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb

e installarla a mano con: dpkg -i .............

(07 Mag, 17:12) sacarde sacarde's gravatar image

Con l'installatore mi fa la solita storia:

(Lettura del database... 368082 file e directory attualmente installati.) Rimozione di linux-image-4.18.0-16-generic (4.18.0-16.17)... /etc/kernel/postrm.d/initramfs-tools: update-initramfs: Deleting /boot/initrd.img-4.18.0-16-generic /etc/kernel/postrm.d/zz-update-grub: Letrura file "/etc/default/grub" Letrura file "/etc/default/grub.d/init-select.cfg" Generazione file di configurazione GRUB... Found background image: Foto.png Trovata immagine linux: /boot/vmlinuz-5.0.0-13-generic Trovata immagine initrd: /boot/initrd.img-5.0.0-13-generic /etc/grub.d/bin/grubcfg_proxy: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127 dpkg: errore nell'elaborare il pacchetto linux-image-4.18.0-16-generic (--remove): il sottoprocesso installato pacchetto linux-image-4.18.0-16-generic script post-removal ha restituito lo stato di errore 1 Rimozione di linux-image-4.18.0-17-generic (4.18.0-17.18)... /etc/kernel/postrm.d/initramfs-tools: update-initramfs: Deleting /boot/initrd.img-4.18.0-17-generic /etc/kernel/postrm.d/zz-update-grub: Letrura file "/etc/default/grub" Letrura file "/etc/default/grub.d/init-select.cfg" Generazione file di configurazione GRUB... Found background image: Foto.png Trovata immagine linux: /boot/vmlinuz-5.0.0-13-generic Trovata immagine initrd: /boot/initrd.img-5.0.0-13-generic /etc/grub.d/bin/grubcfg_proxy: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127 dpkg: errore nell'elaborare il pacchetto linux-image-4.18.0-17-generic (--remove): il sottoprocesso installato pacchetto linux-image-4.18.0-17-generic script post-removal ha restituito lo stato di errore 1 Si sono verificati degli errori nell'elaborazione: linux-image-4.18.0-16-generic linux-image-4.18.0-17-generic

coll. permanente

ha risposto 07 Mag, 17:17

aanesti's gravatar image

aanesti
202

Provo a installare a mano ma devo guardare come fare...

coll. permanente

ha risposto 07 Mag, 17:18

aanesti's gravatar image

aanesti
202

fatto, ma segnala un errore user@user-Satellite-Pro-R50-B:~$ sudo dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb Selezionato il pacchetto libssl1.0.0:amd64 non precedentemente selezionato. (Lettura del database... 368083 file e directory attualmente installati.) Preparativi per estrarre libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb... De-configurazione di libssl1.0.0:i386 (1.0.2n-1ubuntu6.2)... Estrazione di libssl1.0.0:amd64 (1.0.2n-1ubuntu5.3)... dpkg: errore nell'elaborare il pacchetto libssl1.0.0:amd64 (--install): il pacchetto libssl1.0.0:amd64 1.0.2n-1ubuntu5.3 non può essere configurato perché libssl1.0.0:i386 ha una versione diversa (1.0.2n-1ubuntu6.2) dpkg: errore nell'elaborare il pacchetto libssl1.0.0:i386 (--install): il pacchetto libssl1.0.0:i386 1.0.2n-1ubuntu6.2 non può essere configurato perché libssl1.0.0:amd64 ha una versione diversa (1.0.2n-1ubuntu5.3) Elaborazione dei trigger per libc-bin (2.29-0ubuntu2)... Si sono verificati degli errori nell'elaborazione: libssl1.0.0:amd64 libssl1.0.0:i386 user@user-Satellite-Pro-R50-B:~$

coll. permanente

ha risposto 07 Mag, 17:26

aanesti's gravatar image

aanesti
202

non ho capito se lo ha installato comunque o no:

dpkg -l | grep libssl

(07 Mag, 17:30) sacarde sacarde's gravatar image

Ora ho il GDebi che non si chiude e l'avviso di un aggiornamento parziale..

coll. permanente

ha risposto 07 Mag, 17:28

aanesti's gravatar image

aanesti
202

quinti era stato installato?

se crea problemi toglilo:

sudo dpkg -r .................

(07 Mag, 17:34) sacarde sacarde's gravatar image

user@user-Satellite-Pro-R50-B:~$ dpkg -l | grep libssl iU libssl1.0.0:amd64 1.0.2n-1ubuntu5.3 amd64 Secure Sockets Layer toolkit - shared libraries iF libssl1.0.0:i386 1.0.2n-1ubuntu6.2 i386 Secure Sockets Layer toolkit - shared libraries ii libssl1.1:amd64 1.1.1b-1ubuntu2 amd64 Secure Sockets Layer toolkit - shared libraries user@user-Satellite-Pro-R50-B:~$

coll. permanente

ha risposto 07 Mag, 17:39

aanesti's gravatar image

aanesti
202

  • se dava noie va tolto...

potremmo tentare un'altra cosa, fare un link della libreria1.1 alla libreria1.0

mi servirebbe: dpkg -L libssl1.1

ma sono lavori sporchi...

  • l'unico sarebbe sapere chi ha installato "/etc/grub.d/bin/grubcfg_proxy" che richiede quella libreria
(07 Mag, 17:59) sacarde sacarde's gravatar image

chiaramente altre alternative...

  • chiedere a un forum (italiano o inglese)

  • o installare direttamente il 18.04 o il 19.04 (non oso pensare a un downgrade)

(07 Mag, 18:02) sacarde sacarde's gravatar image

Se riavvio il computer non riparte, immagino......

coll. permanente

ha risposto 07 Mag, 17:55

aanesti's gravatar image

aanesti
202

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×75

domanda posta: 05 Mag, 10:44

domanda visualizzata: 278 volte

ultimo aggiornamento: 07 Mag, 19:54

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.