Buona Sera, premetto che non è molto che uso xubuntu sul mio computer, un vecchio dell inspiron 6400, quindi scusatemi se magari può sembrare banale la mia richiesta d' aiuto. Il problema che ho riscontrato non è grave ma frustrante, dopo gli aggiornamenti recenti di xubuntu 18.04.2 LTS, all' avvio il computer si blocca e mostra lo schermo nero ma se forzo l' arresto del sistema, tenendo premuto il tasto d' accensione, al secondo tentativo si avvia perfettamente senza errori. Se spengo correttamente il computer dopo una sessione di lavoro, il problema si ripresenta al riavvio. La versione del GNU GRUB è 2.02, la scheda video e una intel Mobile 945GM

chiesto 12 Giu, 18:26

sandalino's gravatar image

sandalino
20

proverei a togliere "quiet" dai parametri al kernel (per vedere i messaggi) e a mettere "nomodeset"

https://wiki.ubuntu.com/Kernel/KernelBootParameters#Temporarily_Add_a_Kernel_Boot_Parameter_for_Testing

(13 Giu, 08:42) sacarde sacarde's gravatar image

Ho eseguito le istruzioni, il sistema si avvia ma non carica correttamente il driver della scheda video. Successivamente ho tolto quiet senza sostituirlo con nomodeset e si è bloccato nuovamente.

(13 Giu, 14:30) sandalino sandalino's gravatar image
  • aggiungendo anche il parametro "xforcevesa" avrai i driver video generici

  • "quiet" elimina soltanto la visualizzazione, niente piu'

(13 Giu, 14:59) sacarde sacarde's gravatar image

aggiunto il parametro, ma la qualità dell' immagine a schermo è scadente, ti ringrazio comunque per i consigli.

(13 Giu, 17:34) sandalino sandalino's gravatar image

i driver per la intel: https://wiki.ubuntu-it.org/Hardware/Video/Intel/Open

togliendo "quiet" bisogna vedere se da errori prima di diventare lo schermo nero e se lo diventa qundo metti "nomodeset"

(13 Giu, 20:44) sacarde sacarde's gravatar image

togliendo quiet si blocca comunque, in alto a sinistra appare un messaggio che non riesco a leggere perchè dopo un secondo lo schermo diventa nero. Con nomodeset non si blocca,non da messaggi di errore e il sistema operativo si avvia ma la qualità della grafica è pessima. Tutto funziona se avvio il computer e dopo la schermata nera, forzo l' arresto tenendo premuto il tasto d' accensione, al successivo riavvio il computer carica il sistema operativo correttamente e la grafica è ottima. Dopo l' arresto del sistema, la volta successiva si ripresenta il problema e bisogna fare la stessa cosa.

(14 Giu, 09:23) sandalino sandalino's gravatar image
  • quando si avvia bene cosa vedi dal comando:

cat /proc/cmdline

  • quando si ferma riesci a accedere alla consolle con ctrl-alt-f...
(14 Giu, 09:36) sacarde sacarde's gravatar image

con il comando cat /proc/cmdline: BOOT_IMAGE=/boot/vmlinuz-4.15.0-51-generic root=UUID=91d2cdfb-f903-40ba-84b0-be4ae4938e5b ro quiet splash

quando si ferma non ti permette di fare nulla compreso ctrl-alt-f1

(14 Giu, 10:35) sandalino sandalino's gravatar image
  • non capisco cosa faccia avviare o no il sistema...

non mi sembra dipenda dai parametri passati

  • lo ha fatto da un certo aggiornamento? o da sempre]

  • in /var/log hai Xorg.0.log.old ?

vedi delle righe con "EE" ?

(14 Giu, 11:04) sacarde sacarde's gravatar image

No fino al mese scorso funzionava benissimo tutto è iniziato con un aggiornamento fatto dopo il 17 maggio.

Si c'è una riga con EE ma dice che è un errore sconosciuto "WW) warning, (EE) error, (NI) not implemented, (??) unknown." e c'è anche nel file Xorg.0.log

(14 Giu, 13:49) sandalino sandalino's gravatar image
(14 Giu, 14:36) sacarde sacarde's gravatar image

questo è quello che è stato rimosso: sandro@sandro-MM061:~$ grep "remove " /var/log/dpkg.log 2019-06-07 09:21:18 remove linux-modules-extra-4.15.0-48-generic:i386 4.15.0-48.51 <nessuna> 2019-06-07 09:21:25 remove linux-image-4.15.0-48-generic:i386 4.15.0-48.51 <nessuna> 2019-06-07 09:22:10 remove linux-headers-4.15.0-48-generic:i386 4.15.0-48.51 <nessuna> 2019-06-07 09:22:26 remove linux-modules-4.15.0-48-generic:i386 4.15.0-48.51 <nessuna> 2019-06-07 09:38:49 remove linux-headers-4.15.0-48:all 4.15.0-48.51 <none>

(17 Giu, 09:56) sandalino sandalino's gravatar image

e questo installato: sandro@sandro-MM061:~$ grep "install " /var/log/dpkg.log 2019-06-06 09:04:24 install linux-modules-4.15.0-51-generic:i386 <nessuna> 4.15.0-51.55 2019-06-06 09:04:34 install linux-image-4.15.0-51-generic:i386 <nessuna> 4.15.0-51.55 2019-06-06 09:04:39 install linux-modules-extra-4.15.0-51-generic:i386 <nessuna> 4.15.0-51.55 2019-06-06 09:05:10 install linux-headers-4.15.0-51:all <nessuna> 4.15.0-51.55 2019-06-06 09:05:28 install linux-headers-4.15.0-51-generic:i386 <nessuna> 4.15.0-51.55 2019-06-07 09:38:58 install gstreamer1.0-gtk3:i386 <none> 1.14.1-1ubuntu1~ubuntu18.04.1

(17 Giu, 09:57) sandalino sandalino's gravatar image

c'e' stato l'aggiornamento del kernel alla versione 4.15.0-51

hai scelto tu di eliminare il vecchio?

potresti reinstallarlo, e poi scegliere da grub quale avviare

(17 Giu, 10:17) sacarde sacarde's gravatar image

No ha eliminato il vecchio kernel in automatico dopo l' aggiornamento. La rimozione del vecchio kernel ha influenzato il funzionamento del nuovo o l' ultima versione non si è installata correttamente? scusa la mia ignoranza ma come ripristino il vecchio kernel rimosso?

(17 Giu, 12:49) sandalino sandalino's gravatar image

reinstalli:

linux-modules-extra-4.15.0-48-generic linux-image-4.15.0-48-generic linux-headers-4.15.0-48-generic linux-modules-4.15.0-48-generic linux-headers-4.15.0-48

sei su un 386 vero?

(17 Giu, 14:15) sacarde sacarde's gravatar image

reinstallati i moduli ma anche questo kernel si comporta allo stesso modo, primo avvio schermata nera, secondo avvio dopo aver forzato l' arresto, schermo nero con alcune righe in alto di diversi colori e al terzo tentativo si avvia correttamente. Ti ringrazio ma a questo punto rinuncio a risolvere il problema e vado avanti cosi, sperando in un aggiornamento del kernel che risolvi l' arcano mistero.

(17 Giu, 16:30) sandalino sandalino's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×263

domanda posta: 12 Giu, 18:26

domanda visualizzata: 92 volte

ultimo aggiornamento: 17 Giu, 16:30

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.