Buongiorno, prima di spiegare il problema vi do qualche informazione che può essere utile: ho(come dal titolo)installato sul mio pc xubuntu 18.04 da un anno oramai, da "sempre" se tento di sospendere il pc mi da problemi, alcune volte si sospende e poi una volta fatto ripartire quando poi voglio spegnerlo non si spegne più e quindi devo spegnere il pc in modo forzato, altre volte non si sospende...insomma mi ha sempre dato problemi. Per motivi didattici ho installato wine per usare "su di esso" acrobat di windows, ma non funzionando ho deciso di disinstallarlo, una volta disinstallato il pc non si riusciva a spegnere con i "comandi convenzionali" e quindi ancora ho dovuto spegnere il pc tenendo premuto il tasto di accensione. A questo punto arriviamo al problema: riavvio il pc e mi "va" sul tty. Ho provato di tutto, sia la combinazione di tasti ctrl+alt+f7, ho provato a digitare il comando startx(questo funziona solo con sudo ma mi avvia il pc con il root ma vorrei farlo da utente), ho provato a digitare il comando startx /usr/bin/startxfce4(funziona sempre e solo con sudo) ma ancora niente da fare.

chiesto 16 Giu, 13:35

lorenzo-_'s gravatar image

lorenzo-_
20136

guarda se ci sono errori tra i servizi:

systemctl --failed

o: journalctl -b -p err

oppure nel log di Xorg: /var/log/Xorg.0.log (righe con "EE")

(16 Giu, 14:19) sacarde sacarde's gravatar image

systemctl --failed: 0 loaded units listed

per journalctl -b -p err: mi da una marea di errori, usando chiaramente un pc diverso non posso fare copia incolla degli errori, anche perchè per come mi si avviava xubuntu(ora addirittura non si apre neanche più con la modalità root attraverso il comando startx)non posso accedere ne a mail e ne posso scrivere quelle righe in un qualche file che da windows posso vedere, ho provato a fare una foto e a caricarla ma questo sito dopo il caricamento da errore

per /var/log/Xorg.0.log anche loggato come root mi da "permesso negato"

(16 Giu, 16:31) lorenzo-_ lorenzo-_'s gravatar image
  • prova a avviare il DM, esempio se hai lightdm

systemctl restart lightdm

(16 Giu, 16:35) sacarde sacarde's gravatar image

Immagine caricata

systemctl restart lightdm: Failed to restart lightdm.service: Unit lightdm.service not found

(16 Giu, 18:00) lorenzo-_ lorenzo-_'s gravatar image
  • una volta caricata devi mostrare l'indirizzo dove poterla vedere!

  • a me risulta che xubuntu18.04 abbia lightdm, boh

che vedi da: systemctl list-unit-files

e cerca un servizio che finisce per "dm"

(16 Giu, 21:39) sacarde sacarde's gravatar image

https://imagebin.ca/v/4kocglV9b9KD

da systemctl list-unit-files ci sono 290 righe, c'è un modo per fare una specie di ctrl-f?(intendo dal tty)

(16 Giu, 22:14) lorenzo-_ lorenzo-_'s gravatar image
  • sembra un errore di risoluzione nomi o di rete (usi networkmanager" vero?)

  • una volta nella lista dei servizi, premi "/" e di seguito "dm" per cercare quale DM hai installato, poi ancora "n" per i successivi

(17 Giu, 09:35) sacarde sacarde's gravatar image

si, uso network manager

esiste solo un file che finisce per dm: initrd-udevadm-cleanup-db.service

(17 Giu, 09:52) lorenzo-_ lorenzo-_'s gravatar image
  • senza servizi DM (sddm, gdm, kdm, lightdm) non capisco come hai avviato la grafica fino ad ora... con startx ?

  • a quel momento hai la rete su? che vedi da: ip a

(17 Giu, 09:58) sacarde sacarde's gravatar image

fino ad ora si è avviato sempre tutto in modo automatico, ho xubuntu da un anno oramai e lo uso tutti i giorni

non capisco cosa intende se ho la rete su, comunque: ip a: https://imagebin.ca/v/4ktUFJnchdhO

(17 Giu, 10:37) lorenzo-_ lorenzo-_'s gravatar image
  • bah! che vedi da: dpkg -l | grep dm

  • non sei in rete, potresti avviare in modalita' "recovery" e poi selezionare con rete

per installare un DM

(17 Giu, 10:46) sacarde sacarde's gravatar image

dpkg -l | grep dm: https://imagebin.ca/v/4ktexPF3ZNKU

ho avviato in modalità recovery, ora?

(17 Giu, 11:12) lorenzo-_ lorenzo-_'s gravatar image

manca proprio il pacchetto: lightdm

se hai avviato con la rete puoi installarlo:

sudo apt install lightdm

(17 Giu, 11:23) sacarde sacarde's gravatar image

ho avviato in recovery(da grub) ma mi dice questo: https://imagebin.ca/v/4ktkSyMqDhAS come vede ho provato anche a lanciare ifconfig wlan 0

(17 Giu, 11:31) lorenzo-_ lorenzo-_'s gravatar image
  • ma risponde al ping? ping 8.8.8.8

  • se sei in rete dai prima: apt update

  • altrimenti prova a accedere alla rete eth: enp2s0

con: dhclient enp2s0

(17 Giu, 11:57) sacarde sacarde's gravatar image

ping 8.8.8.8: la rete non è raggiungibile

ho collegato il cavo ethernet al portatile ma con dhclient enp2s0 non dice nulla ma sembra che resti in attesa

apt update quindi niente

(17 Giu, 13:21) lorenzo-_ lorenzo-_'s gravatar image
  • ma l'ethernet funzionava?

  • prova se il pacchetto lo trovassi in /var/cache/apt/archives

cd /var/cache/apt/archives

ls | grep lightdm

(17 Giu, 13:57) sacarde sacarde's gravatar image

cd /var/cache/apt/archives -> ls | grep lightdm: non fa vedere niente

Per l'ethernet non mi pare di averla mai usata sul mio portatile

(17 Giu, 14:49) lorenzo-_ lorenzo-_'s gravatar image

dopo qualche minuto sembra connettersi all'ethernet ma...: https://imagebin.ca/v/4kulRsr4LtIr

(17 Giu, 14:59) lorenzo-_ lorenzo-_'s gravatar image
  • la wireless quali dati necessita? essid / chiave ... ?

  • si puo' provare a avviare dal servizio NetworkManager

systemctl restart NetworkManager

  • oppure scarichi il pacchetto da un'altro sistema
(17 Giu, 16:15) sacarde sacarde's gravatar image

mi scuso per la poca precisione: la Wi-Fi ha un essid(nome della rete?) e una password

systemctl restart NetworkManager: Failed to restart Network manager.service: Unit NetworkManger.service not found

Deduco che qui stiamo andando un po' male, non capisco perché manchi tutta sta roba....

(17 Giu, 16:52) lorenzo-_ lorenzo-_'s gravatar image
  • puo' darsi che il nomeNetworkManager non sia scritto esattamente cosi, puoi dedurlo dall'elenco completo

systemctl list-unit-files

  • non sono sicuro su come avviare la wireless da riga di comando:

iwconfig wlp3s0 essid ...... key ......

dhclient wlp3s0

(17 Giu, 17:36) sacarde sacarde's gravatar image

Di nomi tipo NetworkManager non se ne trovano, ho trovato però un certo "display-manager.service" con a fianco "bad"

iwconfig wlp3s0 essid ...... key ......: ho cercato su Internet il comando ma mi da errore

per il pacchetto da scaricare, una volta scaricato?

(17 Giu, 18:01) lorenzo-_ lorenzo-_'s gravatar image

lo metti su una chiavetta e lo carichi in ubuntu

e poi dai: sudo dpkg -i lightdm_1.26.0-0ubuntu1_amd64.deb

(17 Giu, 18:07) sacarde sacarde's gravatar image

mi scusi ma come faccio a caricarlo su Ubuntu? inserisco la chiavetta e lo legge direttamente?

(17 Giu, 18:39) lorenzo-_ lorenzo-_'s gravatar image
  • o lo monta in automatico, allora per vedere il path digiti: df

  • o lo monti tu a mano, guardi le ultime righe di: dmesg

e poi lo monti a mano:

sudo mount /dev/sd.... /mnt

(17 Giu, 20:35) sacarde sacarde's gravatar image

df: non vedo niente che mi dica qualcosa sulla USB dmesg: stessa cosa del messaggio sopra

guardando da internet se faccio "sudo fdisk -l" mi fa vedere questo: https://imagebin.ca/v/4kwcujP4RCE2 alla fine c'è quel "/dev/sdb" che corrisponde come dimensioni alla mia chiavetta ma tentando di fare "sudo mount /dev/sdb/mnt" dice : "can't find in /etc/fstab"

(17 Giu, 21:23) lorenzo-_ lorenzo-_'s gravatar image

si si , e' quella la chiavetta in vfat

puoi montarla con:

sudo mount /dev/sdb1 /mnt

(metti gli spazi giusti)

poi dentro /mnt trovi i dati salvati

(17 Giu, 21:42) sacarde sacarde's gravatar image

ho montato la chiavetta e lanciato l'installazione ma da problemi con le dipendenze: https://imagebin.ca/v/4kwwhR5vwTLz

(17 Giu, 22:28) lorenzo-_ lorenzo-_'s gravatar image
(18 Giu, 08:51) sacarde sacarde's gravatar image

ok, sono riuscito a installare lightdm, ma una volta partita la GUI, inserisco la password del mio utente, premo invio e dopo pochi secondi me la richiede

(18 Giu, 10:10) lorenzo-_ lorenzo-_'s gravatar image
  • non da messaggi di errore?

  • da consolle riesci a loggarti? premi ctrl-alt-f..

  • dal comando: df vedi partizioni piene?

(18 Giu, 10:43) sacarde sacarde's gravatar image

non da nessun errore

si riesco a loggarmi

df: https://imagebin.ca/v/4l0cHC5Gp4TP

(18 Giu, 11:00) lorenzo-_ lorenzo-_'s gravatar image

prova a loggarti (col tuo utente) da consolle

e a creare il file: .xinitrc

con dentro: exec startxfce4

e poi a dare: startx

p.s. una volta dentro la consolle sei in rete, no?

(18 Giu, 11:43) sacarde sacarde's gravatar image

mi dica se è giusto: https://imagebin.ca/v/4l0xM8eq0BEl comunque startx poi non fa nulla e mi da errore:https://imagebin.ca/v/4l0ykJKhQDZn

non saprei se sono in rete, la Wi-Fi non la vede e la ethernet funziona malissimo(100% pacchetti persi)

(18 Giu, 12:14) lorenzo-_ lorenzo-_'s gravatar image

per esempio, usando l'editor "nano"

nano .xinitrc

inserire la riga: exec startxfce4

chiudere e salvare

poi: startx

(18 Giu, 13:26) sacarde sacarde's gravatar image

l'ho aperto con vim e dentro c'era già "exec startxfce4" ho fatto startx ma poi come prima mi da errore

(18 Giu, 13:59) lorenzo-_ lorenzo-_'s gravatar image

forse prima bisogna stoppare: sudo systemctl stop lightdm

(18 Giu, 14:16) sacarde sacarde's gravatar image

dopo un po' di tempo si avvia ma in modalità root

(18 Giu, 15:06) lorenzo-_ lorenzo-_'s gravatar image
  • parte l'ambiente grafico con utente root? (da dove lo vedi?)

  • puoi fare "chiudi sessione" per riloggarti col tuo utente?

(18 Giu, 16:47) sacarde sacarde's gravatar image

lo vedo dal fatto che se apro i miei file mi da l'avviso dicendomi che sono da root per citarne una

posso fare solo esci, se lo faccio mi va sul tty e se premo ctrl-alt-f7 mi va sulla schermata del login che come prima ho detto ha il problema che si ripete se mi loggo

(18 Giu, 17:02) lorenzo-_ lorenzo-_'s gravatar image
  • ma hai abilitato l'utente root? riesci a inserirlo dalla finestra del login?

  • avevi attivo l'autologin del tuo utente?

  • bisognerebbe riuscire a far andare la rete networkmanager si puo' usare anche via commanline:

https://www.tekops.com/sub/index.php?option=com_content&view=article&id=193:setting-up-network-manager-in-ubuntu-16-lts-via-cli&catid=59:tek-articles&Itemid=100

(18 Giu, 18:05) sacarde sacarde's gravatar image

secondo quanto scritto non ho installato il network-manager

dalla finestra del login c'è solo il mio utente e "altro"

se con autologin intende che ogni volta in cui si entra si logga in automatico senza credenziali, no non lo avevo attivo

(18 Giu, 18:35) lorenzo-_ lorenzo-_'s gravatar image
  • cliccando su altro puoi inserire root e relativa password?

  • dalla grafica prova a mettere user e password, una volta che ti ritorna la richiesta, prova a andare dalla consolle (ctrl-alt-f..) e vedere se si riesce a capire l'errore:

dal comando "lastb" che visualizza i login falliti o dal journal: journalctl -b (le ultime righe)

  • a me risulta che xubuntu18.04 ha network-manager
(18 Giu, 20:42) sacarde sacarde's gravatar image

no, root non c'è

lastb: https://imagebin.ca/v/4l3dDLtec6zq

da journal -b non saprei("ultime" di 1250 righe):https://imagebin.ca/v/4l3dmweb4OPa

seguendo la guida che mi ha inviato sembra che non abbia network-manager, ogni cosa che provo a fare mi dice che manca qualcosa o deve essere installato

(18 Giu, 21:23) lorenzo-_ lorenzo-_'s gravatar image
  • non hai il comando: nmcli ?

  • che vedi da: ls -l .Xauthority (dalla consolle del tuo user)

(18 Giu, 21:47) sacarde sacarde's gravatar image
  • strano, che tu lo abbia disinstallato?

  • prova a dare il comando: sudo chown lorenzo:lorenzo .Xauthority

(18 Giu, 22:02) sacarde sacarde's gravatar image

in modo doloso non l'ho disinstallato ma non è detto che non lo abbia fatto per sbaglio

per il comando l'ho lanciato ma non dice nulla

(18 Giu, 22:27) lorenzo-_ lorenzo-_'s gravatar image

riprova a loggarti da lightdm

(18 Giu, 23:03) sacarde sacarde's gravatar image

se intende dalla GUI, nulla da fare, mi fa sempre il solito scherzo

(18 Giu, 23:14) lorenzo-_ lorenzo-_'s gravatar image

guardiamo se ti mancano questi file:

ls -l /lib/security/pam_kwall*

p.s. io aggiungerei per sicurezza anche:

sudo chown lorenzo:lorenzo .ICEauthority

(19 Giu, 08:43) sacarde sacarde's gravatar image

mi dice file o directory inesistente

(19 Giu, 09:16) lorenzo-_ lorenzo-_'s gravatar image

proviamo con: cd /lib/security

ls | grep pam_kwall

oppure: cd /lib/x86_64-linux-gnu/security/

ls | grep pam_kwall

p.s. i pacchetti li hai?

dpkg -l | grep libpam-kwallet

(19 Giu, 09:35) sacarde sacarde's gravatar image

cd /lib/security: file o directory inesistente

ls | grep pam_kwall: nulla quindi

cd /lib/x86_64-linux-gnu/security/: entra ma poi con ls | grep pam_kwall non stampa a schermo nulla

dpkg -l | grep libpam-kwallet: nulla

(19 Giu, 10:35) lorenzo-_ lorenzo-_'s gravatar image
  • secondo l'errore che ho visto dal tuo screenshot ci dovevano essere i 2 pacchetti: libpam-kwallet4 libpam-kwallet5

riesci a rifare la schermata tipo questa? https://ibin.co/4l3dmweb4OPa.jpg

  • io penserei, se non hai particolari configurazioni e la /home separata, a una reinstallazione
(19 Giu, 10:51) sacarde sacarde's gravatar image

Mi scusi, vuole che le faccia lo screen dei risultati dei comandi sopra?

Per la reinstallazione ci stavo pensando da un po' sinceramente,non so cosa intende con "particolari configurazioni e la /home separata", l'unica cosa se si può è sapere se si possono salvare alcuni dati(non c'è nulla di importante, ho solo qualche progetto personale di poco conto), non ho fatto backup; nel caso non si possa pazienza, non è un problema per niente

(19 Giu, 11:29) lorenzo-_ lorenzo-_'s gravatar image
  • sinceramente gli errori sul modulo kwallet sono in un pacchetto che originariamente non c'e' su xubuntu, non so cosa pensare

  • se la /home fosse stata su una partizione separata i dati li sopra non sarebbero toccati

altrimenti basta inserire una chiavetta e copiarli a mano lo puoi fare o da riga di comando o da grafica di root (se funziona)

(19 Giu, 11:36) sacarde sacarde's gravatar image

una volta salvati i dati, per la reinstallazione?

(19 Giu, 13:31) lorenzo-_ lorenzo-_'s gravatar image

scegli la iso da scaricare, la metti su un supporto e installi

qui tutti i passi: https://wiki.ubuntu-it.org/Installazione/InstallareUbuntu

(19 Giu, 13:39) sacarde sacarde's gravatar image

per quanto riguarda grub e la partizione già creata?

(19 Giu, 14:06) lorenzo-_ lorenzo-_'s gravatar image
  • sei su un uefi, no?

  • segui la guida per uefi, quindi:

/boot la partizione minima (da formattare, se non hai altri sistemi che la usano)

/ la partizione di sistema (da formattare)

(19 Giu, 14:16) sacarde sacarde's gravatar image

quindi in sostanza cancello tutto compreso il grub e faccio una installazione pulita come se fosse la prima volta?

(19 Giu, 15:42) lorenzo-_ lorenzo-_'s gravatar image

si, come l'hai installata, ma, se scarichi la versione 18.04.2 trovi gia' gli aggiornamenti fatti

(19 Giu, 16:32) sacarde sacarde's gravatar image

Va bene, ti ringrazio per avermi aiutato. Buonagiornata

(19 Giu, 17:32) lorenzo-_ lorenzo-_'s gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×263

domanda posta: 16 Giu, 13:35

domanda visualizzata: 157 volte

ultimo aggiornamento: 19 Giu, 17:32

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.