Salve a tutti sono nuovo su linux e in pochi giorni ho già fatto un mucchio di casini. Di recente ho provato a usare gparted installandolo su chiavetta usb, ma si avvia ubuntu nonostante abbia impostato la sua attivazione dopo quella della chiavetta e il secure boot. Così ho provato a installarlo da terminale e ha funzionato perchè trovavo gparted tra le applicazioni, ma dopo avermi chiesto la password l'applicazione scompare dalla barra delle attività e da terminale mi da un errore. Mi potreste aiutare a farlo partire, grazie

chiesto 21 Giu, 15:57

Francesco%20Dile's gravatar image

Francesco Dile
202

  • gparted installato su chiavetta? ma intendi il programma o la distribuzione?

  • per vedere eventuali errori lancia "gparted" da terminale

(22 Giu, 09:23) sacarde sacarde's gravatar image

allora per la chiavetta non ti preoccupare, l'ho già rotta e non ne ho altre :(, per quanto riguarda il terminale se scrivo sudo gparted su terminale mi rimanda questo: Unit -.mount does not exist, proceeding anyway. /usr/sbin/gpartedbin: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory

(22 Giu, 15:54) Francesco Dile Francesco%20Dile's gravatar image

se lancio da terminale sudo gparted mi rimanda questo:Unit -.mount does not exist, proceeding anyway. /usr/sbin/gpartedbin: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory

(22 Giu, 16:01) Francesco Dile Francesco%20Dile's gravatar image

se lancio da terminale sudo gparted mi rimanda questo:Unit -.mount does not exist, proceeding anyway. /usr/sbin/gpartedbin: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory

coll. permanente

ha risposto 22 Giu, 16:02

Francesco%20Dile's gravatar image

Francesco Dile
202

quella libreria si trova nel pacchetto: libgtkmm-2.4-1v5

prova a installarlo

(22 Giu, 16:28) sacarde sacarde's gravatar image

allora il terminale mi dice che il pacchetto(come gparted) è installato alla versione più recente, inoltre volevo scusarmi del fatto che non ho ancora capito come rispondere su un forum (è la prima volta che ne uso uno ;-) )

(22 Giu, 18:18) Francesco Dile Francesco%20Dile's gravatar image

proviamo a vedere i file che lo compongono:

dpkg -L libgtkmm-2.4-1v5

e se esiste la libreria:

ls -l /usr/lib/x86_64-linux-gnu | grep libgtkmm

p.s. altrimenti reinstallalo:

sudo apt install --reinstall libgtkmm-2.4-1v5

p.s. questo non e' un vero forum, basta che accodi i commenti (in attesa della risposta giusta)

(22 Giu, 20:38) sacarde sacarde's gravatar image

allora scusa inanzi tutto per l'orario, comunque ho usato la funzione per reinstallarlo e il terminale al secondo comando che mi hai detto il terminale rimanda:

lrwxrwxrwx 1 root root 21 dic 18 2017 libgtkmm-2.4.so.1 -> libgtkmm-2.4.so.1.1.0 -rw-r--r-- 1 root root 4261512 dic 18 2017 libgtkmm-2.4.so.1.1.0

tuttavia cercando di avviare gparted mi rimanda:

Unit -.mount does not exist, proceeding anyway. /usr/sbin/gpartedbin: error while loading shared libraries: libatkmm-1.6.so.1: cannot open shared object file: No such file or directory

(22 Giu, 23:52) Francesco Dile Francesco%20Dile's gravatar image

reinstalla anche: libatkmm-1.6-1v5

(23 Giu, 08:34) sacarde sacarde's gravatar image

ok ho fatto ma se provo ora a installare gparted mi esce che non esiste libpangomm-1.4.so.1 e se provo il comando di reinstallazione mi dice che è impossibile trovarlo

(23 Giu, 11:01) Francesco Dile Francesco%20Dile's gravatar image

installa/reinstalla: libpangomm-1.4-1v5

(23 Giu, 11:04) sacarde sacarde's gravatar image

a quanto pare è installato alla versione più recente

(23 Giu, 11:12) Francesco Dile Francesco%20Dile's gravatar image

hai provato a reinstallarlo forzatamente anche lui?

sudo apt install --reinstall libpangomm-1.4-1v5

(23 Giu, 11:35) sacarde sacarde's gravatar image

con i comandi che mi hai scritto sono riuscito a installare/reinstallare libpangomm-1.4-1v5 un altro paio di pacchetti ma ora mi esce un certo libpangomm-2.0.so.0 che con i tuoi comandi non me lo trova

(23 Giu, 11:35) Francesco Dile Francesco%20Dile's gravatar image

con i tuoi comandi sono riuscito a installare diversi pacchetti ma ora è comparso un libsigc-2.0.so.0 che non riesco a installare con essi

coll. permanente

ha risposto 23 Giu, 12:01

Francesco%20Dile's gravatar image

Francesco Dile
202

prova con il pacchetto: libsigc++-2.0-0v5

sudo apt install --reinstall libsigc++-2.0-0v5

p.s. il file libpangomm-2.0.so.0 mai sentito !!

(23 Giu, 13:35) sacarde sacarde's gravatar image

Grazie mille, dopo quello ho dovuto solo installare un altro pacchetto e gparted si avvia, ora devo solo controllare che funzioni correttamente ed è apposto :-)

(23 Giu, 15:31) Francesco Dile Francesco%20Dile's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×30

domanda posta: 21 Giu, 15:57

domanda visualizzata: 73 volte

ultimo aggiornamento: 23 Giu, 15:31

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.