Ubuntu 19.04 x86_64 è lentissimo all'avvio. Mi pare di aver capito che il file radice è quasi completamento pieno e ho visto che ho una ventina di dev/loop e un sacco di altra roba.... intanto quale comando posso dare per rappresentare meglio la situazione? Grazie

chiesto 09 Lug, 22:19

andrea_ale's gravatar image

andrea_ale
10

  • per lo stato delle partizioni, prova a eseguire da terminale:

df -HT

  • per vedere i processi che usano piu' cpu: top
(10 Lug, 09:37) sacarde sacarde's gravatar image

12avanti »

Buongiorno, ecco qua:

user@user-Satellite-Pro-R50-B:~$ sudo df -HT [sudo] password di user: File system Tipo Dim. Usati Dispon. Uso% Montato su udev devtmpfs 2,0G 0 2,0G 0% /dev tmpfs tmpfs 405M 3,3M 402M 1% /run /dev/sda2 ext4 488G 310G 154G 67% / tmpfs tmpfs 2,1G 20M 2,1G 1% /dev/shm tmpfs tmpfs 5,3M 4,1k 5,3M 1% /run/lock tmpfs tmpfs 2,1G 0 2,1G 0% /sys/fs/cgroup /dev/loop1 squashfs 57M 57M 0 100% /snap/core18/1013 /dev/loop4 squashfs 38M 38M 0 100% /snap/gtk-common-themes/1198 /dev/loop0 squashfs 148M 148M 0 100% /snap/gnome-3-26-1604/88 /dev/loop11 squashfs 16M 16M 0 100% /snap/gnome-characters/292 /dev/loop2 squashfs 37M 37M 0 100% /snap/gtk-common-themes/818 /dev/loop13 squashfs 4,4M 4,4M 0 100% /snap/gnome-calculator/352 /dev/loop14 squashfs 1,1M 1,1M 0 100% /snap/gnome-logs/61 /dev/loop16 squashfs 4,0M 4,0M 0 100% /snap/gnome-system-monitor/95 /dev/loop3 squashfs 4,4M 4,4M 0 100% /snap/gnome-calculator/406 /dev/loop17 squashfs 4,0M 4,0M 0 100% /snap/gnome-system-monitor/91 /dev/loop12 squashfs 93M 93M 0 100% /snap/core/7270 /dev/loop8 squashfs 37M 37M 0 100% /snap/gtk-common-themes/1122 /dev/loop6 squashfs 158M 158M 0 100% /snap/gnome-3-28-1804/63 /dev/loop19 squashfs 16M 16M 0 100% /snap/gnome-logs/45 /dev/loop21 squashfs 2,4M 2,4M 0 100% /snap/gnome-calculator/260 /dev/loop18 squashfs 16M 16M 0 100% /snap/gnome-characters/288 /dev/loop20 squashfs 159M 159M 0 100% /snap/gnome-3-28-1804/59 /dev/loop10 squashfs 148M 148M 0 100% /snap/gnome-3-26-1604/90 /dev/loop9 squashfs 58M 58M 0 100% /snap/core18/1049 /dev/loop7 squashfs 9,0M 9,0M 0 100% /snap/canonical-livepatch/77 /dev/loop15 squashfs 93M 93M 0 100% /snap/core/7169 /dev/loop5 squashfs 9,0M 9,0M 0 100% /snap/canonical-livepatch/81 /dev/loop22 squashfs 1,1M 1,1M 0 100% /snap/gnome-logs/57 /dev/sda1 vfat 536M 8,0M 528M 2% /boot/efi tmpfs tmpfs 405M 144k 405M 1% /run/user/1000 user@user-Satellite-Pro-R50-B:~$

coll. permanente

ha risposto 10 Lug, 10:50

andrea_ale's gravatar image

andrea_ale
10

  • se vedo bene la "/" e' al 67 %

  • e' lento l'avvio o anche dopo? che vedi da: systemd-analyze critical-chain

incollalo qui: https://paste.ubuntu.com/

  • da "top" vedi sia i processi che la memoria
(10 Lug, 11:11) sacarde sacarde's gravatar image

Ho incollato. Allora, ci mette tanto ad avviare; poi una volta inserita la psw ci mette ancora tanto. Se può essere utile posso cronometrare. La "/" mi viene segnalata come critica da BleachBit. Mi pare di aver capito (ma non sono competente) che non si può aumentare...

coll. permanente

ha risposto 10 Lug, 12:07

andrea_ale's gravatar image

andrea_ale
10

  • dopo aver incollato devi riportare l'indirizzo

  • la "/" ha 154gb liberi

  • un altro comando per vedere i tempi: systemd-analyze blame

(10 Lug, 13:56) sacarde sacarde's gravatar image

Scusa, ma dove metto l'indirizzo (e quale) ?. Nel form c'è solo uno spazio per 30 caratteri nel quale ho inserito il nome...

(10 Lug, 16:14) andrea_ale andrea_ale's gravatar image

una volta pastato il testo nel form, premi "paste"

e ti ritorna una videata col testo immesso, devi indicare l'url completo

(10 Lug, 16:21) sacarde sacarde's gravatar image

L'ho postato tre volte, ho tolto le ultime due e ora non c'è pi niente... Riecco:

https://paste.ubuntu.com/p/GZ55sBpHds/

coll. permanente

ha risposto 10 Lug, 16:30

andrea_ale's gravatar image

andrea_ale
10

qui casi simili:

(10 Lug, 18:05) sacarde sacarde's gravatar image

Come faccio a vedere se ho il file..

(10 Lug, 18:52) andrea_ale andrea_ale's gravatar image

prova a editarlo con un qualsiasi editor, es:

sudo nano /etc/systemd/system/updatedb.timer.d/updatedb.timer.conf

(10 Lug, 19:18) sacarde sacarde's gravatar image

Allora, il file non ce l'ho, però ho seguito l'altro link che hai postato. Se ho ben capito si tratta di far partire gli aggiornamenti dopo che il computer è avviato. Ho editato i valori a 10 secondi e poi ho aggiunto (o almeno spero) un comando che fa partire apt-daily dopo almeno 15 minuti che il sistema è avviato. Va bene?

apt-daily timer configuration override

[Timer] OnBootSec=15min OnUnitActiveSec=1d AccuracySec=1h RandomizedDelaySec=30min

coll. permanente

ha risposto 10 Lug, 19:34

andrea_ale's gravatar image

andrea_ale
10

  • si, l'hai poi provato? e' piu veloce?

  • per l'altro faccio altre ricerche

(10 Lug, 19:50) sacarde sacarde's gravatar image

Macché, 3 minuti in tutto (1 min. e 43 secondi per arrivare alla psw e il resto prima che appaia la scrivania e poi passano altri pochi secondi prima che risponda ai comandi....) Controllo che mi abbia davvero modificato i valori a 10 secondi, per scrupolo

coll. permanente

ha risposto 10 Lug, 21:19

andrea_ale's gravatar image

andrea_ale
10

Controllato, ha cambiato i valori:

https://paste.ubuntu.com/p/79WxQBPTgD/

coll. permanente

ha risposto 10 Lug, 21:22

andrea_ale's gravatar image

andrea_ale
10

non ho capito... e' questo il comando che non ha funzionato?

sudo systemctl edit apt-daily.timer

(10 Lug, 21:56) sacarde sacarde's gravatar image

Questo non lo so, sono solo in grado di vedere se sono stati impostati i valori a 10 sec. e questo, in effetti, è avvenuto. Ho postato il risultato del terminale. Per il comando sudo systemctl edit apt-daily.timer ho fatto e non mi ha dato errori quindi dovrebbe essere a posto anche quello. Se c'è un comando che posso dare per verificarlo lo faccio subito se lo posti

coll. permanente

ha risposto 10 Lug, 22:17

andrea_ale's gravatar image

andrea_ale
10

i servizi dovrebbero essere dei file nella dir: /etc/systemd/system

mentre gli originali sono in: /usr/lib/systemd/system/

(10 Lug, 23:44) sacarde sacarde's gravatar image

ma il tempo di apt-daily non e' cambiato nonostante la modifica?

hai riavviato?

(11 Lug, 08:20) sacarde sacarde's gravatar image

E' lento come prima, più di 3 minuti. Ho guardato dal monitor del sistema e apt-daily non c'è all'avvio. Nel frattempo ho anche modificato la frequenza dei controlli per gli aggiornamenti è ho impostato una settimana. Quindi, per quanto ne posso capire, direi che il problema non è nella ricerca degli aggiornamenti. Ne dico una: la lentezza all'avvio può dipendere dal numero di files presenti nel computer?

coll. permanente

ha risposto 11 Lug, 13:38

andrea_ale's gravatar image

andrea_ale
10

  • quindi rimane solo il servizio man-db.service tra i piu lenti?

  • che vedi da:

ls -l /usr/lib/systemd/system | grep man-db

(11 Lug, 13:52) sacarde sacarde's gravatar image

user@user-Satellite-Pro-R50-B:~ $ ls -l /usr/lib/systemd/system | grep man-db ls: impossibile accedere a '/usr/lib/systemd/system': File o directory non esistente

coll. permanente

ha risposto 11 Lug, 13:59

andrea_ale's gravatar image

andrea_ale
10

Ho dato anche questo comando:

user@user-Satellite-Pro-R50-B:~$ systemd-analyze Startup finished in 2.794s (firmware) + 1.966s (loader) + 7.321s (kernel) + 1min 22.136s (userspace) = 1min 34.219s graphical.target reached after 1min 21.172s in userspace

coll. permanente

ha risposto 11 Lug, 14:11

andrea_ale's gravatar image

andrea_ale
10

rimane solo il servizio man-db.service tra i piu lenti?

  • pensi che sia rallentato anche dopo il boot? vedi i processi da: top
(11 Lug, 14:36) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×174

domanda posta: 09 Lug, 22:19

domanda visualizzata: 84 volte

ultimo aggiornamento: 11 Lug, 18:48

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.