0
1

Buongiorno, ho Ubuntu 18.04 che non rileva l'antenna WIFI USB AC600 dual band RT2870, come posso installarla? (Con Windows funziona). Premetto che non sono un esperto e col dischetto fornito seguo le istruzioni del file README_STA_usb ma mi blocco sulla riga:
$tar -xvzf DPB_RT2870_Linux_STA_x.x.x.x.tgz go to "./DPB_RT2870_Linux_STA_x.x.x.x" directory.

non so cme compilare le X Questo il risultato al comando lsusb thor@thor-Lenovo:~$ lsusb Bus 001 Device 005: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter Bus 001 Device 006: ID 0e8d:7610 MediaTek Inc. Bus 001 Device 004: ID 1a40:0101 Terminus Technology Inc. Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 003 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

chiesto 28 Set, 21:51

rperry's gravatar image

rperry
202

modificato 05 Ott, 23:13

non la vedi nel: lsusb ?

non e' la:

0bda:8178 Realtek Semiconductor Corp. RTL8192CU

?

(28 Set, 21:58) sacarde sacarde's gravatar image

Una doverosa precisazione, quella rilevata da lsusb come:

Device 005: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN

non è altro la chiavetta wifi 2,4Ghz che mi permette di navigare normalmente, il mio intento è di sfruttare il 5Gz con la AC600

coll. permanente

ha risposto 28 Set, 22:11

rperry's gravatar image

rperry
202

quando inserisci questa chiavetta... nelle ultime righe dal comando: dmesg

cosa vedi aggiunto?

(28 Set, 23:46) sacarde sacarde's gravatar image

Al comando DMESG inviato, prima senza aver collegato l'antenna USB e poi dopo averla collegata, si aggiungono queste righe:

[ 3458.166375] usb 1-5.3: new high-speed USB device number 9 using ehci-pci [ 3458.394734] usb 1-5.3: New USB device found, idVendor=0e8d, idProduct=7610 [ 3458.394737] usb 1-5.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [ 3458.394739] usb 1-5.3: Product: WiFi [ 3458.394741] usb 1-5.3: Manufacturer: MediaTek [ 3458.394742] usb 1-5.3: SerialNumber: 1.0

coll. permanente

ha risposto 29 Set, 17:37

rperry's gravatar image

rperry
202

Ho eseguito la sequenza di comandi indicata nel link ma arrivato all'installazione del driver viene chiesta user e password che non conosco alla riga:

thor@thor-Lenovo:~/mt7610u$ git clone https://github.com/ulli-kroll/mt7610u.git Cloning into 'mt7610u'... Username for 'https://github.com': mona lisa^[[D^[[D Password for 'https://mona li@github.com': remote: Invalid username or password. fatal: Authentication failed for 'https://github.com/ulli-kroll/mt7610u.git/'

E' stato fatto un bel passo avanti difatti ora l'antenna viene rilevata dal comando LSUSB ma non è disponibile tra le opzioni della rete WIFI.

thor@thor-Lenovo:~$ lsusb Bus 001 Device 005: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter Bus 001 Device 006: ID 0e8d:7610 MediaTek Inc. Bus 001 Device 004: ID 1a40:0101 Terminus Technology Inc. Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 003 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

coll. permanente

ha risposto 30 Set, 22:27

rperry's gravatar image

rperry
202

la riga e' tutt'una:

git clone https://github.com/xtknight/mt7610u-linksys-ae6000-wifi-fixes.git mt7610u_sta-1.0

(01 Ott, 09:45) sacarde sacarde's gravatar image

Grazie mille, ora ho completato tutti i passaggi indicati dal link di www.robarts. Non trovo però nella selezione del wifi nessuno switch a forma di pulsante e nella sezione reti e wifi vi è solo la vecchia chiavetta solo 2,4Ghz.

thor@thor-Lenovo:~$ iwconfig lo no wireless extensions.

ra0 Ralink STA ESSID:"11n-AP" Nickname:"MT7610U_STA" Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s
RTS thr:off Fragment thr:off Link Quality=10/100 Signal level:0 dBm Noise level:0 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

ens33 no wireless extensions.

wlxe8de27a6561a IEEE 802.11 ESSID:"2,4GHz Perry TIM-21006411"
Mode:Managed Frequency:2.437 GHz Access Point: A4:91:B1:40:88:4B
Bit Rate=72.2 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off Power Management:off Link Quality=46/70 Signal level=-64 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:8 Missed beacon:0

coll. permanente

ha risposto 01 Ott, 22:12

rperry's gravatar image

rperry
202

sembra la "ra0"

che vedi da:

ip a

inxi -n

iwconfig

dmesg|grep mt7610u

(02 Ott, 08:37) sacarde sacarde's gravatar image

Questi sono i risultati ottenuti:

thor@thor-Lenovo:~$ inxi -n Network: Card-1: Marvell 88E8056 PCI-E Gigabit Ethernet Controller driver: sky2 IF: ens33 state: down mac: 00:21:97:27:64:8b Card-2: Realtek RTL8192CU 802.11n WLAN Adapter driver: rtl8192cu IF: wlxe8de27a6561a state: N/A mac: N/A thor@thor-Lenovo:~$ iwconfig ra0 Ralink STA ESSID:"11n-AP" Nickname:"MT7610U_STA" Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s
RTS thr:off Fragment thr:off Link Quality=10/100 Signal level:0 dBm Noise level:0 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

ens33 no wireless extensions.

lo no wireless extensions.

wlxe8de27a6561a IEEE 802.11 ESSID:"2,4GHz Perry TIM-21006411"
Mode:Managed Frequency:2.437 GHz Access Point: A4:91:B1:40:88:4B
Bit Rate=72.2 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off Power Management:off Link Quality=54/70 Signal level=-56 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:53 Missed beacon:0

thor@thor-Lenovo:~$ dmesg|grep mt7610u [ 39.525558] mt7610u_sta: loading out-of-tree module taints kernel. [ 39.526583] mt7610u_sta: module verification failed: signature and/or required key missing - tainting kernel [ 54.898043] /home/thor/mt7610u_sta-1.0/os/linux/../../chips/mt76x0.c:2114 assert (pAd->TxPower[choffset].Channel == 36)failed

coll. permanente

ha risposto 02 Ott, 19:45

rperry's gravatar image

rperry
202

che vedi con:

modinfo mt7610u_sta

(03 Ott, 08:31) sacarde sacarde's gravatar image

e con:

sudo modprobe mt7610u_sta

e le ultime righe: dmesg

(03 Ott, 10:46) sacarde sacarde's gravatar image

Ancora grazie, questo con modinfo mt7610u_sta:

thor@thor-Lenovo:~$ modinfo mt7610u_sta filename: /lib/modules/4.15.0-65-generic/kernel/drivers/net/wireless/mt7610u_sta.ko version: 3.0.0.2 license: GPL description: RT2870 Wireless Lan Linux Driver author: Paul Lin paul_lin@ralinktech.com license: GPL srcversion: E6A5241C6891F1DFF8957C4 alias: usb:v0E8Dp7650ddcdscdpicFFisc02ipFFin alias: usb:v0E8Dp7630ddcdscdpicFFisc02ipFFin alias: usb:v20F4p806Bddcdscdpiciscipin alias: usb:v2019pAB31ddcdscdpiciscipin alias: usb:v293Cp5702ddcdscdpiciscipin alias: usb:v057Cp8502ddcdscdpiciscipin alias: usb:v04BBp0951ddcdscdpiciscipin alias: usb:v07B8p7610ddcdscdpiciscipin alias: usb:v0586p3425ddcdscdpiciscipin alias: usb:v2001p3D02ddcdscdpiciscipin alias: usb:v0DF6p0075ddcdscdpiciscipin alias: usb:v0B05p17DBddcdscdpiciscipin alias: usb:v0B05p17D1ddcdscdpiciscipin alias: usb:v2357p0105ddcdscdpiciscipin alias: usb:v148Fp760Addcdscdpiciscipin alias: usb:v2357p010Bddcdscdpiciscipin alias: usb:v148Fp761Addcdscdpiciscipin alias: usb:v7392pC711ddcdscdpiciscipin alias: usb:v7392pB711ddcdscdpiciscipin alias: usb:v7392pA711ddcdscdpiciscipin alias: usb:v13B1p003Eddcdscdpiciscipin alias: usb:v0E8Dp7610ddcdscdpiciscipin alias: usb:v148Fp7610ddcdscdpiciscipin depends: cfg80211 retpoline: Y name: mt7610u_sta vermagic: 4.15.0-65-generic SMP mod_unload parm: mac:wireless mac addr (charp) parm: debug:log verbosity level (0: off, 1: error only [default], 2: warnings, 3: trace, 4: info, 5: loud) (long) thor@thor-Lenovo:~$

queste le ultime righe con dmesg: [22578.214827] 80211> CFG80211_OpsScan ==> [22581.877457] 80211> Can not find any chan info! [22581.939585] 80211> Can not find any chan info! [22584.271329] 80211> cfg80211_scan_done [22584.271660] 80211> CFG80211_OpsSurveyGet ==> [22584.271663] 80211> busy time = -121671235268608 -121671237495040 [22641.214710] 80211> CFG80211_OpsScan ==> [22644.888858] 80211> Can not find any chan info! [22644.938853] 80211> Can not find any chan info! [22647.290972] 80211> cfg80211_scan_done [22647.291281] 80211> CFG80211_OpsSurveyGet ==> [22647.291284] 80211> busy time = -121671235268608 -121668996782592 [22704.220278] 80211> CFG80211_OpsScan ==> [22707.972255] 80211> Can not find any chan info! [22708.022269] 80211> Can not find any chan info! [22710.352746] 80211> cfg80211_scan_done [22710.353098] 80211> CFG80211_OpsSurveyGet ==> [22710.353102] 80211> busy time = -121671235268608 -121669012380416

coll. permanente

ha risposto 03 Ott, 21:21

rperry's gravatar image

rperry
202

che vedi da:

ifconfig -a

systool -vm mt7610u_sta

lsmod | grep mt7610u

p.s. le istruzioni (per la costruzione del modulo) le hai eseguite in modo preciso?

(04 Ott, 08:41) sacarde sacarde's gravatar image

le istruzioni le ho seguite precisamente, ma solo l'ultima volta, perché la prima volta avevo impostato la riga incompleta. Queste le risposte ai comandi che hai riportato: thor@thor-Lenovo:~$ ifconfig -a ens33: flags=4099<up,broadcast,multicast> mtu 1500 ether 00:21:97:27:64:8b txqueuelen 1000 (Ethernet) RX packets 0 bytes 0 (0.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 0 bytes 0 (0.0 B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 device interrupt 17

lo: flags=73<up,loopback,running> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 prefixlen 128 scopeid 0x10<host> loop txqueuelen 1000 (Loopback locale) RX packets 13945 bytes 26876588 (26.8 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 13945 bytes 26876588 (26.8 MB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

ra0: flags=4099<up,broadcast,multicast> mtu 1500 ether 80:3f:5d:16:af:63 txqueuelen 1000 (Ethernet) RX packets 4316 bytes 1177674 (1.1 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 470 bytes 47560 (47.5 KB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlxe8de27a6561a: flags=4163<up,broadcast,running,multicast> mtu 1500 inet 192.168.1.191 netmask 255.255.255.0 broadcast 192.168.1.255 inet6 fe80::eade:27ff:fea6:561a prefixlen 64 scopeid 0x20<link> ether e8:de:27:a6:56:1a txqueuelen 1000 (Ethernet) RX packets 25734 bytes 31869820 (31.8 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 17164 bytes 2898910 (2.8 MB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

thor@thor-Lenovo:~$ systool -vm mt7610u_sta Module = "mt7610u_sta"

Attributes: coresize = "880640" initsize = "0" initstate = "live" refcnt = "0" srcversion = "E6A5241C6891F1DFF8957C4" taint = "OE" uevent = <store method="" only=""> version = "3.0.0.2"

Sections:

thor@thor-Lenovo:~$ lsmod | grep mt7610u mt7610u_sta 880640 0 cfg80211 622592 3 rtlwifi,mac80211,mt7610u_sta

coll. permanente

ha risposto 04 Ott, 17:49

rperry's gravatar image

rperry
202

  • strano che il comando: systool non ci sia una sezione "parametri" con vari valori

  • mi confermi che da questo: dmesg|grep mt7610u ricevi sempre errori

  • dall'applet del networkmanager non c'e' traccia della "ra0" (sai se la dualband funziona come un'altra interfaccia wireless?)

  • che vedi da: rfkill list

(04 Ott, 20:48) sacarde sacarde's gravatar image

Come posso verificare se la dualband funziona come un'altra interfaccia wireless? Quali righe di comando dovrei dare per eliminare l'installazione e ripeterla ex novo? Ho spento e acceso il PC e ripetuto l'interrogazione: thor@thor-Lenovo:~$ systool -vm mt7610u_sta Module = "mt7610u_sta"

Attributes: coresize = "880640" initsize = "0" initstate = "live" refcnt = "0" srcversion = "E6A5241C6891F1DFF8957C4" taint = "OE" uevent = <store method="" only=""> version = "3.0.0.2"

Sections:

thor@thor-Lenovo:~$ dmesg|grep mt7610 [ 21.967856] mt7610u_sta: loading out-of-tree module taints kernel. [ 21.968754] mt7610u_sta: module verification failed: signature and/or required key missing - tainting kernel [ 52.846071] /home/thor/mt7610u_sta-1.0/os/linux/../../chips/mt76x0.c:2114 assert (pAd->TxPower[choffset].Channel == 36)failed

thor@thor-Lenovo:~$ rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no 1: phy1: Wireless LAN Soft blocked: no Hard blocked: no

coll. permanente

ha risposto 04 Ott, 21:40

rperry's gravatar image

rperry
202

p.s. per disintallarlo, da dentro la dir: mt7610u_sta-1.0 puoi dare:

make clean

make uninstall

(05 Ott, 09:53) sacarde sacarde's gravatar image

ho trovato il modulo dkms per ubuntu-18.04

https://launchpad.net/~timchen119/+archive/ubuntu/mt7610u-dkms

da provare:

sudo add-apt-repository ppa:timchen119/mt7610u-dkms

sudo apt-get update

sudo apt install mt7610u-dkms (installare il pcchetto)

sudo dkms add -m mt7610u -v 1.0

sudo dkms build -m mt7610u -v 1.0

sudo dkms install -m mt7610u -v 1.0

(05 Ott, 10:21) sacarde sacarde's gravatar image

RISOLTO!

Con il modulo dkms per ubuntu-18.04 mi ha dato una serie di errori e quindi non è andato a buon fine. Come mi hai suggerito, ho fatto l'upgrade a Ubuntu 19.04 e dopo un ora di aggiornamento come per incanto nella selezione rete è comparsa l'antenna dual band col 5 GHz perfettamente funzionate. GRAZIE MILLE dopo un anno di tentativi finalmente funzionaaaaa

coll. permanente

ha risposto 05 Ott, 23:08

rperry's gravatar image

rperry
202

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×436
×222

domanda posta: 28 Set, 21:51

domanda visualizzata: 86 volte

ultimo aggiornamento: 05 Ott, 23:13

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.