Salve a tutti, ho letto varie discussioni in merito ma ancora non sono riuscito a venire a capo del problema. Da qualche mese collegando il computer ad un qualunque cavo ethernet non riesco ad avere accesso alla rete. La connessione wifi funziona (anche se a tratti,a volte).

sudo lshw -c network *-network                 
   description: Wireless interface
   product: AR9485 Wireless Network Adapter
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 01
   serial: 6c:71:d9:29:73:03
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=4.18.0-25-generic firmware=N/A ip=192.168.1.19 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:17 memory:f7900000-f797ffff memory:f7980000-f798ffff 
*-network
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0.2
   bus info: pci@0000:04:00.2
   logical name: enp4s0f2
   version: 0a
   serial: 08:60:6e:1c:cd:1c
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8411-1_0.0.3 06/18/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:19 ioport:d000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff

Questo mi fa quindi pensare che il driver c'è ed è installato, a differenza delle altre discussioni che ho trovato.

Versione kernel: 4.18.0-25-generic

Versione Ubuntu: 18.10

chiesto 05 Ott, 18:53

albb's gravatar image

albb
202

che vedi da: lspci

da: systool -vm r8169

da: ip a

  • usi networkmanager vero? ci sono errori?

systemctl --failed

journalctl -b -p err

(05 Ott, 20:59) sacarde sacarde's gravatar image

Ciao, grazie per aver risposto.

lspci
    00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
    00:04.0 Signal processing controller: Intel Corporation 3rd Gen Core Processor Thermal Subsystem (rev 09)
    00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
    00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
    00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
    00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
    00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
    00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
    00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
    00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
    00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
    00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
    00:1f.6 Signal processing controller: Intel Corporation 7 Series/C210 Series Chipset Family Thermal Management Controller (rev 04)
    01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 635M] (rev a1)
    03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
    04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411 PCI Express Card Reader (rev 01)
    04:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)

systool -vm r8169
Module = "r8169"

  Attributes:
    coresize            = "86016"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "0"
    srcversion          = "BE818F2928AD877F2F8CF7A"
    taint               = ""
    uevent              = <store method only>
    version             = "2.3LK-NAPI"

  Sections:

ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0f2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 08:60:6e:1c:cd:1c brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 6c:71:d9:29:73:03 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.19/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp3s0
       valid_lft 2375sec preferred_lft 2375sec
    inet6 fe80::c8da:adba:83e1:1823/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

systemctl --failed
0 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

systemctl --failed -all
0 loaded units listed.
To show all installed unit files use 'systemctl list-unit-files'.

journalctl -b -p err
-- Logs begin at Thu 2019-03-14 17:55:06 CET, end at Sat 2019-10-05 21:17:01 CEST. --
ott 05 18:12:15 alberto-K56CM kernel: ACPI Error: Needed type [Reference], found [Integer] (____ptrval____) (20180531/exre
ott 05 18:12:15 alberto-K56CM kernel: ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20180531/dswe
ott 05 18:12:15 alberto-K56CM kernel: ACPI Error: Method parse/execution failed \_PR.CPU0._PDC, AE_AML_OPERAND_TYPE (20180
ott 05 18:12:15 alberto-K56CM kernel: sd 6:0:0:0: [sdb] No Caching mode page found
ott 05 18:12:15 alberto-K56CM kernel: sd 6:0:0:0: [sdb] Assuming drive cache: write through
ott 05 18:12:15 alberto-K56CM kernel: scsi 6:0:0:1: Wrong diagnostic page; asked for 1 got 8
ott 05 18:12:15 alberto-K56CM kernel: scsi 6:0:0:1: Failed to get diagnostic page 0x1
ott 05 18:12:15 alberto-K56CM kernel: scsi 6:0:0:1: Failed to bind enclosure -19
ott 05 18:12:15 alberto-K56CM kernel: ACPI Error: AE_AML_PACKAGE_LIMIT, Index (0x000000003) is beyond end of object (lengt
ott 05 18:12:15 alberto-K56CM kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.GFX0._DSM, AE_AML_PACKAGE_LIMIT 
ott 05 18:12:15 alberto-K56CM kernel: ACPI Error: AE_AML_PACKAGE_LIMIT, Index (0x000000003) is beyond end of object (lengt
ott 05 18:12:15 alberto-K56CM kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.GFX0._DSM, AE_AML_PACKAGE_LIMIT 
ott 05 18:12:15 alberto-K56CM kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.PEG0.PEGP._DSM, AE_AML_PACKAGE_L
ott 05 18:12:18 alberto-K56CM gdm3[1200]: GLib-GObject: g_object_add_weak_pointer: assertion 'G_IS_OBJECT (object)' failed
ott 05 18:12:24 alberto-K56CM spice-vdagent[1886]: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice
ott 05 18:47:03 alberto-K56CM kernel: nouveau 0000:01:00.0: msvld: unable to load firmware data
ott 05 18:47:03 alberto-K56CM kernel: nouveau 0000:01:00.0: msvld: init failed, -19
coll. permanente

ha risposto 05 Ott, 21:21

albb's gravatar image

albb
202

qui simile risolvono

https://forum.ubuntu-it.org/viewtopic.php?p=5090946

p.s. p.s. che vedi con: dmesg | grep r8169

ls -l /lib/firmware/rtl_nic/

(06 Ott, 08:38) sacarde sacarde's gravatar image
    dmesg | grep r8169
[    1.640891] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    1.640902] r8169 0000:04:00.2: can't disable ASPM; OS doesn't have ASPM control
[    1.641826] r8169 0000:04:00.2 eth0: RTL8411, 08:60:6e:1c:cd:1c, XID 48800800, IRQ 27
[    1.641828] r8169 0000:04:00.2 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[    1.670792] r8169 0000:04:00.2 enp4s0f2: renamed from eth0
[    7.934220] r8169 0000:04:00.2 enp4s0f2: link down

ls -l /lib/firmware/rtl_nic/
totale 92
-rw-r--r-- 1 root root 2076 mar 30  2017 rtl8105e-1.fw
-rw-r--r-- 1 root root 1856 mar 30  2017 rtl8106e-1.fw
-rw-r--r-- 1 root root  832 mar 30  2017 rtl8106e-2.fw
-rw-r--r-- 1 root root  992 mar 30  2017 rtl8107e-1.fw
-rw-r--r-- 1 root root  976 mar 30  2017 rtl8107e-2.fw
-rw-r--r-- 1 root root 1492 mar 30  2017 rtl8168d-1.fw
-rw-r--r-- 1 root root 1324 mar 30  2017 rtl8168d-2.fw
-rw-r--r-- 1 root root 5500 mar 30  2017 rtl8168e-1.fw
-rw-r--r-- 1 root root 3920 mar 30  2017 rtl8168e-2.fw
-rw-r--r-- 1 root root 3872 mar 30  2017 rtl8168e-3.fw
-rw-r--r-- 1 root root 3424 mar 30  2017 rtl8168f-1.fw
-rw-r--r-- 1 root root 1232 mar 30  2017 rtl8168f-2.fw
-rw-r--r-- 1 root root 4304 mar 30  2017 rtl8168g-1.fw
-rw-r--r-- 1 root root 4896 mar 30  2017 rtl8168g-2.fw
-rw-r--r-- 1 root root  832 mar 30  2017 rtl8168g-3.fw
-rw-r--r-- 1 root root  992 mar 30  2017 rtl8168h-1.fw
-rw-r--r-- 1 root root  976 mar 30  2017 rtl8168h-2.fw
-rw-r--r-- 1 root root 1824 mar 30  2017 rtl8402-1.fw
-rw-r--r-- 1 root root 2112 mar 30  2017 rtl8411-1.fw
-rw-r--r-- 1 root root 1040 mar 30  2017 rtl8411-2.fw

ho seguito i comandi riportati nel link che hai postato.

Le risposte a questi comandi non cambiano. Cambia lsmod che ora ha r8168.

Comunque non funziona.

Grazie per il tempo che mi stai dedicando

coll. permanente

ha risposto 06 Ott, 14:18

albb's gravatar image

albb
202

  • quindi avevi il pacchetto r8168-dkms e l'hai tolto? come dice quel link?

  • che vedi con: modinfo r8168

modinfo r8169

ip a

(06 Ott, 17:34) sacarde sacarde's gravatar image

Ho seguito quella "guida" ma nulla era cambiato. Poi ho provato ad installare r8168 con synaptic, ma ancora non risolto. Questo è il risultato di modinfo. Inizio a perdere le speranze di potermi collegare di nuovo alla rete ethernet

modinfo r8168
filename:       /lib/modules/4.18.0-25-generic/kernel/drivers/net/ethernet/realtek/r8168.ko
version:        8.047.04-NAPI
license:        GPL
description:    RealTek RTL-8168 Gigabit Ethernet driver
author:         Realtek and the Linux r8168 crew <netdev@vger.kernel.org>
srcversion:     D3FC079D8040CD24274CA37
alias:          pci:v00001186d00004300sv00001186sd00004B10bc*sc*i*
alias:          pci:v000010ECd00002600sv*sd*bc*sc*i*
alias:          pci:v000010ECd00002502sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008161sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008168sv*sd*bc*sc*i*
depends:        
retpoline:      Y
name:           r8168
vermagic:       4.18.0-25-generic SMP mod_unload 
parm:           speed_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           duplex_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           autoneg_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           advertising_mode:force phy operation. Deprecated by ethtool (8). (uint)
parm:           aspm:Enable ASPM. (int)
parm:           s5wol:Enable Shutdown Wake On Lan. (int)
parm:           s5_keep_curr_mac:Enable Shutdown Keep Current MAC Address. (int)
parm:           rx_copybreak:Copy breakpoint for copy-only-tiny-frames (int)
parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm:           timer_count:Timer Interrupt Interval. (int)
parm:           eee_enable:Enable Energy Efficient Ethernet. (int)
parm:           hwoptimize:Enable HW optimization function. (ulong)
parm:           s0_magic_packet:Enable S0 Magic Packet. (int)
parm:           debug:Debug verbosity level (0=none, ..., 16=all) (int)
coll. permanente

ha risposto 06 Ott, 18:54

albb's gravatar image

albb
202

da synaptic quale pacchetto? r8168-dkms ?

p.s. non ho chiaro... quindi r8168 o r8169 non funzionano ugualmente?

p.s. la configurazione dalla applet networkmanager e' sempre la stessa?

(06 Ott, 21:03) sacarde sacarde's gravatar image

Esatto r8168 , c'è solo quello. Esatto sembrano non funzionare nessuno dei due Direi di sì, intendi le icone della barra in alto?

coll. permanente

ha risposto 06 Ott, 22:50

albb's gravatar image

albb
202

inxi -n

  • si la applet della config di rete in alto a destra
(07 Ott, 09:53) sacarde sacarde's gravatar image

Ho seguito il secondo metodo della guida linkata. Ancora nessuna connessione

    ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 6c:71:d9:29:73:03 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.22/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp3s0
       valid_lft 3323sec preferred_lft 3323sec
    inet6 fe80::c8da:adba:83e1:1823/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
5: enp4s0f2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 08:60:6e:1c:cd:1c brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.23/24 brd 192.168.1.255 scope global dynamic noprefixroute enp4s0f2
       valid_lft 2851sec preferred_lft 2851sec
    inet6 fe80::a60:6eff:fe1c:cd1c/64 scope link 
       valid_lft forever preferred_lft forever

///////////////////////////////////////

ethtool -i enp4s0f2
driver: r8168
version: 8.046.00-NAPI
firmware-version: 
expansion-rom-version: 
bus-info: 0000:04:00.2
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes
supports-priv-flags: no

/////////////////////////////////

inxi -n
Network:   Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
           IF: wlp3s0 state: up mac: 6c:71:d9:29:73:03 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: enp4s0f2 state: up speed: 100 Mbps duplex: full mac: 08:60:6e:1c:cd:1c 
           Device-3: IMC Networks Atheros AR3012 Bluetooth 4.0 Adapter type: USB driver: btusb
coll. permanente

ha risposto 07 Ott, 16:45

albb's gravatar image

albb
202

mah... mi pare che abbia preso l'IP

enp4s0f2 192.168.1.23

no ?

(07 Ott, 18:00) sacarde sacarde's gravatar image

E quindi dovrebbe funzionare, questo intendi? Purtroppo non si carica nessuna pagina. Da monitor di sistema vedo che scambia pochissimi Kb di dati.

coll. permanente

ha risposto 07 Ott, 18:05

albb's gravatar image

albb
202

  • prova a disattivare la wireless (dall'applet networkmanager)

connetti/controlla la enp4s0f2

e da terminale esegui:

ping 8.8.8.8

ping google.it

risponde?

(07 Ott, 20:27) sacarde sacarde's gravatar image

Niente da fare.

//////////////////////

ifconfig enp4s0f2 enp4s0f2: flags=4163<up,broadcast,running,multicast> mtu 1500 inet 192.168.1.23 netmask 255.255.255.0 broadcast 192.168.1.255 inet6 fe80::a60:6eff:fe1c:cd1c prefixlen 64 scopeid 0x20<link> ether 08:60:6e:1c:cd:1c txqueuelen 1000 (Ethernet) RX packets 33990 bytes 42446084 (42.4 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 947 bytes 83203 (83.2 KB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 device interrupt 27 base 0x5000

/////////////////////////////////

ping google.it
    connect: La rete non è raggiungibile
coll. permanente

ha risposto 07 Ott, 23:02

albb's gravatar image

albb
202

Niente da fare

ifconfig enp4s0f2
enp4s0f2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.23  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::a60:6eff:fe1c:cd1c  prefixlen 64  scopeid 0x20<link>
        ether 08:60:6e:1c:cd:1c  txqueuelen 1000  (Ethernet)
        RX packets 33990  bytes 42446084 (42.4 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 947  bytes 83203 (83.2 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 27  base 0x5000

ping google.it
connect: La rete non è raggiungibile
coll. permanente

ha risposto 07 Ott, 23:11

albb's gravatar image

albb
202

prova a disattivare tutte e 2 le reti da networkmanager

e a provare a prendere l'IP della ethernet:

sudo ifconfig enp4s0f2 up

sudo dhclient enp4s0f2

lo prende l'IP ?

(07 Ott, 23:44) sacarde sacarde's gravatar image

Dopo aver dato

sudo dhclient enp4s0f2

RTNETLINK answers: File exists

la lan funziona e pinga bene. Però al riavvio tutto come prima. Non sono per nulla esperto di questa roba. Riesco a trovare una soluzione?

(08 Ott, 14:02) albb albb's gravatar image
  • quindi disattivando la wireless funziona la ethernet? ho capito bene?

  • allora e' un problema di configurazione di networkmanager

prova a seguire qui: (connessione e impostazione dns) https://wiki.ubuntu-it.org/InternetRete/ConfigurazioneRete/NetworkManager#Connessione_simultanea_ethernet_e_WiFi

(08 Ott, 16:36) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×31
×20

domanda posta: 05 Ott, 18:53

domanda visualizzata: 59 volte

ultimo aggiornamento: 08 Ott, 16:36

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.