Salve a tutti, ho un problema, alcune applicazuoni su ubuntu 18.04.3 si istallano ma non si avviano, mi danno questo errore: $ qbittorrent qbittorrent: error while loading shared libraries: libdouble-conversion.so.1: cannot open shared object file: No such file or directory

~$ gparted Unit -.mount does not exist, proceeding anyway. /usr/sbin/gpartedbin: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory

Ho provato vari modi x risolverlo, ma non ci riesco. Grazie x l'aiuto

chiesto 19 Nov, 01:04

strendi's gravatar image

strendi
202

le 2 librerie che non trova sono nei pacchetti:

libdouble-conversion-dev

libgtkmm-2.4-dev

quindi o aggiorni tutto il sistema o questi 2 pacchetti

sudo apt install --reinstall ......

(19 Nov, 09:27) sacarde sacarde's gravatar image

Grazie x la risposta, avevo già provato quei comandi, ho lo stesso problema su linux mint con l'app boor repair, ho provato a istallare e reinstallare l'applicazione in tutti i modi e cercato di aggiornare i pacchetti che mi chiedeva ma niente, ho provato anche questi comandi ma senza successo:

sudo apt-get --fix-broken install

sudo rm /var/lib/apt/lists/* -vf sudo apt-get update

sudo apt-get clean sudo apt-get autoclean sudo apt-get autoremove

sudo apt-get updatesudo dpkg --configure -a sudo apt-get update

se hai qualche altra soluzuone ti sarei grato. Grazie ancora

(19 Nov, 16:54) strendi strendi's gravatar image
  • hai anche eseguito:

sudo apt update

sudo apt upgrade

aggiornando tutto?

p.s. per vedere se hai quelle librerie:

locate libdouble-conversion.so

locate libgtkmm-2.4.so

(19 Nov, 16:59) sacarde sacarde's gravatar image

adesso sono su mint, e mi da questo errore, ma non riesco ad aggiornare questo pacchetto: $ boot-repair [sudo] password di strendi:
Traceback (most recent call last): File "/usr/bin/glade2script-gtk2", line 4638, in <module> m = Gui() File "/usr/bin/glade2script-gtk2", line 1832, in init self.widgets.add_from_file(f_glade) glib.GError: /usr/share/boot-sav/boot-sav.glade: required gtk+ version 3.0, current version is 2.24

(19 Nov, 17:29) strendi strendi's gravatar image

intendi questo?

https://wiki.ubuntu-it.org/AmministrazioneSistema/BootRepair

ma cosa c'entra con questa domanda?

(19 Nov, 17:44) sacarde sacarde's gravatar image

(Scusami x la domanda di prima è ke ero su mint e ho lo stesso problema con l'applicazione boot repair.) ho provato i due comandi su ubuntu, che mi hai detto tu e mi sembra che ci siano i due pacchetti, ti posto il terminale: strendi@strendi-SATELLITE-L850-1PD:~$ dpkg -L libdouble-conversion-dev | grep libdouble-conversion.so /usr/lib/x86_64-linux-gnu/libdouble-conversion.so strendi@strendi-SATELLITE-L850-1PD:~$ dpkg -L libgtkmm-2.4-dev | grep libgtkmm-2.4.so /usr/lib/x86_64-linux-gnu/libgtkmm-2.4.so

cosa dici?

coll. permanente

ha risposto 19 Nov, 18:36

strendi's gravatar image

strendi
202

dico che doveva venire fuori anche le librerie:

libdouble-conversion.so.1 e libgtkmm-2.4.so.1

ma non le vedo, proviamo a cancellarli nella cache di apt e reinstallarli

cd /var/cache/apt/archives/

sudo rm libdouble-conversion-dev*

sudo rm libgtkmm-2.4-dev*

e reinstalliamoli

(19 Nov, 21:32) sacarde sacarde's gravatar image

mi sono sbagliato pacchetti...

prova a installare: libdouble-conversion1 e libgtkmm-2.4-1v5

(19 Nov, 22:03) sacarde sacarde's gravatar image

grazie x la risposta, avevo già provato quei comandi e li ho riprovati ma niente,ho lo stesso problema anche su linux mint con l'app boot repair, ho provato a disinstallarla e riistallarla sia da terminale che dal repository e istallare i pacchetti che mi chiede ma niente non si avvia, sbaglierò qualcosa ma non sò dove, ho provato anche questi comandi ma niente lo stesso:

sudo apt-get --fix-broken install

sudo rm /var/lib/apt/lists/* -vf sudo apt-get update

sudo apt-get clean sudo apt-get autoclean sudo apt-get autoremove

sudo apt-get updatesudo dpkg --configure -a sudo apt-get update

se hai qualche altra soluzione te ne sarei grato. Grazie ancora

coll. permanente

ha risposto 19 Nov, 17:15

strendi's gravatar image

strendi
202

per assicurarti di avere quelle librerie:

dpkg -L libdouble-conversion-dev | grep libdouble-conversion.so

dpkg -L libgtkmm-2.4-dev | grep libgtkmm-2.4.so

(19 Nov, 17:21) sacarde sacarde's gravatar image

ciao, grazie ancora ho fatto tutto quello she mi hai detto, istallato e aggiornato ma non và, mi dà che devo ristallare l'applicazione, ho provato ad istallarla dal repository, da terminale e da pacchetto .deb, ma mi da sempre questo, ti posto il terminale: strendi@strendi-SATELLITE-L850-1PD:~$ qbittorrent This application failed to start because it could not find or load the Qt platform plugin "xcb" in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Reinstalling the application may fix this problem. Annullato (core dump creato)

Grazie ancora

coll. permanente

ha risposto 19 Nov, 23:51

strendi's gravatar image

strendi
202

prova a eseguire da terminale:

export QT_PLUGIN_PATH=/usr/lib/x86_64-linux-gnu/qt5/plugins

e poi a lanciare: qbittorrent

(20 Nov, 08:31) sacarde sacarde's gravatar image

dimmi come votare le tue risposte. Grazie ancora

(21 Nov, 10:42) strendi strendi's gravatar image

Ciao, grazie delle tue rispose e del tuo tempo, ho provato ad eseguire da terminale quello che hai detto ma non cambiava nulla, poi ho cercato un pò in rete e ho trovato questo comando: export QT_DEBUG_PLUGINS=1 .Per vedere l'effttivo messaggio di errore generato da QT e mi diceva che mi mancava il pacchetto libxcb-xinerama.so.0 allora ho provato ad istallarlo da terminale ma non lo trovava, così ho cercato il pacchetto in rete, scaricato e istallato normalmente con apri istallarore software,e qBittorrent è partito subito. GRAZIE ancora del tuo aiuto

coll. permanente

ha risposto 21 Nov, 09:55

strendi's gravatar image

strendi
202

Ciao, sacarde, spiegami come devo fare per votare le tue risposte, perche non ci riesco, mi escono i pollici x votare solo sulle mie risposte.

coll. permanente

ha risposto 21 Nov, 10:41

strendi's gravatar image

strendi
202

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×291

domanda posta: 19 Nov, 01:04

domanda visualizzata: 55 volte

ultimo aggiornamento: 21 Nov, 10:42

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.