salve, in seguito ad una modifica del file xorg xubuntu non si avvia ,nemmeno da live, mi appare lo schermo nero con trattino lampeggiante in alto a sinistra , il mio pc è un DESKTOP-6FG93G9 HP processore Dual-Core CPU E5200 2.50GHz RAM 4,00 GB, inoltre xubuntu è installato in dual boot con win 10 da cui sto scrivendo, potete consigliarmi una soluzione? Grazie

chiesto 24 Jan '20, 10:27

marcarm's gravatar image

marcarm
20136

volevo aggiungere che la mia scheda video è una Intel(R) Q33 Express Chipset Family

(24 Jan '20, 10:33) marcarm marcarm's gravatar image
  • provato a passare al kernel: "nomodeset" ?

  • nemmeno la live? prova anche da li "nomodeset" o "xforcefesa"

https://wiki.ubuntu-it.org/Installazione/ParametriAvvio

(24 Jan '20, 10:40) sacarde sacarde's gravatar image

salve non conosco la procedura per passare al kernell "nomodeset", cercando di ripristinare da live peggio, non si avvia nessuna live, mi da errore di kernell, oro voglio provare con una versione vecchia tipo 16.4

(24 Jan '20, 12:31) marcarm marcarm's gravatar image

nienta da fare la live non mi parte ne da usb e ne da dvd, non conosco la procedura "nomodeset" cercherò qualcosa on line, ora pensavo di provare con una versione live 16.4 per vedere se con la vecchia versione mi parte la live

(24 Jan '20, 12:36) marcarm marcarm's gravatar image

ho provato anche con una versione live precedente, la 16.4 ma non si avvia mi rimanda un messaggio KERNELL PANIC ,sono sconcertato

(24 Jan '20, 12:46) marcarm marcarm's gravatar image
  • "nomodeset" lo puoi aggiungere alla live come descritto nel mio link di sopra

  • il sistema installato quale era/e' ?

  • l'hai controllato l'iso? lo puoi fare anche dal live con: controlla disco da difetti

  • come hai costruito il dvd/chiavetta?

  • l'hardware e' vecchio? provato a fare un test della ram?

(24 Jan '20, 13:29) sacarde sacarde's gravatar image

ho provato con "nomodeset" nulla. Il mio sistema è xubuntu 18.4 LTS la iSO l'ho scaricata da sito ufficiale, comunque proverò a controllarla, ma non credo abbia problemi perché ho provato cone tre ISO differenti ed il risultato è uguale. Per quanto riguarda la chiavetta l'ho preparata sia con "Rufus" che con "Linuxlive usb creator" nessuna differenza

(24 Jan '20, 16:33) marcarm marcarm's gravatar image
  • "schermo nero con trattino" e "kernel panic" sono 2 errori molto diversi

  • controlla anche la ram

  • prova a immettere anche altri parametri:

acpi=off noapic nolapic xforcevesa nomodeset

(24 Jan '20, 16:58) sacarde sacarde's gravatar image

la ram è stata testata di recente e comunque con win 10 va una favola per mi sento di escluderla, per il secondo suggerimento provo ora anche se andare per tentativi mi fa un po' di paura aggiorno quanto prima

(24 Jan '20, 17:11) marcarm marcarm's gravatar image
  • strano che non funzioni neanche la live... nemmeno quella con la quale hai installato...!
(24 Jan '20, 17:13) sacarde sacarde's gravatar image

il sistema fu installato più di tre anni fa sempre con usb dopo ripartizione disco rigido,adesso ho appena provato con tutte le opzioni da live con il tasto F6 (acpi=off noapic nolapic xforcevesa nomodeset) ma mi da sempre lo stesso errore ; END KERNEL PANIC -NOT SYNCING : ATTEMPTED TO KILL INIT! EXIT CODE = 0X00000009. Nel web non trovo niente, sto pensando di formattare la partizione con ubuntu e reinstallare

(24 Jan '20, 20:20) marcarm marcarm's gravatar image
  • installasti il 16.04 poi aggiornato alla 18.04 ?

  • controllato "difetti del disco" ?

  • prima del kernel panic, cosa vedi?

  • cel'hai un altro pc per provare la chiavetta?

(24 Jan '20, 20:46) sacarde sacarde's gravatar image

si naturalmente era la versione 16.4 successivamente aggiornata alla 18.04, ho provato a controllare i difetti del disco da usb mi da errore KERNEL come mostrato in precedenza, prima del "kernel panic " vedo la schermata dell'installer di ubuntu ma appena clicco su qualsiasi opzione mi da errore PANIC KERNEL, cosa mi consigli riguardo l'idea di riformattare la partizione da Windows e poi reinstallare?

(24 Jan '20, 20:52) marcarm marcarm's gravatar image

ma come fai a reinstallare? se non parte

p.s. qui passano al kernel: retain_initrd

https://www.linuxquestions.org/questions/slackware-installation-40/kernel-panic-4175614613/

(24 Jan '20, 20:57) sacarde sacarde's gravatar image

bhè immagino che riformattando il disco l'installazione dovrebbe partire, infatti il problema non è la macchina, due giorni fa ho tolto win 7 e messo il 10 senza problemi, io credo che ci sia un problema di compatibilità tra il kernel e il software installato nella partizione

(24 Jan '20, 21:03) marcarm marcarm's gravatar image

grazie per il link, gli darò uno sguardo domani, per oggi ho già dato abbastanza

(24 Jan '20, 21:06) marcarm marcarm's gravatar image
  • facendo partire il live, non tocca/legge l'HD

p.s. cosa vedi prima della riga: "kernel panic..."?

(24 Jan '20, 21:08) sacarde sacarde's gravatar image

scusa ma non ho capito la domanda

(24 Jan '20, 21:38) marcarm marcarm's gravatar image
  • che io sappia il live non legge/scrive nulla sul HD
(24 Jan '20, 21:46) sacarde sacarde's gravatar image

io andrei per gradi, cioè vorrei tentare di ripristinare la versione di xubuntu in uso e poi tenterei di risolvere la questione del KERNEL PANIC, dico questo perché sono quasi certo che la versione in uso non si apre a causa del server grafico danneggiato, come posso fare a riscriverlo in modalità provvisoria?

(25 Jan '20, 09:54) marcarm marcarm's gravatar image
  • ah, quindi intervenire sulla modifica al file con di xorg.... ok ok

  • se non ti parte nessuna live, non so come farlo da windows!!

a meno che non parta in modalita' "ripristino" (singolo utente) accedendo da root, e poi rinominare il file /etc/X11/xorg.conf

(25 Jan '20, 10:08) sacarde sacarde's gravatar image

io pensavo di entrare in modalità provvisoria (riesco a vedere la schermata con tutte le opzioni) attivare internet e aprire la shell con privilegi di root per poi apportare le modifiche P.S. in precedenza ho tentato di reinstallare il file xorg da root e mi dice file assente, inoltre non ricordo dove ho letto che le distro odierne non utilizzano più il file xorg

(25 Jan '20, 12:20) marcarm marcarm's gravatar image
  • ma hai detto tu: "modifica del file di xorg" , tu a quale file ti riferivi?
(25 Jan '20, 13:19) sacarde sacarde's gravatar image

cerco di spiegarmi meglio : io credevo di dover modificare il file di xorg e facendolo 1° ho commesso sicuramente errori di scrittura 2° cercando poi il sopracitato file per verificare i danni mi è giunta risposta che IL FILE NON ESISTE 3° facendo una ricerca mi pare di aver capito che xorg non viene più usato nelle attuali distro, per cui immagino di aver incasinato il server grafico di defoult, che mi consigli?

(25 Jan '20, 16:48) marcarm marcarm's gravatar image
(25 Jan '20, 17:21) sacarde sacarde's gravatar image

forse ho dimenticato di dire che sono un utente ubuntu ma non sono esperto di Linux, quello che mi occorre sapere è come posso riparare il server grafico da modalità provvisoria con privilegi di root, credo che si possa tentare ma avrei bisogno di una guida passo passo

(25 Jan '20, 18:18) marcarm marcarm's gravatar image

Aggiornamento: ho tentato di reinstallare il server Xubuntu-Desktop da modalità di ripristino con privilegi di root e ho scoperto che pur attivando la rete non si connette con nessuna repository, ho letto che può essere un problema di IP statico, ma da ripristino non saprei come cambiarlo

(25 Jan '20, 19:03) marcarm marcarm's gravatar image
  • ma il file /etc/X11/xorg.conf c'e' o no?

  • hai avviato con funzionalita' di rete? che vedi da: ip a

e da: ping 8.8.8.8

e da: ping google.it

(25 Jan '20, 20:47) sacarde sacarde's gravatar image

da quello che ho potuto capire il file /etc/X11/xorg.conf risulta corrotto o assente, la tua seconda citazione per me è incomprensibile, non sono un esperto come già detto, se per cortesia me lo rispieghi in modo elementare, magari ci provo

(26 Jan '20, 08:48) marcarm marcarm's gravatar image
  • dopo che sei entrato in modalita' recovery, accesso root con rete, prova a dare questi comandi:

ip a

ping 8.8.8.8

ping google.it

cosa risponde?

(26 Jan '20, 09:01) sacarde sacarde's gravatar image

grazie per la pazienza dunque vado a memoria perchè come già detto devo usare win 10 per scrivere quindi non saprei come copiare ed incollare i risultati dei comandi, ad ogni modo i primi due comandi mi rispondono positivamente, nel primo vedo le carattesristiche di rete o qualcosa di simile, con il secondo mi da i tempi di risposta del provider(credo) mentre l'ultimo comando mi dice "ERRORE TEMPORANEO NELLA RISOLUZIONE DEL NOME" sono sempre più sconcertato

(26 Jan '20, 10:14) marcarm marcarm's gravatar image

ok, la rete sembra attiva, manca la risoluzione dei nomi...

prova a editare il file /etc/resolv.conf e a mettere nella prima riga:

nameserver 8.8.8.8

e salva

e riprova: ping google.it

(26 Jan '20, 10:19) sacarde sacarde's gravatar image

scusa ma non ci sono riuscito, sono entrato con nano per editare il file, c'erano 4 righe di cui una in maiuscolo mi avvertiva di non modificare il file manualmente, mi è venuta paura nel caso avessi perso anche la connessione con win 10 isolandomi dal mondo (ti ricordo che i sistemi sono 2 ma la macchina è 1. inoltre la prima riga era occupata non sapevo se cancellarla e scrivere la nuova o se aggiungere una nuova riga in alto (ma non so come si fa) puoi suggerirmi una guida dettagliata, intanto io guardo sul web

(26 Jan '20, 10:46) marcarm marcarm's gravatar image

basta che la prima riga sia quella che ti ho detto... (le righe che iniziano con # sono dei commenti)

questo file viene sovrascritto quando parte (in modalita' grafica) il network-manager

(26 Jan '20, 10:54) sacarde sacarde's gravatar image

cerco di essere ancora più chiaro: NON SONO CAPACE! scusa le maiuscole ma così forse si capisce meglio ti spiego sono entrato in /etc/resolv.conf ho aggiunto la riga senza cancelletto "nameserver 8.8.8.8 premo ctrl+x poi s e mi chiede di nominare il file aggiunto......qui mi perdo

(26 Jan '20, 17:56) marcarm marcarm's gravatar image

non devi rinominarlo, ma mantenere lo stesso nome, lo devi sovrascrivere, poi esci e ripeti i vari "ping" per verifica

(26 Jan '20, 18:05) sacarde sacarde's gravatar image

grazie per il tuo tempo ma i tuoi commenti esprimono l'idea ma non spiegano come realizzarla. essendo poco pratico non riesco a capire come fare ad ottenere quello che mi consigli, mi sono convinto a riformattare la partizione di linux da windows con "gestione dischi" e poi tento una installazione da zero con live usb

(26 Jan '20, 19:05) marcarm marcarm's gravatar image
  • forse ho capito male, ma, come fai a reinstallare se l'usb/live non ti parte?

  • una volta dentro "nano" e aggiunta la riga, devi dare:

ctrl-X poi rispondere S + invio (per salvare)

(26 Jan '20, 20:31) sacarde sacarde's gravatar image

io credo che la live non parte per conflitto software-kernell quindi cancellando ubuntu elimino il conflitto e installo da zero

quando clicco S in nano per salvare in basso mi appare una scritta che mi chiede come nominare il file e non mi fa uscire da nano

sto cercando una guida dettagliata perchè sicuramente sbaglio qualcosa ma non trovo niente

(26 Jan '20, 21:28) marcarm marcarm's gravatar image
  • il live non si occupa del sistema nella partizione

  • dopo ctrl-X rispondi "S" e poi premi "invio" mantenendo inalterato il nome

(questa operazione la fai da "root" vero?)

(26 Jan '20, 21:32) sacarde sacarde's gravatar image

il sistema nella partizione prima lo cancello poi formatto in ext4 e poi uso la live

ctrl+X +S + invio mi blocca sulla scritta in basso non mi fa uscire da nano

tutto questo lo faccio da shell con privilegi di root in modalità ripristino

(26 Jan '20, 22:04) marcarm marcarm's gravatar image

AGGIORNAMENTO

sono riuscito ad attivare la rete da root

ho dato apt-get autoremove apt-get update apt-get dist-upgrade ma la distro non si avvia

(26 Jan '20, 23:10) marcarm marcarm's gravatar image

quindi stessi problemi? trattino in alto

p.s. puoi provare a ristartare il DM:

systemctl restart gdm

(26 Jan '20, 23:36) sacarde sacarde's gravatar image

francamente non so di cosa stai parlando, ma se ha a che fare con il server grafico potrebbe funzionare perchè sono certo che il problema si trova nel server sopracitato

pensavo di provare con "installa xubuntu-desktop" o provare a creare un file xorg.conf valido e senza errori

(27 Jan '20, 07:50) marcarm marcarm's gravatar image

ho visto che xubuntu utilizza lightdm (e non gdm)

quindi per riavviare il display-manager devi fare:

systemctl restart lightdm

e per vedere eventuali errori: systemctl status lightdm

(27 Jan '20, 08:21) sacarde sacarde's gravatar image

ho provato come dici

lo status risultava spento

ho provato con il comando systemctl restart lightdm e niente

ho dato su -c "apt-get upadate" su -c "dpkg configure -a" su -c "apt-get -f install"

tutto inutile adesso mi appare il cursore con due righe che recitano "usb 1-3: 3:1: cannot get freq at ep 0x84

ho notato che molti repository risultano con firma mancante o inutilizzati perchè non sicuri

sgomento!

(27 Jan '20, 09:35) marcarm marcarm's gravatar image

ho dimenticato di aggiungere che ho tentato anche di reinstallare xubuntu desktop con il comando "apt-get install xubuntu-desktop"

mi ha restituito alcuni errori con i repository come descritto al commento precedente

(27 Jan '20, 09:44) marcarm marcarm's gravatar image
  • se hai riavviato, il file /etc/resolv.conf l'hai rimodificato?

quindi alcuni repository li trova e altri no?

controllali con questi: https://wiki.ubuntu-it.org/Repository/SourcesList

  • /etc/X11/xorg.conf non c'e' vero?

  • se da recovery, avvii il sistema con grafica ridotta che errori hai?

  • ci sarebbe un'altro modo per avviare la grafica, creare un file di nome ".xinitrc" con dentro una riga:

exec startxfce4

e successivamente eseguire: startx

(27 Jan '20, 09:57) sacarde sacarde's gravatar image

si certamente il /etc/resolv.conf lo modifico ogni volta

si alcuni repository fungono normalmente

il /etc/X11/xorg.con non ho verificato

Grafica ridotta ? cosa intendi....

e se tentassi di riconfigurare-installare il file xorg?

(27 Jan '20, 10:12) marcarm marcarm's gravatar image
(27 Jan '20, 10:24) sacarde sacarde's gravatar image

in recovery riesco ad arrivare tranquillamente alla schermata rosso grigia con le varie opzioni

ho provato a riconfigurare il server grafico come da guida mi restituisce due errori e con "cp $HOME/xorg.conf.new /etc/X11/xorg.conf" mi dice file root/xorg.conf.new non esiste

(27 Jan '20, 10:59) marcarm marcarm's gravatar image
  • tra le opzioni c'e' anche "modalita grafica ridotta" ?

  • prova con: cp /root/xorg.conf.new /etc/X11/xorg.conf

(27 Jan '20, 11:11) sacarde sacarde's gravatar image

FATTO! Grazie infinite

ho dato il comando che dicevi tu dopo aver stoppato il server X ed infine ho fatto ripartire il server con start e tutto è risolto adesso ti sto scrivendo da xubuntu

grazie ancora

P.S. dove posso postare una guida?

(27 Jan '20, 11:57) marcarm marcarm's gravatar image

posto una guida per descrivere come ho risolto.

I comandi che seguono vanno dati senza le virgolette.

Nel comando X -configure la (X) deve essere maiuscola

iniziamo

1 sono entrato in modalità provvisoria

2 nelle opzioni ho scelto "abilita rete"

3 poi sono andato in shell con privilegi di root

4 ho digitato "mount -o remount,rw /

5 poi ho dato "nano /etc/resolv.conf"

6 ho aggiunto in alto "nameserver 8.8.8.8" nella seconda riga "nameserver 8.8.4.4" questo passaggio va fatto solo se non si riesce a collegarsi con i repository a causa dell IP statico

per terminare con il passo nr 6 premere "ctrl" poi "x" poi "s" poi "invio"

7 a seguire ho scritto " service lightdm stop "

                    " X -configure "

                    " cp /root/xorg.conf.new /etc/X11/xorg.conf "

                    premere"invio"

                    " service lightdm start "

Finito!

coll. permanente

ha risposto 27 Jan '20, 12:55

marcarm's gravatar image

marcarm
20136

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×279

domanda posta: 24 Jan '20, 10:27

domanda visualizzata: 374 volte

ultimo aggiornamento: 27 Jan '20, 12:55

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.