Buongiorno. Pensavo di saper saper fare questa installazione (fatta più volte in passato), ma con questa macchina, quando vado ad installare Ubuntu 18.04 il PC si blocca, come se Ubuntu andasse a danneggiare qualche file di avvio di Win10. Credo sia un problema di settaggio HW, perché non riesco a disabilitare il Secure Boot. Inoltre c'è un menu boot\CSM che parla di UEFI e legacy OPROM (?) che si articola in ulteriore menu, dove cè, fra le altre, la dizione UEFI driver first... Il mio dispositivo è:CPU Intel Core i7 7700K @ 4.20GHz Tecnologia Kaby Lake 14nm RAM 32,0GB Canale Doppio Sconosciuto @ 1467 MHz (15-17-17-35) Scheda Madre ASUSTeK COMPUTER INC. Z170 PRO GAMING (LGA1151) Grafica Acer Z271 (1920x1080@60Hz) HAIER (1920x1080@60Hz) 4095 MBNVIDIA GeForce GTX 1080 (NVIDIA) Memorizzazione 465GB Samsung SSD 850 EVO 500GB (SSD) 931GB Western Digital WDC WD10EZRZ-00HTKB0 (SATA) 223GB SanDisk SDSSDA240G (SSD) Grazie in anticipo per qualsiasi aiuto... spero di non dover abbandonare Ubunu!

chiesto 02 Feb, 14:31

Frency's gravatar image

Frency
352512

l'installazione inizia? dove si ferma?

https://wiki.ubuntu-it.org/Installazione/InstallareUbuntu

(02 Feb, 16:49) sacarde sacarde's gravatar image

Sì, l'installazione inizia. Quando arrivo alle partizioni, mi dice un messaggio di allarme che riguarda le GPT e MBR (se ricordo bene), però va fino in fondo. Ma quando riavvio si blocca tutto. La macchina va spontaneamente sui settaggi HW. Ti ringrazio per il link, ma quello l'ho letto varie volte. Credo che sia una cosa non difficile, ma io che non sono un installatore di professione, non riesco a capirla...

(03 Feb, 14:47) Frency Frency's gravatar image
  • se l'installazione e' terminata correttamente, al riavvio per vedere i messaggi del kernel per capire dove si ferma prova a eliminare (temporaneamente) i parametri passati al kernel "quiet splash" e a aggiungere "nomodeset"

qui la guida: https://wiki.ubuntu.com/Kernel/KernelBootParameters#Temporarily_Add_a_Kernel_Boot_Parameter_for_Testing

(03 Feb, 17:57) sacarde sacarde's gravatar image

Ti ringrazio molto per il tuo tempo; purtroppo devo dirti che non sono in grado di inoltrarmi in questo ginepraio. Speravo ci fosse un modo più semplice (come in passato). Sono certo che basterebbe sapere come settare l'HW del mio PC. Ho 60 anni e fatico molto a stare appresso a questi tecnicismi. Speravo che qualcuno mi linkasse un tutorial fatto con macchina simile. A titolo di collaboraz. per la com. Linux ribadisco che se si vuole che questo meraviglioso SO surclassi definitivamente gli altri, è indispensabile semplificare la vita agli appassionati "un po'limitati" come me. Grazie ancora

(03 Feb, 18:12) Frency Frency's gravatar image
  • quella guida spiega passo passo come modificare quei parametri...(temporaneamente)

  • cosa intendi per "hw del PC"

p.s. io ho 55 anni

(03 Feb, 18:27) sacarde sacarde's gravatar image

Ok, grazie, adesso me la vado a rileggere; ma non avevo trovato delle voci uguali alle mie. Spero di "indovinare" una corrispondenza...Per HW del PC intendo settaggio iniziale della macchina, quello che una volta si chiamava BIOS. Beato te che a 55 anni sei ancora fresco di mente, io sto cominciando a perdere colpi...comunque ribadisco che sono certo che molta più gente userebbe Linux se si potesse evitare di usare il terminale... almeno per un uso basico

(04 Feb, 12:19) Frency Frency's gravatar image

ubuntu non e' che scassa windows...

accortezze:

  • usare la partizione /boot quella che usa anche windows

  • installare grub (sia per linux che per windows) in /dev/sda (il disco principale)

(04 Feb, 13:34) sacarde sacarde's gravatar image

Ok, grazie. Mi sto accingendo a riprovare e ti informo. Comunque credo che nel mio caso devo fare un'installazione UEFI, perché, come anticipato, non riesco a disattivare il secure boot nel BIOS. Il GRUB sicuramente cercherò di metterlo lì, ma avendo tre dischi Linux volevo metterlo sul 3° disco, come già feci su un'altra macchina in passato... che ne dici?

(05 Feb, 10:45) Frency Frency's gravatar image
  • "credo" che tu lo possa mettere anche su un'altro disco, ma conta dove installi il loader grub ...
(05 Feb, 10:50) sacarde sacarde's gravatar image

...questo in teoria l'avevo capito anche prima... in teoria! Spero di farcela! ti faccio sapere...

(05 Feb, 10:57) Frency Frency's gravatar image

Sono al punto cruciale! Dove piazzo GRUB? in /dev/sda oppure in in /dev/sda2 Woindows boot manager?

(05 Feb, 13:22) Frency Frency's gravatar image

oltretutto non sono riuscito a disattivare il secure boot nel BIOS. Comunque finora sembrerebbe non aver infastidito la partenza della "live"

(05 Feb, 13:23) Frency Frency's gravatar image

Sono al punto cruciale. Dove installo il GRUB, in in /dev/sda o in in /dev/sda2 Windows boot manager? La live è partita, ma non sono riuscito a disattivare il secure boot del BIOS

(05 Feb, 13:25) Frency Frency's gravatar image
  • come mai? non trovi l'opzione o non lo fa fare? (comunque lo vedi se ti fa fare l'installazione o no)

  • sicuramente nel disco /dev/sda (o comunque nel disco da cui fai partire il boot)

(05 Feb, 13:41) sacarde sacarde's gravatar image

... credo di avercela fatta! Siccome la tua risposta tardava, ho agito d'iniziativa, anche sulla base dell'esperienza di precedenti tentativi ed ho collocato il GRUB in /dev/sda2 Windows boot manager. Sembra funzionare anche con il secure boot non disabilitato (ho consultato anche un installatore di PC che non mi ha saputo rispondere). Per avere la massima chiarezza e ridurre la possibilità di casini, durante la live ho lanciato gparted è ho predisposto le partizioni...

(05 Feb, 13:48) Frency Frency's gravatar image
  • ma vedi che parte il loader di windows? e da li ubuntu?

  • ma avevi mai installato grub in /dev/sda?

(05 Feb, 14:07) sacarde sacarde's gravatar image

Non capisco la tua 1^ domanda. Win parte sì se dal GRUB lo selezioni; in un tentativo prec.e mi pareva di averlo messo su sda e si era bloccato tutto. Comunque rimane il problema del secure boot. Ubuntu mi avverte che non potrò scaricare SW di terze parti. Mi ha proposto un aiuto per disabilitarlo, ma seguendo le sue istruzioni ad un tratto mi sono trovato ad una schermata blu (tipo BIOS, ma non l'avevo mai vista prima) con menu che parlava di un certo MOK... per evitare complicazioni l'ho aggirata e sono tornato a Ubuntu... sai darmi qualche dritta al riguardo? Grazie ancora...

(05 Feb, 14:21) Frency Frency's gravatar image
  • mmm software di terze parti? schermata blu? ... non mi viene in mente al momento

MOK ? ma ubuntu si era gia' avviato? o prima?

(05 Feb, 14:43) sacarde sacarde's gravatar image

Sì, sì, Ubuntu si era avviato prima, anche se "limitato" da questi avvertimenti. Certo, 'sto problema del secure boot è una iattura... ora proverò in rete. Comunque grazie per il sostegno. Se trovo qualcosa è opportuno che lo posto qui?

(05 Feb, 15:40) Frency Frency's gravatar image

certo...

il PC e' un assemblato ? o ha una marca

(05 Feb, 16:36) sacarde sacarde's gravatar image

Il mio PC è assemblato. La MB è ASUS. Comunque ti aggiorno. Nei milioni di tentativi che ho fatto, ho provato a cambiare questo settaggio, nel menu boot del BIOS: da "windows UEFI" ad "other OS". Credo (non ne sono ancora sicuro) che questo sia l'unico modo praticabile per poveri mortali di aggirare il secure boot. Per disabilitarlo completamente servirebbe districarsi in un casino con delle "chiavi"...boh! Comunque per ora sembra funzionare tutto. Ho fatto gli aggiornamenti è sto completando il lavoro con una guida post-installazione... speriamo!

(05 Feb, 16:52) Frency Frency's gravatar image

Ciao. Senti, il mio dispositivo sembra funzionare. Che devo fare, devo mettere risolto, anche se non ben chiaro il perché? Che ne pensi?

(06 Feb, 20:57) Frency Frency's gravatar image

puoi lasciare cosi... se ti viene in mente qualcosa la aggiungi...

(06 Feb, 21:26) sacarde sacarde's gravatar image

Ok, grazie ancora per il supporto

(07 Feb, 15:35) Frency Frency's gravatar image

Ciao, anche io ho avuto dei problemi durante l'installazione ma per fortuna ho risolto. Parto dalla base (sicuramente la sai ma è per capire cosa ho fatto dopo):

Innanzitutto per togliere il secure-boot bisogna impostare una password per il UEFI (segnatela bene perché è irrecuperabile). Poi mi sono accorto che i tutorial di youtube che ho guardato erano corretti, tranne per il fatto dello /boot, di cui nessuno mi aveva mai parlato. Dopo l'installazione dovrebbe tornare a Windows, e lì mettere nel cmd(da amministratore) questo comando per il GRUB: bcdedit /set “{bootmgr}” path \EFI\ubuntu\grubx64.efi

Ora arriviamo alla sostanza: nonostante la password del UEFI e ad aver disabilitato il secure-boot, quest'ultimo si è riattivato senza preavviso. Dopo il GRUB ho fatto il riavvio avanzato e sono andato nuovamente nel UEFI e l'ho ridisabilitato per poi riavviare il sistema.

Non penso che il problema sia il danneggiamento dei file di Windows, questo sempre che tu abbia dato le giuste partizioni. Ti sconsiglio di usare "Installa Ubuntu con Windows 10" (o quello che c'è scritto) perché è importante che tu gli dica esplicitamente cosa fare dello spazio libero. Il blocco durante l'installazione è una cosa normale, infatti anche a me si bloccava. Tu lascialo lavorare, tieni comunque da conto che stai installando un Sistema Operativo, non un programma qualsiasi. Fai il solito backup prima dell'installazione e dovrebbe andare tutto a gonfie vele.

Spero di esserti stato utile!

coll. permanente

ha risposto 11 Feb, 19:10

giulio-ubuntu's gravatar image

giulio-ubuntu
1813

Intanto grazie per esserti interessato e aver perso tempo. Mi rincresce ammettere di non aver capito molto di quello che hai spiegato. Comunque, alla fine, ero già riuscito ad installare Ubuntu in Dual Boot con Windows, MA non sono riuscito a disattivare il secure boot (ho trovato un'altra opzione, "other OS" che sembra aver funzionato); per di più il GRUB, dopo vari tentativi, ho dovuto installarlo non all'inizio, ma sulla voce "Windows Boot Manager" che compare fra le opzioni nella schermata delle partizioni. Spero di essermi spiegato...

(12 Feb, 15:01) Frency Frency's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×292
×48
×38

domanda posta: 02 Feb, 14:31

domanda visualizzata: 224 volte

ultimo aggiornamento: 12 Feb, 15:02

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.