Salve, vorrei cercare di risolvere una situazione che si è create al termine della configurazione di un computer, cercherò di descrivere la situazione nel modo più esauriente possibile. Hard disk con tre partizioni primarie, più una estesa con due partizioni logiche:

1° partizione: installo Windows 10

2° partizione: installo ancora Windows 10, ma con una label personalizzata per distinguerlo dall'altro Windows 10; è una partizione che serve per effettuare backup e ripristini di varie immagini di Windows 10 della prima partizione mediante software di terze parti

3° partizione: dopo aver generato e salvato (su una delle partizioni logiche) tutte le immagini di Windows di mio interesse, ho installato Ubuntu, nello specifico Caine 11.0, la cui procedura di installazione, trattandosi di un computer basato su un BIOS datato, ha richiesto l'esecuzione del BootRepair e, al riavvio, la correzione di alcune voci con il Grub Customizer.

Ora, in questa configurazione, la schermata di boot di Ubuntu vede soltanto un Windows 10, Ubuntu/Caine e il recovery mode. Per accedere al Windows sulla seconda partizione devo selezionare Windows 10 dal boot di Ubuntu, accedere al dual boot di Windows, scegliere da lì il secondo Windows, il che riapre il boot di Ubuntu dove la voce Windows 10 finalmente mi apre il Windows sulla seconda partizione!

E' risolvibile questo problema? Cioè come faccio ad avviare tutto dal boot di Ubuntu senza dover passare più dal dual boot tra i due Windows?

chiesto 16 Feb, 11:13

gaspare75's gravatar image

gaspare75
102

modificato 16 Feb, 11:14

quando da ubuntu esegui: sudo update-grub

quanto windows ti trova?

(16 Feb, 14:25) sacarde sacarde's gravatar image

Trova due Windows 10 entrambi su /dev/sda1

Che si può fare per sistemare?

(17 Feb, 09:08) gaspare75 gaspare75's gravatar image
  • che vedi da: fdisk -l /dev/sda

  • provato a avviare i 2 windows?

(17 Feb, 11:51) sacarde sacarde's gravatar image

Dice "fdisk; cannot open /dev/sda: permission denied

I due Windows si avviano tranquillamente ma con la sequenza che avevo descritto: primo Windows boot da Ubuntu e boot da Windows; secondo Windows boot da Ubuntu, boot da Windows, di nuovo boot da Ubuntu (scegliendo la stessa voce Windows 10 per accedere al primo).

(17 Feb, 15:45) gaspare75 gaspare75's gravatar image
  • e con: sudo fdisk -l /dev/sda

  • i 2 windows dal menu di grub ti portano allo stesso loader di windows, ho capito bene?

  • i 2 windows hanno l'avvio veloce abilitato?

(17 Feb, 16:46) sacarde sacarde's gravatar image

Quel comando causa un fdisk bad usage.

No, nel grub ho un solo Windows 10, che mi porta al boot loader di Windows dove posso scegliere quale Windows avviare, ma passando nuovamente dal grub di Ubuntu e scegliendo di nuovo lo stesso Windows 10.

Non ho idea sull'avvio veloce di Windows, posso dirti che per installare i sistemi operativi da chiavetta ho dovuto disabilitare il fast bios mode.

(18 Feb, 11:41) gaspare75 gaspare75's gravatar image
(18 Feb, 11:55) sacarde sacarde's gravatar image

L'avvio rapido è attivo, impostazione predefinita e alquanto annidata. Disabilitarla in tutte le immagini di backup fatte e rifare i backup è tuttavia insostenibile. :(

Avevo capito che quella fosse una elle e come tale l'ho inserita. ;)

No UEFI, il che mi ha dato qualche intoppo anche nell'installazione di Ubuntu, con un Boot Repair da eseguire manualmente a installazione terminata...

(18 Feb, 12:22) gaspare75 gaspare75's gravatar image
  • l'avvio rapido deve essere disattivato, altrimenti e' come se il sistema fosse ibernato su una partizione

  • al posto di fdisk prova con: parted -l

  • cosa vedi da: dmesg | grep sda

(18 Feb, 13:23) sacarde sacarde's gravatar image

Non dubito la correttezza delle impostazioni, ma è strano che su un'altra macchina ho installato la stessa configurazione 2 Windows + Ubuntu e funziona.

(18 Feb, 13:26) gaspare75 gaspare75's gravatar image

Parted -l non fa nulla, dmesg visualizza correttamente tutte le sda.

(21 Feb, 10:46) gaspare75 gaspare75's gravatar image

e: sudo parted -l /dev/sda

(21 Feb, 10:59) sacarde sacarde's gravatar image

Anche togliendo l'avvio rapido al sistema operativo non visto, la schermata delle partizioni di Ubuntu vede il primo Windows solamente, l'altra partizione risulta occupata ma non da un sistema operativo. Il problema si presenta identico anche su un Acer oltre che su un Samsung. Perché la fanno tanto complicata l'installazione di Ubuntu???

(21 Feb, 11:00) gaspare75 gaspare75's gravatar image

hai rieseguito: sudo update-grub

(21 Feb, 11:26) sacarde sacarde's gravatar image

sudo parted -l /dev/sda Visualizza tutte le partizioni esistenti riconoscendo le primary e le relative label. Anche Gparted vede le label ma la schermata dove decidere di installare Ubuntu (sda3) vede sda2 occupata ma non da un sistema operativo. Non so più come spiegare la situazione, ho anche tolto l'avvio rapido ai due Windows.

(21 Feb, 11:28) gaspare75 gaspare75's gravatar image

Potrò verificare domani mattina questa cosa e fornire una risposta precisa. Posso dire che, all'atto dell'installazione di Ubuntu, la schermata delle partizioni vedeva Windows 10 su sda1 (con tanto di label) mentre sda2 risultava occupato ma senza label. Anche quando ho fatto il BootRepair tra le righe del terminale ho visto l'etichetta di Windows 10 ma non del Windows sulla partizione sda2 che, ripeto, resta accessibile dopo quel curioso rimbalzo di boot tra Ubuntu e Windows...

coll. permanente

ha risposto 16 Feb, 14:40

gaspare75's gravatar image

gaspare75
102

fa quel rimbalzo perche' grub e' installato su una partizione e il loader di windows su un'altra

(16 Feb, 17:06) sacarde sacarde's gravatar image

Fuori dell'ambiente Windows non sono molto smaliziato: più persone mi hanno detto di installare il grub in /dev/sda; in passato avevo installato qualche distribuzione di Linux sul mio pc personale senza dover scegliere nulla se non tra affiancarlo a Windows o formattare l'intero disco.

(16 Feb, 17:23) gaspare75 gaspare75's gravatar image

allora e' grub che lancia il loader di windows (anche se a regola dovrebbe trovare lui tutti i vari sistemi esistenti...)

(16 Feb, 17:30) sacarde sacarde's gravatar image

In pratica sia l'installer di Ubuntu che il grub vedono soltanto la partizione attiva.

(16 Feb, 17:44) gaspare75 gaspare75's gravatar image

sudo update-grub risponde con /usr/sbin/grub-probe: error: failed to get canonical path of '/cow'

Che è adesso questo cow???

coll. permanente

ha risposto 21 Feb, 11:32

gaspare75's gravatar image

gaspare75
102

(21 Feb, 11:40) sacarde sacarde's gravatar image

BootRepair l'ho tentato prima di chiedere qui sul forum, nulla di fatto. Credo ci sia qualcosa da impostare da Windows, in modo che Ubuntu veda entrambe i sistemi, ma cosa?

(21 Feb, 11:46) gaspare75 gaspare75's gravatar image

ma l'hai eseguito anche dopo aver tolto il fastboot?

oppure eseguire "sudo update-grub" da una live

(21 Feb, 11:54) sacarde sacarde's gravatar image

Boot Repair non ha cambiato di una virgola la situazione anche dopo l'avvio rapido dai due Windows: il secondo Windows per Ubuntu non è un sistema operativo! sudo update-grub continua a non trovare il path del /cow.

(21 Feb, 12:53) gaspare75 gaspare75's gravatar image

mai provato un ripristino "normale" di grub ?

https://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino

(21 Feb, 13:44) sacarde sacarde's gravatar image

Ho provato soltanto boot repair... Purtroppo non essendo esperto di Linux non amo "tentare" soluzioni da terminale, dato che non oltre due mesi fa, per risolvere un problema di login che andava in loop (come se la password fosse sbagliata), inviai dei comandi che non fecero più avviare nulla, né Ubuntu né Windows, e dovetti reinstallare tutto da zero.

Per questo speravo in una soluzione via Windows che permettesse a Ubuntu di vedere i due Windows.

(21 Feb, 13:59) gaspare75 gaspare75's gravatar image
  • o provi a chiedere ai forum istituzionali di ubuntu, italiano o inglese

  • o chiedi suggerimenti su canali windows

  • o reinstalli ubuntu

(21 Feb, 14:14) sacarde sacarde's gravatar image

Ubuntu non l'ho installato poiché mi perderebbe, come già successo, l'accesso al secondo Windows; i tentativi sono tutti dalla chiavetta live.

Grazie per la pazienza, cercherò altrove una eventuale soluzione...

(21 Feb, 16:47) gaspare75 gaspare75's gravatar image

i comandi da terminale per il ripristino non sono poi cosi' difficili...

sono 7 passi: https://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino/BiosMBR

p.s. purtroppo su windows non ti posso aiutare

(21 Feb, 16:58) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,933
×211
×71
×3

domanda posta: 16 Feb, 11:13

domanda visualizzata: 247 volte

ultimo aggiornamento: 21 Feb, 17:20

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.