Salve a tutti, ho da poco installato Ubuntu 18.04 Lts, ed ho riscontrato un problema con il Joystick usb, non da segni di vita (lo stesso joystick in passato funzionava su ubuntu 14.04). Nelle cartelle di sistema dev\input\by id risultano solo mouse e tastiera. Mentre digitando dal terminale il comando usb-devices mi da questo:

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 2 D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1 P: Vendor=1d6b ProdID=0002 Rev=05.03 S: Manufacturer=Linux 5.3.0-45-generic ehci_hcd S: Product=EHCI Host Controller S: SerialNumber=0000:00:1a.0 C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 4 D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1 P: Vendor=8087 ProdID=0024 Rev=00.00 C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 2 D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1 P: Vendor=1d6b ProdID=0002 Rev=05.03 S: Manufacturer=Linux 5.3.0-45-generic ehci_hcd S: Product=EHCI Host Controller S: SerialNumber=0000:00:1d.0 C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 6 D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1 P: Vendor=8087 ProdID=0024 Rev=00.00 C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=02 Lev=02 Prnt=02 Port=01 Cnt=01 Dev#= 3 Spd=1.5 MxCh= 0 D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1 P: Vendor=0000 ProdID=0538 Rev=01.00 S: Product= USB OPTICAL MOUSE C: #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA I: If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=02 Driver=usbhid

T: Bus=02 Lev=02 Prnt=02 Port=03 Cnt=02 Dev#= 23 Spd=1.5 MxCh= 0 D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1 P: Vendor=1c4f ProdID=0002 Rev=01.10 S: Manufacturer=SIGMACHIP S: Product=USB Keyboard C: #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=98mA I: If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=01 Driver=usbhid I: If#= 1 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=00 Driver=usbhid

Quindi se ho capito bene (sono ignorante in materia scusatemi) viene letto come collegato. Per cortesia potete aiutarmi, grazie.

chiesto 03 Apr, 04:29

manzodiego83's gravatar image

manzodiego83
201

che vedi da: lsusb

che vedi, dopo che lo hai inserito, dalle ultime righe del comando: dmesg

p.s. letto? https://wiki.ubuntu-it.org/Hardware/Periferiche/JoystickGenerico

(03 Apr, 09:09) sacarde sacarde's gravatar image

Grazie, usando il comando lsusb esce:

Bus 002 Device 004: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory Bus 002 Device 003: ID 0000:0538
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Comunque credo che il sistema non lo legga proprio il Joystick o che non lo installi. riguardo la guida digitando il commando ls /dev/js* mi da directory inesistente e dando il comando jstest mi da: Usage: jstest [<mode>] <device>

Modes: --normal One-line mode showing immediate status --old Same as --normal, using 0.x interface --event Prints events as they come in --nonblock Same as --event, in nonblocking mode --select Same as --event, using select() call

coll. permanente

ha risposto 03 Apr, 13:10

manzodiego83's gravatar image

manzodiego83
201

  • cel'hai il pacchetto: joystick?

dpkg -l | grep joystick

  • quando inserisci il joystick, cosa vedi dalle ultime righe del comando: dmesg
(03 Apr, 13:41) sacarde sacarde's gravatar image

Dando il comando dpkg -l | grep joystick esce: ii joystick 1:1.6.0-2 amd64 set of testing and calibration tools for joysticks

Mentre digitando dmesg esce nelle stringhe che riguardano le porte usb:

[ 326.568777] usb 2-1.6: new low-speed USB device number 5 using ehci-pci [ 326.648777] usb 2-1.6: device descriptor read/64, error -32 [ 326.836778] usb 2-1.6: device descriptor read/64, error -32 [ 327.024780] usb 2-1.6: new low-speed USB device number 6 using ehci-pci [ 327.104779] usb 2-1.6: device descriptor read/64, error -32 [ 327.292782] usb 2-1.6: device descriptor read/64, error -32 [ 327.400894] usb 2-1-port6: attempt power cycle [ 328.004788] usb 2-1.6: new low-speed USB device number 7 using ehci-pci [ 328.420790] usb 2-1.6: device not accepting address 7, error -32 [ 328.500793] usb 2-1.6: new low-speed USB device number 8 using ehci-pci [ 328.916811] usb 2-1.6: device not accepting address 8, error -32 [ 328.917017] usb 2-1-port6: unable to enumerate USB device

coll. permanente

ha risposto 03 Apr, 14:10

manzodiego83's gravatar image

manzodiego83
201

  • si vede da: dmesg | grep js

  • sembra che non lo senta

  • hai una live del 14.04 ?

(03 Apr, 14:15) sacarde sacarde's gravatar image

No non la possiedo.

(03 Apr, 14:48) manzodiego83 manzodiego83's gravatar image
  • che vedi da: dmesg | grep js

  • "lsusb" prima e dopo aver inserito il joystick, non cambia?

(03 Apr, 14:52) sacarde sacarde's gravatar image

Grazie mille per la tua disponibilità

dando il comando: dmesg | grep js non mi da nulla, mi riporta la string nome pc e basta

Dando lsusb il risultato non cambia a joystick inserito e non.

(03 Apr, 15:06) manzodiego83 manzodiego83's gravatar image
  • non lo vede proprio... prova a cambiare porta usb....

  • hai altri sistemi per verificare che non sia guasto?

  • o procurarti una live della 14.04 per vedere

(03 Apr, 16:56) sacarde sacarde's gravatar image
  • dalla 14.04 alla 18.04 hai fatto un avanzamento o installato ex novo?
(03 Apr, 16:57) sacarde sacarde's gravatar image

Ho provato con tutte le porte e non va, su windows 7 il joystick funziona. Ho installato ex novo Provo a cercare una live 14.04, grazie ancora.

(03 Apr, 18:57) manzodiego83 manzodiego83's gravatar image

Ho provato con una live ubuntu 14.04, non viene letto neanche li. Non capisco cosa accade, in precedenza su ubuntu 14.04 funzionava, e tuttora funziona su windows. Mi sa che devo comprare un altro joystick. Grazie comunque.

coll. permanente

ha risposto 03 Apr, 20:36

manzodiego83's gravatar image

manzodiego83
201

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,882

domanda posta: 03 Apr, 04:29

domanda visualizzata: 125 volte

ultimo aggiornamento: 03 Apr, 20:36

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.