Buongiorno, sono nuovo in Ubuntu, ho installato ubuntu 19.10 in modalità persistent live usb su un hard disk esterno. Lo sto usando con un utente con i diritti di amministratore. Ho scoperto che, a quanto pare, non posso utilizzare pacchetti installaati usando snap, danno vari tipi di errori. Essendo che il sistema è appena installato e a parte cambiare la lingua non ho fatto nient'altro, mi viene da pensare che i pacchetti snap non siano semplicemente utilizzabili in un sistema su live usb. Ora sto quindi provando a installare dei pacchetti con metodi alternativi trovati sui siti ufficiali degli applicativi, in particolare emulatori per videogiochi, ma continuo a ricevere errori, stavolta di tipo diverso. come da istruzioni sul sito di retroarch, faccio:

sudo add-apt-repository ppa:libretro/stable && sudo apt-get update && sudo apt-get install retroarch*

e ottengo

sudo apt-get install retroarch*

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Nota, viene selezionato "retroarch" per l'espressione glob "retroarch*"
Nota, viene selezionato "retroarch-dbg" per l'espressione glob "retroarch*"
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 retroarch : Dipende: libqt5waylandclient5 ma non è installabile
             Dipende: libavcodec58 (>= 7:4.0) ma non è installabile
             Dipende: libavformat58 (>= 7:4.1) ma non è installabile
             Dipende: libavutil56 (>= 7:4.0) ma non è installabile
             Dipende: libcg (>= 3.0.0007) ma non è installabile
             Dipende: libcggl (>= 3.0.0007) ma non è installabile
             Dipende: libopenal1 (>= 1.14) ma non è installabile
             Dipende: libqt5core5a (>= 5.12.2) ma non è installabile
             Dipende: libqt5gui5 (>= 5.2.0) ma non è installabile oppure
                      libqt5gui5-gles (>= 5.2.0) ma non è installabile
             Dipende: libqt5network5 (>= 5.0.2) ma non è installabile
             Dipende: libqt5widgets5 (>= 5.11.0~rc1) ma non è installabile
             Dipende: libsdl2-2.0-0 (>= 2.0.10) ma non è installabile
             Dipende: libswresample3 (>= 7:4.0) ma non è installabile
             Dipende: libswscale5 (>= 7:4.0) ma non è installabile
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

provo a installare il MAME, dal sito ufficiale faccio

sudo add-apt-repository ppa:c.falco/mame
sudo apt-get update
sudo apt-get install mame

e ottengo:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 mame : Dipende: libportaudio2 (>= 19+svn20101113) ma non è installabile
        Dipende: libportmidi0 ma non è installabile
        Dipende: libpugixml1v5 (>= 1.7) ma non è installabile
        Dipende: libqt5core5a (>= 5.12.2) ma non è installabile
        Dipende: libqt5gui5 (>= 5.0.2) ma non è installabile oppure
                 libqt5gui5-gles (>= 5.0.2) ma non è installabile
        Dipende: libqt5widgets5 (>= 5.0.2) ma non è installabile
        Dipende: libsdl2-2.0-0 (>= 2.0.10) ma non è installabile
        Dipende: libsdl2-ttf-2.0-0 (>= 2.0.14) ma non è installabile
        Dipende: libutf8proc2 (>= 1.3) ma non è installabile
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

Come posso risolvere questo probleme delle dipendenze? E' possibile che il problema sia ancora legato al fatto che sono in modalità live usb? Io ho la sensazione che qualcosa da qualche parte non abbia i permessi di scrittura su USB.

Grazie!

chiesto 06 Apr, 12:33

marcellino247's gravatar image

marcellino247
202


Un aggiornamento, ho provato con questi metodi trovati in rete:

sudo apt-get clean

non dà nulla.

sudo apt-get autoclean

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto

Ho provato ad abilitare tutti i repository (main, restricted, universe e multiverse) poi ho dato

sudo apt-get update

e ho ridato il comando per l'installazione dinretroarch, e ora ha funzionato. Immagino che il problema sia risolto.

coll. permanente

ha risposto 07 Apr, 09:35

marcellino247's gravatar image

marcellino247
202

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×39

domanda posta: 06 Apr, 12:33

domanda visualizzata: 51 volte

ultimo aggiornamento: 07 Apr, 09:35

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.