Chiedo aiuto in quanto più che neofita su ubuntu, per cui mi scuso per inesattezze e imprecisioni... Una settimana fa ho installato su un portatile Sony Vaio con Win10 già montato e funzionante la versione 19.10 di Ubuntu. Non è la prima volta che installo Ubuntu in dualboot, e anche questa volta è andato tutto bene. Dopo 4 giorni di uso senza problemi, ho spento il pc e al riavvio è comparsa la seguente dicitura:

GRUB versione 2.04 Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completion

Da quel momento l'unico modo per avviare ed utilizzare il pc è con la live USB di Ubuntu, con la quale riesco a lavorare, sebbene ogni volta i settaggi ripartano ovviamente da zero. Prima di chiedere aiuto ho seguito le seguenti strade:

  • Digitato exit per avviare un SO qualsiasi: il pc cerca Ubuntu, non lo trova e torna al messaggio precedente
  • Tentato un ripristino in automatico del Grub con Super Grub 2 avviato da USB: secondo il software il Grub non c'è
  • Tentato un ulteriore passaggio con Rescatux, avviato da USB, utilizzando alcune delle utility presenti nella suite: si fermano tutte all'ultimo passaggio e restituiscono un messaggio di errore come se non potessero accedere alla partizione del disco su cui è presente Ubuntu, nel mio caso sda8
  • Verificato a quel punto la situazione delle varie partizioni: in effetti la sda8, su cui è linux, dall'utility Dischi di Ubuntu risulta Linux Filesystem ma non può essere montata, e non so se questo è normale
  • Fatto un ulteriore tentativo con Boot-repair, che di nuovo si blocca perché non trova la partizione su cui è Linux

Aggiungo che il disco si avvia in UEFI, e che non ho assolutamente modificato nulla nel BIOS (al quale posso accedere) e che i parametri sono corretti. Grazie sin d'ora per l'aiuto!

chiesto 16 Apr, 11:55

massimo-cotellessa's gravatar image

massimo-cote...
201

(16 Apr, 13:24) sacarde sacarde's gravatar image

Da sacarde

partendo da un live, prova a fare i controlli sulle partizioni *uefi e sistema-linux e dati-linux

provato un ripristino di grub? https://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino/Uefi


Questa è la risposta al comando sudo parted -l:

Model: ATA ST500LT012-9WS14 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags 1 1049kB 274MB 273MB fat32 EFI system partition hidden 2 274MB 1819MB 1546MB ntfs Basic data partition hidden, diag 3 1819MB 2092MB 273MB fat32 EFI system partition boot, esp 4 2092MB 2226MB 134MB Microsoft reserved partition msftres 5 2226MB 372GB 370GB ntfs Basic data partition msftdata 8 372GB 473GB 100GB 6 473GB 474GB 1016MB ntfs hidden, diag 7 474GB 500GB 26.5GB ntfs Basic data partition hidden, diag

La partizione sda8, per la quale mancano le info riguardo a file system e nome, è quella in cui si trova l'installazione di Ubuntu... questo pregiudica il ripristino di grub secondo la guida, perché quando arrivo al punto 2 della procedura e provo a montare il sistema (sda8), ricevo questa risposta:

mount: /mnt: wrong fs type, bad option, bad superblock on /dev/sda8, missing codepage or helper program, or other error.

(16 Apr, 16:19) massimo-cote... massimo-cotellessa's gravatar image
  • provato con gparted a controllarla? o da consolle: fsck

sembrerebbe proprio non formattata, l'installazione si completa regolarmente?

  • tu quale partizione uefi avevi utilizzato? l'1 o la 3?
(16 Apr, 16:28) sacarde sacarde's gravatar image

L'installazione era completa e il sistema funzionante, funzionavano sia ubuntu che windows 10. Le partizioni uefi sono due, la prima è quella che Sony destina all'avvio del bios e delle chiavette con il tasto "assist" sul pc, quindi quella utilizzata da me è la 3. La partizione sda8 è quella con il sistema linux, ma credo il file system sia corrotto o ci sia stato qualche problema con una chiusura fallita di Windows 10, perché tramite Google ho capito che anche altri utenti hanno avuto un problema simile. Idee?

(16 Apr, 18:06) massimo-cote... massimo-cotellessa's gravatar image
  • da "gsmartcontrol" del disco vedi errori hardware?

  • facendo un "fsck" delle altre partizioni trovi errori?

(16 Apr, 20:34) sacarde sacarde's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×293
×231
×97

domanda posta: 16 Apr, 11:55

domanda visualizzata: 126 volte

ultimo aggiornamento: 16 Apr, 20:35

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.