Ciao a tutti, non riesco più ad aggiornare ubuntu server. La versione esatta e distribuzione sono:

Distributor ID: Ubuntu
Description:    Ubuntu 19.04
Release:    19.04
Codename:   disco

Se eseguo apt-get update l'output è il seguente:

Ignorato:1 http://it.archive.ubuntu.com/ubuntu disco InRelease
Ignorato:2 http://it.archive.ubuntu.com/ubuntu disco-updates InRelease      
Ignorato:3 http://security.ubuntu.com/ubuntu disco-security InRelease       
Ignorato:4 http://it.archive.ubuntu.com/ubuntu disco-backports InRelease    
Errore:5 http://it.archive.ubuntu.com/ubuntu disco Release                  
  404  Not Found [IP: 90.147.160.70 80]
Trovato:6 https://download.docker.com/linux/ubuntu disco InRelease          
Errore:7 http://it.archive.ubuntu.com/ubuntu disco-updates Release
  404  Not Found [IP: 90.147.160.70 80]
Errore:8 http://security.ubuntu.com/ubuntu disco-security Release
  404  Not Found [IP: 91.189.88.152 80]
Errore:9 http://it.archive.ubuntu.com/ubuntu disco-backports Release
  404  Not Found [IP: 90.147.160.70 80]
Lettura elenco dei pacchetti... Fatto
E: Il repository "http://it.archive.ubuntu.com/ubuntu disco Release" non ha più un file Release.
N: L'aggiornamento da tale repository non può essere eseguito in modo sicuro ed è quindi disabilitato come impostazione predefinita.
N: Consultare la pagina man apt-secure(8) per la creazione di un repository e la configurazione utente.
E: Il repository "http://it.archive.ubuntu.com/ubuntu disco-updates Release" non ha più un file Release.
N: L'aggiornamento da tale repository non può essere eseguito in modo sicuro ed è quindi disabilitato come impostazione predefinita.
N: Consultare la pagina man apt-secure(8) per la creazione di un repository e la configurazione utente.
E: Il repository "http://security.ubuntu.com/ubuntu disco-security Release" non ha più un file Release.
N: L'aggiornamento da tale repository non può essere eseguito in modo sicuro ed è quindi disabilitato come impostazione predefinita.
N: Consultare la pagina man apt-secure(8) per la creazione di un repository e la configurazione utente.
E: Il repository "http://it.archive.ubuntu.com/ubuntu disco-backports Release" non ha più un file Release.
N: L'aggiornamento da tale repository non può essere eseguito in modo sicuro ed è quindi disabilitato come impostazione predefinita.
N: Consultare la pagina man apt-secure(8) per la creazione di un repository e la configurazione utente.

Il mio file source-list è:

# deb cdrom:[Ubuntu 19.04 _Disco Dingo_ - Release amd64 (20190416)]/ disco main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://it.archive.ubuntu.com/ubuntu/ disco main restricted
# deb-src http://it.archive.ubuntu.com/ubuntu/ disco main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://it.archive.ubuntu.com/ubuntu/ disco-updates main restricted
# deb-src http://it.archive.ubuntu.com/ubuntu/ disco-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://it.archive.ubuntu.com/ubuntu/ disco universe
# deb-src http://it.archive.ubuntu.com/ubuntu/ disco universe
deb http://it.archive.ubuntu.com/ubuntu/ disco-updates universe
# deb-src http://it.archive.ubuntu.com/ubuntu/ disco-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://it.archive.ubuntu.com/ubuntu/ disco multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ disco multiverse
deb http://it.archive.ubuntu.com/ubuntu/ disco-updates multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ disco-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://it.archive.ubuntu.com/ubuntu/ disco-backports main restricted universe multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ disco-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu disco partner
# deb-src http://archive.canonical.com/ubuntu disco partner

deb http://security.ubuntu.com/ubuntu disco-security main restricted
# deb-src http://security.ubuntu.com/ubuntu disco-security main restricted
deb http://security.ubuntu.com/ubuntu disco-security universe
# deb-src http://security.ubuntu.com/ubuntu disco-security universe
deb http://security.ubuntu.com/ubuntu disco-security multiverse
# deb-src http://security.ubuntu.com/ubuntu disco-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
#deb [arch=amd64] https://osm-download.etsi.org/repository/osm/debian/ReleaseSIX stable IM osmclient devops
# deb-src [arch=amd64] https://osm-download.etsi.org/repository/osm/debian/ReleaseSEVEN stable devops
deb [arch=amd64] https://download.docker.com/linux/ubuntu disco stable
# deb-src [arch=amd64] https://download.docker.com/linux/ubuntu disco stable
# deb-src [arch=amd64] https://osm-download.etsi.org/repository/osm/debian/ReleaseSEVEN stable osmclient IM
# see the sources.list(5) manual.

Quando provo ad installare un nuovo pacchetto con apt-get install l'errore è il seguente:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  dkms libdouble-conversion1 libgsoap-2.8.75 libpcre2-16-0 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5svg5 libqt5widgets5 libqt5x11extras5 libsdl1.2debian
  libvncserver1 libxcb-xinerama0 libxcb-xinput0 qt5-gtk-platformtheme qttranslations5-l10n virtualbox-dkms virtualbox-qt
Pacchetti suggeriti:
  menu qt5-image-formats-plugins qtwayland5 vde2 virtualbox-guest-additions-iso
I seguenti pacchetti NUOVI saranno installati:
  dkms libdouble-conversion1 libgsoap-2.8.75 libpcre2-16-0 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5svg5 libqt5widgets5 libqt5x11extras5 libsdl1.2debian
  libvncserver1 libxcb-xinerama0 libxcb-xinput0 qt5-gtk-platformtheme qttranslations5-l10n virtualbox virtualbox-dkms virtualbox-qt
0 aggiornati, 22 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 56,9 MB/57,2 MB di archivi.
Dopo quest'operazione, verranno occupati 206 MB di spazio su disco.
Continuare? [S/n] 
Errore:1 http://it.archive.ubuntu.com/ubuntu disco/universe amd64 libdouble-conversion1 amd64 3.1.0-2
  404  Not Found [IP: 90.147.160.73 80]
Errore:2 http://it.archive.ubuntu.com/ubuntu disco-updates/universe amd64 libqt5core5a amd64 5.12.2+dfsg-4ubuntu1.1
  404  Not Found [IP: 90.147.160.73 80]
Errore:3 http://it.archive.ubuntu.com/ubuntu disco-updates/universe amd64 libqt5dbus5 amd64 5.12.2+dfsg-4ubuntu1.1
  404  Not Found [IP: 90.147.160.73 80]
Errore:4 http://it.archive.ubuntu.com/ubuntu disco-updates/universe amd64 libqt5network5 amd64 5.12.2+dfsg-4ubuntu1.1
  404  Not Found [IP: 90.147.160.73 80]
Errore:5 http://it.archive.ubuntu.com/ubuntu disco-updates/universe amd64 libqt5gui5 amd64 5.12.2+dfsg-4ubuntu1.1
  404  Not Found [IP: 90.147.160.73 80]
Errore:6 http://it.archive.ubuntu.com/ubuntu disco-updates/universe amd64 libqt5widgets5 amd64 5.12.2+dfsg-4ubuntu1.1
  404  Not Found [IP: 90.147.160.73 80]
Errore:7 http://it.archive.ubuntu.com/ubuntu disco/universe amd64 libqt5svg5 amd64 5.12.2-1
  404  Not Found [IP: 90.147.160.73 80]
Ignorato:8 http://it.archive.ubuntu.com/ubuntu disco-updates/main amd64 dkms all 2.6.1-4ubuntu2.5
Errore:9 http://it.archive.ubuntu.com/ubuntu disco/universe amd64 libgsoap-2.8.75 amd64 2.8.75-1
  404  Not Found [IP: 90.147.160.73 80]
Errore:10 http://it.archive.ubuntu.com/ubuntu disco-updates/universe amd64 libqt5opengl5 amd64 5.12.2+dfsg-4ubuntu1.1
  404  Not Found [IP: 90.147.160.73 80]
Errore:11 http://it.archive.ubuntu.com/ubuntu disco-updates/universe amd64 libqt5printsupport5 amd64 5.12.2+dfsg-4ubuntu1.1
  404  Not Found [IP: 90.147.160.73 80]
Errore:12 http://it.archive.ubuntu.com/ubuntu disco/universe amd64 libqt5x11extras5 amd64 5.12.2-1
  404  Not Found [IP: 90.147.160.73 80]
Errore:13 http://it.archive.ubuntu.com/ubuntu disco/universe amd64 libsdl1.2debian amd64 1.2.15+dfsg2-4
  404  Not Found [IP: 90.147.160.73 80]
Errore:14 http://it.archive.ubuntu.com/ubuntu disco-updates/universe amd64 qt5-gtk-platformtheme amd64 5.12.2+dfsg-4ubuntu1.1
  404  Not Found [IP: 90.147.160.73 80]
Ignorato:15 http://it.archive.ubuntu.com/ubuntu disco/universe amd64 qttranslations5-l10n all 5.12.2-1
Ignorato:16 http://it.archive.ubuntu.com/ubuntu disco/multiverse amd64 virtualbox-dkms all 6.0.6-dfsg-1
Errore:17 http://it.archive.ubuntu.com/ubuntu disco/multiverse amd64 virtualbox amd64 6.0.6-dfsg-1
  404  Not Found [IP: 90.147.160.73 80]
Errore:18 http://it.archive.ubuntu.com/ubuntu disco/multiverse amd64 virtualbox-qt amd64 6.0.6-dfsg-1
  404  Not Found [IP: 90.147.160.73 80]
Errore:8 http://it.archive.ubuntu.com/ubuntu disco-updates/main amd64 dkms all 2.6.1-4ubuntu2.5
  404  Not Found [IP: 90.147.160.73 80]
Errore:15 http://it.archive.ubuntu.com/ubuntu disco/universe amd64 qttranslations5-l10n all 5.12.2-1
  404  Not Found [IP: 90.147.160.73 80]
Errore:16 http://it.archive.ubuntu.com/ubuntu disco/multiverse amd64 virtualbox-dkms all 6.0.6-dfsg-1
  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/d/double-conversion/libdouble-conversion1_3.1.0-2_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtbase-opensource-src/libqt5core5a_5.12.2+dfsg-4ubuntu1.1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtbase-opensource-src/libqt5dbus5_5.12.2+dfsg-4ubuntu1.1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtbase-opensource-src/libqt5network5_5.12.2+dfsg-4ubuntu1.1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtbase-opensource-src/libqt5gui5_5.12.2+dfsg-4ubuntu1.1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtbase-opensource-src/libqt5widgets5_5.12.2+dfsg-4ubuntu1.1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtsvg-opensource-src/libqt5svg5_5.12.2-1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/main/d/dkms/dkms_2.6.1-4ubuntu2.5_all.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/g/gsoap/libgsoap-2.8.75_2.8.75-1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtbase-opensource-src/libqt5opengl5_5.12.2+dfsg-4ubuntu1.1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtbase-opensource-src/libqt5printsupport5_5.12.2+dfsg-4ubuntu1.1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtx11extras-opensource-src/libqt5x11extras5_5.12.2-1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/libs/libsdl1.2/libsdl1.2debian_1.2.15+dfsg2-4_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qtbase-opensource-src/qt5-gtk-platformtheme_5.12.2+dfsg-4ubuntu1.1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/universe/q/qttranslations-opensource-src/qttranslations5-l10n_5.12.2-1_all.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-dkms_6.0.6-dfsg-1_all.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox_6.0.6-dfsg-1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/multiverse/v/virtualbox/virtualbox-qt_6.0.6-dfsg-1_amd64.deb  404  Not Found [IP: 90.147.160.73 80]
E: Impossibile scaricare alcuni pacchetti. Potrebbe essere utile eseguire "apt-get update" o provare l'opzione "--fix-missing".

Ho provato a lanciare il comando con --fix-missing e ovviamente anche l'update ma non riesco a risolvere ne a trovare l'errore nel source.list. Qualcuno riesce a darmi una mano? Grazie :)

chiesto 20 Apr, 12:58

mellgood's gravatar image

mellgood
10

(21 Apr, 08:41) sacarde sacarde's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×41
×37
×12

domanda posta: 20 Apr, 12:58

domanda visualizzata: 195 volte

ultimo aggiornamento: 21 Apr, 08:41

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.