Salve a tutti, ho questo problema che non riesco a trovare da nessuna parte, Ho assemblato un PC nuovo con processore AMD Ryzen 3 3200G, 32 GB RAM, MB gygabite B450 lo schermo è collegato tramite la porta VGA della MB in quanto è uno schermo vecchio... Ho installato Ubuntu studio 20.04 tutto bene durante l'installazione nessun problema con lo schermo così anche fino alla pagina del login, poi una volta fatto il Login il desktop si splitta in 6/7 strisce sfalsate tra loro e ogni una è un desktop diverso, fa uguale anche in modalità live, altra cosa se accedo in modalità xfce la prima volta tutto bene forse sfarfalla un po' lo schermo ma funziona, dalla seconda volta in poi si splitta come descritto, ... Ho provato anche ad installare in safe screen ma fa uguale penso che sia un problema di driver ma dovrebbe essere già presenti almeno così mi pare se vado nella Shell prima del login... Vi ringrazio già se qualcuno mi aiutarmi

chiesto 10 May, 09:25

oozoop's gravatar image

oozoop
202

modificato 10 May, 09:33

  • vedi errori dal log di Xorg? (se stai usando xorg e non wayland) /var/log/Xorg.0.log (righe con "EE")

o nel log: journalctl -b -p err

(10 May, 09:30) sacarde sacarde's gravatar image

Grazie per la risposta... Allora non ho idea se sto usando Xorg o. Cosa... Cmq dalla shell con Ctrl+alt+f2 prima del log. Se digiti /var/log/Xorg.0.log mi scrive permesso negato ... Se scrivo :journalctl -b -p err Mi restituisce una serie di errori

Kernel: unpacking failed: decodiding failled Kernel: pci 0000:00:00.2: amd-Vi: unable to read/write to IOMMU perf counter. Lighttdm mi riporta 8 errori diversi unable to open... Agetty:tty2: invalid character 0x01b in log name

Di solito se ho problemi mi limito a cercare il problema uguale al mio e copiare la soluzione non sono molto esperto per tante cose...

coll. permanente

ha risposto 10 May, 11:45

oozoop's gravatar image

oozoop
202

  • per vedere il log usa un editor o less:

less /var/log/Xorg.0.log (cerca gli errori [EE])

  • provato a passare al kernel: nomodeset xforcevesa

https://wiki.ubuntu.com/Kernel/KernelBootParameters#Temporarily_Add_a_Kernel_Boot_Parameter_for_Testing

  • il live non ha questi problemi, vero?

  • scheda video?

(10 May, 13:12) sacarde sacarde's gravatar image

In realtà anche in modalità live ho lo stesso problema, appena torno a casa provo a cambiare kernel, La scheda video è integrata nella CPU Radeon Vega 8,

coll. permanente

ha risposto 10 May, 14:02

oozoop's gravatar image

oozoop
202

Ho trovato l'inghippo ma non ho risolto, Allora con il log come mi hai suggerito nessun errore cambiando kernel provvisoriamente come da guida stesso problema.. poi ho collegato la TV con la porta HDMI e tutto funziona perfettamente riavviato più volte sulla TV si vede benissimo, quindi il problema e lo schermo collegato tramite porta VGA ho in vecchio Acer x223w ... Sto cercando di capire come impostare la risoluzione da shell se ė un problema di risoluzione visto che prima del login si vede bene in qualche modo si deve vedere bene anche dopo

coll. permanente

ha risposto 10 May, 20:13

oozoop's gravatar image

oozoop
202

da terminale puoi vedere le risoluzioni: xrandr

e cambi con: xrandr -s ...x...

(10 May, 20:29) sacarde sacarde's gravatar image

Can't open display, mi scrive ...

coll. permanente

ha risposto 10 May, 20:55

oozoop's gravatar image

oozoop
202

ma lo fai da root?

lo devi fare dall'utente che si e' loggato

(10 May, 20:58) sacarde sacarde's gravatar image

Si si lo faccio da utente normale

coll. permanente

ha risposto 10 May, 21:03

oozoop's gravatar image

oozoop
202

che vedi: echo $DISPLAY

sei nella sessione video, no?

(10 May, 21:11) sacarde sacarde's gravatar image

Sessione video? Sono nella Shell che ci accedo prima del login con alt+crlt+F2 e mi loggo da lì

Con echo $DISPLAY Non cambia niente

coll. permanente

ha risposto 10 May, 22:32

oozoop's gravatar image

oozoop
202

  • non cela fai a farlo nella sessione grafica (anche se splitta)?

  • altrimenti devi generare xorg.conf con le risoluzioni

https://wiki.ubuntu-it.org/Hardware/Video/Xorg?action=show&redirect=Hardware%2FVideo%2FConfigurareXorg#Generare_il_file_xorg.conf

(10 May, 23:47) sacarde sacarde's gravatar image

eccomi, ho diciamo risolto installando ubuntu 20.04 lts al posto di ubuntu studio 20.04 lts e magicamente tutto funziona perfettamente, da qui ho installato i programmi di editing che mi interessano e sono apposto.

non capisco perché questa differenza ma fa lo stesso, un giorno capirò ho mi prenderò uno schermo nuovo.

grazie per l'aiuto

coll. permanente

ha risposto 11 May, 10:35

oozoop's gravatar image

oozoop
202

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×3

domanda posta: 10 May, 09:25

domanda visualizzata: 168 volte

ultimo aggiornamento: 11 May, 10:35

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.