DATI: multifunzione Canon PIXMA MG3650 installata in ubuntu con i drivers suggeriti da forum; Sistema operativo 20.04 installato, pc lENOVO T430s; PROBLEMA: il sistema "sente" la stampante ma non riesce a connettesi allo scanner - Riuscite a darmi una soluzione? Anticipo un grazie.

chiesto 15 May, 07:38

stefanoluigivittorio's gravatar image

stefanoluigi...
201

l'hai scaricato e installato il driver?

scangearmp2_3.20-1_amd64.deb

(15 May, 09:35) sacarde sacarde's gravatar image

12avanti »

sì.. ho scaricato ed installato scangearmp2_3.20-1_amd64.deb, ma il sistema mi dice che non riesce a connettersi con lo scanner..per la stampante nessun problema

coll. permanente

ha risposto 15 May, 12:02

stefanoluigivittorio's gravatar image

stefanoluigi...
201

  • l'utente e' nel gruppo "scanner" ?

  • cosa usi per scannerizzare? xsane?

  • ma la usi in rete wireless?

(15 May, 13:16) sacarde sacarde's gravatar image

ti ringrazio sacarde per il supporto che stai tentando di fornirmi, ma: - domanda 1: non so rispondere, puoi precisare? - domanda 2: utilizzo simple scan - domanda 3: utilizzo la connessione tamite USB

coll. permanente

ha risposto 15 May, 14:13

stefanoluigivittorio's gravatar image

stefanoluigi...
201

  • esegui il comando: groups (visualizza i gruppi dell'utente)

  • quando apri "simplescan" ti presenta lo scanner da usare?

  • vedi errori quando tenti di scannerizzare? journalctl -b -p err

(15 May, 14:23) sacarde sacarde's gravatar image

ecco le risposte: - stefano adm cdrom sudo dip plugdev lpadmin lxd sambashare - mi si presenta CANON canon PIXMA MG 3600 Series - mi si presenta solamente il seguente errore "ACQUISIZIONE NON RIUSCITA" ed il commento "impossibile connettersi allo scanner"

coll. permanente

ha risposto 15 May, 15:23

stefanoluigivittorio's gravatar image

stefanoluigi...
201

prova a aggiungerti al gruppo "scanner":

sudo adduser stefano scanner

  • da: sudo sane-find-scanner

  • da: sudo scanimage -L

(15 May, 16:58) sacarde sacarde's gravatar image

ecco quanto mi dice il terminale: stefano@T430s:~$ sudo adduser stefano scanner [sudo] password di stefano: Aggiunta dell'utente «stefano» al gruppo «scanner» ... Aggiunta dell'utente stefano al gruppo scanner Fatto. stefano@T430s:~$ sudo sane-find-scanner

# sane-find-scanner will now attempt to detect your scanner. If the # result is different from what you expected, first make sure your # scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x178a [MG3600 series]) at libusb:003:003 # Your USB scanner was (probably) detected. It may or may not be supported by # SANE. Try scanimage -L and read the backend's manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports # can't be detected by this program. stefano@T430s:~$ sudo scanimage -L Created directory: /var/lib/snmp/mib_indexes device pixma:04A9178A' is a CANON Canon PIXMA MG3600 Series multi-function peripheral deviceescl:http://127.0.0.1:60000' is a ESCL MG3600 series flatbed scanner stefano@T430s:~$ COMMENTO: - la macchina Canon è accesa e collegata tramite porta USB - la funzione scanner ricerca lo scanner e lo trova (CANON canon PIXMA MG 3600 Series) - avvio e mi ricompare il solito messaggio ""ACQUISIZIONE NON RIUSCITA" ed il commento "impossibile connettersi allo scanner"

coll. permanente

ha risposto 15 May, 18:25

stefanoluigivittorio's gravatar image

stefanoluigi...
201

(15 May, 20:41) sacarde sacarde's gravatar image

Intanto ti ringrazio per pazienza ed aiuto. Ecco le risposte: - "Windows Server" titolo "Allowing 127.0.0.1:600000 to be used by non-admin users RRS feed" ecc. ecc. - dentro "/etc/udev/rules.d/" trovo "70-snap.core.rules 70-snap.gimp.rules 80-canon_mfp2.rules" - cosa devo fare esattamente per utilizzare "xsane"? - aprendo l'indirizzo mi porta a scaricare il file che ho già scaricato ed installato con il risultato che ti ho già visualizzato nei precedenti messaggi

coll. permanente

ha risposto 15 May, 21:27

stefanoluigivittorio's gravatar image

stefanoluigi...
201

  • controlla che dentro 80-canon_mfp2.rules ci siano i valori ID tuoi: vendor=0x04a9 , product=0x178a

  • per installare xsane: sudo apt install xsane

  • nella discussione di sopra risolvono con: scangearmp2

(15 May, 21:35) sacarde sacarde's gravatar image

Ecco le risposte: 1-# 80-canon_mfp2.rules

ACTION!="add", GOTO="canon_mfp_end" SUBSYSTEM=="usb_device", GOTO="canon_mfp_start" SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GOTO="canon_mfp_start" GOTO="canon_mfp_end"

LABEL="canon_mfp_start"

MG7500 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="177c", MODE="666"

MG6600 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="177e", MODE="666"

MG5600 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="177f", MODE="666"

MG2900 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="1780", MODE="666"

MB2000 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="1778", MODE="666"

MB2300 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="1779", MODE="666"

MB5000 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="1776", MODE="666"

MB5300 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="1777", MODE="666"

E460 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="1788", MODE="666"

MX490 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="1787", MODE="666"

E480 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="1789", MODE="666"

MG7700 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="178b", MODE="666"

MG6900 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="178c", MODE="666"

MG6800 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="178d", MODE="666"

MG5700 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="178e", MODE="666"

MG3600 series

ATTR{idVendor}=="04a9", ATTR{idProduct}=="178a", MODE="666"

LABEL="canon_mfp_end" (MI SEMBRA CHE I CODICI CI SIANO)

2- Installato 3- non capisco bene la tua argomentazione; dopo aver installato xsane cosa devo fare?

coll. permanente

ha risposto 15 May, 22:31

stefanoluigivittorio's gravatar image

stefanoluigi...
201

Buongiorno Ho installato ed eseguito XSane XSane "sente" la macchina, la riconosce, ma al momento di eseguire il comando di procedere appare un finestra XSane 0.999 che rimanda il seguente messaggio: "Non è possibile aprire il dispositivo pixma 04A9178A: il dispositivo è occupato"

coll. permanente

ha risposto 16 May, 11:21

stefanoluigivittorio's gravatar image

stefanoluigi...
201

  • vedi qualche altro programma in esecuzione?

ps aux|grep scan

ps aux|grep sane

  • e se esegui: scangearmp2
(16 May, 11:40) sacarde sacarde's gravatar image

Ulteriore aggiornamento. XSane mi propone 2 macchine da utilizzare (una è CANON PIXMA MG36 multi-function peri [pixma:04A9178A] e che non parte come da messaggio inviato qualche minuto fa Ho chiesto allora a XSane di eseguire la scansione utilizzando l'altra macchina che mi propone come ESCL MG3600 scanner da tavolo [escl:http://127.0.0.1:60000]; si apre la finestra per l'acquisizione della scansione, ma quando do il comando di esecuzione "acquisisci" il programma mi rimanda il messaggio:"Non è possibile avviare lo scanner: L'argomento non è valido" (di che argomento si tratta?)

coll. permanente

ha risposto 16 May, 11:43

stefanoluigivittorio's gravatar image

stefanoluigi...
201

che hai in: lsusb

(16 May, 11:49) sacarde sacarde's gravatar image

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 004: ID 5986:02d5 Acer, Inc Bus 001 Device 003: ID 1c4f:0034 SiGma Micro Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 003 Device 002: ID 0bdb:1926 Ericsson Business Mobile Networks BV H5321 gw Mobile Broadband Driver Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

coll. permanente

ha risposto 16 May, 13:38

stefanoluigivittorio's gravatar image

stefanoluigi...
201

  • mmm mi aspettavo anche un: 04A9:178A

  • "scangearmp2" cosa dice?

(16 May, 13:59) sacarde sacarde's gravatar image

Nonostante sia accesa e collagata (con USB) la macchina il programma "scangearmp2" avviato tramite terminale (la cartella "zippata" del programma si trova nella cartella HOME) mi restituisce il messaggio "Cannot find available scanners - Cable may be disconnected or scanner may be turned off. Check the scanner status, and then try again". Il terminale mi restituisce anche il seguente messaggio "Gtk-Message: 18:18:53.126: Failed to load module "canberra-gtk-module"

coll. permanente

ha risposto 16 May, 18:28

stefanoluigivittorio's gravatar image

stefanoluigi...
201

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×45

domanda posta: 15 May, 07:38

domanda visualizzata: 152 volte

ultimo aggiornamento: 17 May, 18:36

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.