Ciao sono nuovo del forum.

ho installato di recente ubnutu 20.04 su desktop. Oggi per un problema con la FTTC ho collegato il mio android al pc per usare l'hotspot via usb. Una volta rientrato il problema della fibra, ho scollegato l'hotsport per tornare all'ethernet , ma non c'è stato più modo di farla funzionare. Da interfaccia rimane l'icona della connessione grigia con tre punti orizzontali sopra e compare un popup con scritto "connessione non riuscita Attivazione della connessione di rete non riuscita"

Lanciando il comando sudo lshw -c network non mi torna nulla se invece lo chiamo attaccando la usb con android torna *network bla bla con logical name: usb0

Dalle impostazioni => rete vedo abilitata lo switch sotto la voce via cavo 100/Mb/s ma in stato "in connessione".

Sapete aiutarmi?

Grazie

chiesto 29 Jun, 16:27

ale647611's gravatar image

ale647611
102

  • che vedi dai log:

dmesg | grep eth

systemctl --failed

journalctl -b -p err

(29 Jun, 20:55) sacarde sacarde's gravatar image

Grazie per la celere risposta e scusa la mia latenza. Di punto in bianco è tornato a funzionare tutto correttamente senza che facessi nulla.

nel caso riapro il caso e facciamo le verifiche

coll. permanente

ha risposto 07 Jul, 09:13

ale647611's gravatar image

ale647611
102

Stamattina il problema si è ripresentato

Premetto che ho virtaulbox installato perchè per lavoro devo usare un ambiente windows

Credo che il problema sia correlato

ale@Zezze01:~$ dmesg | grep eth [ 0.795334] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64. [ 1.311731] forcedeth 0000:00:07.0: ifname eth0, PHY OUI 0x732 @ 1, addr 70:71:bc:e1:8a:68 [ 1.311734] forcedeth 0000:00:07.0: highdma pwrctl mgmt lnktim msi desc-v3 [ 1.312652] forcedeth 0000:00:07.0 enp0s7: renamed from eth0 [ 9.985094] forcedeth 0000:00:07.0 enp0s7: MSI enabled [ 34.245731] audit: type=1107 audit(1594194349.077:54): pid=537 uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED" operation="dbus_method_call" bus="system" path="/org/freedesktop/NetworkManager" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.11" pid=1893 label="snap.snap-store.ubuntu-software" peer_pid=538 peer_label="unconfined" [ 38.362606] audit: type=1107 audit(1594194353.193:59): pid=537 uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED" operation="dbus_method_call" bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.7" pid=1893 label="snap.snap-store.ubuntu-software" peer_pid=561 peer_label="unconfined" [ 38.363519] audit: type=1107 audit(1594194353.197:60): pid=537 uid=103 auid=4294967295 ses=4294967295 msg='apparmor="DENIED" operation="dbus_method_call" bus="system" path="/org/freedesktop/PolicyKit1/Authority" interface="org.freedesktop.PolicyKit1.Authority" member="CheckAuthorization" mask="send" name=":1.7" pid=1893 label="snap.snap-store.ubuntu-software" peer_pid=561 peer_label="unconfined" ale@Zezze01:~$ systemctl --failed UNIT LOAD ACTIVE SUB DESCRIPTION
● NetworkManager-wait-online.service loaded failed failed Network Manager Wait Online ● vboxweb.service loaded failed failed VirtualBox Web Service

LOAD = Reflects whether the unit definition was properly loaded. ACTIVE = The high-level unit activation state, i.e. generalization of SUB. SUB = The low-level unit activation state, values depend on unit type.

2 loaded units listed. ale@Zezze01:~$ journalctl -b -p err -- Logs begin at Thu 2020-05-28 15:17:51 CEST, end at Wed 2020-07-08 09:48:34 CEST. -- lug 08 09:45:23 Zezze01 systemd[1]: Failed to start VirtualBox Web Service. lug 08 09:45:38 Zezze01 gdm-password][1323]: gkr-pam: unable to locate daemon control file lug 08 09:45:52 Zezze01 pulseaudio[1338]: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms) lug 08 09:45:53 Zezze01 systemd[1]: Failed to start Network Manager Wait Online.

coll. permanente

ha risposto 08 Jul, 09:56

ale647611's gravatar image

ale647611
102

modificato 08 Jul, 09:58

  • se non utilizzi virtualbox funziona?

  • la rete in virtualbox e' "bridge" ?

  • per "apparmor" https://wiki.ubuntu-it.org/Sicurezza/AppArmor

(08 Jul, 11:12) sacarde sacarde's gravatar image

Sì, il problema ce l'ho su Linux, virtualbox di conseguenza.

Una volta che collego l'hotspot USB , sia la macchina host che la virtuale navigano.

coll. permanente

ha risposto 08 Jul, 11:48

ale647611's gravatar image

ale647611
102

  • senza virtualbox , la connessione ethernet funziona?

  • in virtualbox non funziona mai la rete? (e' "bridge"?)

(08 Jul, 18:02) sacarde sacarde's gravatar image

La rete funziona e la condivide correttamente, tranne a volte (a seguito di qualche evento ) per cui smette di funzionare sia su Linux che su VirtualBox. Poi se attacco l'hotspot del mobile ,mi funziona in entrambi gli ambienti, ma non la ehternet

coll. permanente

ha risposto 08 Jul, 21:26

ale647611's gravatar image

ale647611
102

  • hai configurato tu il "VirtualBox Web Service" ?

  • riavviando il servizio: NetworkManager-wait-online.service

sudo systemctl restart NetworkManager-wait-online.service

sudo systemctl status NetworkManager-wait-online.service

(08 Jul, 21:40) sacarde sacarde's gravatar image

il virtualbox nelle impostazioni vedo che è settato come NAT.

Adesso ad esempio funziona, la prossima volta che non mi funziona provo a lanciare il comando per riavviare il servizio come indicato, controllando prima magari lo stato

grazie

coll. permanente

ha risposto 10 Jul, 15:20

ale647611's gravatar image

ale647611
102

io proverei anche a impostare la rete come "bridge"

(10 Jul, 16:42) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,930
×24

domanda posta: 29 Jun, 16:27

domanda visualizzata: 288 volte

ultimo aggiornamento: 10 Jul, 16:42

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.