Ho installato da circa un mesetto la nuova versione di Pop_os (20.04) sul mio computer ed ho riscontrato un problema al boot che non riesco a risolvere e che comporta un'accensione sicuramente più lenta di come dovrebbe essere. Il computer è come se si "accendesse" due volte, quando sembra che stia per arrivare la schermata di login, lo schermo torna nero e riparte con l'accensione. In questa "seconda fase" capita circa 1 volta su 7 un glitch allo schermo di poca durata immediatamente prima del caricamento della schermata di login.

Se possono servire le specifiche del computer sono: AMD Ryzen 7 Pro 3700U, 512 gb SSD e 16 gb RAM con Pop!_OS 20.04 LTS

28.284s plymouth-quit-wait.service
11.939s rtkit-daemon.service
8.782s resolvconf-pull-resolved.service
1.435s snapd.seeded.service
1.420s dev-nvme0n1p3.device
1.336s snapd.service
839ms accounts-daemon.service
775ms systemd-logind.service
691ms systemd-journald.service
659ms fwupd.service
581ms upower.service
565ms dev-loop1.device
553ms snap-hello\x2dworld-29.mount
546ms snap-sublime\x2dtext-85.mount
543ms snap-spotify-41.mount
521ms fprintd.service
492ms dev-loop3.device
481ms dev-loop2.device
475ms snap-stacker-22.mount
465ms systemd-timesyncd.service
464ms systemd-resolved.service
449ms dev-loop8.device
435ms dev-loop4.device

chiesto 22 Jul, 10:35

lorenzos98's gravatar image

lorenzos98
303

modificato 22 Jul, 10:40

ma e' un sembrare o effettivamente si riavvia?

controlla il journal:

journalctl -b (vedi il journal dall'ultimo avvio)

e

journalctl -b -1 (vedi il journal del penultimo avvio)

controlla data ora e minuti

(22 Jul, 17:38) sacarde sacarde's gravatar image

12avanti »

Posso visionare solo i dati dell'ultimissimo boot, non quelli precedenti. Non so se questo possa essere o meno parte del problema.

Ho eseguito il journalctl -b -1 che mi ha restituito: Specifying boot ID or boot offset has no effect, no persistent journal was found.

Ho allora eseguito journalctl --list-boots ed effettivamente mi ha restituito solo: 0 f07868116ffc452fb7f25e0bf385d83a Wed 2020-07-22 09:54:20 CEST—Wed 2020-07-22 18:11:28 CEST

Per sicurezza sono andato anche a controllare in "/var" e non ho il boot.log, nemmeno la directory "/log".

I dettagli dell'ultimo boot sono comunque questi:

-- Logs begin at Wed 2020-07-22 09:54:20 CEST, end at Wed 2020-07-22 18:10:17 CEST. -- lug 22 09:54:20 pop-os kernel: Linux version 5.4.0-7634-generic (buildd@lgw01-amd64-017) (gcc version 9.3.0 (Ubuntu 9.3.> lug 22 09:54:20 pop-os kernel: Command line: initrd=\EFI\Pop_OS-b7018560-7e9e-4570-8c57-a27c023deea9\initrd.img root=UUI> lug 22 09:54:20 pop-os kernel: KERNEL supported cpus: lug 22 09:54:20 pop-os kernel: Intel GenuineIntel lug 22 09:54:20 pop-os kernel: AMD AuthenticAMD lug 22 09:54:20 pop-os kernel: Hygon HygonGenuine lug 22 09:54:20 pop-os kernel: Centaur CentaurHauls lug 22 09:54:20 pop-os kernel: zhaoxin Shanghai
lug 22 09:54:20 pop-os kernel: x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers' lug 22 09:54:20 pop-os kernel: x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers' lug 22 09:54:20 pop-os kernel: x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers' lug 22 09:54:20 pop-os kernel: x86/fpu: xstate_offset[2]: 576, xstate_sizes[2]: 256 lug 22 09:54:20 pop-os kernel: x86/fpu: Enabled xstate features 0x7, context size is 832 bytes, using 'compacted' format. lug 22 09:54:20 pop-os kernel: BIOS-provided physical RAM map: lug 22 09:54:20 pop-os kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009efff] usable lug 22 09:54:20 pop-os kernel: BIOS-e820: [mem 0x000000000009f000-0x000000000009ffff] reserved lug 22 09:54:20 pop-os kernel: BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved lug 22 09:54:20 pop-os kernel: BIOS-e820: [mem 0x0000000000100000-0x0000000009bfffff] usable lug 22 09:54:20 pop-os kernel: BIOS-e820: [mem 0x0000000009c00000-0x0000000009cd0fff] reserved lug 22 09:54:20 pop-os kernel: BIOS-e820: [mem 0x0000000009cd1000-0x0000000009efffff] usable lug 22 09:54:20 pop-os kernel: BIOS-e820: [mem 0x0000000009f00000-0x0000000009f0afff] ACPI NVS lug 22 09:54:20 pop-os kernel: BIOS-e820: [mem 0x0000000009f0b000-0x00000000ba7b7fff] usable

coll. permanente

ha risposto 22 Jul, 18:24

lorenzos98's gravatar image

lorenzos98
303

modificato 22 Jul, 18:26

  • cosa hai in /etc/systemd/journald.conf ?

  • non hai la dir /var/log/journal/ ?

forse perche sei su una derivata?

(22 Jul, 20:40) sacarde sacarde's gravatar image

Journald.conf :

This file is part of systemd ... See journald.conf(5) for details.

[Journal]

  • Storage=auto
  • Compress=yes
  • Seal=yes
  • SplitMode=uid
  • SyncIntervalSec=5m
  • RateLimitIntervalSec=30s
  • RateLimitBurst=10000
  • SystemMaxUse=
  • SystemKeepFree=
  • SystemMaxFileSize=
  • SystemMaxFiles=100
  • RuntimeMaxUse=
  • RuntimeKeepFree=
  • RuntimeMaxFileSize=
  • RuntimeMaxFiles=100
  • MaxRetentionSec=
  • MaxFileSec=1month
  • ForwardToSyslog=yes
  • ForwardToKMsg=no
  • ForwardToConsole=no
  • ForwardToWall=yes
  • TTYPath=/dev/console
  • MaxLevelStore=debug
  • MaxLevelSyslog=debug
  • MaxLevelKMsg=notice
  • MaxLevelConsole=info
  • MaxLevelWall=emerg
  • LineMax=48K
  • ReadKMsg=yes

No, in /var/log le uniche directories che ho sono:

apt, cups, dist-upgrade, gdm3, private

coll. permanente

ha risposto 23 Jul, 10:25

lorenzos98's gravatar image

lorenzos98
303

non si vede se al primo carattere c'e' il cancelletto, puoi incollarlo qui?

https://paste.ubuntu.com

(23 Jul, 10:31) sacarde sacarde's gravatar image
coll. permanente

ha risposto 23 Jul, 11:15

lorenzos98's gravatar image

lorenzos98
303

come il mio kubuntu e' tutto col cancelletto al primo posto...

prova a eseguire: systemctl list-unit-files

e a digitare: /journal

dovresti trovare 5 servizi abilitati "static":

systemd-journal-flush.service

systemd-journald.service

systemd-journald-audit.socket

systemd-journald-dev-log.socket

systemd-journald.socket

(23 Jul, 11:40) sacarde sacarde's gravatar image

Ho solo questi 3:
systemd-journal-flush.service static enabled
systemd-journald.service static enabled
systemd-journald@.service static enabled

coll. permanente

ha risposto 23 Jul, 11:55

lorenzos98's gravatar image

lorenzos98
303

modificato 23 Jul, 11:56

potrebbe essere una personalizzazione di pop-os

ho chiesto sul canale irc #system76 su freenode, sentiamo cosa rispondono

(23 Jul, 13:53) sacarde sacarde's gravatar image

Grazie mille

coll. permanente

ha risposto 23 Jul, 15:16

lorenzos98's gravatar image

lorenzos98
303

per adesso nessuna risposta da:

system76 su irc.freenode.net

(23 Jul, 23:39) sacarde sacarde's gravatar image

Se può servire questo è il link per il video che avevo fatto:
https://mega.nz/file/FIF1TCpa#Fx3MhxCVfpzwLvZDIfHTYJed1QdygLG54DcBf0ptcBU
Come dicevo nel mio primo messaggio il glitch ha una frequenza di circa 1 volta su 7, e in questo video si riesce a vedere. Si nota anche come lo schermo diventi nero prima di caricare la schermata di login, cosa che invece capita sempre con durata anche leggermente maggiore.

coll. permanente

ha risposto 24 Jul, 19:20

lorenzos98's gravatar image

lorenzos98
303

modificato 24 Jul, 19:21

  • quale scheda video e quali driver usi?

  • da irc ancora nessun intervento

(24 Jul, 20:42) sacarde sacarde's gravatar image

sudo lshw -c display

-display
description: VGA compatible controller
product: Picasso
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:05:00.0
version: d1
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
configuration: driver=amdgpu latency=0
resources: irq:57 memory:c0000000-cfffffff memory:d0000000-d01fffff ioport:1000(size=256) memory:d0500000-d057ffff

coll. permanente

ha risposto 24 Jul, 21:09

lorenzos98's gravatar image

lorenzos98
303

modificato 24 Jul, 21:11

Ho letto il link ed eseguendo il comando nominato lspci | grep -E 'VGA|Display|3D' ottengo:
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev d1)

Eseguendo invece sudo lshw -c display | grep driver per vedere i driver:
configuration: driver=amdgpu latency=0

coll. permanente

ha risposto 25 Jul, 01:26

lorenzos98's gravatar image

lorenzos98
303

modificato 25 Jul, 01:26

da: software-properties-gtk

nella parte "driver aggiuntivi" trovi nulla?

(25 Jul, 09:38) sacarde sacarde's gravatar image

No, ho nessun driver aggiuntivo disponibile

coll. permanente

ha risposto 25 Jul, 11:23

lorenzos98's gravatar image

lorenzos98
303

  • lo stesso problema lo hai avviando la live?

  • provato la live di ubuntu?

(25 Jul, 11:59) sacarde sacarde's gravatar image

Non ho provato, ricordo che al momento dell'installazione non feci la live, ma installai direttamente.
Riflettendo però su un possibile avvio da live ho provato a mettere l'accesso automatico dalle impostazioni per vedere cosa potesse succedere nel caso in cui non dovesse caricare la schermata di login.
Il risultato è stato probabilmente peggiore.
Su più di una decina di avvii provati i glitch si sono ridotti, ma un paio di volte lo schermo è diventato nero costringendomi a spegnere il pc bruscamente. Nella maggior parte delle volte invece l'accensione procedeva correttamente, ma una volta caricato il sistema ero "bloccato" nel senso che non veniva caricato il puntatore e l'input da tastiera non era percepito.
(cosa mai successa con la schermata di login)

coll. permanente

ha risposto 25 Jul, 13:24

lorenzos98's gravatar image

lorenzos98
303

modificato 25 Jul, 13:28

  • ripensa alla necessita di avere la Pop!_OS (quale ambiente grafico usa?)

  • prova con la relativa *ubuntu

(25 Jul, 13:46) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×211

domanda posta: 22 Jul, 10:35

domanda visualizzata: 231 volte

ultimo aggiornamento: 25 Jul, 15:26

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.