Buona sera ragazzi, sto avendo un problema da un bel po di tempo nella Scrivania di Ubuntu mate 18.04 lts, cioè nella Scrivania sulla barra del menu a destra in mezzo al WiFi e Bluetoot mi visualizza un cerchio rosso simile al senso vietato, il cui mi dice che si è verificato un errore di dipendenze su aggiornamenti delle applicazioni e software. questo problema è un molto tosto che non sono riuscito a risolverlo da un anno perchè ho rovinato alcuni file del sistema facendo l'installazione del virtualBox. il mio obbiettivo è di togliere questo simbolo simile al senso vietato possibilmente senza fare aggiornamenti, per favore mi potete dare un aiuto?

Una cosa che devo aggiungere al testo di sopra: questo segno del senso vietato mi appare molto spesso quando sbuca all'improviso un messaggio di errore del sistema e mi dice di mandare ai sviluppatori o annullare , quando clicco invia a sviluppatori mi esce questo segno del senso vietato.

chiesto 23 Sep, 21:11

anto-nio's gravatar image

anto-nio
102

da terminale hai provato a dare:

sudo apt update

sudo apt upgrade (e vedere cosa ti aggiornerebbe) senza poi eseguirlo

(24 Sep, 09:52) sacarde sacarde's gravatar image

provato ed esce questo: Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto È utile eseguire "apt --fix-broken install" per correggere ciò. I seguenti pacchetti hanno dipendenze non soddisfatte: libc6-dbg : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 è installata libc6-dev : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 è installata mysql-server-5.7 : Dipende: mysql-server-core-5.7 (= 5.7.28-0ubuntu0.18.04.4) ma la versione 5.7.31-0ubuntu0.18.04.1 è installata E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).

la stessa cosa mi è uscita quando ho trovato questo problema che ho detto all'inizio. inoltre mi è apparso dinuovo XD un botto di problemi a causa di questo problema che ho detto all'inizio tipo la tastiera non digita le lettere la barra menu quando clicco qualcosa non appare niente e devo per forza fare l'arresto forzato.

(24 Sep, 10:29) anto-nio anto-nio's gravatar image

e fare cosa suggerisce?

sudo apt --fix-broken install

p.s. https://wiki.ubuntu-it.org/AmministrazioneSistema/InstallareProgrammi/Apt

(24 Sep, 10:44) sacarde sacarde's gravatar image

In che senso a fare cosa suggerisce

(24 Sep, 11:09) anto-nio anto-nio's gravatar image

a eseguire il comando suggerito...

(24 Sep, 11:36) sacarde sacarde's gravatar image

ho provato e mi dice che i due pacchetti del nome libc hanno restituito come errore 1

(24 Sep, 15:05) anto-nio anto-nio's gravatar image

e a provare se un aggiornamento risolve?

sudo apt upgrade

cosa ti aggiornerebbe?

(24 Sep, 18:09) sacarde sacarde's gravatar image

la stessa cosa che mi esce con sudo apt update, cioè mi dice che ci sono due pacchetti del nome libc che hanno restituito come errore 1

(26 Sep, 08:02) anto-nio anto-nio's gravatar image

con upgrade esce questo: I seguenti pacchetti hanno dipendenze non soddisfatte: libc6-dbg : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 è installata libc6-dev : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 è installata mysql-server-5.7 : Dipende: mysql-server-core-5.7 (= 5.7.28-0ubuntu0.18.04.4) ma la versione 5.7.31-0ubuntu0.18.04.1 è installata E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).

(26 Sep, 08:05) anto-nio anto-nio's gravatar image
  • e con: sudo apt-get -f install

  • cosa vedi dal comando: lsb_release -a

(26 Sep, 09:26) sacarde sacarde's gravatar image

con il secondo comando vedo: No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.4 LTS Release: 18.04 Codename: bionic

(27 Sep, 20:14) anto-nio anto-nio's gravatar image

con il primo mi dice prima casa c'è da installare cosa da aggiornare e cosa da eliminare poi clicco si e inizia i problemi uguale al codice detto sopra del pacchetto lib che ha restituito errore 1

(27 Sep, 20:15) anto-nio anto-nio's gravatar image

il sottoprocesso nuovo pacchetto libc6:i386 script pre-installation ha restituito lo stato di errore 1 Si sono verificati degli errori nell'elaborazione: /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb Questi sono la parte finale di quello che mi esce con il primo comando.

(27 Sep, 20:17) anto-nio anto-nio's gravatar image

ma adesso virtualbox c'e' ancora? lo vuoi togliere?

forse e' iniziato tutto dalla sua installazione?

(27 Sep, 20:44) sacarde sacarde's gravatar image

si tutto questo casino è iniziato dopo l'installazione fallita di virtualbox e vmware player. pero virtualbox e vmware non è presente nel pc ma ci sono dei file di questi due programmi che sono stati installati durante l'installazione di queste due app e da qui ho iniziato ad avere tutti questi problemi

(27 Sep, 21:57) anto-nio anto-nio's gravatar image

lo vedi dai log tutti i pacchetti installati come dipendenza dei virtualizatori?

ubuntu log installazioni pacchetti:

/var/log/apt/history.log

/var/log/apt/term.log

/var/cache/apt/archives

(27 Sep, 23:18) sacarde sacarde's gravatar image

mi dice permesso negato non è che devo mettere accesso di amministratore?

(28 Sep, 15:40) anto-nio anto-nio's gravatar image

strano, con quale comando provi a accedere?

prova con: sudo less /var/log/apt/history.log

sudo less /var/log/apt/term.log

sudo cd /var/cache/apt/archives

(28 Sep, 16:45) sacarde sacarde's gravatar image

ho provato tutte e tre e due non mi fanno accedere come ho detto sopra e l'altra mi dice che è una directory

(29 Sep, 20:38) anto-nio anto-nio's gravatar image
(29 Sep, 20:45) sacarde sacarde's gravatar image

no con sudo sono apparse tante cose a tutte tre e non so cosa siano e non riesco a copiarle una alla volta qui nei commenti.

(30 Sep, 09:57) anto-nio anto-nio's gravatar image

poi il problema che ciò adesso si è peggiorato di molto, adesso non riesco a scaricare nessun programma o file del terminale con sudo apt-get install + nome del programma o file.

il sottoprocesso nuovo pacchetto libc6:i386 script pre-installation ha restituito lo stato di errore 1 Si sono verificati degli errori nell'elaborazione: /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_amd64.deb /var/cache/apt/archives/libc6_2.27-3ubuntu1.2_i386.deb

(30 Sep, 09:57) anto-nio anto-nio's gravatar image

devi vedere tra tutte le voci, quando hai installato virtualbox e/o vmware, cosa hai dovuto installare come dipendenza e provare a toglierlo/i

(30 Sep, 10:07) sacarde sacarde's gravatar image

eh questo è un gran problema non mi ricordo nulla perché lo fatto due anni fa questa installazione di virtualbox e vmware

di preciso mi visualizza questo durante l'installazione: È utile eseguire "apt --fix-broken install" per correggere ciò. I seguenti pacchetti hanno dipendenze non soddisfatte: libc6-dbg : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 sta per essere installata libc6-dev : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 sta per essere installata

(30 Sep, 10:18) anto-nio anto-nio's gravatar image

ma da quei file di log di "apt" dovresti trovare anche i tentativi di installazione piu' vecchi

(30 Sep, 10:29) sacarde sacarde's gravatar image

no non li ho trovati

(03 Oct, 14:41) anto-nio anto-nio's gravatar image
(03 Oct, 17:01) sacarde sacarde's gravatar image

no mi visualizza direttamente quello che ho scritto sopra

(05 Oct, 12:55) anto-nio anto-nio's gravatar image

potrei presumere che il pacchetto libc6-dbg sia eliminabile

proverei a toglierlo e a ripetere i comandi correttori

sudo apt --fix-broken install

sudo apt-get -f install

(05 Oct, 14:17) sacarde sacarde's gravatar image

Questo problema non è che una reazione catena di problemi causato dalla fallita installazione di virtual box? Dopo che ho fatto questa installazione un anno fa ha iniziato a dare molti problemi

(06 Oct, 16:09) anto-nio anto-nio's gravatar image

si, per questo ti facevo cercare nella history della pacchettizzazione

proviamo a cercare nella dir /var/log se trovi un log che contenga la parola "virtualbox" o "vmware"

ce la fai da filemanager?

(06 Oct, 16:46) sacarde sacarde's gravatar image

adesso sono andato nella dir (non da terminale ma dalla cartella home file system fino a log) e ho trovato vbox-setup.log vbox-setup.log.1 vbox-setup.log.2 vbox-setup.log.3 vbox-setup.log.4 vm-installer , poi una cartella vmware. queste ho trovato pero devo aggiungere che nella home cioè con dir /home/nome-utente ho trovato la cartella vmware

(06 Oct, 21:03) anto-nio anto-nio's gravatar image
  • mah, cosa ci sarebbe in vbox-setup.log ?

  • nella /home/..../vmware vedrai ci sono le macchine virtuali create, credo

(07 Oct, 08:31) sacarde sacarde's gravatar image

in vbox-setup.log non lo so cosa ci può stare lo scritto perché vbox assomiglia a v=virtual box. invece /homr/..../vmware c'è una cartella Windows 10x64 e all'interno diversi file con nome Windows 10 x64-s001.vmdk Windows 10 x64-s002.vmdk Windows 10 x64-s003.vmdk ecc...

(07 Oct, 09:46) anto-nio anto-nio's gravatar image
  • ma virtualbox o vmware li hai ancora?

  • nella home probabilmente hai i rimasugli di una vm windows che avevi creata? (.vmdk)

(07 Oct, 10:01) sacarde sacarde's gravatar image

virtualbox penso che lo disinstallata un anno fa pero la disinstallazione forse è incompleta, invece vmware me lo ricordo che lo disinstallato dal comando di terminale forse quello che ho detto sopra è un sistema virtuale creato in precedenza

si comunque ci sono i file .vmdk

(07 Oct, 13:22) anto-nio anto-nio's gravatar image

dal comando: dpkg -l | grep virtualbox

o

dpkg -l | grep vmware

trovi nulla?

(07 Oct, 13:43) sacarde sacarde's gravatar image

pi virtualbox-6.0 6.0.14-133895~Ubuntu~bionic amd64 Oracle VM VirtualBox

ii xserver-xorg-video-vmware 1:13.2.1-1build1 amd64 X.Org X server -- VMware display driver

che sorpresa XD ecco cosa esce con i due comandi (1 virtualbox 2 vmware)

(08 Oct, 08:59) anto-nio anto-nio's gravatar image
  • le lettere "pi" significa installato e purgato

  • le lettere "ii" significa installato (pero' e' soltanto il driver di xorg, puoi toglierlo ma non fara' molto per il problema)

  • non vedo il terzo!

p.s. se non l'hai gia' fatto potresti provare a eseguire:

sudo apt autoremove

https://wiki.ubuntu-it.org/AmministrazioneSistema/InstallareProgrammi/Apt

(08 Oct, 09:16) sacarde sacarde's gravatar image

per il terzo cosa intendi? autoremove non funziona esce la stessa cosa con upgrade

I seguenti pacchetti hanno dipendenze non soddisfatte: libc6-dbg : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 è installata libc6-dev : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 è installata mysql-server-5.7 : Dipende: mysql-server-core-5.7 (= 5.7.28-0ubuntu0.18.04.4) ma la versione 5.7.31-0ubuntu0.18.04.1 è installata

(08 Oct, 09:22) anto-nio anto-nio's gravatar image

proverei a togliere fra questi pacchetti quelli che non usi:

libc6-dbg mysql-server mysql-server-core

(08 Oct, 09:35) sacarde sacarde's gravatar image

mysql lo uso per programmare non so se tolgo questo mysql-server rovina tutto mysql comunque precedentemente io ho provato a togliere entrambi i due pacchetti sia da terminale che manualmente ed a entrambe non sono riuscito a disinstallare non mi fa mettere l'opzione cancella

(08 Oct, 12:33) anto-nio anto-nio's gravatar image

e libc6-dbg ?

(08 Oct, 13:38) sacarde sacarde's gravatar image

questo non so che paccheto è, mi puoi dire come eliminare? o aggiornare, ho provato con autoremove e upgrade ma nessuno funziona

(08 Oct, 13:51) anto-nio anto-nio's gravatar image

da terminale: sudo apt purge libc6-dbg

(08 Oct, 14:09) sacarde sacarde's gravatar image

non funziona XD rimane come era rimasto prima

(08 Oct, 20:46) anto-nio anto-nio's gravatar image

da errore il comando? che dice

(08 Oct, 21:00) sacarde sacarde's gravatar image

I seguenti pacchetti hanno dipendenze non soddisfatte: libc6-dbg : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 è installata libc6-dev : Dipende: libc6 (= 2.27-3ubuntu1.2) ma la versione 2.27-3ubuntu1 è installata mysql-server-5.7 : Dipende: mysql-server-core-5.7 (= 5.7.28-0ubuntu0.18.04.4) ma la versione 5.7.31-0ubuntu0.18.04.1 è installata

dopo che ho usato il codice il lib si elimina poi ho provato a fare un update e upgrade , alla fine esce questo che ho scritto sopra

(09 Oct, 09:40) anto-nio anto-nio's gravatar image

quindi il libc6-dbg non lo fa togliere?

forse qui ti sanno aiutare: https://forum.ubuntu-it.org/viewforum.php?f=30&sid=9c9ab7275db0381206ec899491a159ce

(09 Oct, 09:58) sacarde sacarde's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×79
×17

domanda posta: 23 Sep, 21:11

domanda visualizzata: 132 volte

ultimo aggiornamento: 09 Oct, 09:58

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.