Salve a tutti, oggi ho installato Ubuntu sul mio pc affiancando a win10. Dopo averlo installato riavvio il pc ma non si avvia nessuno dei due sistemi operativi. Specifico che sono scaricati entrambi su un hdd esterno.

chiesto 15 Oct, 21:19

vikvv's gravatar image

vikvv
10

ma arrivi al menu di grub? se bno premi SHIFT durante il boot

e trovi le scelte da avviare?

(15 Oct, 21:39) sacarde sacarde's gravatar image

Quando accendo il pc mi da la scritta in basso a destra per aprire il bios ma poi si ferma in una schermata nera e non mostra più niente, l'ho lasciato per 30 minuti ma non succede niente.

(16 Oct, 07:04) vikvv vikvv's gravatar image
  • l'installazione si e' conclusa bene?

  • se premi SHIFT ?

(16 Oct, 08:15) sacarde sacarde's gravatar image

L'installazione si è conclusa bene, dopo provo con shift e ti dico. Grazie mille per l'aiuto.

(16 Oct, 12:27) vikvv vikvv's gravatar image

Ho provato a premere shift ma si ferma alla schermata Grub loading.

(16 Oct, 12:40) vikvv vikvv's gravatar image
  • ma e' apparso il menu di grub?

  • potresti provare con un ripristino di grub:

https://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino

(16 Oct, 13:14) sacarde sacarde's gravatar image

Ho provato a ripristinare grub ma rimane fermo ad una schermata in cui è scritto GRUB Loading.

(16 Oct, 15:02) vikvv vikvv's gravatar image
  • i sistemi te li ha riconosciuti con il comando: sudo update-grub ?
(16 Oct, 16:42) sacarde sacarde's gravatar image

Sì, li ha riconosciuti entrambi.

(16 Oct, 18:43) vikvv vikvv's gravatar image

dove hai installato grub? sei su uefi? nella partizione /boot ?

(16 Oct, 20:48) sacarde sacarde's gravatar image

Ho scaricato grub con la versione live di Ubuntu, sono su bios. L'hard disk è diviso in due partizioni.

(16 Oct, 21:05) vikvv vikvv's gravatar image

quindi grub l'hai installato su /dev/sda :

sudo grub-install /dev/sda

sudo update-grub

(16 Oct, 21:35) sacarde sacarde's gravatar image

Sì, ho provato a riscaricare ma continua a fermarsi alla schermata grub loading

(17 Oct, 13:53) vikvv vikvv's gravatar image

quando avvii col dvd/usb per l'installazione, se fai "prova il sistema" ti si avvia regolarmente?

(17 Oct, 14:09) sacarde sacarde's gravatar image

Si, in modalità live funziona

(17 Oct, 15:26) vikvv vikvv's gravatar image
  • provato anche a reinstallare da zero? controllando l'ultima parte dove installa e configura grub

  • quindi adesso non parte nessun sistema, no?

p.s. sei sicuro che non sei su uefi?

(17 Oct, 16:46) sacarde sacarde's gravatar image

Ho formattato l'hard disk eliminando tutte le partizioni, ho reinstallato Ubuntu, è andato tutto bene ma quando riavvio si ferma alla schermata grub loading. Comunque sono sicuro di essere su bios, anche perché il laptop è un po' datato.

(17 Oct, 19:43) vikvv vikvv's gravatar image
  • mah... l'ordine di avvio va bene?

provato a resettare il BIOS?

(17 Oct, 20:39) sacarde sacarde's gravatar image

L'ordine di avvio è apposto, ho resettato il BIOS ma ancora non funziona.

(17 Oct, 21:23) vikvv vikvv's gravatar image
  • mai provato il cd/usb con supergrub/supergrub2 per avviare il/i sistemi installati su disco?

https://wiki.ubuntu-it.org/AmministrazioneSistema/SuperGrubDisk

(17 Oct, 21:57) sacarde sacarde's gravatar image

Adesso ho provato supergrub ma non funziona neanche questo, si ferma ad una schermata in cui c'è scritto: Grub loading. Welcome tu grub. Rimane bloccato qui.

(17 Oct, 23:33) vikvv vikvv's gravatar image

mah...

cel'hai un'altro PC da poter provare a far partire quel hd? (bios, no uefi)

(18 Oct, 08:26) sacarde sacarde's gravatar image

Non ho nessun altro pc. Avevo pensato di Riscaricare Windows per poi passare da Bios a Uefi. Può funzionare?

(18 Oct, 10:24) vikvv vikvv's gravatar image

che vuoi dire "passare da bios a uefi"? il PC o e' bios o e' uefi

(18 Oct, 10:29) sacarde sacarde's gravatar image

Il pc è bios, intendevo "aggiornarlo" (?) a Uefi. L'ho letto in questa guida: https://www.navigaweb.net/2019/04/passare-da-bios-uefi-e-convertire-disco.html?m=1#id1

(18 Oct, 10:35) vikvv vikvv's gravatar image
  • li parla sopratutto della tabella delle partizioni, dalla vecchia MBR alla GPT (e' soltanto la modalita' nella struttuta della tabella delle partizioni)

  • un'altra cosa e' la struttura del bios, se il pc e' vecchio non credo sia possibile passare da una all'altra.... vedi voci "uefi" tra i menu del tuo BIOS?

(18 Oct, 10:50) sacarde sacarde's gravatar image

No, non c'è.

(18 Oct, 11:06) vikvv vikvv's gravatar image
  • non rimane che provare un'altra distribuzione

p.s. e provare a reinstallare windows?

(18 Oct, 11:55) sacarde sacarde's gravatar image

Ho provato con debian e Kubuntu ma non funziona lo stesso. Adesso ho riformattato e reinstallato Windows e funziona.

(18 Oct, 16:46) vikvv vikvv's gravatar image

Ma secondo te qual è il problema per il quale non funziona Linux?

(18 Oct, 16:48) vikvv vikvv's gravatar image

fammi capire bene... una volta reinstallato windows, questo parte bene..ok

e se successivamente reinstalli linux o ripristini grub continua a funzionare soltanto windows?

windows ha attivo il boot veloce? o simili?

(18 Oct, 16:55) sacarde sacarde's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,912
×228
×197

domanda posta: 15 Oct, 21:19

domanda visualizzata: 82 volte

ultimo aggiornamento: 18 Oct, 16:55

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.