Ciao ragazzi. E' da ieri che provo in tutti i modi a far partire vscode su ubuntu 18.04 ma senza successo. Me lo installa ma poi non me lo fa partire. Non so più dove battere la testa.

Questo è ciò che mi esce con code --verbose

[7422:1103/081059.137337:ERROR:appcenter_api.cc(52)] expecting appcenter url prefix [7454:1103/081059.210058:ERROR:appcenter_api.cc(52)] expecting appcenter url prefix libGL error: MESA-LOADER: failed to open i965 (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri) libGL error: failed to load driver: i965 libGL error: MESA-LOADER: failed to open i965 (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri) libGL error: failed to load driver: i965 libGL error: MESA-LOADER: failed to open swrast (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri) libGL error: failed to load driver: swrast [7454:1103/081059.223098:ERROR:gl_context_glx.cc(187)] Failed to create GL context with glXCreateNewContext. [7454:1103/081059.223176:ERROR:gpu_info_collector.cc(76)] gl::init::CreateGLContext failed [7454:1103/081059.223218:ERROR:gpu_info_collector.cc(208)] Could not create context for info collection. [7454:1103/081059.223259:ERROR:gpu_init.cc(70)] gpu::CollectGraphicsInfo failed. [7454:1103/081059.225666:WARNING:x11_util.cc(1520)] X error received: serial 205, error_code 158 (GLXBadContext), request_code 152, minor_code 6 (X_GLXIsDirect) [7454:1103/081059.226088:WARNING:x11_util.cc(1520)] X error received: serial 204, error_code 2 (BadValue (integer parameter out of range for operation)), request_code 152, minor_code 24 (X_GLXCreateNewContext) [7454:1103/081059.226196:ERROR:viz_main_impl.cc(152)] Exiting GPU process due to errors during initialization [7463:1103/081059.229362:ERROR:appcenter_api.cc(52)] expecting appcenter url prefix [7462:1103/081059.251988:ERROR:appcenter_api.cc(52)] expecting appcenter url prefix [main 2020-11-03T07:10:59.295Z] Error: ENOENT: no such file or directory, mkdir [main 2020-11-03T07:10:59.297Z] Lifecycle#kill()

chiesto 03 Nov '20, 07:46

n3v3's gravatar image

n3v3
101

modificato 03 Nov '20, 08:12

(03 Nov '20, 08:11) sacarde sacarde's gravatar image
(03 Nov '20, 09:37) n3v3 n3v3's gravatar image

ma con snap o con il pacchetto .deb?

(03 Nov '20, 09:46) sacarde sacarde's gravatar image

ho fatto copia incolla alla procedura di installazione con apt. Se lancio # code --user-data-dir da terminale me lo apre ma come superuser

(03 Nov '20, 10:07) n3v3 n3v3's gravatar image
  • e se dai da utente: code --user-data-dir ?

  • che vedi da: snap list | grep code

(03 Nov '20, 10:21) sacarde sacarde's gravatar image

Entrambi non fanno niente

(03 Nov '20, 12:21) n3v3 n3v3's gravatar image

neanche da: ps aux|grep code

p.s. la grafica va bene?

cosa vedi da: inxi -G

(03 Nov '20, 13:48) sacarde sacarde's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,946

domanda posta: 03 Nov '20, 07:46

domanda visualizzata: 69 volte

ultimo aggiornamento: 03 Nov '20, 13:49

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.