Salve a tutti.
Non riesco più ad aggiornare la mia versione di Ubuntu 12.04.

Il gestore aggiornamenti mi dà questo enigmatico (per le mie scarse competenze) messaggio:

mysql-server-5.5: PreDepends: mysql-common (>= 5.5.32-0ubuntu0.12.04.2) ma 5.5.34-0ubuntu0.12.04.1 è installato
    Depends: mysql-client-5.5 (>= 5.5.32-0ubuntu0.12.04.2) ma 5.5.34-0ubuntu0.12.04.1 è installato    
    Depends: perl (>= 5.6) ma 5.14.2-6ubuntu2.3 è installato
    Depends: libgcc1 (>= 1:4.1.1) ma 1:4.6.3-1ubuntu5 è installato
    Depends: zlib1g (>= 1:1.1.4) ma 1:1.2.3.4.dfsg-3ubuntu4 è installato
    Depends: upstart-job ma è un pacchetto virtuale
    Depends: mysql-server-core-5.5 (= 5.5.32-0ubuntu0.12.04.2) ma 5.5.34-0ubuntu0.12.04.1 è installato

Che si possa fare qualcosa?

Grazie

chiesto 29 Ott '13, 13:09

farfallon's gravatar image

farfallon
15111

modificato 29 Ott '13, 16:36

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Sembra che tu abbia installato paccetti più recenti di quelli proposti. Ti consiglio di progare il comando sudo apt-get update per vedere che non sia un problema di fonti non aggiornate.

(29 Ott '13, 13:20) Marco Marco's gravatar image

Inoltre, quali repository esterni hai aggiunto?

(29 Ott '13, 13:30) dadexix86 ♦♦ dadexix86's gravatar image

Ho provato con sudo apt-get update e mi ha dato questa risposta:

    W: Impossibile recuperare cdrom://Ubuntu 11.04 _Natty Narwhal_ - Release i386 (20110427.1)/dists/natty/main/binary-i386/Packages  Usare apt-cdrom per far riconoscere questo CD-ROM da APT. apt-get update non può essere usato per aggiungere nuovi CD-ROM

    W: Impossibile recuperare cdrom://Ubuntu 11.04 _Natty Narwhal_ - Release i386 (20110427.1)/dists/natty/restricted/binary-i386/Packages  Usare apt-cdrom per far riconoscere questo CD-ROM da APT. apt-get update non può essere usato per aggiungere nuovi CD-ROM

E: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.
(29 Ott '13, 15:07) farfallon farfallon's gravatar image

Non so come è successo ma hai i repository della 11.04 sulla 12.04. Per fortuna che apt non sovrascrive pacchetti nuovi con vecchi o ti trovavi con parecchi problemi.

La soluzione è quella ri ripristinare le fonti corrette nel file /etc/apt/sources.list

Per farlo esegui i seguenti comandi:

sudo mv /etc/apt/sources.list /etc/apt/sources.list.old
sudo nano /etc/apt/sources.list

Nell'editor che si apre incolla le seguenti righe:

deb http://it.archive.ubuntu.com/ubuntu/ precise main universe restricted multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ precise main universe restricted multiverse

deb http://security.ubuntu.com/ubuntu precise-security main universe restricted multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security main universe restricted multiverse

deb http://it.archive.ubuntu.com/ubuntu/ precise-updates main universe restricted multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ precise-updates main universe restricted multiverse

deb http://it.archive.ubuntu.com/ubuntu precise-backports main restricted universe multiverse
deb-src http://it.archive.ubuntu.com/ubuntu precise-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

Salva premendo Ctrl+X e digitando S alla richiesta di salvataggio.

A questo punto riprova i comandi:

sudo apt-get update
sudo apt-get dist-upgrade

Il primo scaricherà le nuove fonti, aggiornate correttamente alla 12.04, il secondo verificherà la presenza di aggiornamenti e li installerà.

Facci sapere.

coll. permanente

ha risposto 29 Ott '13, 17:34

Marco's gravatar image

Marco
1.5k4930

modificato 29 Ott '13, 17:34

Innanzi tutto, grazie per l'aiuto! Ho fatto come mi hai detto ed è uscito questo messaggio:

Lettura elenco dei pacchetti... Fatto

NOME DEL MIO PC:~$ sudo apt-get dist-upgrade

Lettura elenco dei pacchetti... Fatto

Generazione albero delle dipendenze

Lettura informazioni sullo stato... Fatto

È utile eseguire "apt-get -f install" per correggere ciò.

I seguenti pacchetti hanno dipendenze non soddisfatte:

mysql-server-5.5 : Dipende: mysql-server-core-5.5 (= 5.5.32-0ubuntu0.12.04.2) ma la versione 5.5.34-0ubuntu0.12.04.1 è installata

E: Dipendenze non trovate. Riprovare usando -f.

Cosa posso fare?

Grazie

(30 Ott '13, 12:41) farfallon farfallon's gravatar image

Contrordine:

Dal gestore aggiornamenti è partito, non so nemmeno io come, un avanzamento parziale di versione che ha rimosso i pacchetti obsoleti e istallato quelli aggiornati.

Pare che tutto sia risolto.

Grazie ancora per l'aiuto!

(30 Ott '13, 13:23) farfallon farfallon's gravatar image

Se hai risolto accetta la risposta cliccando l'apposito tasto con la spunta, sulla sinistra.

(30 Ott '13, 20:10) Marco Marco's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×90
×16

domanda posta: 29 Ott '13, 13:09

domanda visualizzata: 1,429 volte

ultimo aggiornamento: 30 Ott '13, 20:10

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.