da quando ho aggiornato a 20.10 e poi ho fatto il downgrade a 20.04.1 LTS ho frequenti crash di sistema: si blocca tutto e devo riavviare con il pulsante power tenuto premuto per 10 sec. Allego le prime 20 righe del file del crash: ProblemType: Crash CrashCounter: 1 CurrentDesktop: ubuntu:GNOME Date: Wed Nov 11 13:57:44 2020 ExecutablePath: /usr/bin/software-properties-gtk ExecutableTimestamp: 1596806134 InterpreterPath: /usr/bin/python3.8 ProcCmdline: /usr/bin/python3 /usr/bin/software-properties-gtk --open-tab 2 --toplevel 33554435 ProcCwd: /home/claudio1644 ProcEnviron: LC_TIME=it_IT.UTF-8 LC_MONETARY=it_IT.UTF-8 PATH=(custom, no user) LC_ADDRESS=it_IT.UTF-8 XDG_RUNTIME_DIR=<set> LANG=en_US.UTF-8 LC_TELEPHONE=it_IT.UTF-8 LC_NAME=it_IT.UTF-8 SHELL=/bin/bash LC_MEASUREMENT=it_IT.UTF-8 LC_IDENTIFICATION=it_IT.UTF-8 LC_NUMERIC=it_IT.UTF-8 LC_PAPER=it_IT.UTF-8 ProcMaps:

chiesto 11 Nov, 16:13

claudio1644's gravatar image

claudio1644
102

  • provare a reinstallare il pacchetto: software-properties-gtk ?

  • il downgrate lo hai fatto reinstallando il 20.04 vero? quindi hai riformattato la partizione "/" ?

p.s. hai problemi sul disco di scrittura/lettura della partizione?

(11 Nov, 20:38) sacarde sacarde's gravatar image

12avanti »

oggi il sistema è andato in crash mentre stava aggiornando "snap" Solito crash con freccia del mouse immobile e finestra di dialogo barra di caricamento bloccata a metà. Dopo 5 minuti di attesa senza fare nulla, ho forzato il riavvio con interruttore power on.

coll. permanente

ha risposto 12 Nov, 16:01

claudio1644's gravatar image

claudio1644
102

modificato 12 Nov, 16:03

  • per reinstallare "snap":

sudo apt-get install --reinstall snapd

  • fatto un controllo della partizione?

da una live: sudo fsck /dev/sd....partizione...

  • quali driver grafici usi?

  • fatto il test della ram?

(12 Nov, 16:44) sacarde sacarde's gravatar image

grazie: reinstallato "software-properties-gtk, la risposta del terminale è stata questa: "software-properties-gtk is already the newest version (0.98.9.2). software-properties-gtk set to manually installed. The following package was automatically installed and is no longer required: libfprint-2-tod1 Use 'sudo apt autoremove' to remove it."

Per cuil'ho rimosso. Ora staro' a vedere se il sistema va ancora in crash e riferiro' qui

coll. permanente

ha risposto 11 Nov, 22:08

claudio1644's gravatar image

claudio1644
102

modificato 11 Nov, 22:11

per reinstallarlo da terminale:

sudo apt-get install --reinstall software-properties-gtk

(11 Nov, 23:24) sacarde sacarde's gravatar image
  • OK, ho reinstallato snap: per ora nessun crash,
  • controllo partizione da live, ora chiudo e lo faccio, poi riferisco
  • Driver grafico: X.OrgXserver al posto di NVIDIA per la scheda grafica GEForce GT 320
  • Test della RAM non fatto, ma su Windows, stesso PC e stesse RAM, non c'è nessun problema, come si fa su Ubuntu?
coll. permanente

ha risposto 12 Nov, 20:21

claudio1644's gravatar image

claudio1644
102

  • se su windows funziona bene, non e' la ram

  • quali driver video? "inxi -G"

  • che hardware e'? vecchio?

(12 Nov, 20:41) sacarde sacarde's gravatar image

Quando ho tentato di fare fsck da live è successo un altro fattaccio: il sistema è andato in crash con Ubuntu in funzione dal DVD live. Probabilmente quindi è proprio un problema di RAM, anche se su windows non c'è alcun problema. Il mio hardware è descritto qui: https://valid.x86.fr/epfnak, è vecchiotto ma ancora valido. A Ubuntu ho assegnato più di 400 GB. Il driver video usato su Ubuntu è X.OrgX (lo vedo dalla scheda del Software Update: ce ne sono 2, uno è l'originale NVIDIA, che non uso da quando ho visto che bloccava il sistema con Gorilla ecc. 20.10 Domani smonto il PC e metto un po' di disossidante sui contatti delle RAM: 665 MHz, DDR3-1330 Grazie per ora per l'aiuto

coll. permanente

ha risposto 12 Nov, 22:20

claudio1644's gravatar image

claudio1644
102

ultime di ieri sera: ho fatto il test della RAM con "diagnostica memoria windows", una app che riavvia, fa il test in ambiente neutro e poi riavvia ancora: tutto OK!

coll. permanente

ha risposto 13 Nov, 09:05

claudio1644's gravatar image

claudio1644
102

  • o e' la partizione (e' un HD vecchio?)

  • o i driver video, li vedi da: "inxi -G"

se fosse, quando si blocca dovresti poter accedere alle consolle testuali: ctrl-alt-f1 o f2

(13 Nov, 09:18) sacarde sacarde's gravatar image

Si, HD è vecchio, ma ho controllato la partizione con fsck /dev/sdc6 (la partizione che ho trovato con fsck -l, l'unica per Linux, e non mi ha dato errore. Ora provo a trovare il driver video con inxi-G e poi faccio sapere. Come faccio a dare il voto? Grazie per l'aiuto

coll. permanente

ha risposto 13 Nov, 13:21

claudio1644's gravatar image

claudio1644
102

Ecco i dati da inxi -G Graphics: Device-1: NVIDIA GT215 [GeForce GT 320] driver: nouveau v: kernel Display: x11 server: X.Org 1.20.8 driver: nouveau resolution: 1920x1080~60Hz OpenGL: renderer: NVA3 v: 3.3 Mesa 20.0.8

coll. permanente

ha risposto 13 Nov, 14:34

claudio1644's gravatar image

claudio1644
102

vediamo come vanno i driver "nouveau" (i proprietari davano problemi vero?) oppure provare i "vesa" (generici)

(13 Nov, 15:30) sacarde sacarde's gravatar image

Ora è appena andato in crash accedendo al sito "Chiedi". Sono riuscito a riavviare col comando CTRL+ALT+F5 (CTRL+ALT+F1/F2 non funzionavano...). Il driver video che usavo, con cui è andato in crash era questo: https://app.box.com/s/koyew93y17n21smibznhkfnysrjeuuik ma ora l'ho cambiato e riprovo quello originale NVIDIA proposto da Ubuntu

coll. permanente

ha risposto 13 Nov, 15:53

claudio1644's gravatar image

claudio1644
102

con il driver NVIDIA ho il problema che avevo prima: quando il sistema va in sospensione dopo il tempo programmato, quando riapro Ubuntu, mi da questo schermo: https://app.box.com/s/oy02yr6s2clil6com5znla3gc262k2z6 Riesco a tornare ad uno schermo accettabile solo dopo che scelgo un altro background facendo click destro su una zona neutra del display. Questa cosa è cominciata a succedermi dopo un aggiornamento qualche tempo fa. Non me ne accorgo se il sistema non va in sospensione. Comunque il driver NVIDIA che uso ora è questo: https://app.box.com/s/uavedene74vydzxc3ugbkasfg9znk6an

coll. permanente

ha risposto 13 Nov, 19:03

claudio1644's gravatar image

claudio1644
102

  • nell'aggiornamento c'era anche il pacchetto nvidia-340-... ?
(13 Nov, 20:50) sacarde sacarde's gravatar image
  • un aggiornamento fatto qualche mese fa, non ricordo, Ricordo solo che, da un certo momento, uscendo dalla sospensione, lo schermo era come pieno di neve, Poi, dopo il cambio dell'immagine del desktop, la cosa spariva. Anche in questo caso, dopo essere passato al driver NVIDIA, dopo qualche minuto si riesce a tornare allo sfondo originario.
  • Comunque, da quando sono tornato al driver NVIDIA, il sistema non è più andato in crash
coll. permanente

ha risposto 13 Nov, 20:56

claudio1644's gravatar image

claudio1644
102

  • i pacchetti scaricati dovrebbero essere in:

/var/cache/apt/archives

o prova a eseguire: apt-cache showpkg nvidia-340

(13 Nov, 21:03) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×88

domanda posta: 11 Nov, 16:13

domanda visualizzata: 74 volte

ultimo aggiornamento: 15 Nov, 12:05

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.