Buongiorno a tutti, Avrei bisogno di fare un debug della scheda audio usb perché viene riconosciuta ma il suono del test di pulseaudio funziona male. Non si tratta di distorsione o di livelli, penso sia un problema più di codifica/ percorso del segnale. Ho provato tantissime soluzioni ma non sono riuscito a venirne a capo, il problema di risolve solo con ubuntu 16. Qualcuno potrebbe aiutarmi? Grazie

chiesto 13 Nov, 13:25

fappo's gravatar image

fappo
101

  • vuoi dirie che con il 18.04 non va come col 20.04?

  • questi test funzionano?

aplay /usr/share/sounds/alsa/*

(13 Nov, 16:22) sacarde sacarde's gravatar image

123avanti »

Grazie della risposta!

Qualsiasi versione successiva alla 16 incluse le varie versioni studio, non funzionano correttamente. In realtà anche se nella 16 se installo Jack audio oppure qualche aggiornamento in più non funziona correttamente.

Provato i test da riga di comando ma il suono esce "tremolante", mi scuso per il termine ma non so come descriverlo, in ogni caso non è pulito.

coll. permanente

ha risposto 13 Nov, 16:49

fappo's gravatar image

fappo
101

che vedi da: inxi -A

(13 Nov, 17:00) sacarde sacarde's gravatar image

Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel Device-3: Alesis type: USB driver: snd-usb-audio Sound Server: ALSA v: k5.4.0-45-generic

(13 Nov, 17:50) fappo fappo's gravatar image
  • che computer e'?

  • cosa vedi da: lsusb (nella riga della scheda audio)

(13 Nov, 17:57) sacarde sacarde's gravatar image

E un desktop un po datato con chipset Asus. almeno dal logo del Bios, un intel 13 ma ho riscontrato lo stesso problema anche su un portatile asus. Sto utilizzando un POD HD300 della line6 come scheda esterna, in pratica nel peggiore dei casi mi fa un fastidioso ronzio al posto dell'audio che qualche volta scompare se apro il menu di pulseaudio per riapparire poco dopo.

Nel migliore dei casi l'audio si sente ma è pieno click e pop con una specie di modulazione , comunque anche usando ardour con i vari jack o alsa mi da un sacco di xruns. A seguito lsusb

Bus 002 Device 004: ID 093a:2521 Pixart Imaging, Inc. Optical Mouse
Bus 002 Device 003: ID 1241:1503 Belkin Keyboard
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 0781:556c SanDisk Corp. Ultra
Bus 001 Device 005: ID 058f:6364 Alcor Micro Corp. AU6477 Card Reader Controller
Bus 001 Device 004: ID 13b2:0087 Alesis 
Bus 001 Device 007: ID 0e41:5057 Line6, Inc. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Grazie ancora

coll. permanente

ha risposto 13 Nov, 18:22

fappo's gravatar image

fappo
101

  • e' questo? 0e41:5057

  • quindi i pc che usi hanno una loro scheda audio, vero? non e' disattivata?

(13 Nov, 20:42) sacarde sacarde's gravatar image
  • si line6 è la scheda audio usb
  • la scheda interna è una realtek alc887-vd
  • poi c'è una scheda grafica nvidia con uscita hdmi

ho provato a disattivarle ma il risultato non cambia provato anche a smanettare con il Bios e alsamixer ma niente

coll. permanente

ha risposto 13 Nov, 20:49

fappo's gravatar image

fappo
101

  • se riesci a disattivarle da bios non dovresti trovarle poi da "alsamixer", e' cosi?

  • cosa vedi da: aplay -l

(13 Nov, 20:58) sacarde sacarde's gravatar image

Certo, ho provato a disattivarle in precedenza ma non vedendo risultati le ho lasciate accese. Esiste un qualche modo per capire il percorso dell' audio, intendo tra pulseaudio, alsa, nvidia, scheda interna e scheda usb esterna?

coll. permanente

ha risposto 13 Nov, 21:42

fappo's gravatar image

fappo
101

  • vedi errori di servizi da:

systemctl --user status pulseaudio

journalctl -b -p err

  • se non usi l'usb, l'audio va bene?

p.s. documento che puo essere utile:

https://help.ubuntu.com/community/HdaIntelSoundHowto

(13 Nov, 21:54) sacarde sacarde's gravatar image
**** Lista di PLAYBACK dispositivi hardware ****
scheda 0: PODHD300 [POD HD300], dispositivo 0: POD HD300 [POD HD300]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 1: PCH [HDA Intel PCH], dispositivo 0: ALC887-VD Analog [ALC887-VD Analog]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 1: PCH [HDA Intel PCH], dispositivo 3: ALC887-VD Digital [ALC887-VD Digital]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 2: NVidia [HDA NVidia], dispositivo 3: HDMI 0 [HDMI 0]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 2: NVidia [HDA NVidia], dispositivo 7: HDMI 0 [HDMI 0]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 2: NVidia [HDA NVidia], dispositivo 8: HDMI 0 [HDMI 0]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 2: NVidia [HDA NVidia], dispositivo 9: HDMI 0 [HDMI 0]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
coll. permanente

ha risposto 13 Nov, 21:48

fappo's gravatar image

fappo
101

La Alc887 ha due pannelli per ingressi/uscite uno anteriore ed uno posteriore

L Nvidia ha solo un HDMI

(13 Nov, 21:57) fappo fappo's gravatar image

Buongiorno e grazie per le celeri risposte, mi scuso per il ritardo. La scheda interna, mi da dei ronzii strani al posto del suono mentre conquella USB il suono arriva ma zoppincate, non pulito. A seguito il codice:

   pulseaudio.service - Sound Service
         Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; vendor preset: enabled)
         Active: active (running) since Sat 2020-11-14 06:27:11 EST; 3min 9s ago
    TriggeredBy: ● pulseaudio.socket
       Main PID: 1419 (pulseaudio)
         CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.service
                 └─1419 /usr/bin/pulseaudio --daemonize=no --log-target=journal

  nov 14 06:27:10 casa-K53SC systemd[1413]: Starting Sound Service...
    nov 14 06:27:11 casa-K53SC systemd[1413]: Started Sound Service.
    nov 14 06:27:13 casa-K53SC pulseaudio[1419]: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate serv>
    nov 14 06:28:57 casa-K53SC pulseaudio[1419]: Got POLLNVAL from ALSA

journalctl -b -p err
-- Logs begin at Mon 2020-07-20 10:14:50 EDT, end at Sat 2020-11-14 06:31:42 EST. --
nov 14 06:26:36 casa-K53SC kernel: rtl8192se: switch case 0x5e not processed
nov 14 06:26:36 casa-K53SC wpa_supplicant[494]: bgscan simple: Failed to enable signal strength monitoring
nov 14 06:27:10 casa-K53SC gdm-password][1406]: gkr-pam: unable to locate daemon control file
nov 14 06:27:13 casa-K53SC pulseaudio[1419]: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate serv>
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #10 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #14 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #4 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #10 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #3 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #8 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #4 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #1 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #7 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #0 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #2 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #0 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #0 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #0 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #1 submission failed (-90)
nov 14 06:28:51 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #0 submission failed (-90)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #10 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #10 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #10 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #10 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #10 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #10 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:57 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB in #0 submission failed (-19)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #15 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #6 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #13 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #6 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #1 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #8 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #6 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #5 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #6 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #1 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #5 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #0 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #0 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #1 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #1 submission failed (-90)
nov 14 06:28:58 casa-K53SC kernel: snd_usb_podhd 1-1.4:1.0: URB out #0 submission failed (-90)

Hai ragione c'è una marea di errori ma non so cosa significhino.

Grazie mille

coll. permanente

ha risposto 14 Nov, 12:41

fappo's gravatar image

fappo
101

Ti ringrazio anche per le guide ma se ho capito bene sono relative più a problemi di riconoscimento della scheda interna oppure al non riconoscimento di quella esterna piuttosto che al corretto funzionamento di una usb, ma cercherò di vedermele meglio...

coll. permanente

ha risposto 14 Nov, 12:47

fappo's gravatar image

fappo
101

pulseaudio -k

Mi ha dato questo altro errore:

nov 14 06:48:49 casa-K53SC pulseaudio[3801]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply>
nov 14 06:52:24 casa-K53SC pulseaudio[13564]: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
coll. permanente

ha risposto 14 Nov, 12:51

fappo's gravatar image

fappo
101

modificato 14 Nov, 12:53

PS. Provato nuovamente a rimuovere da Bios sia la scheda audio che la Nvidia. Alsa mixer mi continua a vedere l 'uscita HDMI dell NVIDIA mentre la scheda audio interna è scomparsa, connettendo quella esterna l'audio si sente male come prima

coll. permanente

ha risposto 14 Nov, 14:12

fappo's gravatar image

fappo
101

che vedi da:

cat /proc/asound/cards

lsmod|grep snd

(14 Nov, 14:27) sacarde sacarde's gravatar image
    cat /proc/asound/cards 
     0 [PODHD300       ]: Line6-PODHD - POD HD300
                          Line 6 POD HD300 at USB 1-1.1:1.0
     1 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xfb080000 irq 17

lsmod|grep snd
snd_hda_codec_hdmi     61440  4
snd_hda_intel          53248  1
snd_intel_dspcfg       24576  1 snd_hda_intel
snd_hda_codec         135168  2 snd_hda_codec_hdmi,snd_hda_intel
snd_hda_core           90112  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_usb_podhd          16384  0
snd_usb_line6          36864  3 snd_usb_podhd
snd_hwdep              20480  2 snd_hda_codec,snd_usb_line6
snd_seq_midi           20480  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            36864  2 snd_seq_midi,snd_usb_line6
snd_pcm               106496  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_usb_line6,snd_hda_core
snd_seq                69632  2 snd_seq_midi,snd_seq_midi_event
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
snd_timer              36864  2 snd_seq,snd_pcm
snd                    90112  17 snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_usb_podhd,snd_usb_line6,snd_pcm,snd_rawmidi
soundcore              16384  1 snd
coll. permanente

ha risposto 14 Nov, 15:22

fappo's gravatar image

fappo
101

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×233
×49

domanda posta: 13 Nov, 13:25

domanda visualizzata: 151 volte

ultimo aggiornamento: ieri

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.