come da titolo ho problemi con wine su Xubuntu 18.04 , prima mi diceva "PlayOnLinux non è in grado di trovare le librerie a 32bit di OpenGL" ho seguito una discussione da qui http://www.debianitalia.org/forum/linux-gaming/playonlinux-problemi-grafica ed ora mi da questo "PlayOnLinux cannot find wine (from Wine)" Ho fatto una ricerca ma trovo solo guide in inglese e non so se sono il mio caso. grazie in anticipo

chiesto 18 Nov, 12:34

Doom's gravatar image

Doom
6062234

modificato 18 Nov, 14:26

Non avevo letto il wiki: ho provato ad installare la versione stabile come da wiki: ma mi da problemi https://paste.ubuntu.com/p/fRtNGXHmpJ/ ho provato da repositori esterno sempre seguendo il wiki per la distro 18.04 ma ce sempre lo stesso problema : https://paste.ubuntu.com/p/zFkHRTW3ZG/

(18 Nov, 22:34) Doom Doom's gravatar image
  • fatto prima un: sudo apt update

  • per correggere dipendenze prova con: sudo apt-get -f install

p.s. che vedi da: lsb_release -a

(19 Nov, 08:32) sacarde sacarde's gravatar image

1) Update fatto prima e anche ora

2)fatto : sudo apt-get -f install non mi ha dato nessuna risposta

3) lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.5 LTS Release: 18.04 Codename: bionic

4) sudo apt install --install-recommends winehq-stable solito messaggio di prima che ,mi dicevi cosa fare https://paste.ubuntu.com/p/zFkHRTW3ZG/

(19 Nov, 15:52) Doom Doom's gravatar image

hai seguito la guida?

vuoi versioni "stable" o "sviluppo" ?

hai seguito: "Installazione da repository esterno di WineHQ"

(19 Nov, 17:40) sacarde sacarde's gravatar image

wine stable ! sempre lo stesso problema anche se provo ad installare da repository esterno-

sudo apt install --install-recommends winehq-stable

I seguenti pacchetti hanno dipendenze non soddisfatte: winehq-stable : Dipende: wine-stable (= 5.0.3~bionic)

E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

(19 Nov, 23:27) Doom Doom's gravatar image

sudo apt install wine-stable wine64 wine32 winetricks Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto Alcuni pacchetti non possono essere installati. Questo può voler dire che è stata richiesta una situazione impossibile oppure, se si sta usando una distribuzione in sviluppo, che alcuni pacchetti richiesti non sono ancora stati creati o sono stati rimossi da Incoming.

(19 Nov, 23:27) Doom Doom's gravatar image

sudo apt-get -f install [sudo] password : Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto 0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

(19 Nov, 23:48) Doom Doom's gravatar image
1
  • quindi hai seguito: "Installazione da repository esterno di WineHQ" i 5 punti

p.s. ma in precedenza avevi installato: wine-stable wine64 wine32 winetricks ?

(20 Nov, 08:15) sacarde sacarde's gravatar image

La prima volta, da gnome software,ma comunque dopo aver installato play on Linux, mi dava errori, poi ho fatto il tentativo con wine stable, e niente. Poi ho provato con repository esterno e mi da gli stessi errori, pensavo di eliminare tutti i residui di pacchetti di wine e riprovare a installarlo , da capo. Non ricordo il comando per disinstallare tutto il pacchetto wine. Comunque ho letto che molti hanno avuto lo stesso problema mio anche con le ditro precedenti.

(20 Nov, 10:24) Doom Doom's gravatar image

prova: sudo apt remove wine*

comunque per vedere quali wine hai installato: dpkg -l | grep wine

(20 Nov, 10:28) sacarde sacarde's gravatar image

dpkg -l | grep wine : ii playonlinux 4.3.4 all This program is a front-end for wine. rc q4wine 1.3.6-2 amd64 Qt GUI for wine (WINE)

con questo non me lo fa disinstallare sudo apt remove wine

Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto Pacchetti virtuali come "wine" non possono essere rimossi 0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

(20 Nov, 22:04) Doom Doom's gravatar image

perche non ne hai piu pacchetti wine installati

"rc q4wine" vuol dire che e' stato disinstallato

(20 Nov, 23:36) sacarde sacarde's gravatar image

ho disinstallato tutti i pacchetti,e ripetuto, lo stesso percorso,ma al momento dell'installazione e sempre la stessa cosa,non riesco a riparare il pacchetto nemmeno da synaptic. Non so piu cosa fare

https://paste.ubuntu.com/p/NzKCXqrRCH/

(21 Nov, 02:34) Doom Doom's gravatar image

ho trovato questo

https://wiki.winehq.org/FAQ#How_do_I_solve_dependency_errors_when_trying_to_install_Wine.3F

ma dalla traduzione non ci ho capito niente

(21 Nov, 02:58) Doom Doom's gravatar image
1

hai sempre il ppa attivo?

da: software-properties-gtk

(21 Nov, 08:07) sacarde sacarde's gravatar image

Ieri ho trovato questo https://www.linuxminditalia.org/index.php?topic=25364.0

e sono riuscito ad installare wine stable ma non lo vedo dall'interfaccia grafica.

Da terminale vedo questo https://paste.ubuntu.com/p/xfVQ6MfHc2/

i ppa sono attivi ci sono questi 2

https://dl.winehq.org/wine-builds/ubuntu/

https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/

(21 Nov, 14:31) Doom Doom's gravatar image

Digitando wine nella barra di ricerca dei programmi vedo tutto queste voci , credo sia la versione vecchia che io ho disinstallato, ma non so come cancellarle. https://postimg.cc/4Y3pxvfw/9df52b20

(21 Nov, 15:49) Doom Doom's gravatar image
1
  • mi sembra installato correttamente la versione 5.0.3

  • i ppa intendo quelli che vedi da software-properties-gtk

  • la brra di ricerca non e' che visualizza l'history delle ricerche?

(21 Nov, 18:01) sacarde sacarde's gravatar image

Scusa ti rispondo solo ora.

si ho fatto una prova con un vecchio gioco di windows su cd e sembra funzionare.

i ppa da software-properties-gtk, io da terminale se digito quel comando mi esce questo : software-properties-gtk

(software-properties-gtk:3488): Gtk-WARNING **: 13:12:59.107: Theme parsing error: gtk-widgets.css:238:26: Missing closing bracket for :not()

e mi si apre la finestra di software e aggiornamenti.

Hai ragione la barra di ricerche visualizzava l'history ora non piu.

(22 Nov, 13:30) Doom Doom's gravatar image
1

da software-properties-gtk non hai una linguetta "altro software" con i ppa e una linguetta "driver aggiuntivi"?

(22 Nov, 13:41) sacarde sacarde's gravatar image
(22 Nov, 21:41) Doom Doom's gravatar image

ok si vedono i 2 ppa dl.winnehd e opensuse..ecc..

quindi non trovi per avviare wine?

(23 Nov, 08:18) sacarde sacarde's gravatar image

se cerco wine ,vedo solo esegui wine, ma selezionando non mi esegue nulla, se inserisco un cd di un gioco vecchio riesco ad installare il gioco con wine, ma normalmente non mi fa aprire wine

(24 Nov, 01:14) Doom Doom's gravatar image

letto il paragrafo "Avvio dei programmi"

da qui: https://wiki.ubuntu-it.org/Virtualizzazione/Wine

(24 Nov, 08:16) sacarde sacarde's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×15

domanda posta: 18 Nov, 12:34

domanda visualizzata: 59 volte

ultimo aggiornamento: 24 Nov, 08:16

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.