*Quando provo ad upgradare il mio sistema:*

$ lsb_release -a LSB Version: core-9.20170808ubuntu1-noarch:security-9.20170808ubuntu1-noarch Distributor ID: Ubuntu Description: Ubuntu 18.04.1 LTS Release: 18.04 Codename: bionic

Incontro il seguente problema:

~$ sudo apt upgrade Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto È utile eseguire "apt --fix-broken install" per correggere ciò. I seguenti pacchetti hanno dipendenze non soddisfatte: libasan2-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non è installato libasan4-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non è installato libatomic1-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non è installato libc6-dev-armel-cross : Dipende: libc6-armel-cross (= 2.23-0ubuntu3cross1) ma non è installato libcilkrts5-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non è installato libgcc1-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non è installato libgomp1-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non è installato libstdc++6-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non è installato libubsan0-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non è installato E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).

Dopo averlo prima disinstallato, ho provato allora a installare il pacchetto che da errore, ma senza successo:

renato@renato-mansarda:~$ sudo apt install libc6-dev-armel-cross Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto È utile eseguire "apt --fix-broken install" per correggere ciò. I seguenti pacchetti hanno dipendenze non soddisfatte: libasan2-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non sta per essere installato libasan4-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non sta per essere installato libatomic1-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non sta per essere installato libc6-dev-armel-cross : Dipende: libc6-armel-cross (= 2.27-3ubuntu1cross1.1) ma non sta per essere installato libcilkrts5-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non sta per essere installato libgcc1-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non sta per essere installato libgomp1-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non sta per essere installato libstdc++6-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non sta per essere installato libubsan0-armel-cross : Dipende: libc6-armel-cross (>= 2.27) ma non sta per essere installato E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).

**Provo allora con il comando suggerito "apt --fix-broken install", ma l'errore persiste:

~$ sudo apt --fix-broken install Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto Correzione delle dipendenze... Fatto I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti: account-plugin-facebook account-plugin-flickr account-plugin-google cgmanager cpp-5-arm-linux-gnueabi cryptsetup-bin deja-dup-backend-gvfs dh-python dleyna-server espeak-data ethtool evolution-data-server-online-accounts fonts-stix g++-5 g++-5-arm-linux-gnueabi gcc-5-arm-linux-gnueabi gcc-5-arm-linux-gnueabi-base gcc-5-cross-base gcc-6-base gcc-6-base:i386 gconf2 gir1.2-javascriptcoregtk-3.0 gir1.2-webkit-3.0 gnome-icon-theme-symbolic hardening-includes hwdata imagemagick-common kdepim-doc libaccount-plugin-1.0-0 libaccount-plugin-generic-oauth libaccount-plugin-google libaccounts-qt5-1 libamd2.4.1 libapparmor-perl libappstream3 libasan2-armel-cross libass5 libautodie-perl libavcodec-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2 libavutil-ffmpeg54 libbabeltrace-ctf1 libbind9-140 libblas-common libbluray1 libboost-date-time1.58.0 libboost-filesystem1.58.0 libboost-iostreams1.58.0 libboost-python1.58.0 libboost-system1.58.0 libboost-thread1.58.0 libbrotli1 libcamd2.4.1 libcamel-1.2-54 libcapnp-0.5.3 libcapnp-0.6.1 libccolamd2.9.1 libcdio-cdda1 libcdio-paranoia1 libcdio13 libcgmanager0 libcholmod3.0.6 libchromaprint0 libcloog-isl4 libclutter-gst-2.0-0 libcolamd2.9.1 libcryptsetup4 libdata-alias-perl libdleyna-connector-dbus-1.0-1 libdleyna-core-1.0-3 libdns-export162 libdns162 libebook-1.2-16 libedataserver-1.2-21 libedataserverui-1.2-1 libefivar0 libespeak1 libevent-2.0-5 libfcitx-gclient0 libfreerdp-cache1.1 libfreerdp-client1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-plugins-standard libfreerdp-primitives1.1 libfreerdp-utils1.1 libfwup0 libfwupd1 libgcc-5-dev-armel-cross libgcr-3-common libgdbm3 libgfortran3 libglew1.13 libgmime-2.6-0 libgnome-desktop-3-12 libgom-1.0-common libgrilo-0.2-1 libgtkglext1 libgtkspell3-3-0 libgtop-2.0-10 libgupnp-av-1.0-2 libgupnp-dlna-2.0-3 libgweather-3-6 libhardware2 libhud2 libhunspell-1.3-0 libhybris libhybris-common1 libical1a libisc-export160 libisc160 libisccc140 libisccfg140 libjasper1 libjavascriptcoregtk-3.0-0 libjson-c2 libkf5calendarcore5 libkf5gpgmepp-pthread5 libkf5gpgmepp5 libkf5identitymanagement5 libkf5kdgantt2-5 libkf5libkleo5 libkf5mime5 libkf5pimtextedit5 libkf5qgpgme5 libkf5webkit5 liblircclient0 libllvm5.0 liblouis9 liblouisutdml6 liblwres141 libmedia1 libmimic0 libmirclient9 libmircommon7 libmircore1 libmirprotobuf3 libmpfr4 libnm-glib-vpn1 libnm-gtk-common libnma-common libopencc1 libopencv-calib3d2.4v5 libopencv-contrib2.4v5 libopencv-core2.4v5 libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4v5 libopencv-imgproc2.4v5 libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-objdetect2.4v5 libopencv-video2.4v5 libopenjpeg5 liborcus-0.10-0v5 libp11-kit-gnome-keyring libpackagekit-glib2-16 libpoppler58 libpostproc-ffmpeg53 libprocps4 libprotobuf-lite9v5 libprotobuf9v5 libpython3.5 libpython3.5-minimal libpython3.5-stdlib libqt4-opengl libqt5feedback5 libqt5multimedia5 libqt5opengl5 libqt5organizer5 libqt5sensors5 libqt5webkit5 libqtwebkit4 libquvi-scripts libquvi7 libraw15 libreoffice-gtk libreoffice-gtk2 libreoffice-style-human librhythmbox-core9 librpm3 librpmbuild3 librpmio3 librpmsign3 libschroedinger-1.0-0 libsignon-extension1 libsignon-plugins-common1 libsignon-qt5-1 libsodium18 libsrtp0 libstdc++-5-dev libstdc++-5-dev-armel-cross libsub-identify-perl libsuitesparseconfig4.4.6 libswresample-ffmpeg1 libswscale-ffmpeg3 libtbb2 libtracker-sparql-1.0-0 libtxc-dxtn-s2tc0 libumfpack5.7.1 libunistring0 libunity-action-qt1 libustr-1.0-1 libva1 libvpx3 libwebkitgtk-3.0-0 libwebp5 libwebpdemux1 libwebpmux1 libwebrtc-audio-processing-0 libwildmidi1 libwinpr-crt0.1 libwinpr-dsparse0.1 libwinpr-environment0.1 libwinpr-file0.1 libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1 libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1 libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1 libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1 libwoff1 libwxgtk3.0-0v5 libx264-148 libx265-79 libx86-1 libxapian-1.3-5 libxapian22v5 libxerces-c3.1 libxfont1 libxtables11 linux-headers-4.4.0-134 linux-headers-4.4.0-134-generic linux-image-4.4.0-134-generic linux-image-extra-4.4.0-134-generic lua-lpeg plainbox-provider-checkbox plainbox-provider-resource-generic plainbox-secure-policy pm-utils python-ndg-httpsclient python3-checkbox-support python3-guacamole python3-jinja2 python3-padme python3-plainbox python3-pyasn1 python3-pycurl python3-pyparsing python3-xlsxwriter python3.5 python3.5-minimal qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings qml-module-qtfeedback qml-module-qtwebkit qml-module-ubuntu-onlineaccounts qml-module-ubuntu-performancemetrics qtdeclarative5-accounts-plugin qtdeclarative5-qtquick2-plugin qtdeclarative5-unity-action-plugin radeontool rename s-nail signon-keyring-extension signon-plugin-oauth2 signon-plugin-password signon-ui signon-ui-service signon-ui-x11 signond snapd-login-service suru-icon-theme tcpd ubuntu-mobile-icons ubuntu-ui-toolkit-theme unity-control-center-signon unity-scope-gdrive vbetool xserver-xorg-video-neomagic xserver-xorg-video-openchrome xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident Usare "sudo apt autoremove" per rimuoverli. I seguenti pacchetti aggiuntivi saranno inoltre installati: libc6-armel-cross libc6-dev-armel-cross I seguenti pacchetti NUOVI saranno installati: libc6-armel-cross I seguenti pacchetti saranno aggiornati: libc6-dev-armel-cross 1 aggiornati, 1 installati, 0 da rimuovere e 862 non aggiornati. 20 non completamente installati o rimossi. È necessario scaricare 0 B/2.967 kB di archivi. Dopo quest'operazione, verranno occupati 0 B di spazio su disco. Continuare? [S/n] s (Lettura del database... 282241 file e directory attualmente installati.) Preparativi per estrarre .../libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb... Estrazione di libc6-dev-armel-cross (2.27-3ubuntu1cross1.1) su (2.23-0ubuntu3cross1)... dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack): impossibile aprire "/usr/arm-linux-gnueabi/lib/Mcrt1.o.dpkg-new": File o directory non esistente Segnalazione apport non scritta poiché il messaggio di errore indica un errore nel sistema locale. Preparativi per estrarre .../libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb... Estrazione di libc6-armel-cross (2.27-3ubuntu1cross1.1)... dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack): impossibile aprire "/usr/arm-linux-gnueabi/lib/ld-2.27.so.dpkg-new": File o directory non esistente Segnalazione apport non scritta poiché il messaggio di errore indica un errore nel sistema locale. Si sono verificati degli errori nell'elaborazione: /var/cache/apt/archives/libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb /var/cache/apt/archives/libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

Potete darmi un aiuto??

chiesto 21 Nov, 18:42

renatorocci's gravatar image

renatorocci
2012

Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×32

domanda posta: 21 Nov, 18:42

domanda visualizzata: 21 volte

ultimo aggiornamento: 21 Nov, 18:42

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.