Ciao a tutti,
sono un neofita di Ubuntu, ho cercato fra le varie domande già postate ma non mi sembra che ci siano delle risposte riguardo al mio problema.

Ho Ubuntu 13.10 installato su un Asus S56C bollato Windows 8. Sostanzialmente Ubuntu Software Center crasha, lo apro e non gira e si chiude semplicemente.
Le uniche operazioni che ho svolto fino ad ora sono state installare Skype e PlayOnLinux, che però non ho mai utilizzato.
Se digito sofware-center sul terminale mi da questo output:

$ software-center
2013-10-31 19:55:44,820 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-10-31 19:55:45,524 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-10-31 19:55:45,529 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-10-31 19:55:45,534 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-10-31 19:55:45,534 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-10-31 19:55:45,577 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
Errore di segmentazione (core dump creato)

Vi ringrazio in anticipo per la pazienza e l'aiuto.

chiesto 31 Ott '13, 20:19

Alessandro29's gravatar image

Alessandro29
20223

modificato 01 Nov '13, 07:50

enzotib's gravatar image

enzotib ♦♦
14.0k112186

grazie ora funziona avevo lo stesso problema ero stato costretto ad installare il lubuntu s.c. ma quando scaricavo i pacchetti mi si apriva in automatico l'ubuntu s.c. adesso è partito grazie di cuore

(27 Mar '14, 23:22) don fotter don%20fotter's gravatar image

Prova da terminale

rm ~/.cache/software-center -R
coll. permanente

ha risposto 01 Nov '13, 00:00

Webber's gravatar image

Webber
3.0k1535

Magari anche ~/.config/software-center

(01 Nov '13, 07:50) enzotib ♦♦ enzotib's gravatar image

Grazie per le risposte. con la prima stringa il terminale risponde: rm: impossibile rimuovere "/home/alessandro/.cache/software-center": File o directory non esistente

con la seconda: bash: /home/alessandro/.config/software-center: È una directory

Se provo ad accedere a Ubuntu Software Center non cambia nulla.

(01 Nov '13, 13:16) Alessandro29 Alessandro29's gravatar image

@Alessandro29: in primo luogo, non usare le risposte, questo non è un forum, usa i commenti. Le risposte sono riservate per gli utenti che propongono una soluzione.
In secondo luogo, non hai messo l'opzione -R che permette di rimuovere una directory con tutto il contenuto.

(01 Nov '13, 13:22) enzotib ♦♦ enzotib's gravatar image

per integrare questa opzione come devo procedere?

(01 Nov '13, 20:53) Alessandro29 Alessandro29's gravatar image

@Alessandro, mi sembra ovvio, come diceva la risposta era
rm ~/.cache/software-center -R
io preferisco mettere l'opzione prima e minuscola, ma dovrebbe andare bene lo stesso
rm -r ~/.config/software-center

(01 Nov '13, 22:13) enzotib ♦♦ enzotib's gravatar image

Usando questa stringa il terminale mi da: rm: impossibile rimuovere "/home/alessandro/.config/software-center": File o directory non esistente

(05 Nov '13, 16:03) Alessandro29 Alessandro29's gravatar image

@Alessandro29: se esegui quel comando, la directory viene rimossa, quindi se lo rifai ti dà quell'errore. Ma poi cosa succede se lanci Softwar Center?

(05 Nov '13, 16:29) enzotib ♦♦ enzotib's gravatar image

Riprova con il comando iniziale

rm ~/.cache/software-center -R

Vedi anche con

rm -rf ~/.cache/software-center

(05 Nov '13, 16:36) Webber Webber's gravatar image

Con : rm ~/.cache/software-center -R rm: impossibile rimuovere "/home/alessandro/.cache/software-center": File o directory non esistente

Con : rm -rf ~/.cache/software-center: nessuna risposta.

Se lancio ubuntu software center si apre non carica e dopo 1 secondo si chiude. Se provo ad aprire un programma come LibreOfficeWriter, fa per caricare ma poi non apre niente.

(09 Nov '13, 13:06) Alessandro29 Alessandro29's gravatar image

Prova ad usare il "Gestore pacchetti" per reinstallare software-center. Se non lo hai ancora installato, da terminale:

sudo apt-get install synaptic
prima di effettuare la reinstallazione di software-center fai la rimozione completa del pacchetto, in modo che anche i file di configurazione vengano poi reinstallati.

coll. permanente

ha risposto 09 Nov '13, 16:50

m3nhir's gravatar image

m3nhir
38718

1

Senza installare synaptic: sudo apt-get purge software-center && sudo apt-get install software-center

(09 Nov '13, 16:57) enzotib ♦♦ enzotib's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×229
×112
×78

domanda posta: 31 Ott '13, 20:19

domanda visualizzata: 2,785 volte

ultimo aggiornamento: 28 Mar '14, 13:17

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.