Buongiorno. Ho a casa una LAN mista (1 PC win10, 1PC dual win10/Ubuntu 20.04, 2 PC Ubuntu 18.04 e 2 iMac + vari tablet e telefoni). La LAN funziona benissimo per tutti tranne che per il PC dual quando sto su Ubuntu 20.04. Penso si tratti della nuova versione di Samba, ma non ne sono sicuro e comunque non so come fare. Aggiungo che il medesimo PC quando è in Win10 si connette perfettamente. Peraltro io riesco comunque a traferire i file da/a questo con il comando apposito (smb://192.168.178.21/pubblici/). Ma così non va bene, anche perché quando lo faccio su postazione win10 DOPO mi dice di segnalare un errore interno di sistema e, inoltre, non riesco a traferire file da/a cellulare. Qualcuno cortesemente mi può aiutare?

chiesto 02 Mar, 19:01

Frency's gravatar image

Frency
352814

prima cosa e' vedere se c'e' il colleamento tra i client e il router con i ping

ping 192.168.178.1 (e' questo il router?)

ping 192.168.178.xxx

ecc...

i ping rispondono?

(02 Mar, 21:30) sacarde sacarde's gravatar image

Intanto grazie per la risposta. Sì, i ping rispondono, ma secondo me non ce n'era bisogno. Il fatto che tutti i PC si "vedano" è accertato. Il problema risiede nel fatto che quando SOLO dal mio PC Dualboot (da Ubuntu) clicco su "altre posizioni" utilizzando nautilus e seleziono un'altra postazione, questo mi dice: impossibile accedere alla posizione - recupero dell'elenco delle condivisioni dal server non riuscito: connessione scaduta. Lui invece si fa accedere dagli altri...

(03 Mar, 14:02) Frency Frency's gravatar image

... e poi, come già detto, se utilizzo il comando smb:// etc., sempre da nautilus, alla fine riesco a trasferire i file. Soprattutto mi da errore il cellulare dal quale devo prelevare foto... su quest'ultimo non ho trovato rimedi.

(03 Mar, 14:04) Frency Frency's gravatar image

forse un problema di risoluzione dei nomi?

cosa hai nei file: /etc/hosts

(03 Mar, 14:15) sacarde sacarde's gravatar image

127.0.0.1 localhost 127.0.1.1 nerone

The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback fe00::0 ip6-localnet ff00::0 ip6-mcastprefix ff02::1 ip6-allnodes ff02::2 ip6-allrouters

(03 Mar, 16:58) Frency Frency's gravatar image

ti ho incollato il contenuto del file hosts che ho trovato nella cartella etc... ci sono altri "hosts" con diverse estensioni: devo mostrarteli tutti? Ma riesci a leggerli così incollati?

(03 Mar, 17:01) Frency Frency's gravatar image

li puoi incollare qui:

https://paste.ubuntu.com/

p.s. quando selezioni un'altra postazione, indichi il nome o l'IP?

(03 Mar, 17:21) sacarde sacarde's gravatar image

Da Nautilus io "vedo" le altre postazioni e ci clicco sopra, esattamente come faccio DALLE altre postazioni. A questo punto mi aspetto che mi chieda le credenziali di accesso come succede DALLE altre postazioni ed invece (solo dal mio PC Ubuntu 20.04) compare il messaggio: impossibile accedere alla posizione - recupero dell'elenco delle condivisioni dal server non riuscito: connessione scaduta. Gli altri PC Ubuntu 18.04 funzionano perfettamente...

(03 Mar, 18:50) Frency Frency's gravatar image

non ho capito se ha preso la mia risposta. Non so come usare il link che mi hai inviato. Devo copiare il contenuto dei files e metterli nello spazio?

(03 Mar, 18:53) Frency Frency's gravatar image
  • incolli il testo , invii e mi restituisci l'url risultante

  • quando selezioni un'altra postazione, indichi il nome o l'IP?

  • usi lo stesso utente nei sistemi "ubuntu" ?

(03 Mar, 21:13) sacarde sacarde's gravatar image

Quando opero da un'altra postazione con nautilus mi compare tutta la rete. Ogni postazione è un icona con nome. Ci clicco sopra e subito mi vengono chieste le credenziali del mio PC dual Ubuntu 20.04. Immettendo le giuste credenziali accedo alla cartella condivisa del mio PC. Come avevo sempre fatto prima di installare Ubuntu 20.04...

(04 Mar, 18:54) Frency Frency's gravatar image
  • forse c'e' qualche servizio non attivo o errato?

systemctl list-unit-files

cerca i servizi: smbd nmbd

  • oppure nella configurazione di samba, la vedi dal comando: testparm
(04 Mar, 20:39) sacarde sacarde's gravatar image

... ho provato a dare il primo comando che mi hai detto, ma il sistema restituisce una marea di roba (373 linee!)

(06 Mar, 18:50) Frency Frency's gravatar image
  • allora, per vedere i servizi in errore: systemctl --failed

systemctl status smbd

systemctl status nmbd

  • il "testparm" lo devi comfrontare con le altre postazioni linux dove samba funziona bene
(06 Mar, 20:42) sacarde sacarde's gravatar image

... non credo di essere in grado di fare quello che mi hai detto.... ho una certa esperienza solamente empirica. Non sono in grado di capire il significato di questi comandi...

(07 Mar, 15:14) Frency Frency's gravatar image

systemctl status .... (restituisce lo stato dei 2 servizi "samba")

p.s. in alternativa puoi montare automaticamente le directory samba da "/etc/fstab"

https://qastack.it/ubuntu/157128/proper-fstab-entry-to-mount-a-samba-share-on-boot

(07 Mar, 16:53) sacarde sacarde's gravatar image

... grazie per il tuo interessamento, ma non sono in grado di interpretare i tuoi suggerimenti. L'unica cosa che posso dirti è che le cose funzionano un pizzico meglio quando sono accesi tutti i PC Ubuntu (totale 3). Come se il terzo fosse in grado di "tenere le fila"...

(08 Mar, 14:47) Frency Frency's gravatar image

riesci a incollare https://paste.ubuntu.com/ l'output dei 3 comandi:

systemctl --failed

systemctl status smbd

systemctl status nmbd

(08 Mar, 14:59) sacarde sacarde's gravatar image

...ecco, spero di aver fatto giusto...

(08 Mar, 16:05) Frency Frency's gravatar image

una volta incollato il testo e dato invio, mi devi riportare l'url

(08 Mar, 16:48) sacarde sacarde's gravatar image

... speriamo bene stavolta!

(09 Mar, 12:33) Frency Frency's gravatar image

ok, nei servizi non ci sono errori (nenche tra i 2 samba)

altro passo e' confrontare i risultato dei comandi "testparm" eseguiti sui vari sistemi

(09 Mar, 13:46) sacarde sacarde's gravatar image

... va bene così?

(09 Mar, 17:35) Frency Frency's gravatar image

queste sono le prime righe...

dando l'invio ti da il dettaglio della configurazione

(09 Mar, 17:49) sacarde sacarde's gravatar image

...adesso va bene?

(10 Mar, 14:03) Frency Frency's gravatar image

ok

come si vede le prime 2 sono identiche

la terza ecco le differenze:

http://sacarde.altervista.org/np/diff-samba.png

potresti (prima salvare il file di config.) e poi modificare /etc/samba/smb.conf

(10 Mar, 14:47) sacarde sacarde's gravatar image

Abbi pazienza Sarcade: allora, devo modificare il file "/etc/samba/smb.conf" del mio PC (quello diverso, quello con 20.04)? Devo aggiungere/inserire in questo file tutte le scritte evidenziate?

(10 Mar, 19:11) Frency Frency's gravatar image

... ma perché questo file è venuto diverso? E' da parecchi anni che per fare la rete domestica uso sempre la stessa procedura. E con Ubuntu non avevo mai avuto problemi. Speriamo che funzioni anche con Android del telefonino...

(10 Mar, 19:13) Frency Frency's gravatar image

... ma posso fare "copia e incolla" dall'altro?

(10 Mar, 19:14) Frency Frency's gravatar image

certo puoi copiarlo dall'altro... (magari prima fattene una copia)

ma usi la stessa versione di samba? e stessa versione di ubuntu?

(10 Mar, 20:38) sacarde sacarde's gravatar image

...no, non uso la stessa versione né di Ubuntu (20.04 su quello che non vuole dialogare e 18.04 sugli altri due), ma probabilmente anche la versione di Samba è diversa. Io applicherò i tuoi suggerimenti, ma mi viene il dubbio se non fosse stato il caso di aggiornare samba... ammesso che si possa fare... e se sì non saprei come fare...

(10 Mar, 21:14) Frency Frency's gravatar image

comunque ora provo il tuo rimedio e ti faccio sapere...

(10 Mar, 21:15) Frency Frency's gravatar image

servizio da controllare:

systemctl status avahi-daemon.service

(11 Mar, 10:53) sacarde sacarde's gravatar image

... mi dispiace Sarcade, ma, da quanto riesco a decifrare, il contenuto del file smb.conf è diverso dalle scritte restituite dal comando "testparm". Questo file è irto di scritte. Provo a inviartelo...

(11 Mar, 11:21) Frency Frency's gravatar image

si, molti sono commenti, comunque per fare una prova rinomina quello diverso e copiaci quello in comune con gli altri 2 sistemi (e' una prova)

(11 Mar, 11:31) sacarde sacarde's gravatar image

... niente da fare. Sostituendo il file smb.conf con quello di uno degli altri due PC (e dopo aver riavviato) il risultato è identico. Se clicco - da Nautilus - sopra l'icona di un'altra postazione, mi restituisce questa dicitura: impossibile accedere alla posizione Recupero dell'elenco delle condivisioni dal server non riuscito Connessione scaduta. ... come se non avessi fatto nulla...

(12 Mar, 16:34) Frency Frency's gravatar image

hai visto lo stato di questo servizio?

systemctl status avahi-daemon.service

(12 Mar, 17:28) sacarde sacarde's gravatar image

ti ho incollato il reso del comando systemctl status avahi-daemon.service. Comunque ti devo dire che è successa questo (forse era già avvenuto prima senza che me ne accorgessi): quando apro nautilus e clicco "altre posizioni" mi compare un elenco doppio delle postazioni in rete. Se uso le prime continua a non funzionare, mentre se uso le seconde (sotto l'icona rete windows) sta volta hanno funzionato. Ha un senso tutto questo? Devo lasciare questo smb.conf che ho prelevato da un altro? Potrebbe darmi problemi in futuro?

(13 Mar, 18:11) Frency Frency's gravatar image
(13 Mar, 18:13) Frency Frency's gravatar image
  • il servizio avahi sembra corretto

  • per la configurazione puoi rimettere il vecchio file config

  • ci deve essere una differenza... la versione di nautilus?

(13 Mar, 21:12) sacarde sacarde's gravatar image

la versione di nautilus (che qui lo chiama "file") è 3.36.3-stable. Volevo anche dirti che che facendo questa sostituzione smb.conf il mio PC ha funzionato, ma gli altri due no. Io non sono esperto, ma ho come la sensazione che ci sia confusione su chi debba tenere la "lista dei servers", oppure che qualcuno non riesca a leggerla...

(14 Mar, 13:38) Frency Frency's gravatar image

cioe', quello su cui non funzionava, ha funzionato?

p.s. comunque, a parte nautilus, se tu facessi i mount a mano riusciresti a montare tutte le risorse samba della rete, no?

(14 Mar, 13:44) sacarde sacarde's gravatar image

... esatto: sostituendo nel mio PC (dualboot, che era quello che "non funzionava") il file smb.conf con quello preso da un altro dei tre, questo ha funzionato. Mentre gli altri due no. Non so cosa intendi per "mount a mano", ma già ti avevo detto che comunque io riesco a traferire i file con questo comando: "smb://192.168.178.21/pubblici/". Ordine che immetto nella casella in basso della finestra di nautilus denominata "connetti al server"... semplicemente volevo una procedura più pulita e intuitiva, come era prima...

(14 Mar, 15:36) Frency Frency's gravatar image

come stiamo con i servizi "avahi..." su gli altri 2 sistemi?

(14 Mar, 17:02) sacarde sacarde's gravatar image

questo è quello che mi ha restituito uno dei due: https://paste.ubuntu.com/p/WrBvf6ZfZJ/

(14 Mar, 18:49) Frency Frency's gravatar image

il pacchetto nautilus-share cel'hai in qualcuno dei sistemi?

dpkg -l | grep nautilus-share

(14 Mar, 20:48) sacarde sacarde's gravatar image

qui c'e', c'e' anche su gli altri? e' una utilita' per le risorse samba

(14 Mar, 21:15) sacarde sacarde's gravatar image

si, la funzionalita' ci sarebbe su tutti

immagino dovrebbe poter accedere a risorse samba in modo semplice direttamete da nautilus

da: altre posizioni ---> reti -->

(15 Mar, 17:14) sacarde sacarde's gravatar image

... ma dove sta "reti"? Su altre posizioni trovo soltanto le icone delle altre postazioni più "rete di windows"; cliccando sulla quale spunta "workgroup": cliccando sulla quale compaiono altre icone con ancora i nomi delle postazioni... boh!

(16 Mar, 12:07) Frency Frency's gravatar image

.. ok, grazie per il tuo tempo...

(16 Mar, 19:01) Frency Frency's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×125
×2

domanda posta: 02 Mar, 19:01

domanda visualizzata: 112 volte

ultimo aggiornamento: 16 Mar, 19:01

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.