Un saluto a tutti. Sono nuovo dell'ambiente Linux. Ieri ho installato Ubuntu 20.04 LTS su un portatile che mi è stato regalato dopo che il mio pc si è rotto. Si verifica questo malfunzionamento: all'uscita dalla sospensione, la videata appare corrotta. Potreste aiutarmi, per favore ?

chiesto 10 Mar, 10:29

green's gravatar image

green
203

Grazie @sacarde ho eseguito "Smoke test di sospensione e ripristino". dopo il ripristino le applicazioni e la scrivania non presentano anomalie (a parte lo schermo che appare sempre corrotto, ma sullo sfondo delle finestre aperte; Le finestre invece vengono visualizzate bene). Quando imposto la sospensione appare una videata fugace in cui compaiono due numeri separati da un punto, e poi: "common interrupt 0.55 no irq handler for vector". La stessa scritta riappare fugacemente sulla stessa videata nera quando il computer esce dalla sospensione.

(10 Mar, 14:44) green green's gravatar image

quali driver video usi?

inxi -G

(10 Mar, 14:53) sacarde sacarde's gravatar image

te lo ha fatto da subito?

o hai fatto aggiornamenti?

(10 Mar, 14:58) sacarde sacarde's gravatar image

Uso il driver NVIDIA binary driver version 340.108 da nvidia-340 (proprietario, testato). Ho impostato questo driver subito dopo l'installazione e l'aggiornamento di Ubuntu. Se non sbaglio, da live-cd, con il driver di default, le cose andavano peggio perché ero costretto a spegnere il cd, ma non sono sicuro di questo. Si, lo ha fatto da subito

(10 Mar, 15:06) green green's gravatar image

uso il driver NVIDIA binary driver version 340-108 da nvidia-340 (proprietario, testato). in pratica me lo ha fatto da subito, ma ho fatto gli aggiornamenti subito dopo aver installato ubuntu. Anche il driver nvidia l'ho installato subito, ma se non sbaglio, da live cd con il driver di default, le cose andavano ancora peggio perché era tutto illeggibile ed ero costretto a riavviare il computer. Ma di questo non sono proprio sicuro al 100%

(10 Mar, 15:14) green green's gravatar image
  • quindi hai fatto degli aggiornamenti?

degli nvidia e o del kernel?

p.s. da poco e' uscita la versione 20.04.2

(10 Mar, 15:16) sacarde sacarde's gravatar image

la versione 20.04.2 è quella che uso io. ho fatto gli aggiornamenti che mi sono stati proposti in automatico durante l'installazione di ubuntu. poi ho impostato il driver di nvidia

(10 Mar, 15:29) green green's gravatar image
  • che vedi da: sudo ubuntu-drivers devices

  • che hai dentro: /etc/gdm3/custom.conf

(10 Mar, 17:45) sacarde sacarde's gravatar image

da sudo ubuntu-drivers devices, vedo questo: == /sys/devices/pci0000:00/0000:00:0d.0/0000:05:00.0 == modalias : pci:v000010DEd00000427sv0000103Csd000030CFbc03sc00i00 vendor : NVIDIA Corporation model : G86M [GeForce 8400M GS] (Pavilion dv9668eg Laptop) driver : nvidia-340 - distro non-free recommended driver : xserver-xorg-video-nouveau - distro free builtin

(10 Mar, 18:10) green green's gravatar image

dentro /etc/gdm3/custom.conf ho questo:

GDM configuration storage

See /usr/share/gdm/gdm.schemas for a list of available options.

[daemon] AutomaticLoginEnable=true AutomaticLogin=flavio

Uncomment the line below to force the login screen to use Xorg

WaylandEnable=false

Enabling automatic login

Enabling timed login

TimedLoginEnable = true

TimedLogin = user1

TimedLoginDelay = 10

[security]

[xdmcp]

[chooser]

[debug]

Uncomment the line below to turn on debugging

More verbose logs

Additionally lets the X server dump core if it crashes

Enable=true

(10 Mar, 18:11) green green's gravatar image

la versione del nvidia-340 ?

dpkg -l | grep nvidia-340

p.s. alternativa sarebbe usare i driver opensource

p.s. strano che i distrurbi li hai sulla parte in sfondo, e non sulle finestre

(10 Mar, 20:32) sacarde sacarde's gravatar image

l'output del comando è questo: ii nvidia-340 340.108-0ubuntu5.20.04.1 amd64 NVIDIA binary driver - version 340.108

confermo che i disturbi li ho sullo sfondo; le finestre vengono visualizzare bene

(10 Mar, 21:42) green green's gravatar image

il driver e' aggiornato,

mi risulta strano l'effetto solo sullo sfondo

p.s. provato a fare un: ctrl-alt-F1 (consolle testuale) e poi un ctrl-alt-F7 se cambia qualcosa?

(10 Mar, 21:59) sacarde sacarde's gravatar image

Se premo ctrl-alt-F1 mi chiede la password, ma dopo lo schermo diventa nero e mi pare che non appare la consolle testuale. Dopo un po' ritorna spontaneamente alla modalità grafica.

(11 Mar, 09:41) green green's gravatar image
  • quando ritorna alla modalita' grafica vedi sempre il problema dello sfondo?

  • nella videata grafica dove metti user/password hai la possibilita' di avviare gnome con x11 oppure wayland ?

(11 Mar, 10:02) sacarde sacarde's gravatar image

Si, quando ritorno alla modalità grafica il problema persiste. Non saprei come avviare gnome con x11 oppure wayland, ma mi pare che non appare nessuna opzione per farlo.

(11 Mar, 10:16) green green's gravatar image
  • ma se ho capito bene hai il log automatico dell'utente?

se si, fai "exit" dalla sessione e ricollegati controllando se vedi una ruota dentata che ti fa scegliere l'ambiente grafico

(11 Mar, 10:23) sacarde sacarde's gravatar image

si, ho il login automatico.

se mi disconnetto e poi rientro, il fondo schermo è ok.

Ma se poi vado in sospensione, il problema si ripropone.

non noto la ruota dentata

(11 Mar, 11:08) green green's gravatar image

mah!

  • per vedere se usi x11 o wayland:

echo $XDG_SESSION_TYPE

  • se vuoi provare wayland: nel file /etc/gdm3/custom.conf

metti:

WaylandEnable=true

(11 Mar, 11:27) sacarde sacarde's gravatar image

l'output del comando echo è x11. comunque, a parte tutto, il problema non è così importante. sei stato molto gentile e disponibile ad interessartene. hai idea perché non va in modalità terminale quando premo ctrl-alt-F1 ?

(11 Mar, 11:35) green green's gravatar image

con ctrl-alt-Fxx accedi alle consolle testuali, hai detto che ti chiede l'user e password, no?

o vedi subito tutto nero?

altrimenti puoi provare a passare al kernel (da grub) il parametro "nomodeset"

istruzioni passare parametri al kernel: temporaneamente https://wiki.ubuntu.com/Kernel/KernelBootParameters#Temporarily_Add_a_Kernel_Boot_Parameter_for_Testing

(11 Mar, 11:45) sacarde sacarde's gravatar image

si, dopo aver digitato ctrl-alt-F1 mi chiede la password. ma dopo averla inserita, dopo un po', torna spontaneamente nella modalità grafica, senza visualizzare la consolle testuale

(11 Mar, 12:37) green green's gravatar image
  • solo la password?

  • il prompt e' un "#" o un "$" ?

  • provato a passare "nomodeset" ?

(11 Mar, 13:54) sacarde sacarde's gravatar image

la password, dopo aver selezionato l'utente, me la chiede da una videata in modalità grafica. mi sembra di non aver notato la visualizzazione di prompt.

(11 Mar, 14:20) green green's gravatar image

ho provato ad avviare con l'opzione nomodeset. ad un certo punto è apparsa una videata che chiedeva password, che ho fornito. sembrava funzionare bene. successivamente ho provato a riavviare sempre con l'opzione nomodeset, non mi appariva più la videata con richiesta della password, e il malfunzionamento era presente. dando il comando lshw -c display | grep driver, mi diceva che il driver è quello di nvidia. come potrei fare per avviare con il driver di default ?

(11 Mar, 14:20) green green's gravatar image

no, non ho capito...

se premi ctrl-alt-F1 (o F2 ecc...) si dovrebbe aprire una consolle testuale, chiedendoti user e password

non e' che hai messo la password ai dati?

(11 Mar, 14:29) sacarde sacarde's gravatar image

se premo ctrl-alt-F1, per un momento appare una videata nera (in modalità testo) con qualcosa scritto sulla prima riga. non faccio in tempo a leggere che subito viene rimpiazzata da una videata grafica nella quale seleziono l'utente e poi inserisco la password. dopo di che viene visualizzato l'usuale desktop grafico.

(11 Mar, 14:45) green green's gravatar image

però mi pare che premendo ctrl-alt-F3, tutto funziona come dovrebbe. per uscire dalla consolle testuale, premo ctrl-alt-F1, seleziono l'utente e premo la password. con ctrl-alt-F7 pare che non riesco ad uscire dalla consolle testuale.

(11 Mar, 14:49) green green's gravatar image

normalmente la ctrl-alt-F7 dovrebbe essere quella grafica, quella che ti fa inserire l'utente e la password (e scegliere l'ambiente grafico se ne hai piu' di uno o il server grafico "x11" o "wayland")

la 1 fino alla 6 dovrebbero essere quelle in modalita' consolle testuale

non mi pare che a te funzioni cosi'..... boh

(11 Mar, 14:54) sacarde sacarde's gravatar image

forse è solo un problema di tastiera, non saprei.

comunque pare che il problema continua a sussistere anche dopo aver visualizzato la consolle testuale e tornando poi al desktop grafico.

(11 Mar, 14:58) green green's gravatar image

ho provato ad avviare con l'opzione nomodeset. ad un certo punto è apparsa una videata che diceva qualcosa e chiedeva la password, che ho fornito. sembrava funzionare bene, dopo la riesumazione dalla sospensione. successivamente ho provato a riavviare sempre con l'opzione nomodeset, non mi appariva più la videata con richiesta della password, e il malfunzionamento era presente. dando il comando lshw -c display | grep driver, mi diceva che il driver è quello di nvidia. come potrei fare per avviare con il driver di default ?

(11 Mar, 14:59) green green's gravatar image

penso che se hai nvidia(proprietari) prenda quello di default, a meno che tu non crei il file di configurazione di xorg /etc/X11/xorg.conf

https://wiki.ubuntu-it.org/Hardware/AbilitareDriverProprietari

(11 Mar, 17:02) sacarde sacarde's gravatar image

va bene, @sacarde.

grazie per il tuo interessamento e per la tua disponibilità.

(11 Mar, 17:24) green green's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,979
×87

domanda posta: 10 Mar, 10:29

domanda visualizzata: 100 volte

ultimo aggiornamento: 11 Mar, 17:24

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.