Buongiorno, vorrei installare ubuntu su un asus N53sv (core i7 2670qm, 8gb ram, Windows 7). Da quel che sono riuscito a capire il sistema dovrebbe non essere UEFI (versione american megatrends 214 Vbios version 2117.I13N53.022). Uso il condizionale perchè nella schermata "Boot" del bios vedo che la prima voce del "Boot Configuration" è "UEFI boot [Enabled]".

Ho creato una live di ubuntu 20.04 con Rufus. Nelle impostazioni di boot viene rilevata come "UEFI: SMI USB DISK 1100" e la faccio partire come prima opzione di boot, mi carica ubuntu normalmente. Arrivo alla schermata di scelta se installare o provare ubuntu. Se provo ubuntu, va normalmente senza problemi.

Provo ad installare. Non rileva windows 7. Siccome voglio installare in dual boot, seleziono "Altro" per effettuare un installazione manuale. Ho già preparato la partizione da dedicare ad ubuntu, viene visualizzata. Seleziono la partizione, la uso come file system ext4 con journaling, formattazione e punto di mount /. Procedo e mi arriva il messaggio: "No EFI system partition was found. This system will likely not be able to boot succesfully,and the installation process may fail. please go back and add an EFI partition system, or continue at your own risk,". Non procedo e rimango fermo qui X)

grazie per l'aiuto

chiesto 24 Mar, 13:28

maestrobiri's gravatar image

maestrobiri
203

  • sembrerebbe proprio uefi, quindi devi indicare anche la partizione /boot quella in vfat/ntfs che dovrebbe usare anche windows

  • cosa vedi da: sudo fdisk -l

(24 Mar, 17:28) sacarde sacarde's gravatar image

riposta sotto :)

(24 Mar, 17:55) maestrobiri maestrobiri's gravatar image

ok grazie ci provo per il primo punto.

Ho fatto il paste, riesci a vederlo? cmq è questo sotto:

Disk /dev/sda: 698,65 GiB, 750156374016 bytes, 1465149168 sectors Disk model: WDC WD7500BPVT-8 Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 4096 bytes I/O size (minimum/optimal): 4096 bytes / 4096 bytes Disklabel type: dos Disk identifier: 0xaa9693fe

Dispositivo Avvio Start Fine Settori Size Id Tipo /dev/sda1 2048 52430847 52428800 25G 1c W95 FAT32 (LBA) nasc /dev/sda2 * 52430848 638488575 586057728 279,5G 7 HPFS/NTFS/exFAT /dev/sda3 638488576 1465145343 826656768 394,2G f W95 Esteso (LBA) /dev/sda5 638490624 901943295 263452672 125,6G 7 HPFS/NTFS/exFAT /dev/sda6 901945344 1465145343 563200000

coll. permanente

ha risposto 24 Mar, 18:39

maestrobiri's gravatar image

maestrobiri
203

se leggo bene, la partizione di "/boot" (uefi) dovrebbe essere sda1 e sda2 windows (insieme a sda5)

(24 Mar, 20:58) sacarde sacarde's gravatar image

Buongionro Sacarde! eccoci! Da Gparted: sda1 è il recovery sda2 è win7 sda3 è diviso in sda5 e sda6 sda5 è la partizione creata da win7 dalle impostazioni di fabbrica sda6 è la partizione creata da me per l'installazione di Ubuntu

(25 Mar, 08:13) maestrobiri maestrobiri's gravatar image

se fosse cosi' (windows non ha la partizione uefi) cosa pero' che chiede l'instsllzione di ubuntu, quindi oltre a fare la partizione sda6 devi farne una anche per /boot di qualche centinaia di MB in vfat e ritentare l'installazione

(25 Mar, 08:19) sacarde sacarde's gravatar image

ok. Dimmi se ho capito bene: quindi devo fare una partizione in win7 tale e quale alla sda6 ma di 200MB circa e quando procedo a fare l'installazione devo indicare quella sempre come file ext4 con journaling ma con punto di mount "/boot"?

(25 Mar, 08:26) maestrobiri maestrobiri's gravatar image
  • la puoi fare anche durante l'installazione, ma anche da windows se ti torna meglio, questa partizione deve essere in "vfat" di 200mb, poi durante l'installazione la monterai in "/boot" (vfat)

come dice qui: https://wiki.ubuntu-it.org/Installazione/InstallareUbuntu

(25 Mar, 08:39) sacarde sacarde's gravatar image

ottimo grazie, ci provo e ti faccio sapere come è andata! :D

(25 Mar, 08:50) maestrobiri maestrobiri's gravatar image

Ciao! ha funzionato! grazie! fantastico!

ora l'unica cosa che mi manca da fare è che vorrei impostare per fare in modo che all'avvio mi chieda quale sistema operativo voglio scegliere. Al momento parte diretto ubuntu.

(25 Mar, 15:55) maestrobiri maestrobiri's gravatar image

riesci a entrare nel menu di grub?

premendo "esc" all'avvio, non vedi una voce "windows"?

(25 Mar, 17:36) sacarde sacarde's gravatar image

no non vedo menu di grub nè Win7. Se premo esc all'avvio mi da una schermata blu stile bios intitolata "Please select boot device:" in cui vedo il disco rigido, il dvd, USB flash. Se seleziono il disco rigido mi dice "This is not a bootable disk. Please insert a bootable floppy and press any key to try again"

(25 Mar, 17:51) maestrobiri maestrobiri's gravatar image
  • e per far avvire ubuntu quale disco scegli tra i tre: hd,dvd,usb ?

  • da ubuntu cosa vedi se esegui: update-grub

(25 Mar, 18:25) sacarde sacarde's gravatar image

primo punto: c'è una quarta voce che si chiama "ubuntu", uso quella

secondo punto: sudo update-grub Lettura file "/etc/default/grub" Lettura file "/etc/default/grub.d/init-select.cfg" Generazione file di configurazione GRUB... Trovata immagine linux: /boot/vmlinuz-5.8.0-48-generic Trovata immagine initrd: /boot/initrd.img-5.8.0-48-generic Trovata immagine linux: /boot/vmlinuz-5.8.0-43-generic Trovata immagine initrd: /boot/initrd.img-5.8.0-43-generic fatto

(25 Mar, 20:38) maestrobiri maestrobiri's gravatar image
  • il problema e' che avrebbe dovuto trovare anche windows...

  • windows e' stato chiuso regolarmente o come fastboot?

(25 Mar, 20:53) sacarde sacarde's gravatar image

su windows ho fatto arresta sistema prima di andare ad installare ubuntu(non so se ho risposto X) )

(26 Mar, 08:29) maestrobiri maestrobiri's gravatar image
(26 Mar, 08:41) sacarde sacarde's gravatar image

No non è veloce win7, non ha questa modalità

(26 Mar, 08:52) maestrobiri maestrobiri's gravatar image

il problema e' che grub non riconosce windows...

ma tieni inserita l'usb al riavvio?

p.s. potresti provare da ubuntu:

sudo update-grub

sudo grub-install

p.s. che vedi eseguendo da ubuntu:

sudo os-prober

(26 Mar, 09:09) sacarde sacarde's gravatar image

no l'usb non è collegata

sudo os-prober non restituisce niente

(26 Mar, 10:04) maestrobiri maestrobiri's gravatar image
  • c'e' in windows il modo di ripristinare l'avvio?

windows usa una partizione uefi?

  • non e' che da bios/uefi hai attivato "legacy" invece di uefi?

  • os-prober nulla? nemmeno ubuntu?

(26 Mar, 10:14) sacarde sacarde's gravatar image

prober nulla, mi ridà la riga di comando

win7 non riesco piu a farlo partire

adesso riavvio e controllo se c'è il legacy in bios

(26 Mar, 10:42) maestrobiri maestrobiri's gravatar image
  • selezionando l'hd all'avvio non parte windows?

  • windows non ha un metodo per il ripristino dell'avvio?

  • in windows usavi l'ibernazione?

(26 Mar, 10:55) sacarde sacarde's gravatar image

no non vedo voci legacy in bios

devo provare a eseguire

sudo update-grub

sudo grub-install

?

(26 Mar, 10:55) maestrobiri maestrobiri's gravatar image

si selezionando l'hd come boot mi dice che il disco non è valido per il boot. Penso che posso avviare il recovery di win7 ma mi formatta l hd immagino e perdo ubuntu. non in windows non usabo l'ibernazione.

ho lanciato update-grub ma non mi fa vedere la schermata di grub

(26 Mar, 11:08) maestrobiri maestrobiri's gravatar image

prova a eseguire da ubuntu: sudo grub-install /dev/sda

p.s. esiste una funzione in windows per reinstallare il bootloader?

(26 Mar, 11:12) sacarde sacarde's gravatar image

sudo grub-install /dev/sda mi da installazione completata con successo, ma non cambia nulla

funzione in windows per reinstallare il bootloader -> Boh X)X)

(26 Mar, 11:26) maestrobiri maestrobiri's gravatar image

sembra che ubuntu continui a non rilevare la presenza di windows e che il disco fisso non sia settato per partire. Puo essere che windows era settato per partire con bios ed adesso mettendo la partizione efi abbia cambiato qualcosa?

(26 Mar, 11:28) maestrobiri maestrobiri's gravatar image

se non era in legacy vuol dire che tutti e 2 i sistemi sono stati installati in uefi

p.s. simile? https://chiedi.ubuntu-it.org/questions/67368/problemi-windows-7-dual-boot

(26 Mar, 11:33) sacarde sacarde's gravatar image

la differenza rispetto alla conversazione che mi hai girato è che non mi da proprio la scelta del sistema operativo. parte ubuntu come se non ci fosse nient'altro sul disco (vedo pero tutti i file presenti nella partizione di win7). In bios nel boot order posso scegliere tra una voce che si chiama "ubuntu" (che fa partire ubuntu), l'hd (che mi da scremata nera con scritta bianca dicendo che il disco non è bootable), il dvd e l'usb

(26 Mar, 11:53) maestrobiri maestrobiri's gravatar image

sembra simile a questa situazione (che adesso mi leggo con calma): https://forum.ubuntu-it.org/viewtopic.php?t=636505

pero non so verificare il partizionamento mbr o gpt

(26 Mar, 12:04) maestrobiri maestrobiri's gravatar image

sudo fdisk -l mi dà alla fine

Partition 3 does not start on physical sector boundary. Partition table entries are not in disk order.

il risultato completo del comando: https://paste.ubuntu.com/p/mGvqQRwWS8/

(26 Mar, 12:38) maestrobiri maestrobiri's gravatar image
  • a volte grub e' installato con zero tempo di preavviso del boot, ma tenendo premuto "esc" o "shift" si dovrebbe accedere al menu di grub

  • la tua tabella delle partizioni e' di tipo "DOS"

  • windows non monta una partizione di boot in vfat?

  • l'errore di boundary non credo sia importante

(26 Mar, 14:11) sacarde sacarde's gravatar image

come faccio a vedere se windows non monta una partizione di boot in vfat?

(26 Mar, 14:35) maestrobiri maestrobiri's gravatar image

bisognerebbe avviare windows

(conosci supergrub disk?) https://wiki.ubuntu-it.org/AmministrazioneSistema/SuperGrubDisk

(26 Mar, 14:45) sacarde sacarde's gravatar image

eh ma windows non lo posso piu avviare X)

no non conosco supergrub. mi puo risolvere il problema?

(26 Mar, 15:17) maestrobiri maestrobiri's gravatar image

Sacarde, ma se reinstallo ubuntu senza la partizione EFI?

Ho letto https://forum.ubuntu-it.org/viewtopic.php?t=636505. Qui sembra abbiano risolto in automatico senza creare la partizione EFI e poi facendo sudo update-grub.

Che ne pensi?

Anche se dovrei capire come fare perchè non riesco piu neanche ad avviare il sistema di ripristino alle impostazioni di fabbrica di windows

(26 Mar, 16:00) maestrobiri maestrobiri's gravatar image
  • avevo capito che dava errore l'installazione...

  • in quel link si dice che se trova la tabella delle partizioni MBR installa legacy, e se trova GPT installa uefi, no?

(26 Mar, 17:19) sacarde sacarde's gravatar image

Da quel che si legge si. Ma cosa succede se elimino la partizione EFI?

(26 Mar, 18:19) maestrobiri maestrobiri's gravatar image

se e' vero quello di sopra della tabella delle partizioni puoi eliminarla e provare a reinstallare ubuntu

(26 Mar, 18:35) sacarde sacarde's gravatar image

ho cancellato EFI e non funziona più niente, non carica neanchè ubuntu. Ho ripristinto ubuntu da live usb.

(29 Mar, 11:11) maestrobiri maestrobiri's gravatar image

chiaro che una volta eliminato /boot occorresse reinstallare

p.s. ma siamo in mbr/legacy o in gpt/uefi ?

(29 Mar, 11:16) sacarde sacarde's gravatar image

p.s. ma siamo in mbr/legacy o in gpt/uefi ? -> non so risponderti con certezza. Come posso verificarlo? Il bios non mi visualizza un opzione di scelta per legacy.

(29 Mar, 12:10) maestrobiri maestrobiri's gravatar image

in un sistema funzionante ci dovrebbe essere una piccola partizione (tipo "/boot" per linux) in vfat

(29 Mar, 13:40) sacarde sacarde's gravatar image

mi hanno dato ulteriori elementi qua https://forum.ubuntu-it.org/viewtopic.php?f=30&t=645382

adesso devo provare a farla

(29 Mar, 13:45) maestrobiri maestrobiri's gravatar image

ma la: prima voce del "Boot Configuration" è "UEFI boot [Enabled]

puoi metterla anche [UEFI boot disable]?

(29 Mar, 13:54) sacarde sacarde's gravatar image

si posso disabilitarla. Dici che quello è il legacy mode?

(29 Mar, 13:55) maestrobiri maestrobiri's gravatar image

beh potrebbe essere.... magari speriamo che non invalidi windows!

(29 Mar, 14:02) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×74

domanda posta: 24 Mar, 13:28

domanda visualizzata: 162 volte

ultimo aggiornamento: 29 Mar, 14:02

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.