Salve a tutti, vi scrivo per cercare la soluzione ad un problema che mi attanaglia ormai da ore.

Ho installato stamane Ubuntu 20.04 sul mio Asus transformer book T100HA e dopo aver configurato il tutto mi sono reso conto che non riconosce le webcam integrate (nè quella anteriore nè quella posteriore). Non vengono rilevate con il comando lsusb e non esiste una cartella video in /dev.

Cosa posso fare?

Grazie anticipatamente

chiesto 07 Apr, 18:05

Peppe3999's gravatar image

Peppe3999
201

modificato 07 Apr, 18:19

e con "lspci" ?

e da: dmesg | grep video

(07 Apr, 21:11) sacarde sacarde's gravatar image

Nulla, purtroppo sospetto sia un problema di driver. Dal sito asus potrei anche scaricarli ma sono solo per Windows. Conoscete altri posti dove possa scaricarli per Ubuntu?

(08 Apr, 09:17) Peppe3999 Peppe3999's gravatar image
  • i comandi sopra non visualizzano proprio nulla? cosa vedi da: lspci ?

  • avviando la live era diverso?

  • da bios/uefi hai il secure-boot abilitato?

(08 Apr, 09:25) sacarde sacarde's gravatar image

da lspci visualizzo molte cose ma nessuna di queste sembra essere una delle webcam. Se utile, posso copiare cosa vedo qui. Mentre da dmesg|grep video vedo solo lo strumento di cattura di ubuntu.

Per quanto riguarda gli altri due punti controllo immediatamente. Posso avviare la live anche con ubuntu installato semplicemente impostando l'usb come priorità di boot?

(08 Apr, 09:39) Peppe3999 Peppe3999's gravatar image

Avevo già visto quel forum ma non saprei proprio come installare quel driver manualmente

(08 Apr, 09:42) Peppe3999 Peppe3999's gravatar image

Nel frattempo ho controllato, il secure boot è disabilitato, mentre la camera non funzione neanche dal live

(08 Apr, 09:53) Peppe3999 Peppe3999's gravatar image
  • anche qui, ma non vedo soluzioni

https://askubuntu.com/questions/1233469/asus-table-t100ha-webcam-does-not-work-with-ubuntu-20-04-lts

  • si per la live avviala come quando hai avviata per installarla
(08 Apr, 10:03) sacarde sacarde's gravatar image

non esiste un modo per trasformare i driver windows in driver ubuntu?

(08 Apr, 10:05) Peppe3999 Peppe3999's gravatar image

un modo in realta' esisterebbe, anche se gli ultimi anni e' usato sempre meno (perche' i driver sono dei moduli del kernel)

il comando e' ndiswrapper:

prima installa: ndiswrapper ndiswrapper-utils-1.9

e poi segui: "Installazione dei driver di Windows" dal link

https://wiki.ubuntu-it.org/Hardware/DispositiviSenzaFili/Ndiswrapper#Installazione_dei_driver

(08 Apr, 10:15) sacarde sacarde's gravatar image

Proverò, grazie infinite

(08 Apr, 10:19) Peppe3999 Peppe3999's gravatar image

Nulla, ho provato a installare tre driver diversi ma quando inserisco il comando ndisdriver -l mi dà per tutti e 3 "invalid driver". Mi sa tanto che dovrò rassegnarmi

(08 Apr, 11:45) Peppe3999 Peppe3999's gravatar image
  • intendi questo comando: sudo ndiswrapper -i ~/driver/nome_driver.inf

  • i driver per quale verisone di windows sono? architettura?

(08 Apr, 11:56) sacarde sacarde's gravatar image

Si, il comando è quello. I driver sono per windows 10 x64

(08 Apr, 12:01) Peppe3999 Peppe3999's gravatar image

quando fai "ndiswrapper -i .......inf" non da errore?

lo da solo quando dai: ndiswrapper -l ?

p.s. hai dato prima:

sudo depmod -a

sudo modprobe ndiswrapper

(08 Apr, 13:36) sacarde sacarde's gravatar image

No quando do il primo comando nessun errore, dice solo installing..poi mi accorgo da ndiswrapper -l che il driver è invalido. No non ho dato quei programmi prima, nella guida dice di darli dopo

(08 Apr, 13:48) Peppe3999 Peppe3999's gravatar image

mmm (nella dir del file .inf hai anche i .sys e .bin ?)

  • che vedi dal comando:

lspci -nnpk

  • io lo farei prima: sudo modprobe ndiswrapper
(08 Apr, 14:07) sacarde sacarde's gravatar image

I sys e i bin ci sono, comunque adesso provo a fare prima modprobe

(08 Apr, 14:12) Peppe3999 Peppe3999's gravatar image

se provo a dare sudo modprobe ndiswrapper mi dà questo: modprobe: FATAL: Module ndiswrapper not found in directory /lib/modules/5.8.0-48-generic

(08 Apr, 14:59) Peppe3999 Peppe3999's gravatar image

Ho provato ad installare altri driver ma risultano tutti invalidi. Inoltre per alcuni di questi esce questo errore:

couldn't find models section "Standard" - installation may be incomplete.

A volte al posto di standard ci sono altre cose come ad esempio "Intel".

(08 Apr, 15:12) Peppe3999 Peppe3999's gravatar image

hai piu di un kernel? ls -l /boot | grep vmlinuz

(08 Apr, 15:17) sacarde sacarde's gravatar image

Questo è quello che esce fuori: lrwxrwxrwx 1 root root 24 apr 6 19:32 vmlinuz -> vmlinuz-5.8.0-48-generic -rw-r--r-- 1 root root 9716672 apr 5 20:04 vmlinuz-5.8.0-43-generic -rw------- 1 root root 9780704 mar 20 14:07 vmlinuz-5.8.0-48-generic lrwxrwxrwx 1 root root 24 apr 6 19:32 vmlinuz.old -> vmlinuz-5.8.0-43-generic

Non so se voglia dire che ho più di un kernel ahaha

(08 Apr, 15:30) Peppe3999 Peppe3999's gravatar image
  • ripeti l'installazione di "ndiswrapper" anche quando avvii il kernel (vecchio o nuovo)

il principale dovrebbe essere il 5.8.0-48, ma se vai dal menu di grub, "opzioni avanzate" puoi scegliere anche il 5.8.0-43

  • che vedi dal comando:

lspci -nnpk

(08 Apr, 16:52) sacarde sacarde's gravatar image

Come apro il menù di grab?

(08 Apr, 16:59) Peppe3999 Peppe3999's gravatar image

per uefi "esc" per bios "shift"

(08 Apr, 17:30) sacarde sacarde's gravatar image

Ok e una volta cambiato kernel ripercorro tutta la procedura?

(08 Apr, 17:31) Peppe3999 Peppe3999's gravatar image

Nulla da fare, ho rifatto tutto anche con l'altro kernel ma niente..non so più che fare. Anche perchè, ammesso di poter installare i driver, il vero problema è che non trova neanche il dispositivo come se fosse scollegato del tutto. Ho visto su internet che alcuni hanno risolto semplicemente schiacciando il tasto sulla tastiera per attivare la fotocamera..ma io ne sono sprovvisto.

(08 Apr, 17:48) Peppe3999 Peppe3999's gravatar image
  • che vedi dal comando:

lspci -nnpk

  • guardato nel bios se c'e' qualche abilitazione?
(08 Apr, 18:04) sacarde sacarde's gravatar image

Nel bios nulla, con lspci -nnpk mi da:

00:00.0 Host bridge [0600]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register [8086:2280] (rev 20) 00:02.0 VGA compatible controller [0300]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller [8086:22b0] (rev 20) 00:03.0 Multimedia controller [0480]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit [8086:22b8] (rev 20) 00:0a.0 Non-VGA unclassified device [0000]: Intel Corporation Device [8086:22d8] (rev 20)

(08 Apr, 18:20) Peppe3999 Peppe3999's gravatar image

00:0b.0 Signal processing controller [1180]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller [8086:22dc] (rev 20) 00:14.0 USB controller [0c03]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller [8086:22b5] (rev 20) 00:1a.0 Encryption controller [1080]: Intel Corporation

(08 Apr, 18:20) Peppe3999 Peppe3999's gravatar image

Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine [8086:2298] (rev 20) 00:1f.0 ISA bridge [0601]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU [8086:229c] (rev 20)

ho diviso in 3 commenti

(08 Apr, 18:20) Peppe3999 Peppe3999's gravatar image

sembra che non ci sia...

hai provato altri sistemi linux, o windows?

(08 Apr, 18:30) sacarde sacarde's gravatar image

Mi sa tanto che tornerò a Windows, in ogni caso grazie mille per aver lottato con me 😂

(08 Apr, 18:58) Peppe3999 Peppe3999's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×108
×71

domanda posta: 07 Apr, 18:05

domanda visualizzata: 73 volte

ultimo aggiornamento: 08 Apr, 18:58

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.