Salve a tutti,

Sto tentando di resuscitare un vecchio pc (Dell vostro 1520). Ho installato correttamente ubuntu 20.04.2. Tutto sembra funzionare a dovere tranne che per le connessioni wireless (attualmente sto usando il cavo ethernet, che funziona).

Ho provato a installare il driver di rete seguendo questa guida: https://wiki.ubuntu-it.org/Hardware/DispositiviSenzaFili/Broadcom

Infatti, eseguendo il comando: lspci -vvnn | grep -A 9 Network

l'output è il seguente:

0e:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)

In particolare, ho seguito la parte della guida :

> Installazione driver proprietari STA con connessione Internet

Alla fine del procedimento sembra che il driver sia installato correttamente. Se vado su "driver aggiuntivi", vedo il driver in questione:

Broadcom Inc. and subsidiaries: BCM4312 802.11b/g LP-PHY (Wireless 1397 WLAN Mini-Card)

e la selezione è su:

In uso Sorgenti del driver wireless Linux STA Broadcom 802.11 da bcmwl-kernel-source (proprietario)

Tuttavia il Wifi non funziona ancora. Infatti sulle impostazioni vedo "Wifi disabilitato via hardware" e non riesco ad accenderlo. Cosa posso fare ?

Cercando online ho visto che di solito si risolve tramite l'apposita combinazione di tasti fn + Fx, ma questo modello di dell non ha il tasto per la connessione wirless sulla tastiera.

Aggiungo infine che, eseguendo il comando rfkill list vedo:

2: phy0: Wireless LAN

Soft blocked: no

Hard blocked: no

3: brcmwl-0: Wireless LAN

Soft blocked: no

Hard blocked: yes

Grazie mille a chiunque riesca ad aiutarmi.

chiesto 15 Apr '21, 18:56

hinder319's gravatar image

hinder319
2012

e con:

sudo rfkill unblock brcmwl-0

o

sudo rfkill unblock all

(15 Apr '21, 21:30) sacarde sacarde's gravatar image

Grazie mille per la risposta, ma ho risolto (anche se non so come).

Stamattina accendendo il pc il wifi risulta acceso, e facendo rfkill list non risulta più hardblocked.

Io non ho fatto assolutamente nulla se non riavviare, ma già ieri avevo riavviato più volte il pc e non era accaduto niente.

coll. permanente

ha risposto 16 Apr '21, 08:51

hinder319's gravatar image

hinder319
2012

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×509
×301
×29
×22

domanda posta: 15 Apr '21, 18:56

domanda visualizzata: 708 volte

ultimo aggiornamento: 16 Apr '21, 08:51

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.