Ubuntu 20.04 LTS x64

Da un pò ormai quando voglio installare qualcosa mi ritorna sempre questo errore:

dpkg: errore: file del trigger di interesse duplicato per il nome file "/usr/lib/gio/modules" e il pacchetto "libglib2.0-0:i386"

ed anche:

E: Sub-process /usr/bin/dpkg returned an error code (2)

In questo caso volevo installare openvpn:

root@Toshiba-Erco:/# apt-get install openvpn
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libexpat1 libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib
  libreadline8 libsqlite3-0 mime-support python2-minimal python2.7
  python2.7-minimal readline-common
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  iproute2 libatm1 libcap2-bin libelf1 liblzo2-2 libmnl0 libpam-cap
  libpkcs11-helper1 libxtables12
Pacchetti suggeriti:
  iproute2-doc resolvconf openvpn-systemd-resolved easy-rsa
I seguenti pacchetti NUOVI saranno installati:
  iproute2 libatm1 libcap2-bin libelf1 liblzo2-2 libmnl0 libpam-cap
  libpkcs11-helper1 libxtables12 openvpn
0 aggiornati, 10 installati, 0 da rimuovere e 4 non aggiornati.
12 non completamente installati o rimossi.
È necessario scaricare 0 B/1.572 kB di archivi.
Dopo quest'operazione, verranno occupati 4.941 kB di spazio su disco.
Continuare? [S/n] s
Preconfigurazione dei pacchetti in corso
dpkg: errore: file del trigger di interesse duplicato per il nome file "/usr/lib/gio/modules" e il pacchetto "libglib2.0-0:i386"
E: Sub-process /usr/bin/dpkg returned an error code (2)
root@Toshiba-Erco:/#

Anche se rimuovo i pacchetti che dice mi ridà sempre lo stesso errore:

root@Toshiba-Erco:/# apt autoremove libexpat1 libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
  libexpat1 libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib
  libreadline8 libsqlite3-0 mime-support python2-minimal python2.7
  python2.7-minimal readline-common
0 aggiornati, 0 installati, 11 da rimuovere e 4 non aggiornati.
12 non completamente installati o rimossi.
Dopo quest'operazione, verranno liberati 18,8 MB di spazio su disco.
Continuare? [S/n] s
Interrotto.

O se provo a rimuovere solo libglib2.0-0:i386:

root@Toshiba-Erco:/# apt autoremove libglib2.0-0:i386
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Il pacchetto "libglib2.0-0:i386" non è installato e quindi non è stato rimosso
I seguenti pacchetti saranno RIMOSSI:
  libexpat1 libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib
  libreadline8 libsqlite3-0 mime-support python2-minimal python2.7
  python2.7-minimal readline-common
0 aggiornati, 0 installati, 11 da rimuovere e 4 non aggiornati.
12 non completamente installati o rimossi.
Dopo quest'operazione, verranno liberati 18,8 MB di spazio su disco.
Continuare? [S/n] s
dpkg: errore: file del trigger di interesse duplicato per il nome file "/usr/lib
/gio/modules" e il pacchetto "libglib2.0-0:i386"
E: Sub-process /usr/bin/dpkg returned an error code (2)

Mi potreste aiutare per favore? GRAZIE MILLE

chiesto 03 May, 11:42

heerkole's gravatar image

heerkole
202

modificato 04 May, 11:21

(03 May, 15:30) sacarde sacarde's gravatar image

Risolto, Grazie!

(04 May, 09:52) heerkole heerkole's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×82

domanda posta: 03 May, 11:42

domanda visualizzata: 36 volte

ultimo aggiornamento: 04 May, 11:21

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.