Ciao, premetto che uso kubuntu 20.04. Ho appena attivato la mia carta nazionale dei servizi per la regione Sardegna. Il lettore di smart card funziona, ma quando provo a connettermi al fascicolo sanitario Firefox mi dà l'errore in oggetto e non riesco ad accedere. Ho installato i driver smartcard-driver-ras_0.17.0_all.deb indicati dal sito della regione alla pagina https://tscns.regione.sardegna.it/it/articoli/linux, non sono riuscita ad installare l'add-on per firefox perchè scaricabile solo in formato .zip (una volta estratto ed aperto con firefox non fa nulla), ho seguito le istruzioni contenute qui https://wiki.ubuntu-it.org/Hardware/Periferiche/CartaNazionaleServizi, tutto pare funzionare a parte per questo errore. Qualcun sa come risolvere? Grazie mille

chiesto 27 Sep, 20:03

lawally's gravatar image

lawally
204

modificato 11 Nov, 18:35


Scusate, aggiungo che ora, quando provo ad installare l'add-on per firefox, questo mi risponde che non può installarlo perchè il pacchetto è danneggiato. Almeno dice qualcosa e non sta in silenzio come prima. Già provato a riscaricare il pacchetto, stessa risposta.

coll. permanente

ha risposto 27 Sep, 20:40

lawally's gravatar image

lawally
204

da;l firefox --> impostazioni --> privacy ---> vedi questo?

http://sacarde.altervista.org/np/Screenshot_20210928_081322.png

(28 Sep, 08:14) sacarde sacarde's gravatar image

No, dove tu hai "Carta Sanitaria Europea" io ho "OpenSC"

(28 Sep, 12:54) lawally lawally's gravatar image

Ho installato la nuova versione di OpenSC (dai repository installava la 0.17, io ho messo la 0.22) per provare a vedere se il problema si risolvesse in automatico, purtroppo così non è stato. Ora se provo ad accedere al sito (es. INPS) prima mi chiede il PIN e poi mi restituisce il messaggio "Non è stato fornito nessun certificato valido per l'accesso: chiudere il browser, verificare i prerequisiti e riprovare con un nuovo certificato valido."

(28 Sep, 13:08) lawally lawally's gravatar image

questo file cel'hai?

/usr/lib/libaseCnsP11.so

(28 Sep, 13:43) sacarde sacarde's gravatar image

no, non ce l'ho

(28 Sep, 13:47) lawally lawally's gravatar image

prova a scaricarlo http://sacarde.altervista.org/libaseCnsP11.zip lo decomprimi e installi il file .so a 64bit

poi: Firefox ---> Edit ---> Preferences ---> Advanced ---> Certificates ---> Security devices

---> Load ed inserite:

descrizione: CartaSanitariaEuropea

path: /usr/lib/libaseCnsP11.so

(28 Sep, 14:07) sacarde sacarde's gravatar image

perdonami, non so come installare quel tipo di file

(30 Sep, 12:34) lawally lawally's gravatar image

una volta scaricato, vai nella dir dove l'hai scaricato, lo decomprimi:

unzip libaseCnsP11.zip

da dentro la dir x64 copi il file nella posizione con:

sudo cp libaseCnsP11.so /usr/lib

e prosegui con firefox

(30 Sep, 13:46) sacarde sacarde's gravatar image

Niente, non funziona. Se prima seguire le tue istruzioni almeno firefox riconosceva la presenza di un certificato e me lo mostrava (avevo seguito queste istruzioni https://wiki.ubuntu-it.org/Hardware/Periferiche/CartaNazionaleServizi), con il tuo metodo se vado nella sezione "Mostra certificati" delle preferenze di firefox nemmeno lui vede nulla.

(01 Oct, 01:41) lawally lawally's gravatar image

Un'ulteriore informazione: se vado nella sezione Gestione dispositivi di firefox (Modifica → Preferenze -> Privacy e sicurezza → Certificati → Dispositivi di Sicurezza) e seleziono il modulo che mi hai fatto caricare tu, alla voce "Stato" mi dice "Non presente", inoltre dice che la mia carta ha chip Athena, quando invece è STMicro. Se invece seleziono il modulo caricato seguendo le istruzioni di UbuntuWiki, alla voce "Stato" dice "Non connesso". Se provo a selezionare "Accedi", mi chiede il PIN, ma una volta immesso mi risponde "Accesso non riuscito". Potrebbe essere il lettore il problema?

(01 Oct, 02:02) lawally lawally's gravatar image

ma c'e' in /usr/lib il file libaseCnsP11.so ? (quello a 64 bit?)

(01 Oct, 08:29) sacarde sacarde's gravatar image

Sisì, ho seguito le tue istruzioni e l'ho copiato in quella cartella

(01 Oct, 15:56) lawally lawally's gravatar image

ce la fai a fare uno screenshot della parte di firefox dove hai inserito il path /usr/lib/libaseCnsP11.so

o a dare nell'indirizzo di firefox: about:preferences#privacy

e poi dispositivi di sicurezza

(01 Oct, 21:53) sacarde sacarde's gravatar image

Purtroppo non posso allegare immagini, quando ci provo il server mi risponde "Error uploading file. Please contact the site administrator. Thank you. [Errno 13] Permission denied: '/srv/chiedi.ubuntu-it.org/www/osqa/forum/upfiles/Screenshot_20211002_005931.png'" Non so come fare a fartelo avere.

(02 Oct, 01:04) lawally lawally's gravatar image

Da ulteriore ricerca suggeriscono che il problema possa essere l'installazione dei driver del mio chip specifico. Avevo installato solo il pacchetto completo dei driver in formato .deb. Ho quindi scaricato i driver per il mio chip (STMicro), ma non riesco ad installarli. Non capisco il file Readme cosa mi indichi di fare. Anche se, come da istruzioni, rendo il file PIN Manager eseguibile, non riesco ad eseguirlo. Forse se riuscissi ad installare quelli risolverei il problema. Li ho scaricati da qui https://swdownload1.agenziaentrate.gov.it/pub/sanita/SafeDive2020.zip

(02 Oct, 01:28) lawally lawally's gravatar image
(02 Oct, 08:13) sacarde sacarde's gravatar image
  1. lo screenshot lo trovi qui https://upload.disroot.org/r/eEmDFm7N#IlKDBrHUWGZgqr5PJh6qQHCEzkF6/dUzpjQEiYjaCUw= (il sito da te indicato non rimanda un url se si caricano le immagini anonimamente e io non ho un account twitter per registrarmi)
  2. mi fermo perchè, dopo aver reso il file eseguibile secondo le istruzioni, il file non si apre.
  3. la guida che mi hai indicato è troppo vecchia e i link lì riportati rimandano a pagine non più esistenti.
  4. :(
(03 Oct, 13:54) lawally lawally's gravatar image
  • che vedi dal comando: file /usr/lib/libaseCnsP11.so

  • siti nopaste:

https://imgur.com o https://i.imgur.com

  • i Prerequisiti (dal README) li hai controllati?

  • ce la fai , da linea di comando, a eseguire il file "PIN Manager" ? (basta che tu vada nella dir dove hai scompattato e poi esegui: ./"PIN Manager")

p.s. a meno che il file libaseCnsP11.so sia in contrasto con i file installati col SafeDive2020.zip

(03 Oct, 14:17) sacarde sacarde's gravatar image

quale chip ha la tua carta?

quale procedura hai eseguito? https://tscns.regione.sardegna.it/it/articoli/linux

(03 Oct, 14:30) sacarde sacarde's gravatar image
  1. https://imgur.com/QOITulE
  2. prerequisiti controllati e a posto
  3. https://imgur.com/Go9ziCY
  4. la mia carta ha chip STMicro
  5. ho eseguito la procedura semplificata per l'installazione della carta, quella manuale per la configurazione di Firefox (non mi fa installare l'add-on che mi indicano, che comunque dovrebbe servire solo per gestire più carte a quanto ho capito)
(03 Oct, 15:02) lawally lawally's gravatar image

Nelle mie innumerevoli ricerche ho anche trovato questo http://www.regione.fvg.it/rafvg/cms/RAFVG/GEN/carta-regionale-servizi/FOGLIA7/FOGLIA3/ e ho provato a seguire le indicazioni contenute, ma nemmeno questo funziona. Alla voce "Dispositivi di sicurezza" i moduli libbit4cpki.so e opensc-pkcs11.so riconoscono la carta ma non mi fanno accedere https://imgur.com/1mut1sg (quando ci provo mi dicono "Accesso non riuscito"), il modulo datomi da te invece non vede nemmeno la scheda https://imgur.com/maZNqGF penso perchè è per chip Athena e io ho STMicro.

(03 Oct, 15:12) lawally lawally's gravatar image
  • strano a me il comando: file /usr/lib/libaseCnsP11.so dice:

/usr/lib/libaseCnsP11.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

  • ma la carta e' stata abilitata?

  • riesci a lanciare il comando "PIN Manager" da terminale ?

(03 Oct, 17:02) sacarde sacarde's gravatar image

Non so perchè quel comando ci dia due risposte diverse, la carta è stata abilitata in farmacia, adesso mi fai venire il dubbio che abbiano sbagliato qualcosa loro, magari faccio un salto a chiedere. Non riesco a lanciare "PIN Manager" da terminale, mi risponde sempre che non ho i permessi per lanciarlo, non so come fare ad averli (più che inserire "sudo" prima del comando non so cosa fare).

(05 Oct, 14:54) lawally lawally's gravatar image
  • il file libaseCnsP11.so e' quello che hai scaricato dal mio indirizzo?

che vedi da: stat /usr/lib/libaseCnsP11.so

  • che vedi dal comando: stat "PIN Manager" ? (eseguendolo da dentro la dir dove lo hai scompattato)
(05 Oct, 16:55) sacarde sacarde's gravatar image

Sì, il file l'ho scaricato dal tuo indirizzo. Qui trovi lo screenshot del terminale con i due comandi che mi hai dato. https://imgur.com/UIvgybD

(06 Oct, 12:42) lawally lawally's gravatar image
  • il mio file libaseCnsP11.so ha dimensione 2468152

o la procedura di installazione lo rimpiazza o hai copiato quello a 32 bit

  • prova a accedere alla dir: SafeDive2020 e una volta dentro a eseguire: ./"PIN Manager"
(06 Oct, 13:42) sacarde sacarde's gravatar image

https://imgur.com/BCNqrQE questo è il pacchetto che ho scaricato da te. Il file x64 pesa 2,7 MB, quello x86 pesa 2,4 MB, io ho copiato quello contenuto nella cartella x64 perchè mi pare che x86 identifichi i sistemi a 32bit, o mi sbaglio?. Al comando ./"PIN Manager" il terminale risponde: sh: 1: ./go.sh: Permission denied

(06 Oct, 14:06) lawally lawally's gravatar image
  • clamoroso.... il mio e' 2,4MB..... sto' usando un driver per 32bit

boh!!!!!

  • con quale utente lo lanci? provato a eseguirlo anteponendo "sudo" ?
(06 Oct, 14:20) sacarde sacarde's gravatar image

Lanciato con sudo, stessa risposta

(06 Oct, 18:23) lawally lawally's gravatar image
  • hai mica provato col file a 32 bit?

  • le operazioni eseguite dal file README una volta fatte, strano, non vedo un riferimento mail per chiedere spiegazioni o assistenza

(hai provato da filemanager a andare nella dir "SafeDive2020"e fare doppio click su "PIN Manager"?)

(06 Oct, 20:55) sacarde sacarde's gravatar image

Ho provato col file a 32bit e quando provo a caricarlo nei dispositivi di sicurezza (stessa procedura indicatami da te) mi risponde che non è possibile caricarlo. Sembra che non piaccia a Firefox. Ho provato da filemanager a fare doppio clic su PIN Manager (come da istruzioni file Readme) e non succede nulla. Sto perdendo le speranze.

(08 Oct, 15:14) lawally lawally's gravatar image

provato a chiedere aiuto qui https://tscns.regione.sardegna.it/it/form/contattaci

oppure ripartire da una situazione pulita (quindi i miei file sembrerebbero non opportuni)

(08 Oct, 17:10) sacarde sacarde's gravatar image

Ho provato a mandare una mail al link che mi hai indicato, speriamo che abbiano già riscontrato lo stesso problema e sappiano darmi una risposta. Nel caso la inoltrerò anche qui di modo da aiutare altre persone che si trovino nella mia stessa situazione. Grazie mille

(09 Oct, 00:28) lawally lawally's gravatar image
(11 Oct, 21:29) sacarde sacarde's gravatar image

mi e' arrivata la mia nuova tessere, purtroppo ha il chip "ST 2021" anche a me non e' riuscito eseguire il comando: "PIN Manager"

te hai risolto?

(27 Oct, 14:58) sacarde sacarde's gravatar image

Ciao, no, non ho risolto. L'assistenza ha anche contattato il produttore del chip e loro dicono che devo disinstallare i driver della procedura autoinstallante (pacchetto .deb) perchè entrano in conflitto con i driver del fornitore (li hanno anche rimossi dalla pagina di istruzioni). Dicono di base di rimuovere tutti i pacchetti e poi installare il programma PIN Manager, solo che non capiscono che non si può installare. L'unica soluzione che ho pensato è una virtual box con windows. Non c'ho ancora provato. Bella merda.

(29 Oct, 13:00) lawally lawally's gravatar image

ho chiesto a help.cse@regione.toscana.it

guardiamo cosa rispondono

(29 Oct, 13:57) sacarde sacarde's gravatar image

mi hanno risposto cosi:

siamo a conoscenza del problema: attendiamo che vengano correttamente aggiornati i driver per carte ST 2021 su Linux.

(29 Oct, 17:00) sacarde sacarde's gravatar image

fatta prova, ho modificato il valore "eseguibile" anche a:

./jre/bin/java

e adesso l'applicativo (gestione carta) parte e sembra funzionare, quello che non funziona e' l'accesso al sito e al fascicolo sanitario, mi da il tuo stesso errore

(30 Oct, 10:00) sacarde sacarde's gravatar image
  • sempre all'help desk della regionetoscana mi dicono:

  • che sia risaputo un problema della libreria alla quale punta il browser, la pkcs11.so e' generica e non e' quella per i chip ST2021

  • un'altro mi dice di controllare firewall/antivirus

mah!!

(09 Nov, 17:41) sacarde sacarde's gravatar image

trovato la soluzione.... basta ricompilare il driver aggiornato di "OpenSC" seguendo:

https://github.com/OpenSC/OpenSC/wiki/Compiling-and-Installing-on-Unix-flavors

e impostando la nuova libreria appena fatta "opensc-pkcs11.so" in firefox

(09 Nov, 20:59) sacarde sacarde's gravatar image

Niente, sempre stesso errore. Ho seguito le istruzioni che mi hai indicato: ho installato le dipendenze, ho scaricato OpenSC-0.22.0, ho compilato come indicato, nella cartella /usr/lib ho selezionato la libreria opensc-pkcs11.so avente data odierna (per essere sicura che fosse quella nuova), inserita in firefox e sempre stessa storia. Firefox vede la scheda, vede il certificato, ma il sito dell'INPS (o qualsiasi altro) mi risponde l'errore in oggetto :( possibile che abbia sbagliato qualcosa?

(10 Nov, 20:06) lawally lawally's gravatar image

mah, sicura di aver installato i pacchetti richiesti e pkg-config e zlib1g-dev ?

  • hai scaricato il tarball o scaricato da git?

  • i passi sono andati bene?

./bootstrap

./configure --prefix=/usr --sysconfdir=/etc/opensc

make

sudo make install

p.s. per testarlo eseguo:

pkcs11-tool --module /usr/lib/opensc-pkcs11.so -t -l

(10 Nov, 20:32) sacarde sacarde's gravatar image

Ciao, ho controllato e le dipendenze sono tutte soddisfatte, i passi sono andati tutti a buon fine però il test che mi hai indicato di fare risponde come da immagine contenuta qui https://imgur.com/w4tmwig

(11 Nov, 15:51) lawally lawally's gravatar image

Dimenticavo, non so cosa sia il tarball, ho scaricato (non mi ricordo nemmeno più da dove) il file opensc-0.22.0.tar.gz

(11 Nov, 15:53) lawally lawally's gravatar image

le uniche differenze... io sono su una kubuntu-18.04 e i sorgenti li ho scaricati col comando:

git clone https://github.com/OpenSC/OpenSC.git

forse e' leggermente diverso dal tarbal 0.22.0

p.s. dentro la dir /etc/opensc cosa hai?

(11 Nov, 17:13) sacarde sacarde's gravatar image

SIIIIIIIIIIIIIIIIIIIIII!!!!!!!! Ho scaricato i sorgenti come mi hai indicato tu e ricompilato tutto seguendo le istruzioni e FUNZIONA!!!!! Sono felicissima e tu sali nel mio Olimpo personale insieme a Dioniso (unico dio che riconosco) Grazie di cuore dell'impegno e del tempo che mi hai dedicato.

(11 Nov, 18:35) lawally lawally's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×181
×157

domanda posta: 27 Sep, 20:03

domanda visualizzata: 240 volte

ultimo aggiornamento: 11 Nov, 18:35

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.