Ho un Asus VM42 collegato alla TV che, da alcune settimane, funziona con Ubuntu 21.10. Qualche problema, prima con l'audio HDMI (che ho marcato risolto, ma è necessario ogni volta un intervento con alsamixer), poi negli ultimi giorni col wifi, le cui prestazioni possono passare da 10 a 100 Mbit (o non andare affatto) a seconda di come gli gira al boot. Leggendo qua e là, ho imparato che i driver wireless sono sempre stati un tallone di Achille di Linux e che qualcuno si è posto il problema di sostituirli con i corrispondenti Windows, che in effetti sono più stabili e soprattutto vanno parecchio più veloci. Tenendo conto che i dispositivi wireless e audio sono entrambi Realteck, azzardo che potrei risolvere entrambi i problemi una volta per tutte. Non me la sento di provare a farlo da solo, soprattutto non saprei come tornare indietro, se qualcosa andasse storto. Qualcuno se la sentirebbe di assistermi? Io intanto ho già scaricato i driver dal sito Asus.

chiesto 22 Nov, 11:46

luticci's gravatar image

luticci
203


Sì, è possibile? Per quanto riguarda l'audio mi ero sbagliato, è il dispositivo Intel integrato:

lt@lt-VM42:~$ lspci 00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b) 00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b) 00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b) 00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04) 00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04) 00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04) 00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4) 00:1c.1 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 2 (rev e4) 00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4) 00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4) 00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04) 00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04) 00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04) 00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04) 03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11) 04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter

coll. permanente

ha risposto 22 Nov, 19:33

luticci's gravatar image

luticci
203

sono anni che non ne faccio piu uso, ma se vuoi provare

quindi sarebbe per la:

RTL8821AE ?

i driver windows li hai? adesso quale modulo/driver usa?

il rtl8821ae ? cosa ha che non funziona bene?

(22 Nov, 20:37) sacarde sacarde's gravatar image

Sì, la schedina è quella. Attualmente ritengo che usi il driver caricato in fase di prima istallazione della 21.04 o della migrazione alla 21.10 che c'è adesso. Come ho scritto nel primo post, le prestazioni sono ballerine, a volte è lentissimo e bisogna rifare il boot, è successo che il wifi non è proprio partito. In ogni caso, rispetto a quando avevo su Win10, va la metà in download e 5 volte meno in upload. Se riusciamo a farlo, pensi che possiamo provare anche col driver audio e risolvere quel problema che richiede alsamixer? Ho tutti i driver scaricati dal sito Asus

(23 Nov, 05:17) luticci luticci's gravatar image
(23 Nov, 08:14) sacarde sacarde's gravatar image

Io ho impostato su potenza bilanciata, non su risparmio energia. Ho trovato questo articolo:

https://itectec.com/ubuntu/ubuntu-how-to-set-performance-instead-of-powersave-as-default/

pensi che impostando su performance potrei risolvere il problema senza cambiare driver?

(23 Nov, 08:32) luticci luticci's gravatar image

ho provato ad installare ndiswrapper, ndiswrapper-common e ndiswrapper-utils-1.9: nessun pacchetto viene trovato

(23 Nov, 08:51) luticci luticci's gravatar image

non ho mai provato quel parametro della cpu, io parlavo del powersafe della scheda wireless, vedi i parametri modificabili dal comando:

modinfo rtl8821ae

p.s. il fatto che non ci sia piu il pacchetto "ndiswrapper" mi preoccupa

(23 Nov, 08:57) sacarde sacarde's gravatar image

E' uscita una valanga di righe, quelle che interessano credo siano queste

parm: swenc:Set to 1 for software crypto (default 0) (bool) parm: ips:Set to 0 to not use link power save (default 1) (bool) parm: swlps:Set to 1 to use SW control power save (default 0) (bool) parm: fwlps:Set to 1 to use FW control power save (default 1) (bool) parm: msi:Set to 1 to use MSI interrupts mode (default 1) (bool) parm: aspm:Set to 1 to enable ASPM (default 1) (int) parm: debug_level:Set debug level (0-5) (default 0) (int) parm: debug_mask:Set debug mask (default 0) (ullong) parm: disable_watchdog:Set to 1 to disable the watchdog (default 0) (bool) parm: int_clear:Set to 0 to disable interrupt clear before set (default 1) (bool)

coll. permanente

ha risposto 23 Nov, 09:08

luticci's gravatar image

luticci
203

  • questi problemi ci sono sempre stati? o da quando hai toccato quei parametri della cpu?

  • per disattivare il powersafe wireless:

nel file /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

metti: wifi.powersave = 2

(23 Nov, 09:22) sacarde sacarde's gravatar image

Non ricordo di aver modificato il parametro Energia, comunque ci sono più o meno sempre stati. Ho fatto la modifica, inizialmente il 5 Mhz sembrava non funzionare, poi connesso a 2,4 e tornato al 5,0 è andato tutto a posto. Per il momento non trovo grandi differenze, farò qualche speed test di controllo. Mi sembra di capire che senza Ndiswrapper non si può fare niente. comunque grazie

(23 Nov, 09:49) luticci luticci's gravatar image

Per il problema audio (non so se ricordi https://chiedi.ubuntu-it.org/questions/76651/risolto-audio-hdmi-raiplay), non potrebbe dipendere dal driver? Con Win10 mai una volta ho perso l'audio su HDMI.

(23 Nov, 09:57) luticci luticci's gravatar image

mi pare che la strada che consigliano sia di usare/aggiustare i moduli che ha il kernel di linux

pero' un tentativo puoi farlo con ndiswrapper/ndiswrapper-dkms (il pacchetto c'e' sulla 20.04)

(23 Nov, 15:25) sacarde sacarde's gravatar image

ndiswrapper a me dice che in c'è. In ogni caso, per il momento voglio vedere se l'intervento fatto porta a qualche risultato apprezzabile. Buona serata

(23 Nov, 16:43) luticci luticci's gravatar image

per disabilitare powersafe dal parametro rtl8821ae

risposta 3 in: https://askubuntu.com/questions/925538/how-do-i-prevent-my-rtl8821ae-from-dropping

(24 Nov, 09:21) sacarde sacarde's gravatar image

Ho l'impressione che non sia il mio caso, ho i due canali 2,4 e 5,0 separati. Ieri sera non ho avuto problemi di rete, forse la modifica fatta qualche buon risultato l'ha dato.

(24 Nov, 09:28) luticci luticci's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×295
×62

domanda posta: 22 Nov, 11:46

domanda visualizzata: 77 volte

ultimo aggiornamento: 24 Nov, 09:28

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.