Ciao ragazzi, sono un un nuovo utente ubuntu. Ho provato ad installare l'ultima versione su un HP EliteDesk 705 G4, con processore AMD PRO A6-9500 con grafica integrata, sa subito ho notato che non si riavviava e non riusciva a spegnersi, da li ho fatto qualche ricerca molti utenti dicono sia un problema di driver video. Ho provato ad installare gli amdgpu specifici, ( o amneno credo che lo siamo) il riavvio e lo spegnimento hanno subito funzionato ma la grafica mi rimane a 1024x768 e non riesco ad umentarla.

chiesto 17 Dec '21, 07:27

fabiusx's gravatar image

fabiusx
101

seguito questo?

https://wiki.ubuntu-it.org/Hardware/AbilitareDriverProprietari

p.s. da consolle se esegui: xrandr cosa vedi?

(17 Dec '21, 10:09) sacarde sacarde's gravatar image

12avanti »

Si già controllato "nessun drive aggiuntivo disponibile". Qeusto è il risultato del comnado

xrandr: Failed to get size of gamma for output default Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768 default connected primary 1024x768+0+0 0mm x 0mm 1024x768 76.00*

coll. permanente

ha risposto 17 Dec '21, 14:23

fabiusx's gravatar image

fabiusx
101

modificato 17 Dec '21, 14:24

  • anche dal live hai la risoluzione 1024 x 768 ?

  • cosa vedi dal comando: cvt yyy xxx

dove yyy e xxx sono la risoluzione che vorresti

(17 Dec '21, 17:14) sacarde sacarde's gravatar image

ecco cosa vedo fabiusx@fabiusx:~$ cvt 1980 1080

1984x1080 59.92 Hz (CVT) hsync: 67.11 kHz; pclk: 178.25 MHz

Modeline "1984x1080_60.00" 178.25 1984 2112 2320 2656 1080 1083 1093 1120 -hsync +vsync

coll. permanente

ha risposto 17 Dec '21, 18:41

fabiusx's gravatar image

fabiusx
101

prova quest'altro comando:

xrandr --newmode "1984x1080_60.00" 178.25 1984 2112 2320 2656 1080 1083 1093 1120 -hsync +vsync

e a rieseguire: xrandr

(17 Dec '21, 20:32) sacarde sacarde's gravatar image

ho ricevuto questo risultato fabiusx@fabiusx:~$ xrandr xrandr: Failed to get size of gamma for output default Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768 default connected primary 1024x768+0+0 0mm x 0mm 1024x768 76.00* 1984x1080_60.00 (0x530) 178.250MHz -HSync +VSync h: width 1984 start 2112 end 2320 total 2656 skew 0 clock 67.11KHz v: height 1080 start 1083 end 1093 total 1120 clock 59.92Hz

coll. permanente

ha risposto 17 Dec '21, 23:56

fabiusx's gravatar image

fabiusx
101

Credo di aver trovato il driver specifico, ma non riesco prorpio ad installarlo il file si chiama fglrx_15.302-0ubuntu1_amd64_ub_14.01.deb. Ho provato cliccando due volte e mi da l'errrore "impossibile installare fglrx: the following packages have unmet dependencies" se invece prova a installare manualmente tramite sudo dpkg -i mi da il seguente errore "dpkg: errore nell'elaborare il pacchetto fglrx (--install): problemi con le dipendenze - lasciato non configurato"

coll. permanente

ha risposto 18 Dec '21, 00:21

fabiusx's gravatar image

fabiusx
101

per installare le dipendenze:

sudo apt-get -f install

(18 Dec '21, 08:13) sacarde sacarde's gravatar image

Come faccio ad utilizzare questo comando? prima del nome del file?

(18 Dec '21, 08:22) fabiusx fabiusx's gravatar image
(18 Dec '21, 09:21) sacarde sacarde's gravatar image

quale e' la tua scheda video?

https://wiki.ubuntu-it.org/Hardware/Video/Amd

lspci | grep -E 'VGA|Display|3D'

(18 Dec '21, 10:34) sacarde sacarde's gravatar image

fabiusx@fabiusx-1:~/AMD_Driver_Packages$ lspci | grep -E 'VGA|Display|3D'

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wani [Radeon R5/R6/R7 Graphics] (rev e6)

coll. permanente

ha risposto 18 Dec '21, 13:55

fabiusx's gravatar image

fabiusx
101

  • "sudo apt-get -f install " l'hai provato?

io credo che fglrx sia vecchio su una ubuntu21.10

  • adesso quale driver hai?
(18 Dec '21, 14:17) sacarde sacarde's gravatar image

Si ho provato ma non ho risolto, ora ho reinstallato ubuntu sono al punto di partenza con la corretta grafica, ma non mi si riavvia e non si spegne.....

coll. permanente

ha risposto 18 Dec '21, 18:57

fabiusx's gravatar image

fabiusx
101

  • provato a passare al kernel: acpi=off noapic nolapic

istruzioni passare parametri al kernel: temporaneamente https://wiki.ubuntu.com/Kernel/KernelBootParameters#Temporarily_Add_a_Kernel_Boot_Parameter_for_Testing

  • hai provato con i comandi:

https://winadmin.it/come-spegnere-un-pc-linux-che-non-si-spegne/

  • quale kernel hai? uname -a
(18 Dec '21, 21:45) sacarde sacarde's gravatar image

Allora ho formattato e reinstallato ubutu, poichè avevo incasinato tutto con le installazioni dei driver video. Ripartendo dall'inizio ora ho in driver originali ubuntu ed il problema del riavvio e lo spegnimento che non funzionano. Avete qualche consiglio per sistemare il riavvio e spegnimento senza installare i driver grafici amd?

coll. permanente

ha risposto 31 Dec '21, 12:41

fabiusx's gravatar image

fabiusx
101

modificato 31 Dec '21, 12:42

una prova da fare e' quella di passare al kernel (temporaneamente) i parametri:

acpi=off noapic nolapic

segui queste istruzioni: https://wiki.ubuntu.com/Kernel/KernelBootParameters#Temporarily_Add_a_Kernel_Boot_Parameter_for_Testing

(31 Dec '21, 16:07) sacarde sacarde's gravatar image

Devo aggiungere i parametri in fondo alla lista di quelli già esistenti? E avviare con cntl+x?

coll. permanente

ha risposto 31 Dec '21, 17:46

fabiusx's gravatar image

fabiusx
101

si, e per controllare se dopo l'avvio sono stati presi esegui:

cat /proc/cmdline

(31 Dec '21, 17:51) sacarde sacarde's gravatar image

Restituisce questo risultato BOOT_IMAGE=/boot/vmlinuz-5.11.0-43-generic root=UUID=a0598d81-3b77-4c7f-a731-6f88621899b0 ro quiet splash vt.handoff=7 pensi siano stati presi? perchè non funziona lo stesso.

coll. permanente

ha risposto 31 Dec '21, 18:04

fabiusx's gravatar image

fabiusx
101

non li vedo...

togli " quiet splash" e metti "acpi=off noapic nolapic"

(31 Dec '21, 20:55) sacarde sacarde's gravatar image

Allora se avvio con questi parametri non si avvia mi dà busybox v.1.30.1...... (Initramfs). Se avvio solo con "acpi=off noapic" parte lo carica ma non risolvo il problema.

coll. permanente

ha risposto 01 Jan, 10:53

fabiusx's gravatar image

fabiusx
101

  • ricapitolando,

con i driver amdgpu non hai la risoluzione voluta

con gli altri driver la risoluzione e' giusta ma non si spegne e si riavvia (il riavvio e' casuale?)

(01 Jan, 11:33) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×132

domanda posta: 17 Dec '21, 07:27

domanda visualizzata: 144 volte

ultimo aggiornamento: 02 Jan, 11:28

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.